Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Nach Festplatten Fehler Bluescreen beim Starten des W2k8 R2 Servers (0x000000f4, 0x00000021)

Frage Microsoft Windows Server

Mitglied: vip3234

vip3234 (Level 1) - Jetzt verbinden

22.11.2011, aktualisiert 12.12.2011, 5924 Aufrufe, 15 Kommentare

Hallo zusammen,

ich habe folgendes schwerwiegende Problem.

1. Setup
  • Hostserver mit Windows Server 2008 R2 Enterprise installiert auf RAID1 Festplattenverbund
  • 2 Virtualisierte Win2k8R2 Server (1x DC, 1x Exchange, IIS etc.) die per Hyper V vom Host virtualisiert werden die VHDs der virtualisierten Server liegen auf einem RAID10 (4 Festplatten a 500GB) Festplattenverbund des Host Systems

2. Der Vorfall
  • Bei einer Systemwartung wurde festgestellt, dass der Raidcontroller (LSI) des Hostrechners eine der 4 Festplatten des RAID10 wegen zu häufiger Lesefehler abgeschaltet hatte. Die Festplatte wurde ausgebaut und in einem anderen Rechner überprüft, war jedoch Fehlerfrei. Daher wurde sie wieder eingebaut und im Raidcontroller Setup wieder online geschaltet. Während des Prüfvorgangs etc. wurde der Hostrechner des öfteren herauf und wieder heruntergefahren. Dabei wurden auch die virtualisierten Systeme mitgestartet und wieder beendet. (Sie waren so konfiguriert, dass der Hostrechner erst beendet wird, wenn die Systeme heruntergefahren wurden) Nun wollte ich die virtuellen Server wieder in betrieb nehmen und sehe, dass bei beiden beim ersten "offiziellen" Startversuch Checkdisk läuft und fleißig Korrekturen durchführt. Nach Ablauf von Checkdisk brach bei beiden Servern der Startvorgang mit einem Bluescreen ab (0x000000f4, 0x00000021).
Anschließend fiel dann die vorher geprüfte Festplatte tatsächlich aus (klackert jetzt nur noch)

3. Was bereits unternommen wurde
  • Beide Server sind nicht mehr zu starten. Datenverlust liegt KEINER vor. Die vhds können gemountet und geöffnet werden, alles scheint normal. Weitere Versuche Checkdisk auszuführen brachten keinen Erfolg. Auch das Ausführen von "sources\recovery\startrep.exe" über die Windows Server 2008 DVD brachte kein neues Ergebnis. "Startrep.exe" behauptete zwar 3 mal, dass der Startvorgang nun repariert wurde, jedoch war dies nicht der Fall. Mittlerweile kommt nach "startrep.exe" nur noch eine Meldung, dass der Startvorgang nicht repariert werden konnte. Ein Backup das wiederhergestellt werden könnte existiert nicht (jaja, ich weiß.....)

Nun ist meine Frage natürlich, wie kann ich weiter vorgehen um die System wieder zum starten zu bewegen ? Eine Option wie bei Windows XP früher, welche die Systemdateien von der DVD neu kopiert hat gibt es ja nicht mehr.
Vielen vielen Dank schon mal für eure Hilfe.

Gruß,
Ludwig


EDIT: Screenshots von den Bluescreens:
748b8507d50e3be9a807142ead461c1d - Klicke auf das Bild, um es zu vergrößern
5e374150b60fd0813a5b0342d031af0b - Klicke auf das Bild, um es zu vergrößern
Mitglied: Arsimael.Inshan
22.11.2011 um 17:01 Uhr
Hm klingt nach VF: Viel Fummlarbeit

Ich würde erstmal so vorgehen:
1.) Installiere eine neue VM mit windows 2008 R2. Stelle die VM genau so ein wie die defekte.
2.) Hänge die "defekte" VHD in die neue VM
3.) Prüfe nun die "defekte" VHD mit dem neuen Server komplett durch, und prüfe ob die 100MB Bootpartition auf der "defekten" VHD als aktiv geschaltet ist (diskpart).
4.) tausche nun "laufende" vhd gegen "defekte" vhd aus.

Läufts wieder?
Bitte warten ..
Mitglied: Lochkartenstanzer
22.11.2011 um 17:13 Uhr
Zitat von vip3234:
Noch ein Tipp:

Während des Prüfvorgangs etc. wurde der Hostrechner des öfteren herauf und wieder heruntergefahren. Dabei wurden

Das sollte man tunlichst lassen. Insbesondere der Prüfvorgang, bzw die Synchronisation wird bein Neustart meist wieder frisch angestoßen, so daß es zu unötigen Verzögerungen führt.

lks
Bitte warten ..
Mitglied: vip3234
22.11.2011 um 17:29 Uhr
Ja, VF, so sehe ich das auch.

Also was meinst du mit "Stelle die VM genauso ein wie die defekte" ? Meinst du lediglich die Hardwarekonfiguration etc. oder meinst du das auch die Win2k8R2 Installation ?

Grundsätzlich habe ich bereits eine VM mit gleicher Hardwarekonfiguration eingerichtet um die VHD dort zu prüfen und dabei eben herausgefunden, dass soweit alle Daten etc. vorhanden sind. Die Bootpartition habe ich nicht geprüft ob diese aktiv geschaltet war. Wieso sollte sich das geändert haben ?
Bitte warten ..
Mitglied: Arsimael.Inshan
22.11.2011 um 18:48 Uhr
Ich hab schon Pferde kotzen sehen.... Schau einfach mal nach, und stell sie wenn icht schon geschehen auf "aktiv"

BTW: bei den Fehlern 0x0000000f4 und 0x00000021 Was für Meldungen bringt er dir da? KERNEL_DATA_INPAGE_ERROR und QUOTA_UNDERFLOW?
Bitte warten ..
Mitglied: Phalanx82
23.11.2011 um 09:16 Uhr
Und nochn Tipp von mir:

Wenn der Raid Controller die Platte raus wirft, hat das idR. einen Grund (wenn nich Firmwarebug, gabs mal bei WD Platten).

So eine Platte würde Ich persönlich nicht mehr in ein Raid einbauen, schon garnicht in eines mit einer Fault Tolerance von 1 Platte
wie ein Raid10.

Und hier stellt sich mir gleich die Frage: Warum keine Hotspare am Start? Sind dir deine Daten nicht wichtig? Kannst du mit einem
Totalverlust leben? :X


Mfg.
Bitte warten ..
Mitglied: vip3234
23.11.2011 um 10:31 Uhr
Danke dir, hinterher ist man immer schlauer.
Nur nochdem wie gesagt die Platte nach dem Prüfen an einem anderen Rechner keine Auffälligkeiten gezeigt hatte war anzunehmen, dass die vom Raidcontroller gemeldeten Lesefehler nur ein Zufall oder sonst was waren.

Hotspare gab es deshalb nicht, weil es sehr unwahrscheinlich ist, dass 2 Platten innerhalb von so kurzer Zeit ausfallen, dass die eine nicht bereits regulär ersetzt wurde. Aber sicher du hast auch hier recht, man sollte sich eine Hotspare Platte leisten.

Glücklicherweise sind die Festplatten ja gerade billig nur 120% teurer, deshalb ist das gerade passend
Bitte warten ..
Mitglied: vip3234
23.11.2011 um 10:33 Uhr
Es ist so, im Moment bin ich bis Mitte Dezember unterwegs und kann nicht an das System, daher kann ich dir die genau Meldung nicht sagen. Sobald ich wieder vorort bin gibts mehr infos.

Daher vielen Dank erst mal, melde mich dann wenn es neues gibt.
Bitte warten ..
Mitglied: vip3234
12.12.2011 um 00:15 Uhr
So, jetzt bin ich wieder vorort am Gerät. Habe deine Anweisungen befolgt. Der Server1 bringt jetzt "c000021a Fatal Error" als Bluescreen, Server2 weiterhin 0x000000f4.
Die Bootpartition war bei beiden VHDs bereits aktiv gesetzt, eine Datenträgerüberprüfung ergab keinerlei Fehler. Die defekten Festplatten das Raids wurden ebenfalls ersetzt und der Status des Raids ist jetzt wieder optimal (Rebuild abgeschlossen).
Bitte warten ..
Mitglied: goscho
12.12.2011 um 08:40 Uhr
Zitat von vip3234:
So, jetzt bin ich wieder vorort am Gerät.
Morgen,
Na, wenn das System 3 Wochen ohne Fehlerbehebung auskam, kann es ja nicht so tragisch gewesen sein, oder hast du uns vergessen, was mitzuteilen?
Bitte warten ..
Mitglied: vip3234
12.12.2011 um 08:52 Uhr
Naja, ich hatte vor meiner Reise ein schnelles Notfallsystem aufgebaut, das in der Zeit die notwendigen Funktionen übernommen hat.. Aber nun sollte das schon behoben werden.

Spielt das jetzt eine Rolle wie tragisch es ist ? Es muss behoben werden punkt um.
Bitte warten ..
Mitglied: goscho
12.12.2011 um 09:39 Uhr
Zitat von vip3234:
Naja, ich hatte vor meiner Reise ein schnelles Notfallsystem aufgebaut, das in der Zeit die notwendigen Funktionen übernommen
hat.. Aber nun sollte das schon behoben werden.
Davon hast du nichts geschrieben.
Wie sieht das aus?
Hast du dazu ein Backup wiederhergestellt?
Spielt das jetzt eine Rolle wie tragisch es ist ? Es muss behoben werden punkt um.
Nein, aber es spielt schon eine Rolle, was wiederhergestellt werden muss.
Ich kann mir beim besten Willen nicht vorstellen, dass eine Firma 3 Wochen auf Ihr Netzwerk mit DC und Exchange verzichten kann.

Wie sollen wir dir jetzt helfen, das System wieder zum Laufen zu bekommen, wenn zwischenzeitlich mit (was auch immer dein Notfallsystem war) weitergearbeitet wurde?
Bitte warten ..
Mitglied: Lochkartenstanzer
12.12.2011 um 11:55 Uhr
Nunja, eine Platte und das Filesystem können zwar in ordnung sein, das schützt einen aber nicht davor, daß die Daten selbst inkonsistent sein können. Wenn es dabnn eine wichtige datei trifft, startet dann halt das OS nicht mehr.

Nachdem es seit W2K8/Windows6 keine echte Reparaturinstallation mehr gibt, kann man nicht wie bei W2k3/Windows5.1 einfach mal eine Reparaturinstallation drüberbügeln.

Von daher wäre das Zeitsparendste einfach die Backups von den VHDs einzuspielen und dann die aktuelleren Daten von den "kaputten" vhds auf die wiedereingespielten Backups zu kopieren. Danach kannst du, ewnn es dich immer noch interessiert, in aller ruhe die kaputten vhds inspizieren.

Du hast doch Backups von den vhds, oder?

lks
Bitte warten ..
Mitglied: Arsimael.Inshan
12.12.2011 um 13:43 Uhr
Zitat von vip3234:
Hotspare gab es deshalb nicht, weil es sehr unwahrscheinlich ist, dass 2 Platten innerhalb von so kurzer Zeit ausfallen, dass die
eine nicht bereits regulär ersetzt wurde. Aber sicher du hast auch hier recht, man sollte sich eine Hotspare Platte leisten.
Also ich kenn das andersrum: eine platte fällt aus und beim Rebuild gibt dann die nächste wegen der gestiegenen beanspruchung den geist auf und die nächste und die nächste......
Bitte warten ..
Mitglied: Lochkartenstanzer
12.12.2011 um 14:00 Uhr
Zitat von vip3234:
Hotspare gab es deshalb nicht, weil es sehr unwahrscheinlich ist, dass 2 Platten innerhalb von so kurzer Zeit ausfallen, dass die
eine nicht bereits regulär ersetzt wurde. Aber sicher du hast auch hier recht, man sollte sich eine Hotspare Platte leisten.

Ich beobachte sehr oft, daß ein RAID mit mehreren baugleichen Platten bestückt wird. Wenn die nun einen "Serienfehler" haben, ist es durchaus sehr wahrscheinlich, daß die alle nach kurzer Zeit hintereinander ausfallen. Habe ich sogar schon beobachtet. Von daher ist ein hot-spare eine sehr sinnvolle Investition. Und man sollte natürlich auch eventuell mindestens 2 oder 3 verschiedene Modelle/Hersteller verwenden. Das kann natürlich auch nach hinten losgehen, weil das wiederum die Wahrscheinlichkeit erhöht, daß da wiederum ein herstelelr dabei ist, der nicht so sorgfältig wie die anderen arbeitet und daher eine Platte ggf auf jeden Fall vorzeitig über den Jordan geht.

Aber was wäre das Leben ohne Risiko?

lks
Bitte warten ..
Mitglied: vip3234
12.12.2011 um 14:59 Uhr
Ein verwendbares Backup von diesem System exisitiert nicht. Ein Backup gibt es lediglich von den Nutzerdaten. Daher habe ich ein komplett neues System aufgesetzt, dass in meiner Abwesenheit den E-Mail Verkehr etc. aufrechterhalten hat.

Was jetzt der ideal Fall wäre, wäre wenn die beiden virtuellen Server wieder zum starten zu bewegen wären. Dann würde ich lediglich die neuen Nutzerdaten vom Notfallsystem den alten hinzufügen und fertig.
Aber wie es aussieht wird es damit wohl nichts, aus diesem Grund werde ich zwei komplett neue Systeme aufsetzen, die und die alten sowie die neuen Nutzerdaten migrieren.

Danke für eure Hilfe, ich bin für alle Vorschläge dankbar.
Bitte warten ..
Ähnliche Inhalte
Mac OS X
MAC-Problem an einer W2k8 R2 Domain

Frage von Leo-le zum Thema Mac OS X ...

Windows 7
gelöst Explorer.exe - starten des Servers fehlgeschlagen (11)

Frage von DeathNote zum Thema Windows 7 ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Off Topic
gelöst Fachzeitschriften als E-Book oder hardcoded? (11)

Frage von KowaKowalski zum Thema Off Topic ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...