Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hohe Latenz bei VDI Verbindung mit RemoteFX über Wlan trotz ausgezeichneter Qualität und UDP

Frage Virtualisierung Hyper-V

Mitglied: vip3234

vip3234 (Level 1) - Jetzt verbinden

06.02.2014 um 09:40 Uhr, 1660 Aufrufe, 6 Kommentare

Hallo zusammen,

es geht um eine VDI Umgebung mit 2 Windows Server 2012 R2 (Hyper-V Host, Verbindungsbroker, Gateway etc..) und Windows 8.1 Enterprise als Verbindungsziel.

Insgesamt gibt es 2 Wege um auf seinen persönlichen Desktop zu verbinden:
1. 1 Gigabit Lan (Ping zum Zieldesktop 1-2ms)
2. 5Ghz Wlan (300Mbit) (Ping zum Zieldesktop 2-4ms)

Im meinem Testszenario gibt es nur die VDI Umgebung sowie einen Benutzer der versucht entweder über Lan oder Wlan Verbindung zu seinem Desktop aufzunehmen. Folglich gibt es auch in den beiden Netzwerken keine weiteren Teilnehmer die zusätzliche Lasten erzeugen können.

Des Weiteren wird 3D Beschleunigung über RemoteFX bereitgestellt.

Zum Problem:
Bei Verbindung über Lan funktioniert alles ausgezeichnet, selbst mit Multimonitor Darstellung auf FullHD läuft auf dem virtuellen Desktop alles flüssig, auch youtube etc. läuft ruckelfrei, die 3D Beschleunigung bei einem Benchmark ist ok.
Bei Verbindung über Wlan und der selben Konfiguration sieht man eine deutliche Verzögerung, man sieht die Fensteranimationen ablaufen beim Aktivieren der Forms und an Videodarstellung ist gar nicht zu denken.
Bei allen beiden Verbindungen wird UDP eingesetzt und die Verbindungsqualität wird als "ausgezeichnet" bestimmt.

Frage:
Wie lässt sich dieses Verhalten erklären, obwohl der Ping zum Zieldesktop bei beiden Netzwerken vergleichbar gering ist ? Könnte es ggf. am verwendeten Accesspoint liegen, der hier keine konstante Verbindung liefert ?

Vielen Dank für eure Hilfe !

Grüße,
Ludwig
Mitglied: Dani
06.02.2014 um 20:20 Uhr
Moin Ludwig,
ie lässt sich dieses Verhalten erklären, obwohl der Ping zum Zieldesktop bei beiden Netzwerken vergleichbar gering ist ?
Der Ping spielt bei VDI keine primäre Rolle. Wichtig ist dort eher, dass es im LAN zu keinen Datenstau auf den Switches, Router oder Firewalls kommt. Gerade bei UDP wird der Empfang des Pakets nicht bestätigt. Gehen also auf einem Weg Pakete verloren, kann es zu sowas kommen.


Grüße,
Dani
Bitte warten ..
Mitglied: vip3234
07.02.2014 um 09:23 Uhr
Morgen Dani,

danke erst einmal für deine Antwort.
Das ist ein guter Ansatz von dir.
Im Aufbau ist es so, dass ein Draytek Wlanrouter im Einsatz ist, der sowohl das verwendete Lan als auch die Wlan Verbindung bereitstellt. Allerdings handelt es sich bei den beiden Netzen um unterschiedliche IP Bereiche zwischen welchen Router intern ebenfalls nach groutet wird. Die VDI Infrastruktur hängt dabei am Lan.
Welche Möglichkeiten gibt es denn die Übertragungsweg hinsichtlich Datenstau etc. zu untersuchen ?

Grüße,
Ludwig
Bitte warten ..
Mitglied: Dani
07.02.2014 um 09:58 Uhr
Moin,
Welche Möglichkeiten gibt es denn die Übertragungsweg hinsichtlich Datenstau etc. zu untersuchen ?
Die einfachste Möglichkeit ist ein MTR zum VDI-Server laufen zu lassen. Zu 99% wird dieser keinen Paketverlust feststellen. Damit stellst du nur sicher, dass kein Gerät überlastet ist.

Dann bleibt dir nur übrig, die Interfacestatistiken jedes Routers/Switches anzuschauen ob der Errorcounter hochzählt.


Grüße,
Dani
Bitte warten ..
Mitglied: vip3234
11.02.2014 um 16:11 Uhr
Hallo Dani,

ich habe nun die Schwachstelle gefunden:

Es handelt sich um das RD-Gateway.
Hintergrund ist der, dass aus dem Lan direkter Zugriff auf den Zieldesktop netzwerkseitig möglich ist. Aus dem Wlan ist es aber so, dass der gesamte RDP Verkehr über das Gateway läuft, da dieses Netz aus Sicherheitsgründen keinen direkten Zugriff auf das Domainnetzwerk hat indem sich u.a. auch der Zieldesktop befindet.
Ich habe diese Möglichkeit anfangs nicht bedacht, da ich bei der Konfiguration der Verbindung in beiden Fällen, sowohl für Lan als auch Wlan die Gatewayverwendung fest aktiviert in der Annahme dass damit immer das Gateway verwendet wird.
Defacto ist es aber so, dass im Lan-Fall das Gateway lediglich den Zieldesktop ermittelt und dann direkt eine RDP Verbindung zu selbigem hergestellt wird. Im Wlan Fall ist dies nicht möglich und der Verkehr läuft komplett über das Gateway ins Zielnetzwerk.

Ich hoffe dies hilft ggf. jemand anderem weiter.

Vielen Dank und viele Grüße,
Ludwig
Bitte warten ..
Mitglied: Dani
11.02.2014 um 16:17 Uhr
Moin,
vielen Dank für die Rückmeldung.
Ist das RD-Gateway unterdimensoniert?


Grüße,
Dani
Bitte warten ..
Mitglied: vip3234
11.02.2014 um 16:37 Uhr
Das Gateway ist in sofern unterdimensioniert als dass es sich dabei um einen virtualisierten Server handelt der seinerseits sich den Host mit einigen weiteren (virtuellen) Testsystemen teilt. Ein Testaufbau eben
Aufgrund dieser Erkenntnis werde ich den Aufbau entsprechend ändern und dem Gateway einen eigenen physikalischen Host geben und ggf. nochmal testen. Das wird aber noch eine weile dauern.


Danke nochmal für die Hilfe !

Grüße,
Ludwig
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
LAN, WAN, Wireless
Hohe Latenz zum Provider (8)

Frage von Valexus zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
gelöst WLAN AP verlieren Verbindung nach unbestimmter Zeit (15)

Frage von 113726 zum Thema Windows Netzwerk ...

LAN, WAN, Wireless
Android Smartphone Kurzfristige Trennung der WLAN-Verbindung (7)

Frage von Coreknabe zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
IP Adressen Konflikt im Ausland, jetzt keine Verbindung zu eduroam (WLAN) mehr - was tun? (2)

Frage von InEnglandforawhile zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...