Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

HP ProCurve Einstellungen

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Akcent

Akcent (Level 2) - Jetzt verbinden

26.07.2013, aktualisiert 10:10 Uhr, 4944 Aufrufe, 16 Kommentare, 2 Danke

Hallo,

wir haben einen HP ProLiant DL380.
Auf diesem sind die beiden LAN-Ports als Teaming eingerichtet.

Die ganze Zeit wurde ein unmanaged Netgear Gibabit Switch eingesetzt.
Nun kommt ein HP ProCurve 1910 zum Einsatz.

Frage:
Muß man die beiden Switch-Ports hier speziell dafür konfigurieren, damit die volle Bandbreite genutzt wird?

Viele Grüße,
Herry
Mitglied: manuel1985
26.07.2013 um 10:22 Uhr
Hi,

wenn du VLANs nutzt, müssen die Ports natürlich im gleichen liegen. Sonst aber eigentlich nicht.
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 10:24 Uhr
Hallo,

Die ganze Zeit wurde ein unmanaged Netgear Gibabit Switch eingesetzt.
Nun kommt ein HP ProCurve 1910 zum Einsatz.
Soll der HP den Netgear ablösen?

>Frage: Muß man die beiden Switch-Ports hier speziell dafür konfigurieren, damit die volle Bandbreite genutzt wird?
Gegenfrage sollen denn beide Switche weiter benutzt werden in Zusammenhang mit dem Server?
Kannst Du das mal näher erklären bitte, normaler Weise geht ein Switch und ein anderer kommt (Austausch).

Also in der Regel nennt man das LAG (LACP) unter Zuhilfenahme des STP (RSTP/MSTP) Protokolls.
Am Server müssen Netzwerkkarten installiert sein die das Unterstützen und der Switch ebenso, einziger Fallstrick ist meistens
das man immer ein und das selbe STP Protokoll auf jeder Seite nutzen sollte, zum Beispiel RSTP.

Gruß
Dobby
Bitte warten ..
Mitglied: MrNetman
26.07.2013 um 11:35 Uhr
Hi Herry,

Die Frage ist nicht, wie du den vorherigen Zustand mit dern neuen Harware wieder herstellst, sondern was tu tun musst um es besser zu machen.

Teaming und unmanged Switches sind normalerweise Ausschlußkriterien. Beides zusammen geht nicht. (Klitzekleine Ausnahme: Hot Standby).

Also musst du erst einmal gucken, was für eine Art Teaming eingestellt ist. SLB und TLB erfordern einen gemanagten Switch, der die beiden Ports als einen verbindet. LAG, LACP, Channel, Trunk sind, die übliche Stichworte dafür.
Was ist das Ziel: Der Switch muss die beiden NICs mit den beiden MACs als eine Verbindung betrachten und darf nicht bei jedem Wechsel des Ports einen Broadcast zum Lernen verschicken.

Gruß
Netman
Bitte warten ..
Mitglied: Akcent
26.07.2013, aktualisiert um 12:39 Uhr
Zitat von MrNetman:
Hi Herry,

Die Frage ist nicht, wie du den vorherigen Zustand mit dern neuen Harware wieder herstellst, sondern was tu tun musst um es besser
zu machen.

Teaming und unmanged Switches sind normalerweise Ausschlußkriterien. Beides zusammen geht nicht. (Klitzekleine Ausnahme: Hot
Standby).

Also musst du erst einmal gucken, was für eine Art Teaming eingestellt ist. SLB und TLB erfordern einen gemanagten
Switch
, der die beiden Ports als einen verbindet. LAG, LACP, Channel, Trunk sind, die übliche Stichworte dafür.
Was ist das Ziel: Der Switch muss die beiden NICs mit den beiden MACs als eine Verbindung betrachten und darf nicht bei jedem
Wechsel des Ports einen Broadcast zum Lernen verschicken.

Also der Netgear wurde abgebaut und dafür wurde der HP Switch installiert.
VLANs' sind keine eingerichtet

Im HP-Treiber des Servers sind
- Team Type Selection auf "Automatic (Recommended)"
- Transmit Load Balancing auch auf "Automatic (Recommended)" eingestellt.

Wenn das angepaßt werden muß, was wäre hier Eure Empfehlung und was müßte ich im HP ProCurve machen müßte (da ich den noch nicht so richtig kennen, wäre es gut hier etwas genauer zu beschreiben)
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 13:06 Uhr
Auf beiden Seiten dass selbe STP Protokoll aktiviert? Also als Beispiel RSTP.
Und dann sollte es ja auch laufen.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
26.07.2013 um 13:43 Uhr
Teaming mit einem unmanaged Switch ist technisch unmöglich ! Mit dem netGear kann es also niemals funktioniert haben.
Du musst erstmal ganz genau klären was bei dir Teaming auf der Serverseite genau bedeutet. Dort kann das alles mögliche sein von einem active / passive Szenario bis und und und...
Teaming Option am Server MUSS gem. Standard 802.3ad / LACP sein und nichts anderes !!
Du musst also ganz sicher stellen das der Server DAS kann und auch entsprechend konfigurieren am Server.

Da Teaming / Link Aggreagtion immer eine 2-seitige Sache ist MUSS es auch auf den Switchports definiert werden. Dort muss dann LACP und Link Aggregation (Trunking) aktiviert sein für diese 2 Ports.
Mit entsprechenden "show" Kommandos oder Übersicht musst du sehen ob der LACP Status auf "Operational" oder "Established" geht !!
Tut er das nicht wird der LAG / Trunk nicht gebildet !
Im 1910er Handbuch:
http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c0296532 ...
ist das doch auf Seite 173 ganz genau beschrieben wie es geht.
Du machst mit dem Klicki Bunti Interface eine Dynamische Link Aggregation und gut iss....
Bitte warten ..
Mitglied: Akcent
26.07.2013 um 14:33 Uhr
Zitat von aqui:
Teaming mit einem unmanaged Switch ist technisch unmöglich ! Mit dem netGear kann es also niemals funktioniert haben.

Irrtum. Hat über 3 Jahre genau so funktioniert.

Du musst erstmal ganz genau klären was bei dir Teaming auf der Serverseite genau bedeutet. Dort kann das alles
mögliche sein von einem active / passive Szenario bis und und und...
Teaming Option am Server MUSS gem. Standard 802.3ad / LACP sein und nichts anderes !!
Du musst also ganz sicher stellen das der Server DAS kann und auch entsprechend konfigurieren am Server.
Also auf dem Server kann ich das hier einstellen

unter "Team Type Selection"
- Automatic
- 802.3ad Dynamic with Fault Tolerance
- Switch-assitend Load Balancing with Fault Tolerance (SLB)
- Transmit Load Balancing with Fault Tolerance (TLB)
- Transmit Load Balancing with Fault Tolerance and Preference Order
- Network Fault Tolerance Only (NFT)
- Network Fault Tolerance with Preference Order

Unter Transmit Load Balancing Methode:
- Automatic
- TCP Connection
- Destination IP Adress
- Destination MAC Adress
- Round Robin

Da Teaming / Link Aggreagtion immer eine 2-seitige Sache ist MUSS es auch auf den Switchports definiert werden. Dort muss dann
LACP und Link Aggregation (Trunking) aktiviert sein für diese 2 Ports.
Mit entsprechenden "show" Kommandos oder Übersicht musst du sehen ob der LACP Status auf "Operational"
oder "Established" geht !!
Tut er das nicht wird der LAG / Trunk nicht gebildet !
Im 1910er Handbuch:
http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c0296532 ...
ist das doch auf Seite 173 ganz genau beschrieben wie es geht.
Du machst mit dem Klicki Bunti Interface eine Dynamische Link Aggregation und gut iss....

ok, schaue ich mir einmal an.
Danke!
Bitte warten ..
Mitglied: MrNetman
26.07.2013 um 15:24 Uhr
Zitat von Akcent:

Zitat von aqui:
Teaming mit einem unmanaged Switch ist technisch unmöglich ! Mit dem netGear kann es also niemals funktioniert haben.

Irrtum. Hat über 3 Jahre genau so funktioniert.
Es gibt eine riesengroßen Unterschied zwischen ist gelaufen und hat gut funktioniert.

Deine Serverkonfiguration erfordert eine LAG / Trunk Konfiguration.

Wenn du es nicht tust, dann fällt der Fehler so lange nicht auf wie die Bandbreite nicht genutzt wird. Sobald aber die Datenraten steigen wird der Effekt extrem spürbar.
Jedesmal wenn ein Interface geändert wird, wird dieses neue Paket als Broadcast an alle Switche weiter geleitet und dort auch wieder weiter geleitet. Die Pakete sind als solche leicht zu erkennen. Sie haben gegenüber Broadcasts eine eindeutige Ziel- und Quell-IP und ein sinnvolles Protokoll. Das kann man an jedem beliebigen Switchport mit Wireshark nachvollziehen.
Wenn jetzt viel Verkehr ist und die Sessions wechseln, so ist jeder Wechsel im Initial mit einem neuen "falschen Broadcast" dabei.
Also, wenn die Bandbreite benötigt wird, dann wird das ganze Netz langsam, da der Verkehr an allen Ports ansteigt. Ausnahme: Hinterm Router fällt das nicht mehr auf.

Netman
Bitte warten ..
Mitglied: aqui
26.07.2013, aktualisiert um 16:52 Uhr
... ."Irrtum. Hat über 3 Jahre genau so funktioniert..."
Technischer Blödsinn !
Es hat nie funktioniert nur du hast nie nachgesehen und es nicht gemerkt !! Das ist Fakt !! Siehe Zitat vom Kollegen Netman dazu !
Lies die technischen Grundlagen zu dem Thema, dann weisst du warum !
Auf einem unmanaged Switch ist sowas de facto NICHT zu realisieren...jedenfalls keinen Link Aggregation also die Bündelung mehrerer Links zu einem logischen !

Wenn dnann kannst du bei einem neuen managed Switch nur 802.3ad Dynamic with Fault Tolerance wählen wenn du Link Aggregation also die Bündelung mehrerer Links machen willst !
Alles andere hat mit Teaming im Sinne von Link Aggregation NICHTS zu tun !
Bitte warten ..
Mitglied: Akcent
26.07.2013 um 16:54 Uhr
Danke Netman.

Deine Serverkonfiguration erfordert eine LAG / Trunk Konfiguration.

Wenn du es nicht tust, dann fällt der Fehler so lange nicht auf wie die Bandbreite nicht genutzt wird. Sobald aber die
Datenraten steigen wird der Effekt extrem spürbar.

Ok, das kann ich bestätigen. Es lief, aber nun nicht performant

Jedesmal wenn ein Interface geändert wird, wird dieses neue Paket als Broadcast an alle Switche weiter geleitet und dort auch
wieder weiter geleitet. Die Pakete sind als solche leicht zu erkennen. Sie haben gegenüber Broadcasts eine eindeutige Ziel-
und Quell-IP und ein sinnvolles Protokoll. Das kann man an jedem beliebigen Switchport mit Wireshark nachvollziehen.
Wenn jetzt viel Verkehr ist und die Sessions wechseln, so ist jeder Wechsel im Initial mit einem neuen "falschen
Broadcast" dabei.
Also, wenn die Bandbreite benötigt wird, dann wird das ganze Netz langsam, da der Verkehr an allen Ports ansteigt. Ausnahme:
Hinterm Router fällt das nicht mehr auf.

dann werde ich das nun einmal ändern.

Was genau von der Auswahl sollte ich denn auf dem Server einstellen?

unter "Team Type Selection"
- Automatic
- 802.3ad Dynamic with Fault Tolerance
- Switch-assitend Load Balancing with Fault Tolerance (SLB)
- Transmit Load Balancing with Fault Tolerance (TLB)
- Transmit Load Balancing with Fault Tolerance and Preference Order
- Network Fault Tolerance Only (NFT)
- Network Fault Tolerance with Preference Order

Unter Transmit Load Balancing Methode:
- Automatic
- TCP Connection
- Destination IP Adress
- Destination MAC Adress
- Round Robin

Auf dem Switch selbst kann ich ja nur LACP aktivieren
In der LAN-Karte kann ich SLB und TLB. as ist hier die geschicktere Wahl?

Herry
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 19:18 Uhr
Sein wir mal fair, ohne den Namen und die Bezeichnung des Netgear Switches kann das so oder so keiner nachvollziehen
was der Switch kann oder nicht! Also liegt MrNetman mit einer grundlegenden Aussage das so etwas nicht funktionieren kann so oder so immer im oberen Drittel, also der Name und die genaue Bezeichnung wären schon schön gewesen!

Server
Was genau von der Auswahl sollte ich denn auf dem Server einstellen?
- 802.3ad Dynamic with Fault Tolerance
In der regeln ruhig dem @aqui vertrauen, denn der gewinnt solche Spielchen immer mit nem Schuss aus der Hüfte!
Kannst Du auch gerne via Suchfunktion überprüfen.

Switch
Auf dem Switch selbst kann ich ja nur LACP aktivieren
Und das dazu gehörige STP/RSTP/MSTP bitte, sonst gibt es eventuell einen Netzwerk "Loop"

Gruß
Dobby
Bitte warten ..
Mitglied: Akcent
26.07.2013, aktualisiert um 21:54 Uhr
Sein wir mal fair, ohne den Namen und die Bezeichnung des Netgear Switches kann das so oder so keiner nachvollziehen
was der Switch kann oder nicht! Also liegt MrNetman mit einer grundlegenden Aussage das so etwas nicht funktionieren kann so oder
so immer im oberen Drittel, also der Name und die genaue Bezeichnung wären schon schön gewesen!

Nochmal genau geprüft. Kein Netgear, sondern ein D-Link DGS-1248T


Server
> Was genau von der Auswahl sollte ich denn auf dem Server einstellen?
- 802.3ad Dynamic with Fault Tolerance

Danke

Switch
> Auf dem Switch selbst kann ich ja nur LACP aktivieren
Und das dazu gehörige STP/RSTP/MSTP bitte, sonst gibt es eventuell einen Netzwerk "Loop"


Wenn ich das richtig verstanden / auf Seite 173 gelesen habe,
aktiviere ich unter Network --> LACP die beiden Ports
und unter
Network --> Link Aggregation --> aktiviere ich Dynamic (LACP Enabled), und ebenso die beiden Ports.

Und was mache ich zu STP/RSTP/MSTP?
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 22:02 Uhr
Nochmal genau geprüft. Kein Netgear, sondern ein D-Link DGS-1248T
48-Port Smart Managed Gigabit Switch, der kann sehr wohl eine "Link Aggregation Group" (LACP) anlegen.

Und was mache ich zu STP/RSTP/MSTP?
Das verhindert das Du eine Netzwerkschleife (NetworkLoop) konfigurierst und das Netzwerk lahm legst oder es im günstigsten Fall einfach nur nicht funktioniert.

Das war aber ganz klar mein Fehler das STP wird nur benötigt wenn VLANs eine Rolle spielen respektive mit im Spiel sind oder auf dem LAG weitergeleitet werden.

Allerdings gibt es auf der Seite 171 im oberen Teil einen Abschnitt ("Note") der von zwei Arten des LAG (LACP) spricht
und bei dem einen Fall eines LAG ist es nicht notwendig das STP oder in diesem Falle das MSTP zu aktivieren, nur in
dem anderen Fall wo man aus dem Class1 Konfiguration eine Class2 Konfiguration macht, aber das kannst Du wohl getrost vergessen und daher das mit dem STP Hinweis einfach ignorieren.


Gruß
Dobby
Bitte warten ..
Mitglied: Akcent
26.07.2013 um 22:22 Uhr
Danke Dobby.
Aber das hier ist soweit ok?

- unter Network --> LACP die beiden Ports aktivieren
- unter Network --> Link Aggregation --> aktiviere ich Dynamic (LACP Enabled), und ebenso die beiden Ports.
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 22:42 Uhr
- unter Network --> LACP die beiden Ports aktivieren
- unter Network --> Link Aggregation --> aktiviere ich Dynamic (LACP Enabled), und ebenso die beiden Ports.
Also ich mache das so bei meinem Switch:
Ich lege eine neue LAG an und weise dieser dann einen Namen zu und dann wähle ich die Switch LAN Ports (Member) aus
die zu dieser LAG gehören sollen (Zuweisung), dann speichere ich das ganze ab und gut ist es.

Das läuft bei Dir auch so oder so ähnlich denke ich einmal. Du stellst zuerst die Netzwerkkarte am Server ein
- 802.3ad Dynamic with Fault Tolerance
und dann die LAN Ports am Switch, über das Webinterface ist das in 2 Minuten zusammen geklickt und dann verbindest Du die Kabel fertig.

Gruß
Dobby
Bitte warten ..
Mitglied: Akcent
27.07.2013 um 11:47 Uhr
Habe das heute mal eingerichtet und sieht ganz gut aus.

Danke an alle für die Unterstützung.

Viele Grüße,
Herry
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Switche und Hubs
gelöst HP Procurve Switch 2650 J4899B Hängt, keine Verbindung möglich (7)

Frage von duke1212 zum Thema Switche und Hubs ...

LAN, WAN, Wireless
gelöst HP Procurve VLAN und Routing (3)

Frage von Fisch2005 zum Thema LAN, WAN, Wireless ...

Linux Netzwerk
Verständnisfrage: NIC Bonding über 2 HP Procurve Switches (5)

Frage von g0drealm zum Thema Linux Netzwerk ...

Switche und Hubs
gelöst HP Procurve 2810-48g Firmware download (2)

Frage von MichiBLNN zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...