Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Icons bauen sich bei Windows-XP Start nur sehr langsam auf

Frage Microsoft Windows XP

Mitglied: Matrox

Matrox (Level 1) - Jetzt verbinden

10.12.2005, aktualisiert 18.10.2012, 36697 Aufrufe, 11 Kommentare

Habe seit kurzem das Problem, dass sich die Icons auf dem Desktop nur sehr langsam aufbauen.

Hallo,

seit einiger Zeit bauen sich die Icons nach dem Windows-XP Start nur sehr langsam auf, früher waren die Icons sofort da, woran kann das liegen?

Matrox
Mitglied: gogoflash
10.12.2005 um 23:47 Uhr
Hi,

ohne genau sagen zu können, was der Grund ist.
Sollest mal probieren, deine Tempverzeichnisse zu löschen. (Datenträger bereinigen oder manuell)
Im Autostart schauen, was nicht hineingehört.
Mit MSConfig oder einem Autostartmanager schauen, was vielleicht noch zusätzlich gestartet wird.
Ein toter Link auf dem Desktop, der ins Netzwerk geht, kann u.u. schon der Grund sein.



Gruß Miguel
Bitte warten ..
Mitglied: Biber
11.12.2005, aktualisiert 18.10.2012
Moin Matrox,

ist ein bisschen früh, um einen Lösungsvorschlag zu machen - dazu wäre schon interessant, ob Du eher 20 oder eher 200 Icons auf dem (oder den?) Desktop(s) hast.
Grundsätzlich ist sogar bei M$ aber nicht auszuschließen, dass -wenn Icons auffällig langsam aufgebaut werden- es etwas mit dem Windows-Icon-Handling zu tun hat. Schau doch mal in diesen Thread <a href=http://www.administrator.de/forum/falsche-icons-f%c3%bcr-s%c3%a4mtliche ... target="blank">Falsche Icons für sämtliche Verknüfungen</a>, dort werden ein paar der störanfälligen Stellschrauben behandelt.

Falls Du da nichts findest, beschreib mal etwas genau Deinen Kontext (Größenordnung der Iconanzahl, Auflösung, Größe Icon Cache etc).

Grüße Biber
Bitte warten ..
Mitglied: Teddyhamster2000
11.12.2005 um 03:15 Uhr
Solche Probleme kenne ich eigentlich nur aus Win98 zeiten...

Es könnte sein, dass du komplette *.exe Dateien auf dem Desktop liegen hast. Sollte das so sein, würde ich ersteinmal alles in Verknüpfungen umwandeln ;)

Gruß, Robert
Bitte warten ..
Mitglied: 10545
11.12.2005 um 09:43 Uhr
Moin,

und wenn das alles nix hilft, dann erhöhe die Cache-Größe der ICONS!
Speichere den folgenden Code in eine Datei "IconCache.reg". Starte diese mit Doppelklick, dann wird der Inhalt in Deine REG eingetragen ? absofort hast Du im Explorer einen Zusatzpunkt für die Cache-Größe.

Jetzt noch den Cache (VERSTECKTE DATEI!) löschen ("frisch machen") (W2K: Windowsverzeichnis/"ShellIconCache").

Ab Windows XP heist die Datei "IconCache.db" und nicht "ShellIconCache". Du findest diese Datei im Verzeichnis "C:\Dokumente und Einstellungen\[Accountname]\Lokale Einstellungen\Anwendungsdaten".

Der Inhalt der REG-Datei:
<font class="code">
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer]
"Max Cached Icons"="4096"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache]
"Text"="Icon Cache Größe"
"Type"="group"
"Bitmap"="SHDOC401.DLL,6"
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Seinmall]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="1024 Icons"
"Type"="radio"
"CheckedValue"="1024"
"ValueName"="Max Cached Icons"
"DefaultValue"="4096"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Medium]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="2048 Icons"
"Type"="radio"
"CheckedValue"="2048"
"ValueName"="Max Cached Icons"
"DefaultValue"="4096"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache\Large]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer"
"Text"="4096 Icons"
"Type"="radio"
"CheckedValue"="4096"
"ValueName"="Max Cached Icons"
"DefaultValue"="4096"
"HKeyRoot"=dword:80000002
"HelpID"="update.hlp#51140"
</font>

Gruß, Rene
Bitte warten ..
Mitglied: Matrox
11.12.2005 um 10:33 Uhr
Hallo,

vielen Dank für die ganzen Lösungsvorschläge, werde mich gleich mal an die Umsetzung machen.

@Biber
Es befinden sich 30 Icons auf dem Desktop, außer den Icons "Eigene Dateien", "Arbeitsplatz", "Netzwerkumgebung", "Papierkorb" und "Internet-Explorer" handelt es sich bei den restlichen Icons um reine Verknüpfungen.
Meinen 20,1"-TFT fahre ich über eine Matrox P750 mit einer Auflösung von 1600x1200 bei 32 Bit.
Der Icon-Cache steht auf einem Wert von 1024.

Matrox

EDIT:
Schon alleine die Datenträgerbereinigung hat geholfen- besten Dank nochmals für die ganzen Lösungsansätze und die schnelle Hilfe!

Matrox
Bitte warten ..
Mitglied: Biber
11.12.2005 um 11:32 Uhr
Moin Matrox,

schön, dass es geklappt hat.
Nach den von Dir gelieferten Infos (20,1" TFT und "Max Cached Icons"-Wert von 1024) hätte ich auch sofort aus dem anderem Icon-Thread zitiert:

Wenn Du diesen Schnickschnack nicht brauchst, hier die Sparvariante:
unter... HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer
neue Zeichenfolge "Max Cached Icons" Datentyp REG_SZ eingeben und den Wert "4096" zuweisen.

Denn Deine 1024 sind garantiert zu knapp kalkuliert.

@Rene
In Deiner *.reg ist ein kleiner Tippfehler "....explorer\Advanced\IconCache\Seinmall] " sollte bestimmt "....explorer\Advanced\IconCache\Small] heißen.

Grüße Biber
Bitte warten ..
Mitglied: Matrox
11.12.2005 um 14:03 Uhr
Hallo Biber,

habe soeben den entsprechenden Wert erhöht.

Danke!

Matrox

Moin Matrox,

schön, dass es geklappt hat.
Nach den von Dir gelieferten Infos
(20,1" TFT und "Max Cached
Icons"-Wert von 1024) hätte ich
auch sofort aus dem anderem Icon-Thread
zitiert:

Wenn Du diesen Schnickschnack nicht
brauchst, hier die Sparvariante:
unter... HKEY_LOCAL_MACHINE\ Software\
Microsoft\ Windows\ CurrentVersion\ Explorer

neue Zeichenfolge "Max Cached
Icons" Datentyp REG_SZ eingeben und den
Wert "4096" zuweisen.

Denn Deine 1024 sind garantiert zu knapp
kalkuliert.

@Rene
In Deiner *.reg ist ein kleiner Tippfehler
"....explorer\Advanced\IconCache\Seinmall]
" sollte bestimmt
"....explorer\Advanced\IconCache\Small]
heißen.

Grüße Biber
Bitte warten ..
Mitglied: 10545
11.12.2005 um 19:30 Uhr
Hallo Biber,

@Rene
In Deiner *.reg ist ein kleiner Tippfehler
"....explorer\Advanced\IconCache\Seinmall]
" sollte bestimmt
"....explorer\Advanced\IconCache\Small]
heißen.

Iihhh! Stimmt ..., aber wofür hab ich Dich denn?

Gruß, Rene
Bitte warten ..
Mitglied: Firefoxer
12.12.2005 um 18:04 Uhr
Hallo!
Irgendwie fehlt hier noch die Löschung/bzw. Leerung des Windows Pfrefetch-Ordners (der nach einiger Zeit dermaßen angefüllt ist dass Windoze beim Booten und 'Abklappern' des Ordners auch schon mal leicht ins Schwitzen kommen kann.
Dann würde ich noch die Hdd's überprüfen ob da eine Defragmentierung fällig ist.
Als letztes (lasse offen ob es noch weitere Dinge gibt...) würde ich noch das berühmte 'Verlangsamungshäkchen' entfernen: über 'Rechtsklick-Arbeitsplatz' -> 'Explorer' -> 'Extras' -> 'Ordneroptionen' den Reiter 'Ansicht' betätigen und den Haken bei 'Automatisch nach Netzwerkordnern und Druckern suchen' eliminieren. Das gibt messbare Bootbeschleunigung, zumindest bei schwächeren CPU's...

Greetz Foxer
Bitte warten ..
Mitglied: gimpel55
02.11.2006 um 15:52 Uhr
Eine Frage zu der Reg-Datei:
Bei meinem XP gibt es keine shdoc401.dll
Und nun?
Bitte warten ..
Mitglied: fleisher
28.04.2007 um 16:27 Uhr
unter... HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer
neue Zeichenfolge "Max Cached Icons" Datentyp REG_SZ eingeben und den Wert "4096" zuweisen.
Denn Deine 1024 sind garantiert zu knapp kalkuliert.



das funktioniert großartig allerdings nur bis zum 3.neustart dann is alles wieder beim alten
will meinen: die änderungegen in der reg stellen sich automatich wieder zurück woran kann das liegen??
Bitte warten ..
Ähnliche Inhalte
Windows 7
Client-PCs starten langsam
gelöst Frage von JensDNDWindows 712 Kommentare

Hallo Admins, hab leider in der Suche nichts richtiges dazu gefunden. Einige PCs im Netzwerk starten sehr langsam (ca. ...

Windows XP
Windows XP: Probleme beim Starten
gelöst Frage von nobody8806Windows XP2 Kommentare

Hallo, ich habe in der Firma noch einen PC mit Windows XP. Wenn ich den PC starte, kommt er ...

Visual Studio
Beständigkeit von Windows Icons
gelöst Frage von emeriksVisual Studio2 Kommentare

Hi, weiß jemand und/oder hat längere Erfahrung damit, wie beständig die im Windows mitgelieferten Standard-Icons sind? Wenn ich in ...

Windows Server
Starten einer Anwendung als Domänen User sehr langsam
Frage von jlaufenburgWindows Server2 Kommentare

Hallo, ich habe ein Problem beim starten einer Anwendungen auf einem Server 2012 R2 Datacenter RWRBE60.exe (Das ist von ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 3 StundenWindows 10

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 5 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 19 StundenInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 23 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte15 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...