Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

LAMP Server nicht erreichbar

Frage Linux

Mitglied: 3mil

3mil (Level 1) - Jetzt verbinden

19.12.2006, aktualisiert 30.12.2006, 5027 Aufrufe, 6 Kommentare

Hallo zusammen,

habe folgendes Problem:

mein frisch aufgesetzter LAMP Server ist in meinem Netzwerk nur per Ping erreichbar. Wenn ich die IP Adresse im Browser eines Windows PC´s eingebe kommt auch wie gewünscht die Apache startseite, wenn ich jedoch versuche in den Browser den Namen (in dem Fall habe ich den Server LOKI genannt) eingebe lande ich auf einer Schweizer Seite im Internet.

Selbst das Pingen des Namens bleibt erfolglos. Mein erster Gedanke war das es ein DNS Problem gibt jedoch lassen sich andere (Windows-) PC´s in meinem Netzwerk mittels dem Namen anpingen.

Das Netzwerk:

Ich habe ein ganz normales Client Netzwerk ohne Server, bestehend aus überwiegend Windows PC´s. Diese sind alle an einem DLINK (DI-524) angebunden und der wiederum an den Standartrouter von der Telekom (Eumex 300 IP). Im DLINK Router ist der Webserver auch als Virtueller Webserver mit den passenden Ports eingeben.

Was mache ich falsch??

Bitte um schnelle Hilfe.

Gruß Steve
Mitglied: Hajo2006
19.12.2006 um 14:41 Uhr
Wie hast du denn LAMP eingerichtet? Was gibst du denn als Namen im Browser
genau ein? (http://....)

Ohne genaue Fehlermeldungen kann man wenig damit anfangen. Es wäre schön
wenn du vielleicht ein paar mehr infos geben würdest. Ich habe auch einen Web-
Server in meinem Netzwerk und der geht mit Namen und auch mit IP. Habe ihn
allerdings auf keiner Windowskiste sondern es ist ein reiner Linux-PC...


Gruß
Hajo
Bitte warten ..
Mitglied: AndreasHoster
19.12.2006 um 15:41 Uhr
Dein erster Gedanke ist durchaus der richtige, Du hast ein DNS Problem.
Das sich Windows PCs anpingen lassen kommt daher, daß der Windows Ping als Fallback noch Namensauflösung über WINS macht, was aber bei Deinem Linux Rechner nicht hilft.
Also den Namen und IP in die HOSTS Datei eintragen und siehe da, es sollte tun.
Bitte warten ..
Mitglied: 3mil
19.12.2006 um 16:38 Uhr
Es gibt ja keine Fehlermeldung. Ich gebe im Browser "http://loki/;ein". Danach kommt unten im Browser, die suche über msn und letztlich wird die Seite "www.loki.ch" angezeigt.

Die Sache mit der Hosts Datei funktioniert Danke. Allerdings hab ich keine Lust an jedem PC die Datei zu ändern um das Sie den Server sehen. Zumal ich ja der Meinung bin das beide Router ebenfalls DNS können. Dazu kann es ja nicht Sinn und Zweck sein jedesmal die Hosts Datei zu ändern.

Muss ich jetzt quasi wie einen DNS Server extra konfigurieren um das der PC erreichbar ist??

Das nächste Mysterium ist, das beide Router so konfiguriert sind das ich den Server mit meiner DYNDNS Adresse erreichen sollte, geht allerdings auch nicht. Mir geht da jetzt ehrlich das wissen aus.

Danke für die schnellen Antworten.

Gruß Steve
Bitte warten ..
Mitglied: petenicker
19.12.2006 um 21:33 Uhr
Hallo,

wie sind denn deine Clients konfiguriert? Erhalten sie ihre Netzwerkkonfiguration über DHCP? Wenn ja, vom D-Link-Router oder von Eumex? Führ mal an einem deiner Clients über die Eingabe-Aufforderung ipconfig /all aus. Was steht da bei DNS-Server?
Ich vermute mal, dass wenn die Clients über DHCP konfiguriert werden, dort die DNS-Server der T-Com eingetragen sind, d.h. deine Router mögen zwar DNS-fähig sein, werden aber nicht zur Namensauflösung verwendet.
Netzintern funktioniert meines Wissens nach die DNYDNS-Variante nicht, das geht nur von außerhalb.
Bitte warten ..
Mitglied: AndreasHoster
20.12.2006 um 08:02 Uhr
Wissen ist Macht und woher soll ein DNS Server wissen, daß Du irgendeinen Rechner irgendwie nennst?
Entweder hast Du einen echten DNS Server in Deinem Netz und konfigurierst ihn so, daß er Loki zu der richtigen IP-Adresse auflöst oder man muß es eben jedem Client sagen.
Deine Router mögen ein DNS Forward haben und die Anfragen an den DNS Server Deines Providers weiterleiten, aber mehr auch nicht. Und woher sollen die denn wissen, wer Loki ist?

Und ich weiß ja nicht, wie Dein Netz konfiguriert ist, aber die Aussage <das beide Router so konfiguriert sind das ich den Server mit meiner DYNDNS Adresse erreichen sollte> lässt mich vermuten, daß da was falsch konfiguriert wird.
Der Router, der die Internetverbindung aufrechterhält, muß ankommende Pakete richtig weiterleiten, was soll der 2. da noch machen? Oder hast Du gleich 2 Subnetze und willst doppelt NAT machen?
Bitte warten ..
Mitglied: 32693
30.12.2006 um 11:37 Uhr
Versuche doch mal die IP und Name in die hosts Datei einzutragen.
Das ist eine Datei in der das System erst nachschaut bevor es den DNS Server fragt.
Der Nachteil ist das auf alle Clienten in Deinem LAN diese Datei angepasst werden muss.
LINUX: /etc/hosts oder als Hilfe >man hosts<
WINDOWS: /windows/system32/drivers/etc/ hosts Datei die einfach mit eine Texteditor ändern
Wenn es nur an der Namensauflösung liegt sollte Dein LAMPP aber über die IP erreichbar sein http://<IP>
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkprotokolle
gelöst Site 2 Site VPN - Server erreichbar, Webseite nicht (5)

Frage von 1410640014 zum Thema Netzwerkprotokolle ...

Apache Server
gelöst LAMP Server aufsetzen (2)

Frage von Paster zum Thema Apache Server ...

Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...