Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Laptop über WLAN ins Internet routen

Frage Netzwerke Router & Routing

Mitglied: HaRLeKin668

HaRLeKin668 (Level 1) - Jetzt verbinden

24.02.2006, aktualisiert 26.04.2006, 8984 Aufrufe, 8 Kommentare

Hallo,

ich möchte meinen Laptop über ein WLAN Netzwerk mit meinem PC verbinden und über diesen das Internet benutzen.
Bisher habe ich ein adhoc-Netzwerk erstellt, und beide Rechner über WLAN verbunden.
Das Schema incl. IP-Adressen sieht wie folgt aus:

PC:
Einwahl ins Internet über ein USB-DSL Modem mittels einer DFÜ-Verbindung (ip adresse muss automatisch bezogen werden, Verbindung für gemeinsame Nutzung freigeschaltet)
Netgear WLAN Usb-Stecker (IP: 192.168.0.1, kein Gateway)

Laptop:
PCMCIA WLAN Karte (IP: 192.168.0.2, Gateway: 192.168.0.1)

Leider komm ich mit dem Laptop kein Stück ins Netz. Der Fehler 623: Der Telefonbucheintrag für diese Verbindung konnte nicht gefunden werden erscheint beim Versuch ins Netz zu kommen.

Hat irgendjemand eine Idee, was ich falsch mache?
Danke & gruß
Mitglied: stagatto
24.02.2006 um 15:27 Uhr
Irgendwie scheint dein Notebook sich ins Internet einwählen zu wollen, was was aber so nicht machen sollte, da es ja über das bestehende LAN routen muss.

Ich schätze, Du hast ein Routingproblem an deinem Notebook.

Frage: kannst Du den PC vom Notebook aus anpingen? Was sagt "route PRINT"? Ist die defautroute dann deine WLAN-NIC gebunden?

stagatto
Bitte warten ..
Mitglied: HaRLeKin668
24.02.2006 um 19:18 Uhr
OK, jetzt wirds immer schlimmer.

Ping funktioniert nicht. Beide Computer verbinden sich ins adhoc-Netz, aber keiner sieht den anderen. Bin jetzt langsam echt überfragt... Je mehr ich mache, desto schlechter wirds
Bitte warten ..
Mitglied: HaRLeKin668
25.02.2006 um 09:16 Uhr
ok, es funktioniert... *staun*
aber wie... und warum?

ich habe die ip adressen auf automatisch beziehen eingestellt, nochmal hochgefahren und den internetgateway in den netzwerkeinstellungen gefunden und auf einmal liefs...

würde das jetzt gerne noch verstehen:
route print gibt folgendes für relevante ip adressen des PCs aus:
192.168.0.0 MASK 255.255.255.0 192.168.0.1
192.168.0.1 MASK 255.255.255.255 127.0.0.1
192.168.0.255 MASK 255.255.255.255 192.168.0.1

und fürs Noteboock
192.168.0.0 MASK 255.255.255.0 192.168.0.93
192.168.0.93 MASK 255.255.255.255 127.0.0.1
192.68.0.255 MASK 255.255.255.255 192.168.0.93

ich würde das wirklich gerne nachvollziehen und bin für Erklärungen aller Art sehr dankbar!
gruß
Bitte warten ..
Mitglied: aqui
25.02.2006 um 21:50 Uhr
Eigentlich hast du netzwerktechnisch alles richtig gemacht ! Ich vermute mal das das jetzt ein Zufall war. Was dir wahrscheinlich gefehlt hat, ist der DNS Nameserver Eintrag auf dem Laptop sonst funktioniert die Namensauflösung hier nicht. Der muss hier statisch eingetragen werden und du findest die Adresse auf den Webseiten deines Providers (z.B. 194.25.2.129 für T-Online)
Eigentlich dürfte es jetzt mit deinen beschriebenen Einstellungen gar nicht funktionieren, denn nun hast du beide WLAN Adapter auf dynamische IP Adressvergabe gestellt und das wäre dann die Vergabe über einen DHCP Server, den du aber in deinem Konstrukt gar nicht hast.
Normalerweise fallen dann die Adapter nach einer Timeoutzeit, wenn sie keine Adressen per DHCP bekommen, unter Windows auf APIPA Adressen (http://www.willemer.de/informatik/net/apipa.htm) zurück und wären dann auch wieder im gleichen Netzwerk nur wiederum ohne korrekten DNS Servereintrag ! Also folglich kann es so auch nicht klappen !
Deine Routen sagen aber etwas anderes !! 192.168.0.x ist definitiv keine APIPA Adresse (die fangen mit 169.254.... an) sondern eine Adresse die du ohne Zweifel selber statisch konfiguriert haben musst ! Oder du hast doch irgendwo einen DHCP Server... ??!!
Wenn du ein DOS Fenster eröffnest und dort ipconfig angibst bekommst du die Übersicht über die aktuell eingestellten IP Adressen. (ipconfig -all zeigt auch DNS Adressen und ob deine Adressen statisch oder per DHCP gekommen sind !) So wie oben beschrieben sind deine Angaben widersprüchlich und folglich fällt einem die Erklärung schwer...
Bitte warten ..
Mitglied: HaRLeKin668
27.02.2006 um 16:14 Uhr
Und er kommt zu dem Ergebnis:
"Nur ein Traum war das Erlebnis.
Weil", so schließt er messerscharf,
"nicht sein kann, was nicht sein darf."

Morgenstern - Die unmögliche Tatsache

Ok, vielen Dank erstmal für die Antwort! Da ich recht glücklich bin, daß das meiste momentan super funktioniert und definitiv den Überblick verloren habe, was ich alles gemacht habe, noch einmal die Korrektur, da ich tatsächlich vergessen habe, daß ich den WLAN-Adapter am PC auf eine fixe IP-Adresse (192.168.0.1 MASK 255.255.255.0) eingestellt habe, allerdings den WLAN-Adapter des Laptops frei wählen lasse (weswegen auch wohl die x.x.x.93 zustande gekommen ist)

Dank dem ipconfig -all habe ich herausgefunden, keinen dhcp server zu benutzen.

Irgendwann im laufe meiner Einstellungen habe ich in der registry den key zum routen manuell auf 1, also aktiv, gestellt, vielleicht spielt das eine rolle, immerhin gibt er mir beim ipconfig -all an, daß ip-routing aktiviert sei.

ausserdem habe ich beizeiten noch beide computer derselben arbeitsgruppe zugeteilt.

Kannst du mit diesen Angaben mehr anfangen?
Bitte warten ..
Mitglied: aqui
28.02.2006 um 11:14 Uhr
Mmmmhhh, alles etwas konfus. Wenn der WLAN Adapter auf der einen Seite fix ist und auf der anderen Seite dynamisch per DHCP kann es eigentlich nicht funktionieren, es sei denn zu hast zufällig die richtige Adresse getroffen was eigentlich besser als ein 6er im Lotto währe und nicht wirklich realistisch ist. Die Arbeitsgruppe hat auch keinen Einfluss, da sie nur für Windows Connectivity relevant ist. Egal...wenn jetzt klappt ist ok, "Never touch a running system..."
Bitte warten ..
Mitglied: c00
23.04.2006 um 20:25 Uhr
hallo zusammen,
ich habe hier so ein ähnliches Problem und weiss einfach nichtmehr weiter.
Hab sehr viel hier gelesen aber es nützt mir irgendwie nichts weil ich davon
leider nur die Hälfte verstehe.
Ich wäre sehr dankbar wenn sich jemand die Mühe machen würde speziell
bei meinem Fall.

Folgende Sachlage:
Laptop & PC haben einen USB-WLAN-Adapter gleichen Typs.
Der Laptop wählt sich über den AP ins Inet ein aber der PC nicht,
obwohl Verbindung besteht.
Bei dem Wlan-Utility ist die Info bei beiden:
Infrastructure | No WEP | SSID=ConnectionPoint
Ja- ich weiss das keine Verschlüsselung riskant ist, aber ich muss es so nehmen wie es kommt ;)
Der Inet-Anschluss bei dem ich dranhänge, gehört meinem Onkel (ein Stockwerk höher.)
Der weiss nix davon und hat noch weniger nen Plan wie ich.

Wenn ich richtig gelesen habe, ist nur 1 Verbindung gleichzeitig per Wlan übern
Router ins Inet möglich.
Wie muss ich vorgehn das mein PC,
die Drahtlose Verbindung vom Laptop nutzen kann?
Komischerweise verbindet der PC auch dann nicht mit dem Inet
wenn der Laptop aus ist.

Laptop:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : NETZ
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter Drahtlose Netzwerkverbindung:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : 802.11b USB Wireless LAN Adapter
Physikalische Adresse . . . . . . : 00-02-72-42-C5-7D
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.2.253
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.2.1
DHCP-Server . . . . . . . . . . . : 192.168.2.1
DNS-Server. . . . . . . . . . . . : 192.168.2.1
Lease erhalten. . . . . . . . . . : Sonntag, 23. April 2006 04:10:03
Lease läuft ab. . . . . . . . . . : Dienstag, 19. Januar 2038 05:14:07


ping 192.168.2.1

Ping wird ausgeführt für 192.168.2.1 mit 32 Bytes Daten:

Antwort von 192.168.2.1: Bytes=32 Zeit=5ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=4ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=3ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=3ms TTL=255

Ping-Statistik für 192.168.2.1:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 3ms, Maximum = 5ms, Mittelwert = 3ms

C:\>route print
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 02 72 42 c5 7d ...... 802.11b USB Wireless LAN Adapter
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.2.1 192.168.2.253 30
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.2.0 255.255.255.0 192.168.2.253 192.168.2.253 30
192.168.2.253 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.2.255 255.255.255.255 192.168.2.253 192.168.2.253 30
224.0.0.0 240.0.0.0 192.168.2.253 192.168.2.253 30
255.255.255.255 255.255.255.255 192.168.2.253 192.168.2.253 1
Standardgateway: 192.168.2.1
Ständige Routen:
Keine

PC:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : NETZ
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter Drahtlose Netzwerkverbindung 8:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : 802.11b USB Wireless LAN Adapter #2
Physikalische Adresse . . . . . . : 00-02-72-42-C5-7C
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.2.252
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.2.1
DHCP-Server . . . . . . . . . . . : 192.168.2.1
DNS-Server. . . . . . . . . . . . : 192.168.2.1
Lease erhalten. . . . . . . . . . : Sonntag, 23. April 2006 17:06:24
Lease läuft ab. . . . . . . . . . : Dienstag, 19. Januar 2038 05:14:07


Ping wird ausgeführt für 192.168.2.1 mit 32 Bytes Daten:

Antwort von 192.168.2.1: Bytes=32 Zeit=11ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=9ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=7ms TTL=255
Antwort von 192.168.2.1: Bytes=32 Zeit=10ms TTL=255

Ping-Statistik für 192.168.2.1:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 7ms, Maximum = 11ms, Mittelwert = 9ms

Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x30003 ...00 02 72 42 c5 7c ...... 802.11b USB Wireless LAN Adapter #2 - Paketp
laner-Miniport
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.2.1 192.168.2.252 30
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.2.0 255.255.255.0 192.168.2.252 192.168.2.252 30
192.168.2.252 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.2.255 255.255.255.255 192.168.2.252 192.168.2.252 30
224.0.0.0 240.0.0.0 192.168.2.252 192.168.2.252 30
255.255.255.255 255.255.255.255 192.168.2.252 192.168.2.252 1
Standardgateway: 192.168.2.1
Ständige Routen:
Keine
Bitte warten ..
Mitglied: aqui
26.04.2006 um 22:50 Uhr
@c00

Mmmhh, das ist eigentlich unverständlich das dein PC nicht über den Router arbeiten kann. An der Tatsache das ebenfalls nicht im Alleinbetrieb ohne Laptop funktioniert siehst du das dort irgend etwas noch faul ist mit der Verbindung.
Das Problem liegt allerdings tiefer und anscheinend nicht im WLAN Link, denn anhand deiner IP Adressvergabe auf dem PC kannst du sehen das die WLAN Verbindung zum Router einwandfrei arbeitet, denn sonst hätte der PC keine richtige IP Adresse per DHCP vom Router bekommen (192.168.2.252). Auch ein Ping funktioniert fehlerfrei wie man am Ende sehen kann. Ebenso alle Adressen DHCP etc. sind richtig vergeben !
Es ist also scheinbar kein Fehler auf dem WLAN Link, denn sonst würde der Ping auf das Ethernet Interface des Routers nicht klappen.
Das der WLAN Router nur eine Verbindung ins Internet unterstützt ist Unsinn. Es ist gerade der Sinn von Routern mehreren Stationen den Zugriff zu ermöglichen.
Ich nehme einmal an das dein Router auch einen Kupfer Ethernet Port hat und (hoffentlich) dein PC auch. Das sollte jetzt dein nächster Test sein einmal das Kupfer Interface auszuprobieren. ACHTUNG: Die WLAN Karte MUSS dafür disabled sein (deaktiviert oder ausgeschaltet), sonst ist dein PC mit 2 Beinen im gleichen Netzwerk, das funktioniert in dieser Konstellation nicht !!!
Du solltest mit dem PC einmal folgenden Befehl im DOS Fenster ausführen:

tracert www.heise.de

Das sollte zeigen wo es klemmt auf dem Weg zum Zielhost. Anhand der funktioniereden WLAN Verbindung würde man ketzerisch vermuten dein Onkel hate eine Accessliste auf dem Router und blockt deine IP ...das will ich ihm aber nicht unterstellen.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Internet
gelöst Wlan erzeugen mit Internet von einem USB Modem Stick (8)

Frage von berli6 zum Thema Internet ...

LAN, WAN, Wireless
Tipps und Hinweise - Internet - Netzwerk - WLAN - 3xAP - Spanien (2)

Frage von herrmeier zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
gelöst Laptop über WLAN anmelden mit RADIUS im active directory (2)

Frage von tobivan zum Thema LAN, WAN, Wireless ...

Peripheriegeräte
Hardware Hilfe Internet WLan Zugangsweg Erkennung (2)

Frage von Polarfuchs0815 zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...