Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Leere Seite mit Frames

Frage Entwicklung Webentwicklung

Mitglied: Neokadesh

Neokadesh (Level 1) - Jetzt verbinden

05.04.2010 um 20:55 Uhr, 4821 Aufrufe, 8 Kommentare

Hallo,

ich habe zurzeit ein großes Problem mit Frames.
Rufe ich meine selbstgeschriebene Seite mit Frames auf, bekomme ich des öfteren eine
Leere Seite. Das einzige was er mir oben anzeigt, ist der im <title></title> hinterlegten text.

Manchmal zeigt er mir alles richtig an, aber manchmal nur eine leere Seite obwohl ich nichtmal was verändere.
Falls es hilft, ich benutze Apache als Webserver.

<html>
<head>

<title>OK</title>
</head>
<body>
<frameset cols="80px, 20px" rows="60px, 10px" border= "no" >
<frame src="luf.php" name="Navigation">
<frame src="menu.php" name="menu">
<frame src="bearbeitung.php" name="Daten">
<noframes>
<body>
<h1>Alternativ-Inhalt</h1>
<p>Wird angezeigt, wenn der Browser keine Frames darstellen kann.</p>
<p>Mindest-Inhalt sollten eine Kurzbeschreibung und eine Sitemap sein.</p>

</body>
</noframes>


</frameset>
</body>
</html>
Mitglied: StefanKittel
05.04.2010 um 20:58 Uhr
Hallo,

da es eine statische Seite ist, dürfte dies nicht auftreten und ich würde das Problem auf das Netzwerk oder den Indianer schieben.
Wie ist Deine Verbindung zum Apache?
Probier doch mal einen anderen WebServer, Cassini oder irgendwas einfaches (also nicht IIS).

Stefan
Bitte warten ..
Mitglied: dog
05.04.2010 um 21:27 Uhr
Syntax-Fehler:
Es gibt immer nur ein Body-Element und es steht immer unterhalb von html!
Bitte warten ..
Mitglied: Xpl0iT
05.04.2010 um 21:29 Uhr
Frames sollten nicht mehr benutzt werden. Ist schon fast eine Straftat.

Dein Code ist völlig falsch.
Das <frameset> Tag wird geschlossen wenn die Framedeklaration zu Ende ist. Nicht im Body!
In einer Frameset Deklaration kann man entweder nur Spalten oder nur Zeilen deklarieren nicht gleichzeitig.

Um Frames aus mehreren Spalten und Zeilen zu erstellen müsstest du diese Verschachteln.

Du hast 4 frames Definiert, aber nur 3 Quelldateien.


Ansonsten lege ich dir dies zu Herzen: http://www.webdesign.rudomazin.de/tutorials/php-tutorials/php-include-s ...


gruß
Xpl0iT


ps. wenn du mir dein Frame vorhaben genauer erkäutern würdest. Könnte ich dir den Code dazu schreiben.
Bitte warten ..
Mitglied: Neokadesh
05.04.2010 um 22:14 Uhr
Stimmt ich hab zweimal body drin. Mein Fehler.

So hab mein Quelltext angepasst, aber bekomme weiterhin nur eine leere Seite.

So weit ich weiß, kann ich sowohl zeilen als auch spalten in einem Framset hinzufügen.
Hatte nie Probleme damit und ich glaube nicht, dass es was mit meinem problem zu tun hat.

Ich möchte weiterhin den Apache nutzen. Nur weil es gerade nicht funktioniert, wechsel ich nicht.
01.
<html> 
02.
<head> 
03.
 
04.
<title>OK</title> 
05.
</head> 
06.
<body> 
07.
<frameset cols="80px, 20px" rows="60px"  border= "no" > 
08.
  <frame src="luf.php" name="Navigation"> 
09.
    <frame src="menu.php" name="menu"> 
10.
  <frame src="bearbeitung.php" name="Daten"> 
11.
  </frameset> 
12.
  <noframes> 
13.
   
14.
      <h1>Alternativ-Inhalt</h1> 
15.
      <p>Wird angezeigt, wenn der Browser keine Frames darstellen kann.</p> 
16.
      <p>Mindest-Inhalt sollten eine Kurzbeschreibung und eine Sitemap sein.</p> 
17.
 
18.
    
19.
  </noframes> 
20.
</body> 
21.
</html>
Ich würde gerne auf Frames verzichten, benötige aber für mein Vorhaben zwei unabhängige Seiten die sperate aktuallisiert werden.
Bitte warten ..
Mitglied: StefanKittel
05.04.2010 um 23:11 Uhr
Zitat von Neokadesh:
Ich möchte weiterhin den Apache nutzen. Nur weil es gerade nicht funktioniert, wechsel ich nicht.
Sollst Du ja auch nicht. Aber wir wollen einen Fehler finden. Dazu müssen wir ihn eingrenzen.
Stefan
Bitte warten ..
Mitglied: Terminatorthree
05.04.2010 um 23:11 Uhr
Wie Xpl0iT schon geschrieben hat kann eine Frameset Deklaration nur aus Zeilen ODER Spalten bestehen. Beides gleichzeitig wie bei dir geht nicht. Wenn du dennoch beides verwenden willst muss du 2 Framesets schachteln. Des Weiteren hast du ja die sache mit dem Body schon korrigiert. Außerdem, wenn man es ganz genau nimmt, sollte am Anfang natürlich noch der Doctype stehen.

Ich denke dein Problem löst sich aber schon wenn du die Framesetdefinition berichtigst.

z.B.
01.
<html> 
02.
<head> 
03.
 
04.
<title>OK</title> 
05.
</head> 
06.
 <frameset cols="80px, *" border= "no" > 
07.
  <frame src="luf.php" name="Navigation"> 
08.
  <frameset rows="60px,*" border= "no" > 
09.
     <frame src="menu.php" name="menu"> 
10.
     <frame src="bearbeitung.php" name="Daten"> 
11.
  </frameset> 
12.
 <noframes> 
13.
  <body> 
14.
   <h1>Keine Frames</h1> 
15.
  </body> 
16.
</noframes> 
17.
</frameset> 
18.
</html> 
19.
 
Ich hoffe mal das stimmt jetzt soweit

MfG Terminatorthree
Bitte warten ..
Mitglied: Neokadesh
06.04.2010 um 11:25 Uhr
Hi,

danke, funktioniert jetzt.
Es lag tatsächlich an der deklaration der zeilen und spalten.

Ich habe anfangs versucht die Framsets zu schachteln, war aber ohne Erfolg aufgrund der falschen deklaration.

Danke an Terminatorthree und Xpl0iT
Bitte warten ..
Mitglied: Terminatorthree
06.04.2010 um 11:35 Uhr
Kein Problem gerne doch.
Freut mich wenn auch einmal helfen kann hier, woch ich sonst immer die Hilfe brauche.

MfG
Terminatorthree
Bitte warten ..
Ähnliche Inhalte
Ubuntu
PHP - Nur leere Seiten
Beitrag von 6 Kommentare

Frage von UItimate zum Thema Ubuntu

Router & Routing
Jumbo-Frames über GRE-Tunnel i.V.m. MPLS möglich?
Beitrag von 3 Kommentare

Frage von LordGurke zum Thema Router & Routing

Exchange Server
Exchange Postfach leeren - nicht löschen
Beitrag von 12 Kommentare

Frage von AndreasOC zum Thema Exchange Server

CPU, RAM, Mainboards
CMOS Batterie leer
Beitrag von 8 Kommentare

Frage von Markowitsch zum Thema CPU, RAM, Mainboards

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Beitrag von 4 Kommentare

Anleitung von colinardo zum Thema MikroTik RouterOS

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Beitrag von

Information von BassFishFox zum Thema Sicherheit

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Beitrag von 5 Kommentare

Information von admtech zum Thema Administrator.de Feedback

Vmware

VMware Desktopprodukte sind verwundbar

Beitrag von

Information von Penny.Cilin zum Thema Vmware

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Beitrag von 24 Kommentare

Frage von ahstax zum Thema Visual Studio

Windows Server
RDP macht Server schneller???
Beitrag von 16 Kommentare

Frage von JaniDJ zum Thema Windows Server

Windows Netzwerk
Netzwerk Neustrukturierung
Beitrag von 16 Kommentare

Frage von IT-Dreamer zum Thema Windows Netzwerk

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Beitrag von 15 Kommentare

Frage von Akcent zum Thema Windows 10