Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Leseperformance unter W2k3 dank Reg Eintrag

Frage Microsoft Windows Server

Mitglied: SamvanRatt

SamvanRatt (Level 3) - Jetzt verbinden

05.05.2009, aktualisiert 22:19 Uhr, 2798 Aufrufe, 1 Kommentar

IOMeter auf 100/0 Sequenteill:
Schreiben: toll (rund 150MB/s) und Lesen schlecht <25MB/s

Hallo zusammen
habe zwei Server eines Mitarbeiters übernommen. Beide haben das selbe Problem: misserable Leseperformance und natürlich die üblichen Werte: 4 mal mehr lesen als schreiben pro Tag. Mein Kollege hat in der Serverdoku nichts besonderes vermerkt als "Reg Performance tuning", was nicht unüblich ist (last access time, 8.3 Name abschalten, ...) bei uns. Leider scheint er andere Einstellungen benutzt zu haben denn die Lese/Schreibwerte weichen unabhängig von der Hardware wenig ab: immer wesentlich schlechter lesen als schreiben.
Die Hardware ist recht neu: HP DL380G5 mit RAID1 Kontroller auf 2*15k 450GB SAS HDs. Zum test habe ich die Konfig einmal auf eine einzelne SATA Hd verlagert: selbes Verhältnis: 90MB/s schreiben, 21MB/s lesen (Der Kontroller ist der eingebaute ICH9, bzw ESB2); nehme ich die HD und stecke sie in einen anderen Rechner (DELL Opti 760) zum Auslesen geht's mit den gewohnten 95MB/s lesen bei der Serie. Wenn's ein Server wäre, kann ich es ja verkraften (dann wird halt eine Neuinst fällig), aber ein zweiter der Bereits seit einem Jahr mit rund 350 Usern arbeitet hat das selbe Verhalten, was nun erst auffiel, da ich ein paar sehr große Imagedaten dort abgelegt habe (im Bereich von etwa 40GB je) und zum lesen über zwei Stunden brauchte (da haben aber auch andere ihre Daten noch parallel bearbeitet. Die Benchmarks stammen natürlich vom Alleinbetrieb während der Wartungszyklen. Die Reg Patches die wir nutzen habe ich bereits übergespielt sprich es muss einer sein den wir normal leer haben und Kontrollerunabhängig ist. Die HD ist beim lesen aber in 100% Auslastung, also nicht mit Latenzen belastet oder einer starken Fragmentierung wie meine Erste Vermutung. Evtl sind es auch altlasten da wir bis Anfang des Jahres O&O Soft CleverCache genutzt haben welche ja in die Reg eingreifen um das Caching zu verändern.
Hat jemand einen Ansatzpunkt? Ich würde auf Reg Einträge tippen, aber welche.
Gruß
Sam
Mitglied: SamvanRatt
15.08.2009 um 22:27 Uhr
Hi zusammen
habe heute mal viel Zeit investiert. Das Problem trat nie auf wenn wir mit einer DOS oder PE/Linux CD gebootet haben daher meine Vermutung es liegt am OS, bzw Reg Keys. Nun habe ich im OS, bzw dem HP RAID Controller mal von WriteBack auf WriteThru umschalten müssen (eine HD war ausgefallen und ich wollte den Rebuild starten), bis mir auffiel das die Mühle viel schneller ist. Nach kurzer Recherche viel mir auf das ohne die Redundanz das Teil normal performt; OK redundanz wieder aufgebaut:Kontroller schaltet wieder auf WB und Problem wieder da, statt 150MB/s lesen wieder bei rund 25MB/s; Dreck; Auf der Suche habe ich dann das Batteriekit abgeklemmt und bingo innerhalb einiger Sekunden ist die Mühle wieder schnell; habe daraufhin gemerkt das ich unseren Kontroller nur offline im Modi umschalten kann, ergo Image ziehen; RAID umgebaut und Image zurück+Batterie dran: geht; der andere AHCI Kontroller macht leider auch mit dem Intel Treiber ein WB, ließ sich aber via Reg Key abschalten.
Denke damit ist der und der andere Fall gepatched; wieso dies nur bei den beiden Rechnern auftritt scheint noch ein Problem von bestimmten NTFS Cachesettings zu sein, die aber weder ich noch Kollegen lösen konnten
Gruß
Sam
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Internet Domänen
gelöst Domain Host Eintrag In Richtfunk Netz (7)

Frage von Betact zum Thema Internet Domänen ...

DNS
gelöst Kann wpad Eintrag nicht erstellen (3)

Frage von Ex0r2k16 zum Thema DNS ...

Hosting & Housing
gelöst HILFE! Nameserver-Eintrag und HTTP-Weiterleitung möglich? (1)

Frage von StillerLeser09 zum Thema Hosting & Housing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...