Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux, Samba, Robocopy - Es klappt fast...

Frage Linux Samba

Mitglied: FlintX

FlintX (Level 1) - Jetzt verbinden

28.03.2006, aktualisiert 30.03.2006, 8967 Aufrufe, 5 Kommentare

Hi zusammen,

Vorneweg die Gegebenheiten:

Ein Fileserver, Suse Linux 10, Samba 3.xx, usw.
Dazu eine NAS-Box - Buffalo Terastation...
und ein Client, rennt mit WinXPSP2...

Was soll passieren:
Der WinXP Client soll mittels Robocopy die Daten von der NAS-Box auf den Fileserver spiegeln... Klappt Prima, aber:

Wenn ich jetzt hingehe und auf der NAS-Box ein Verzeichniss lösche, bleibt das, nach dem Robocopy Durchlauf, auf dem Fileserver bestehen, die Dateien darin werden aber gelöscht...
Verblüffend daran ist - es gibt keinerlei Fehlermeldungen oder Log-Einträge (Weder auf der Windows-Büchse, noch auf dem Server...)
Händisches löschen der Verzeichnisse auf dem Fileserver funktioniert...
Wenn ich das spielgeln auf die Platte von dem XP Client oder ne USB-Platte mache, klappts...
Nehme ich einen anderen Client zum spiegeln, ist das Ergebnis das gleiche - Verzeichnisse bleiben leer "übrig"...

Hat jemand eine Idee, woran das liegen kann?

Gruß
Roman
Mitglied: ketchup
28.03.2006 um 22:42 Uhr
kannst du mal deinen robocopy-befehl posten?

j.
Bitte warten ..
Mitglied: FlintX
28.03.2006 um 22:49 Uhr
klar...

ROBOCOPY P: J: /MIR /FFT /W:1 /R:3

unter P: ist die NAS gemappt, unter J: folglich der Samba Share...
Bitte warten ..
Mitglied: 27631
29.03.2006 um 20:08 Uhr
also ich hab genau des gleiche Problem.

Auszug aus der den Windows-Resource-Tools beiliegendem robocopy.doc:
/E Copies all subdirectories (including empty ones).
/PURGE Deletes destination files and directories that no longer exist in the source.
/MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).

selbst mit all diesen Optionen gleichzeitig gesetzt bleibt das leere Verzeichnis im Ziel
liegen. Komischerweise ist im log von robocopy das leere Verzeichnis als Quelle auch
garnicht geführt - es wird anscheinend einfach übersprungen.

jetzt aber feierabend
huha
Bitte warten ..
Mitglied: rrr1
30.03.2006 um 13:03 Uhr
Moin,

ich meine mich erinnern zu können, dass Robocopy Probleme hat, wenn Verzeichnisse in der Root eines Laufwerks liegen. Evtl. wird das Share \\host\share auch so gedeutet.

HTH rrr1
Bitte warten ..
Mitglied: 27631
30.03.2006 um 17:43 Uhr
ich hab das jetzt so ausprobiert:

das Verzeichnis temp hatte ich in der quelle [eigene dateien] gelöscht und nach [H:]
gesynct; unter [H:] gab es dann weiterhin ein leers temp Verzeichnis.
Ich habe es dann eine Ebene weiter unten als temp\testdir\ probiert aber auch dieses
Verzeichnis bleibt in Ziel leer liegen!
Ich hatte in dieses "testdir" sogar daten reinkopiert. Nach dem Sync ist das Verzeichnis zwar noch da, aber es liegt nichts mehr drin, wenn ich in der Quelle Verzeichnis samt Inhalt lösche.

soweit meine Beobachtungen
grüße huha

PS: habs noch ein zweites mal mit anderem verzeichnis und anderen dateien probiert - selbes ergebnis
Bitte warten ..
Ähnliche Inhalte
Samba
Linux SAMBA Vererbbare Berechtigungen des Übergeordneten Ordners Einschließen klappt nicht
gelöst Frage von bonkersdeluxe1Samba8 Kommentare

Guten Tag, Ich hoffe das Ihr mir helfen könnt den Irgendwie stehe ich auf dem Schlauch. Ich möchte gerne ...

Debian
Windows 7 Samba Domänen beitritt klappt nicht, mit Ubuntu, Samba u. Zimbra
gelöst Frage von ckedingDebian12 Kommentare

Hallo zusammen, ich versuche seit Tagen mich an einer Samba3 Domäne anzumelden, mit der Fehlermeldung: "Ein an das System ...

Windows Netzwerk
Linux Samba Freigaben können "angeblich" nicht gemoutet werden
Frage von Der-DudeWindows Netzwerk5 Kommentare

Es ist mir aufgefallen, dass irgendwie niemand eine Lösung oder Erklärung für ein Phänomen hat, welches ich seit einiger ...

Debian
Verständnis Frage zur Linux Rechten + Samba Freigabe
gelöst Frage von suB2010Debian2 Kommentare

Hallo Community, Ich bitte um Eure Hilfe! Hautproblem: Ganz klar mir Fehlt es an Erfahrung. Ich habe mich viel ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner14 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...