Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux, Samba, Robocopy - Es klappt fast...

Frage Linux Samba

Mitglied: FlintX

FlintX (Level 1) - Jetzt verbinden

28.03.2006, aktualisiert 30.03.2006, 8958 Aufrufe, 5 Kommentare

Hi zusammen,

Vorneweg die Gegebenheiten:

Ein Fileserver, Suse Linux 10, Samba 3.xx, usw.
Dazu eine NAS-Box - Buffalo Terastation...
und ein Client, rennt mit WinXPSP2...

Was soll passieren:
Der WinXP Client soll mittels Robocopy die Daten von der NAS-Box auf den Fileserver spiegeln... Klappt Prima, aber:

Wenn ich jetzt hingehe und auf der NAS-Box ein Verzeichniss lösche, bleibt das, nach dem Robocopy Durchlauf, auf dem Fileserver bestehen, die Dateien darin werden aber gelöscht...
Verblüffend daran ist - es gibt keinerlei Fehlermeldungen oder Log-Einträge (Weder auf der Windows-Büchse, noch auf dem Server...)
Händisches löschen der Verzeichnisse auf dem Fileserver funktioniert...
Wenn ich das spielgeln auf die Platte von dem XP Client oder ne USB-Platte mache, klappts...
Nehme ich einen anderen Client zum spiegeln, ist das Ergebnis das gleiche - Verzeichnisse bleiben leer "übrig"...

Hat jemand eine Idee, woran das liegen kann?

Gruß
Roman
Mitglied: ketchup
28.03.2006 um 22:42 Uhr
kannst du mal deinen robocopy-befehl posten?

j.
Bitte warten ..
Mitglied: FlintX
28.03.2006 um 22:49 Uhr
klar...

ROBOCOPY P: J: /MIR /FFT /W:1 /R:3

unter P: ist die NAS gemappt, unter J: folglich der Samba Share...
Bitte warten ..
Mitglied: 27631
29.03.2006 um 20:08 Uhr
also ich hab genau des gleiche Problem.

Auszug aus der den Windows-Resource-Tools beiliegendem robocopy.doc:
/E Copies all subdirectories (including empty ones).
/PURGE Deletes destination files and directories that no longer exist in the source.
/MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).

selbst mit all diesen Optionen gleichzeitig gesetzt bleibt das leere Verzeichnis im Ziel
liegen. Komischerweise ist im log von robocopy das leere Verzeichnis als Quelle auch
garnicht geführt - es wird anscheinend einfach übersprungen.

jetzt aber feierabend
huha
Bitte warten ..
Mitglied: rrr1
30.03.2006 um 13:03 Uhr
Moin,

ich meine mich erinnern zu können, dass Robocopy Probleme hat, wenn Verzeichnisse in der Root eines Laufwerks liegen. Evtl. wird das Share \\host\share auch so gedeutet.

HTH rrr1
Bitte warten ..
Mitglied: 27631
30.03.2006 um 17:43 Uhr
ich hab das jetzt so ausprobiert:

das Verzeichnis temp hatte ich in der quelle [eigene dateien] gelöscht und nach [H:]
gesynct; unter [H:] gab es dann weiterhin ein leers temp Verzeichnis.
Ich habe es dann eine Ebene weiter unten als temp\testdir\ probiert aber auch dieses
Verzeichnis bleibt in Ziel leer liegen!
Ich hatte in dieses "testdir" sogar daten reinkopiert. Nach dem Sync ist das Verzeichnis zwar noch da, aber es liegt nichts mehr drin, wenn ich in der Quelle Verzeichnis samt Inhalt lösche.

soweit meine Beobachtungen
grüße huha

PS: habs noch ein zweites mal mit anderem verzeichnis und anderen dateien probiert - selbes ergebnis
Bitte warten ..
Ähnliche Inhalte
Samba
gelöst Samba 4.2.14 - 4.4.2 auf Debian 8.4 (2)

Frage von internet2107 zum Thema Samba ...

Windows Server
Schattenkopien mit Robocopy (11)

Frage von AveiroCR7 zum Thema Windows Server ...

Backup
Robocopy Inkrementelle Sicherung Windows Share (3)

Frage von firevegeta zum Thema Backup ...

Server
gelöst Robocopy RECYCLE.BIN (21)

Frage von swissbull zum Thema Server ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Microsoft Office
Office Druck fehler (18)

Frage von DaistwasimBusch zum Thema Microsoft Office ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
Uninitialisierte Festplatte - Daten retten (11)

Frage von peterla zum Thema Festplatten, SSD, Raid ...

Microsoft Office
Outlook 2016 in Ordneransicht starten - GPO (9)

Frage von D-Line zum Thema Microsoft Office ...