Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

lm-sensors unter Debian Etch mit Kernel 2.4 will nicht (fehlendes Modul?)

Frage Linux Debian

Mitglied: Drizzt

Drizzt (Level 1) - Jetzt verbinden

05.03.2009, aktualisiert 13:12 Uhr, 5502 Aufrufe, 1 Kommentar

Hallo zusammen,

ich versuche gerade lm-sensors auf meinem Debian Etch Server einzurichten / zu installieren, aber irgendwie will das Perl-Script sensors-detect keine Sensoren finden.

Was ich bisher gemacht habe:
I2C Support im Kernel (2.4.33) aktiviert und in den Kernel compiliert
Ebenso konnte ich die Module für "I2C device interface" und "I2C /proc interface", also i2c-dev und i2c_proc, compilieren und in den laufenden Kernel ohne Fehlermeldungen laden.
Folgende Pakete habe ich per apt-get installiert:
lm-sensors (2.10.1-3)
libsensors3 (s. o.)
Ebenfalls ohne Fehlermeldungen.

Nun mein Problem:
Starte ich nun das Perl-Script sensors-detect, fehlt mir scheinbar das Modul i2c_i801 und ich erhalte die Fehlermeldung:
Sorry, no sensors were detected.
Either your sensors are not supported, or they are connected to an
I2C or SMBus adapter that is not supported. See doc/FAQ,
doc/lm_sensors-FAQ.html or http://www.lm-sensors.org/wiki/FAQ
(FAQ #4.24.3) for further information.
If you find out what chips are on your board, check
http://www.lm-sensors.org/wiki/Devices for driver status.

Gibt es irgendeine Möglichkeit das oben genannte Modul auch für den 2.4er Kernel zu kriegen? Und nein, ich kann/will nicht auf den 2.6er Kernel upgraden.

Welche Möglichkeiten hätte ich noch, die CPU-Temperatur unter Debian auslesen? Oder wäre das evtl. auch in einer VM mit Windows möglich?

mbmon habe ich ebenfalls ausgetestet. Auch dieses Programm findet keine passenden "Sensoren".

Vielen Dank vorab für Eure Hilfe!!
Grüße
Drizzt
Mitglied: Drizzt
08.03.2009 um 15:48 Uhr
Und hier die Lösung:
Von der LM-Sensors-Webseite den Source-Code für i2c und lm-sensors herunterladen. Zuerst wird der i2c-Code in den eigenen Kernel eincompiliert (siehe http://antbear.org/linux24_lm_sensors.html / mkpatch ...).

Das Paket lm-sensors entpacken, Makefile anpassen und make aufrufen. Dies erzeugt alle weiteren benötigten Module. Die Module vorerst per insmod zum Test laden.

Nach einem Neustart und vorherigem kopieren der passenden Module nach /lib/modules... sollte auch ein modprobe funktionieren.

Grüße
Drizzt
Bitte warten ..
Ähnliche Inhalte
Erkennung und -Abwehr
IT-Sicherheit: Koalition will Deep Packet Inspection und Netzsperren (1)

Link von magicteddy zum Thema Erkennung und -Abwehr ...

Apache Server
gelöst Debian CPU Auslastung durch Apache2 sehr hoch (12)

Frage von zeroblue2005 zum Thema Apache Server ...

Hyper-V
Hyper-V 2016 Debian 8 VM frisst Speicherplatz (2)

Frage von m.reeger zum Thema Hyper-V ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (16)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (15)

Frage von Static zum Thema CMS ...

LAN, WAN, Wireless
IP im privaten Netz nicht erreichbar (14)

Frage von guntis zum Thema LAN, WAN, Wireless ...

Java
gelöst Net user per script aus txt oder csv für FTP (12)

Frage von OlliPWS zum Thema Java ...