Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

meldung INVALID PARTITION TABLE nach FIXMBR

Frage Microsoft Windows Installation

Mitglied: fritzra

fritzra (Level 1) - Jetzt verbinden

25.06.2009, aktualisiert 23:28 Uhr, 11780 Aufrufe, 8 Kommentare

Zur Deinstallation von openSuse11.1 neben WinXP sollte Bootvorgang geregelt sein.

Hallo Admin-Forum!

Ich hatte vor einiger Zeit das neue openSuse 11.1 neben mein WinXP installiert und entsprechend weitere Partitionen angelegt.
Alles hat hervorragend funktioniert. openSuse hat via GRUB den Bootvorgang übernommen.

Nun wollte ich das Linux OS lieber in einer virtuellen Box laufen lassen und
zuvor gerne das openSuse deinstallieren.
Ein Kollege meinte, dass nur das Löschen der entsprechenden Partitionen natürlich nicht reichen kann.
Mit fixmbr in der WinXP Wiederherstellungskonsole sollte die Master Boot Record also
wieder auf WinXP standardisiert werden.
Nach angeblich erfolgreichem Neuschreiben erhalte ich beim Start des PC
aber nur die Meldung

invalid partition table.

Was kann ich jetzt tun? Wo liegt mein Fehler?

Ich will natürlich möglichst schnell und einfach wieder an ein laufendes System kommen.
Habe kaum weitere Erfahrung in diesem Bereich.
Beim googeln bin ich über boot.ini und fixboot gestolpert, weiß aber nichts damit anzufangen.

Ich hoffe jemand kann helfen!
Danke, fritzra
Mitglied: michi1983
25.06.2009 um 23:37 Uhr
Hallo,

nachdem du ja weißt, wie du in die Wiederherstellungskonsole kommst, könntest du die Konsole nochmal starten. Dann "fdisk" eingeben.

Dort gibts eine Möglichkeit einzusehen, ob die richtige Partition auf "active" gesetzt ist. Kann dich leider nicht ganz durchs Menü führen, da ich es auch nicht auswendig kann. Aber vielleicht siehst du eh gleich um was es geht.

Mit freundlichen Grüßen, Michael

Edit:
http:
www.datarecovery.com.sg/data_recovery/troubleshoot_invalid_partition_table.htm
vielleicht hilft dir das
Bitte warten ..
Mitglied: 2hard4you
26.06.2009 um 08:27 Uhr
Moin,

mach dem fixmbr auch fixboot machen, da wird der bootsector neu geschrieben.

24
Bitte warten ..
Mitglied: fritzra
26.06.2009 um 09:13 Uhr
Guten Morgen!

Danke Euch für die ersten Hinweise.
Der Fehler ist über Nacht leider nicht besser geworden

Habe nun zunächst mal die Kombination von fixmbr und fixboot ausprobiert.
Ich erhalte im Anschluss an beide Befehle eine Erfolgsmeldung.
Aber nach dem Neustart bleibt es bei INVALID PARTITION TABLE.

Habe auch den Befehl fdisk in der Wiederherstellungskonsole ausprobiert.
Doch dabei scheint es sich um einen ungültigen/unbekannten Befehl für die Konsole zu handeln...

Unter help bekomme ich ne Liste mit den möglichen Befehlen. Da steht fdisk leider nicht dabei. Der Befehl scheint in seiner Beschreibung jedoch sinnvoll zu sein.

ALSO:
Kann ich den Befehl FDISK irgendwo anders verwenden?
Oder seine Funktion durch einen anderen Befehl erhalten?

Kann ich evtl was mit BOOTCFG anfangen?

Beste Grüße, fritzra

Edit:
Habe nun BOOTCFG /ADD versucht und die WinXP Installation, die ja noch auf C: gefunden wird, hinzugefügt.
Es blieb aber erfolglos. Weiterhin kommt es zur Fehlermeldung.

Nun findet BOOTCFG /LIST neben dem alten Eintrag [2] MS WinXP Pro auch meinen neuen Eintrag [1] WinXP.
Beide verweisen auf den gleichen Ort des OS, aber es funktioniert nicht.

BOOTCFG /REBUILD würde wohl auch nur die Win Installation finden und hinzufügen können.
Das scheint mir keine bessere Aussicht zu versprechen als obiges /ADD.

Werde jetzt mal mit BOOTCFG /DEFAULT versuchen den alten Eintrag zumindest als Standardwert festzulegen.
Bitte warten ..
Mitglied: michi1983
26.06.2009 um 09:50 Uhr
Hallo,

mir ist grad eingefallen dass FDISK sowieso nur Sinn macht, wenn deine Festplatte NICHT im NTFS Format ist.
Kannst du dazu Angaben machen?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: KHP
26.06.2009 um 09:50 Uhr
Hallo,

ich denke die Sache mit dem fdisk ist der richtige Weg, es ist sicherlich der Fall, dass das fdisk nicht aus der Konsole gestartet werden kann.
Deshalb solltest Du einfach Deine Suse-CD starten und Dir damit mal die Partitionen ansehen.
1.) von Linux CD starten (Live-Session)
2.) gparted starten (in Konsole eingeben oder aus dem System-Menu raussuchen)
3.) irgendwas verändern, z.B. alte Suse-Partition erneut anlegen, dann wieder löschen oder sowas
4.) Veränderungen speichern
5.) ausprobieren!

Die Fehlermeldung sollte jetzt verschwunden sein, fixboot und fixmbr wirst Du allerdings nochmals ausführen dürfen.

Vielleicht hilfts - Tobias
Bitte warten ..
Mitglied: fritzra
26.06.2009 um 10:11 Uhr
Hallo,
danke Euch für die weiteren Hinweise.

Habe gerade von der SUSE CD ne Live Session gestartet.

@michi1983
Meine XP Partition ist tatsächlich im NTFS Format!
Was heißt das nun für die Möglichkeiten mit FDISK zu arbeiten?
Muss ich das nun canceln?

@KHP
Welchen Zweck soll Deine Anleitung erfüllen?
Besonders 5.) ausprobieren! verwirrt mich.
Geht es darum, erneut und evtl mehrfach die MBR zu ändern, um irgendwann fehlerfreie Einträge zu erhalten?

Danke Euch!
Bitte warten ..
Mitglied: KHP
26.06.2009 um 10:15 Uhr
Der Sinn war, einfach mal die Partition-Table neu schreiben!

Da Du es nicht mit fdisk machen kannst, versuche es mit gparted (bzw. parted).
Bitte warten ..
Mitglied: fritzra
26.06.2009 um 10:50 Uhr
Hallo,

Danke Euch - die Sache ist gelöst!

In der Live Session den MBR neu geschrieben, obwohl da alles einwandfrei ausgesehen hat.

FDISK war der richtige und wichtige Hinweis.

Windows hat wieder gebootet.
In der boot.ini hab ich noch schnell meinen zusätzlichen und überflüssigen Eintrag gelöscht.

Damit startet das XP wieder einwandfrei.

Danke Euch nochmal!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 7
Invalid Partition Table Win7 (7)

Frage von Lauchheimer zum Thema Windows 7 ...

Verschlüsselung & Zertifikate
Verschlüsselung: Mit Veracrypt lässt sich nur eine Partition verschlüsseln (1)

Frage von NCCTech zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst C-Partition vergrößern, bei vorhandenem D? (7)

Frage von 1410640014 zum Thema Windows Server ...

Windows 10
gelöst Partition vor der Systempartition löschen - Windows10 (4)

Frage von Selassi zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...