Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MikroTik - Internetzugriff über nicht default Route per Mangle Regeln

Frage Netzwerke Router & Routing

Mitglied: Tobi_

Tobi_ (Level 1) - Jetzt verbinden

03.10.2012, aktualisiert 13:12 Uhr, 3473 Aufrufe, 11 Kommentare

Hallo zusammen,

folgendes Problem stellt sich mir. Ich habe ein Subnetz(192.168.128.0/24) mit einem Speedport W701V der an einem Telekom DSL Anschluss hängt. Der Übergang in ein anderes Subnetz ist über einen MikroTik RB750GL realisiert. Im anderen Subnetz befindet sich ein Fritzbox die ebenfalls einen DSL Zugang bereitstellt. Nun möchte ich die Clients im 192.168.128.0/24 Subnetz dazu bewegen den Speedport als Internet Gateway zu nutzen und nicht das default FritzBox Gateway des anderen DSL Anschlusses.
Das Subnetz 192.168.128.0/24 hängt an Interface 3 des Mikrotik Gerätes. Darüber wird das Subnetz auch per MikroTik DHCP mit IP Adressen und dem Default Gateway 192.168.128.254 versorgt. Natürlich könnte ich als default GW den Speedport eintragen, damit verliere ich aber die Flexibilität dass der Internetverkehr auch über die FritzBox im anderen Subnetz geleitet werden kann.


Hier meine Geräte im Subnetz:
Sppedport Telekom DSL modem 192.168.128.240
VM Win XP 192.168.128.90
RB750GL port 3 192.168.128.254

Bisher habe ich versucht das per Mangle/Route zu lösen. Ping und traceroute funktionieren korrekt (sie gehen über den Speedport). DNSlookup macht auch keine Probleme. Was hingegen nicht funkioniert ist der Internetzugriff per Browser oder sonstigen Programmen wie Windows Update...

Hier der config Auszug:

01.
/ip firewall mangle 
02.
add action=mark-connection chain=prerouting comment=\ 
03.
    "Mark connection ::: each new connection ::: incoming from 'ether3'" \ 
04.
    connection-state=new disabled=no in-interface=ether3_telekom \ 
05.
    new-connection-mark=conn_Telekom passthrough=yes src-address=\ 
06.
    192.168.128.0/24 
07.
add action=mark-routing chain=prerouting comment="Place a router tag for packe\ 
08.
    ts from Telekom Subnet and destination internet." connection-mark=\ 
09.
    conn_Telekom disabled=no new-routing-mark=fromTelekomSubnetToWWW \ 
10.
    passthrough=yes src-address=192.168.128.0/24 
11.
  
12.
  
13.
/ip route 
14.
add check-gateway=ping comment="----- Internet over Telekom -----" disabled=\ 
15.
    no distance=1 dst-address=0.0.0.0/0 gateway=192.168.128.240 routing-mark=\ 
16.
    fromTelekomSubnetToWWW scope=30 target-scope=10

Der Paketzähler signalisiert auch deutlich dass die Regeln Pakete erkennen. Bin echt langsam am verzweifeln, diese Problem beschäftigt mich schon länger....
Danke!

Grüße Tobi


d3945135a8044beb3e31459cc042ecb9 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Dani
03.10.2012 um 12:45 Uhr
Moin Tobi,
mit einem Speedport W701V der an einem Telekom DSL Anschluss hängt
Das ist schon das erste PRoblem. Denn soweit ich die Serie kenne, kannst du dort keine Routen anpassen bzw. hinzufügen. D.h. den Router müsstest du ersetzen.

Zeichne doch bitte eine grobe Skizze wo was wie verbunden samt allen IP-Adressen der Geräte bzw. Interfaces.


Grüße,
Dani
Bitte warten ..
Mitglied: Tobi_
03.10.2012 um 13:12 Uhr
Grafik ist nun oben eingebaut.
Bitte warten ..
Mitglied: Dani
03.10.2012 um 13:18 Uhr
Moin,
okay... das heißt du müsstest am den Client das Gateway einfach auf den MikroTik Router umkonfiguieren. Auf dem MikroTik Router sollte die FB dann das Default-Router sein. Wenn du nun keine spezielle Firwall-Rule hast, sollte es sofort gehen.


Grüße,
Dani
Bitte warten ..
Mitglied: Tobi_
03.10.2012 um 13:27 Uhr
Die default route auf dem Mikrotik zeigt in Richtung FritzBox und das sollte auch so bleiben. Der Client sendet also sein Daten in Richtung 192.168.128.254 und dort müsste sie dann Richtung Speedport umgebogen werden.

Funktioniert nur leider nicht ganz...
Bitte warten ..
Mitglied: Dani
03.10.2012 um 13:30 Uhr
Okay, falsch verstanden.
Du brauchst eine Route, die sagt wenn die Quell 192.168.128.0 ist und Ziel 0.0.0.0 dann schicke die Daten über 192.168.128.240.

Allerdings kenn ich die MikroTik Router nicht.


Grüße,
Dani
Bitte warten ..
Mitglied: Tobi_
03.10.2012 um 13:33 Uhr
Ja so hätte ich es versucht. Hm dann brauchen wir einen MK Experten!
Bitte warten ..
Mitglied: 108012
03.10.2012, aktualisiert um 17:02 Uhr
Hallo _Tobi_,

entweder Du wartest auf DOG oder aqui hier im Forum oder wenn Du des englischen mächtig bist kannst Du Dein Glück auch im MikroTik Forum versuchen!

Sind das denn getrennte Räume oder Gebäude in denen das Netzwerk installiert ist oder alles in einem
Haus, Wohnung oder Raum?


Gruß
Dobby

Edit #

P.S. Es gibt auch drei Bücher zu MikroTik RouterOS, vielleicht etwas für Dich?

Learn RouterOS 1
Learn RouterOS 2
Learn RouterOS by examples
Bitte warten ..
Mitglied: dog
04.10.2012 um 01:52 Uhr
Also mit eine Von-der-Stange Dual-WAN-Router hättest du das sicher leichter einrichten könnnen...

1. Hast du den Router vor dem Einrichten zurückgesetzt und die Default-Konfiguration gelöscht?

2. Spar dir die zwei Mangle-Regeln (die sollen nur eine bessere Performance bei Hoch-Last bringen), in der Praxis tut es auch eine:
01.
add action=mark-routing chain=prerouting comment="Netz 1 fuer dsl01 Routing Tabelle markieren" disabled=no new-routing-mark=dsl01 passthrough=yes src-address=192.168.128.0/24
3. Du musst von Mangle allen Traffic ausschließen, der nicht ins Internet geht:
01.
 
02.
add action=accept chain=prerouting comment="Bestimmten Traffic von den alternativen Routing-Tabellen ausschliessen (lokaler Traffic)" disabled=no dst-address-list=master-table place-before=0 
03.
 
04.
/ip firewall address-list 
05.
add address=192.168.0.0/24 disabled=no list=master-table 
06.
add address=192.168.128.0/24 disabled=no list=master-table
4. Ich gehe mal davon aus, dass du die Default-Route für das andere Netzwerk einfach nicht gepostet hast.

5. Solange du nicht in Fritzbox und Speedport eine Rückroute für das jeweils andere Netz einträgst, oder eine NAT-Regel auf dem MT hinzufügst wirst du trotzdem nicht so einfach umschalten können.
Bitte warten ..
Mitglied: 108012
04.10.2012 um 02:47 Uhr
Hallo dog,

sag mal würde das funktionieren, wenn man den RB750GL nicht NAT machen lassen würde und nur einfaches Routing?


Gruß
Dobby
Bitte warten ..
Mitglied: Tobi_
04.10.2012 um 17:37 Uhr
Zitat von dog:
Also mit eine Von-der-Stange Dual-WAN-Router hättest du das sicher leichter einrichten könnnen...

1. Hast du den Router vor dem Einrichten zurückgesetzt und die Default-Konfiguration gelöscht?

2. Spar dir die zwei Mangle-Regeln (die sollen nur eine bessere Performance bei Hoch-Last bringen), in der Praxis tut es auch
eine:
01.
> add action=mark-routing chain=prerouting comment="Netz 1 fuer dsl01 Routing Tabelle markieren" disabled=no 
02.
> new-routing-mark=dsl01 passthrough=yes src-address=192.168.128.0/24 
03.
> 
3. Du musst von Mangle allen Traffic ausschließen, der nicht ins Internet geht:
01.
>  
02.
> add action=accept chain=prerouting comment="Bestimmten Traffic von den alternativen Routing-Tabellen ausschliessen (lokaler 
03.
> Traffic)" disabled=no dst-address-list=master-table place-before=0 
04.
>  
05.
> /ip firewall address-list 
06.
> add address=192.168.0.0/24 disabled=no list=master-table 
07.
> add address=192.168.128.0/24 disabled=no list=master-table 
08.
> 
4. Ich gehe mal davon aus, dass du die Default-Route für das andere Netzwerk einfach nicht gepostet hast.

5. Solange du nicht in Fritzbox und Speedport eine Rückroute für das jeweils andere Netz einträgst, oder eine
NAT-Regel auf dem MT hinzufügst wirst du trotzdem nicht so einfach umschalten können.


Klar gehen die Standard Router aber ich möchte mich näher mit dem Thema beschäftigen uns was lernen. Mich faszinieren diese Geräte in Anbetracht des Preises.... Danke für das Beispiel werde es evtl. heute Abend ausprobieren. Die Default Routen habe ich nicht gepostet, richtig.
Bitte warten ..
Mitglied: Tobi_
08.10.2012 um 18:04 Uhr
So die Sache funktioniert, Danke nochmal an dog für die Hilfe!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Mikrotik hex firewall regeln
Frage von ecki33Router & Routing2 Kommentare

Hallo mal wieder Bin jetzt von einem älteren RB750 auf den aktuellen RB750G3 Hex umgestiegen, geht auch alles soweit. ...

LAN, WAN, Wireless
Mit Router verbunden, trotzdem kein Internetzugriff
gelöst Frage von BleistiftLAN, WAN, Wireless4 Kommentare

Hallo, ich habe seit einigen Tagen das Problem, dass mein Laptop mir zwar eine Verbindung mit dem Router anzeigt, ...

Router & Routing
Mikrotik Router und OpenVPN
Frage von Wild-WolfRouter & Routing

Hallo Leute. hänge gerade an einem Problem. Wir haben einen Mikrotik Router auf dem OpenVPN eingerichtet werden soll. Die ...

Router & Routing
Mikrotik Router hinter Firtzbox
Frage von dawdadRouter & Routing3 Kommentare

Moin, ich hätte eine Frage zur Netzwerk Konfiguration eines Mikrotik Routers. Ich nutze eine Fritz box um mich mit ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 13 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 15 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.