Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mod rewrite - https zu http mit Ausnahmen - Problem

Frage Internet Server

Mitglied: Sophie20

Sophie20 (Level 1) - Jetzt verbinden

29.09.2011, aktualisiert 16:00 Uhr, 5639 Aufrufe, 1 Kommentar

mod_rewrite scheint meine .htaccess Umleitung von https auf http nur fehlerhaft zu erkennen.

Hallo Gemeinde,

ich nutze in der .htaccess folgende Umleitungsanweisung für meine Webseite:

RewriteEngine On 
Options +FollowSymlinks 
RewriteBase / 
 
# für www 
RewriteCond %{HTTP_HOST} !^www\.domain\.de$ [NC] 
RewriteRule ^(.*)$ http://www.domain.de/$1 [R=301,L] 
 
# https zu http mit Ausnahme 
RewriteCond %{SERVER_PORT} =443 
RewriteCond %{REQUEST_URI} !=/ordner/ordner/seite.php 
RewriteRule (.*) http://%{SERVER_NAME}%{REQUEST_URI} [R=301,L] 
 
# http zu https mit Ausnahme 
RewriteCond %{SERVER_PORT} =80 
RewriteCond %{REQUEST_URI} =/ordner/ordner/seite.php 
RewriteRule ^(.*)$ https://%{SERVER_NAME}/$1 [L,R=301] 
 
# Frameworksachen 
RewriteRule !\.(gif|jpg|png|ico|js|css|pdf|xml|txt|swf|wmv|zip|cur|rar) - [C] 
RewriteRule .* index.php
Die Seite wird mit http://www.domain.de/ordner/ordner/seite.php?variable=gna aufgerufen und leitet auf https weiter. Nur wird sie dann wieder auf http://www.domain.de/index.php?variable=gna umgeleitet, was in einer Endlosschleife endet.

Könnt Ihr mir beim Lösen des Problems behilflich sein.

Edit: als Webserver setze ich einen Apache/2.2.9 (Debian) ein.

Danke & Gruß,

Sophie
Mitglied: dog
29.09.2011 um 17:23 Uhr
Ein Tipp:

01.
RewriteRule ^(.*)$ https://%{SERVER_NAME}/$1 [L,R=301] 
Überleg dir mal genau, was in $1 steht und wie das zu deiner HTTPS-Regel darüber passt.
Bitte warten ..
Ähnliche Inhalte
Rechtliche Fragen
gelöst Microsoftkonto wurde gehackt - Liegt das Problem direkt bei Microsoft? (6)

Frage von Stefan007 zum Thema Rechtliche Fragen ...

Python
Problem mit Python und imaplib2

Frage von meinsm zum Thema Python ...

Windows 7
gelöst Windows 7 Umzug zum neuen PC (SATA-Problem) (7)

Frage von MaxMoritz6 zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...