Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MSI über Gruppenrichtlinien fehlgeschlagen da Netzlaufwerk noch nicht verbunden.

Frage Microsoft Windows Server

Mitglied: Machete

Machete (Level 1) - Jetzt verbinden

18.07.2011 um 01:08 Uhr, 5366 Aufrufe, 8 Kommentare

Hallo Zusammen,

Bin im Thema Server noch recht neu und hätte da mal eine Frage zur Verteilung von Software über die Gruppenrichtlinien.

Es geht um eine Software, welche ein zentrales Verzeichnis auf dem Server nutzt.
Server: Win 2003 als auch Win 2008.
Clients: XP, Vista und Win 7.

Die Rechner auf welche die Software verteil werden, sind entsprechend die Clients.
Das Zentrale Verzeichnis wird über ein Laufwerks mapping verbunden.

Wenn nun das Setup/MSI verteilt wird, bricht die Installation ab, da vor der Win Useranmeldung das Laufwerk noch nicht verbunden ist.

Die Software hat eine Abfrage drin, ob das gemappte Laufwerk vorhanden ist.

Hat jemand eine Idee wie ich das Ganze hinbekommen könnte?

Vielen Dank schon mal im voraus.

Gruß Machete
Mitglied: breppe
18.07.2011 um 07:08 Uhr
Hallo,

schau dir mal folgende GPO an:
Computerconfg -> Richtlinien -> Admin. Vorlagen -> System -> anmelden -> Bei neustart immer auf Netzwerk warten (so, oder so ähnlich)

Gruß
Bitte warten ..
Mitglied: Xboxer
18.07.2011 um 07:12 Uhr
Hi,

das mit der Abfrage wird immer fehlschlagen, da das Loginscript erst mit der Benutzeranmeldung ausgeführt wird.

Warum nutzt du keine UNC Pfade?

Gruß
Christoph
Bitte warten ..
Mitglied: Machete
18.07.2011 um 07:35 Uhr
Hallo Christoph,

es wird nur ein Verzeichnis gepflegt und dann auf die anderen Server geklont.
In manchen Dateien ist der Pfad hinterlegt, d.h. wenn nun die Clients auf einen anderen Server zugreifen würden
Sie die richtigen Dateien nicht mehr finden da es sich um einen anderen UNC Pfad handelt.

Es kann schon mal vorkommen das bis zu 30 Server im Einsatz sind, diese alle einzeln zu Pflegen wäre zu zeitaufwendig.

@breppe: Werde ich mal nach schauen.

Gruß
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 07:42 Uhr
Moin,

welchen Sinn hat das denn, dass die Software über mehrere Server verteilt werden?

Eigentlich braucht man nur einen und da liegt die Software.

Bei der GPO wird dann die Software aus dem Ordner :

\\Servername\Install

eingetragen und gut ist.
Da braucht man keine Laufwerkmappings - eh sinnlos, weil warum sollen die User auf dieses Verzeichnis direkten Zugriff haben?
Überflüssig und lästig und verwirrend.

VG
Bitte warten ..
Mitglied: tikayevent
18.07.2011 um 09:01 Uhr
Ich lege saemtliche msi-Pakete die per GPO verteilt werden sollen in den SYSVOL-Ordner. Dadrauf haben normale Benuter nur Leserechte, aber die Computer koennen auch vor der Anmeldung darauf zugreifen. Ebenfalls wird das Verzeichnis zwischen allen Domaenencontrollern repliziert. In die GPO haenge ich das msi-Paket dann mit dem DFS-Pfad ein, also \\domaene.local\sysvol\scripts\...
Bitte warten ..
Mitglied: 101238
18.07.2011 um 19:27 Uhr
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000 war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige Ansatz.

Viel Glück
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 19:30 Uhr
Zitat von 101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück

Diese Richtlinie ist nicht relevant, wenn man die Software per UNC Pfad angibt wie ich es oben schrieb.

VG
Bitte warten ..
Mitglied: Machete
18.07.2011 um 22:30 Uhr
Zitat von 101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück



So etwas habe ich bei Herrn Google auch gefunden und es geht nun endlich.

Es werden mehrere Server benötigt, da diese in unterschiedlichen Filialen zum Einsatz kommen.
Die eigentliche Pflege soll aber nur aus einer Filiale heraus stattfinden.

Deshalb keine Installation über UNC Pfad möglich.

Vielen Dank,
Gruß Machete
Bitte warten ..
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Windows Netzwerk
gelöst Anonymer Zugriff auf Netzlaufwerk für WSUS Offline (5)

Frage von hannsgmaulwurf zum Thema Windows Netzwerk ...

Windows 7
ADB Treiber unter Windows 7 isntallationen fehlgeschlagen (3)

Frage von wieselfried zum Thema Windows 7 ...

Batch & Shell
Problem Mapping von Sharepoint Links als Netzlaufwerk

Frage von chaos2go zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...