Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MySQL arbeitet nicht mit PHP

Frage Microsoft Windows Server

Mitglied: medikopter

medikopter (Level 1) - Jetzt verbinden

25.12.2008, aktualisiert 13:30 Uhr, 6111 Aufrufe, 4 Kommentare

Windows 2008 mit Plesk 9 IIS7 und PHP

Hallo zusammen,

ich habe da ein Problem :D

Mein PHP arbeitet nicht mit MYSQL zusammen.
Ich kann den Dienst von MYSQL auch nicht im Dienste Explorer finden.
Mein Server wurde mit Windows 2008 und Plesk 9 vorkonfiguriert.
Dieses Problem hatte ich bei der letzten Neuinstallation schon mal. habe es da aber irgendwie geschafft leider habe ich mir das nicht aufgeschrieben.
websrvmng diesen Dienst gibt es nicht der ist ja meines Wissens für MYSQL verantwortlich. 08c4ad9d3135fcef032d8591bec4aa10-dienste - Klicke auf das Bild, um es zu vergrößern
im Plesk Service Monitor ist allerdings der deinst gestartet auch mehrmaliges neustarte hat nichts geholfen. 50c86c4d98c648e136bd43bd7f0e47c6-plesk1 - Klicke auf das Bild, um es zu vergrößern
in der Plesk Browser Verwaltung ist der Deinst auch als gestartet markiert 9e1ddab766e2892b073d1ad6679a33f2-plesk_2 - Klicke auf das Bild, um es zu vergrößern
wordpress stellt mir die frage ob ich überhaupt MYSQL installiert habe. bdd27ea7282ed78ddee4e2d10dd2406b-wordpress - Klicke auf das Bild, um es zu vergrößern
Joomla sagt ich kann die mindest Voraussetzungen nicht erfüllen da es kein MYSQL gibt. c26021f03747cfdb0e4f0d68b5baa447-1 - Klicke auf das Bild, um es zu vergrößern

Ich habe es aber immerhin schon geschafft das mein IIS7 mit PHP zusammenarbeitet.

Ich bedanke mich schon mal für die Hilfe

und euch noch fröhliche weihnachten

Mit freundlichen Grüßen

Medikopter
Mitglied: Devian
25.12.2008 um 23:47 Uhr
Wenn dein PHP arbeitet, führ mal ein PHPINFO() aus und schau ob du MySQL überhaupt eingebunden hast.. Ist zumindest mein Verdacht, da Joomla rumnörgelt.
Bitte warten ..
Mitglied: medikopter
26.12.2008 um 12:04 Uhr
Lösung
Plesk hat die mysql Daten gar nicht in die php.ini geschrieben.
habe einfach die neue Version von php in das Verzeichnis von dem php5 bei Plesk drüber in installiert dann hat es automatisch die mysql Daten übernommen.

danke trotzdem
Bitte warten ..
Mitglied: Devian
26.12.2008 um 12:06 Uhr
Zitat von medikopter:
Lösung
Plesk hat die mysql Daten gar nicht in die php.ini geschrieben.

Genau das habe ich geahnt. Deshalb mein Vorschlag mit PHPINFO(). Ist fast immer der einfachste Weg einen Bug zu finden.
Bitte warten ..
Mitglied: medikopter
26.12.2008 um 13:10 Uhr
in der php info stand auch das er die ini aus dem Windows Verzeichnes lädt habe die mal zu test zwecken gelöscht lief aber trotzdem noch nach dem neustart.

Ich verstehe nicht warum Plesk das nicht automatisch richtig einrichtet.
Bitte warten ..
Ähnliche Inhalte
PHP
PHP MySQL Login (7)

Frage von Yanmai zum Thema PHP ...

PHP
MySQL-Abfrage mit php: Wert + true bzw. false (2)

Frage von tomolpi zum Thema PHP ...

Batch & Shell
Wie arbeitet das cmdlet "Set-HPBiosUEFIBootOrder" ? (3)

Frage von MasterBaiter zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Firewall
Richtige Grundeinstellungen der Pfsense für mein Netzwerk (15)

Frage von Spitzbube zum Thema Firewall ...

Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...