Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Net Use - Login Script erfordert Eingabe des Benutzernames und des Passwortes

Frage Microsoft Windows Netzwerk

Mitglied: RAinerweis

RAinerweis (Level 1) - Jetzt verbinden

10.10.2014 um 17:33 Uhr, 1849 Aufrufe, 6 Kommentare

Hallo liebe Administratoren Gemeinde,
erst mal ein dickes Lob für Euer tolles Forum

Ich habe hier gerade ein Problem, das mich zum Verzweifeln bringt und natürlich tritt es nur bei meinem Chef auf ... wo sonst

Beim Arbeiten von remote nutzen unsere User eine VPN Verbindung. Sobald diese aufgebaut ist, wird automatisch ein Skript gestartet, um Netzlaufwerke zu mappen.
Dies funktioniert in 99,9% der Fälle perfekt.
Ab und zu, ganz selten, frägt er allerdings bereits beim aller ersten Befehl, dem net use nach Benutzer und Kennwort.

Zur Info: der Rechner ist dabei neu gebootet und kurz nach dem Start wird die VPN aufgebaut gefolgt vom Skript.

Leider konnte ich das Problem nicht nachvollziehen, selbst wenn ich selbst extern bin. Aber es trat auch bei mir und meinem Rechner mal vor x Wochen bereits auf.

Das Problem wurde auch bereits in folgenden Thread beschrieben, aber leider nicht gelöst:
http://www.administrator.de/frage/logonscript-erfordert-eingabe-des-ben ...

Es besteht der Wunsch (meines Chefs), die Ursache zu beheben oder gar einen automatischen Retry zu veranlassen, wenn dies nicht ging.

Ursache:
Wir haben bereits intensiv gesucht. Der Benutzer und dessen Rechte sind ok etc.

Retry:
Wenn net use nach dem Passwort frägt, dann ist es doch bereits zu spät, da dann nur noch das Skript mit Ctrl+C abgebrochen werden kann.
Gibt es also irgendwie die Möglichkeit die Voraussetzungen für Net Use zu testen, sprich warum es nicht geht und zumindest eine sprechende Fehlermeldung auszugeben ?

Würde eine Pause vor dem ersten Net Use von z.B. 5 Sek helfen ?
Wurde ein Net Use /delete als erster Befehl helfen ? Ich glaube eher nicht, da ja der Rechner neu gebootet ist ...

In manchen Foren ließt man, daß man es glaubt gelöst zu haben, indem man User und PW explizit im Skript dem Net Use mitgibt. Dies wage ich zu bezweifeln UND die Skripte sind dann leider nicht mehr User-anonym sowie die PW würden in den Skripten im Klartext stehen (sowie geändert werden müssen sobald sich das PW ändert ...)

Bin für jeden Tip dankbar. Bin irgendwie am Verzweifeln.

Danke im voraus.
Beste Grüße
Rainer
Mitglied: Dani
10.10.2014 um 17:53 Uhr
Moin,
handelt sich um das Gerät des Chefs um ein Notebook, welches Domänenmitglied ist oder um ein privates Gerät?
Wir das Skript manuell gestartet oder durch den VPN-Client?


Gruß,
Dani
Bitte warten ..
Mitglied: Pjordorf
10.10.2014 um 19:35 Uhr
Hallo,

Zitat von RAinerweis:
Beim Arbeiten von remote nutzen unsere User eine VPN Verbindung. Sobald diese aufgebaut ist
Was bedeutet in diesem Fall aufgebaut?

wird automatisch ein Skript gestartet
Vielleicht mal dazwischen etwas warten bis sich dein Rechner mit sein VPN gütlich geeinigt haben? Was passiert denn wenn dort eine ca. 15 Sekunden pause mit ping 127.0.0.1 -n15 eingebaut wird?

Dies funktioniert in 99,9% der Fälle perfekt.
Lohnt sich der Aufwand denn für 0,1 % (Und wie viel ist 100 %)?

Es besteht der Wunsch (meines Chefs), die Ursache zu beheben oder gar einen automatischen Retry zu veranlassen, wenn dies nicht ging.
Warum nicht am Router eine Standort - Standort VPN nutzen um dann eben keine Probleme zu haben?

Wir haben bereits intensiv gesucht
Fragt sich nur wonach?

Der Benutzer und dessen Rechte sind ok etc.
Der Mitarbeiter sollte ja auch gesund sein, gell

Wenn net use nach dem Passwort frägt, dann ist es doch bereits zu spät
Ja.

Gibt es also irgendwie die Möglichkeit die Voraussetzungen für Net Use zu testen
Nun, wir kennen weder deine Firmenumgebung oder die des Reisenden um zu wissen ob du auf Freigaben oder anderes zugreifen kannst mit nur einen halben VPN oder sonst was ohne sich mal eben Authentifizieren zu müssen...

sprich warum es nicht geht und
Fehlendes VPN zu diesem bestimmten Zeitpunkt?

zumindest eine sprechende Fehlermeldung auszugeben ?
Nun, was ist dein Script, was kann das und vor allem wie kann es Fehler auswerten um dir dann eine Sprechende Fehlermeldung zu nennen wo do doch gar nicht weißt was gerade geschieht?

Würde eine Pause vor dem ersten Net Use von z.B. 5 Sek helfen ?
Bestimmt, wenn dein Problem nur darin besteht das es ein zeitliches ist....

Wurde ein Net Use /delete als erster Befehl helfen ?
Kommt drauf an....

Ich glaube eher nicht, da ja der Rechner neu gebootet ist ...
Es gibt aber auch Freigaben welche Persistent sein sollen...

Dies wage ich zu bezweifeln
Nein, die haben teilweise recht, würde aber ein Zeitliches Problem (wie vermutlich bei dir) eben nicht helfen zu lösen.

UND die Skripte sind dann leider nicht mehr User-anonym sowie die PW würden in den Skripten im Klartext stehen (sowie geändert werden müssen sobald sich das PW ändert ...)
Si, Si.

Warum nicht ein Client mit entsprechender Hardware verwenden wo du das VPN noch vor der lokalen Windows Anmeldung abfackeln kannst, Dann könnte auch die GPO "Immer auf das Netzwerk warten" dir helfen.....

Ein Raspberry PI als VPN Router ins Netz und Standort - Standort VPN mit ACL nur für bestimmte Clients und gut ist. Oder sind die Remote alles nur iPads und Co welche am Flughafen oder auf der AIDA Anwendung finden?

Eine kleine PFSense hinter den Fritzboxen kann es auch sein.... Und entlastet deine Clients von ihren Problem.....

Gruß,
Peter
Bitte warten ..
Mitglied: emeriks
11.10.2014 um 16:24 Uhr
Hi,
@Pjordorf
Wenn das VPN noch nicht stehen würde, dann würde auch nicht die Frage nach einem Passwort kommen, sondern einfach "geht nicht", weil das Ziel ja dann nicht erreichbar wäre.

@RAinerweis
Man müsste schon genauer wissen, wie, womit und wohin der VPN-Tunnel aufgebaut wird, um das hier analysieren zu können.
Weiterhin: Mit einem VBS-Scripts könnte man fehlertoleranter reagieren und Meldungen unterdrücken.
z.B. folgendes würde vielleicht helfen, wenn es ein Timing-Problem sein sollte.
01.
on error resume next 
02.
dim FSO : set FSO = CreateObject("Scripting.FileSystemObject") 
03.
dim i : i = 0 
04.
for i = 1 to 10 
05.
  FSO.MapNetworkDrive("X:", "\\server\freigabe") 
06.
  if FSO.DriveExists("X:") then 
07.
    exit for 
08.
  end if 
09.
  Wscript.Sleep 500 
10.
next
E.
Bitte warten ..
Mitglied: rubberman
11.10.2014, aktualisiert um 17:20 Uhr
@emeriks
Meldungen unterdrücken halte ich für kontraproduktiv. Wenn ein Fehler auftritt sollte man das auch merken und den Benutzer nicht im Unklaren lassen.
Ansonsten lässt sich auch mittels Batch prüfen, ob auf einen Netzwerkpfad zugegriffen werden kann. Bin kein "Netzwerker", aber etwa so würde ich das anstellen:
01.
@echo off &setlocal 
02.
 
03.
set "maxtrials=10" 
04.
 
05.
set "share1=\\server\share" 
06.
set "drive1=X:" 
07.
 
08.
rem ~~~~~~~~~~~ 
09.
set "trials=0" 
10.
:retryloop1 
11.
if %trials% lss %maxtrials% if not exist "%share1%\" ( 
12.
  >nul timeout /t 1 /nobreak 
13.
  set /a "trials += 1" 
14.
  goto retryloop1 
15.
16.
if %trials% lss %maxtrials% ( 
17.
  echo Toll 
18.
  net use %drive1% %share1% /persistent:no 
19.
) else ( 
20.
  echo Fehler! 
21.
  pause 
22.
23.
rem ~~~~~~~~~~~
Die in rem's eingepackte Phrase könnte man auch als Subroutine auslagern, wenn man mehrere Laufwerke verbinden will.

Grüße
rubberman
Bitte warten ..
Mitglied: emeriks
11.10.2014 um 17:31 Uhr
Hi,
Meldungen unterdrücken halte ich für kontraproduktiv. Wenn ein Fehler auftritt sollte man das auch merken und den Benutzer nicht im Unklaren lassen.
Der Chef hat sich doch beschwert über die Meldung. Außerdem eine Frage der "Philosophie".

Ansonsten lässt sich auch mittels Batch prüfen, ob auf einen Netzwerkpfad zugegriffen werden kann.
Ja sicher.
Jedoch, hast Du geprüft, wie sich "if not exist \\server\share" verhält, wenn man (noch) keine Zugriffsrechte hat? Kommt da nicht auch erstmal die Passwort-Abfrage?

E.
Bitte warten ..
Mitglied: rubberman
11.10.2014 um 19:56 Uhr
Jedoch, hast Du geprüft, wie sich "if not exist \\server\share" verhält, wenn man (noch) keine Zugriffsrechte hat? Kommt da nicht auch erstmal die Passwort-Abfrage?
Ich glaube nicht. Mit Sicherheit kann ich das aber erst am Montag sagen, wenn ich es ausprobieren kann...

Grüße
rubberman
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
Net use Befehl -Eingabe ungültig nach System-Neustart (8)

Frage von lderigo zum Thema Windows 7 ...

Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows Server
Windows 10 und Windows SSB 2008 - Login Script greift nicht (21)

Frage von heisenberg4 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...