Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

net use bei Win2k und WinXP unterschiedlich

Frage Microsoft Windows Netzwerk

Mitglied: wannoy

wannoy (Level 1) - Jetzt verbinden

05.01.2008, aktualisiert 16.01.2008, 8560 Aufrufe, 5 Kommentare

Möchte Netzwerkdrucker mittels "net use lpt" einem Terminal Server W2003 sichtbar machen

Hallo,

ich habe folgendes Problem:

Wir haben hier in unserem kleinen lokalen Netz (192.168.x, kein DHCP, alles fixe Adressen) einen Netzwerkdrucker stehen. Dieser wird normalerweise von allen Clients (WinXP, Win2K und Win98) via TCP direkt über die IP-Adresse angesprochen. Funktioniert tadellos.

Nun müssen einige Rechner via Remote-Desktop auf einem TS2003 arbeiten. Der Netzwerkdrucker wird aber im Remote-Desktop nicht erkannt. Mit

C:\>net use lpt3 \\DRUCKSERVR\C252 /persistent:yes

habe ich den Netztwerkdrucker auf einem WinXP-Client auf LPT3: gelegt und voilá, kann prima aus dem Remote-Desktop drucken.

Leider führt das beim Win2K Client zu nix!

1. Schritt

C:\>net view
Servername
\\DRUCKSERVER
\\SERVER1
\\SERVER2
Der Befehl wurde erfolgreich ausgeführt.

2. Schritt

C:\>net view \\DRUCKSERVER
Freigegebene Ressourcen auf \\DRUCKSERVER
Name Typ
C252 Drucker
Der Befehl wurde erfolgreich ausgefuhrt.

alles bestens also jetzt den Drucker auf LPT3 mappen:

3. Schritt

C:\>net use lpt3 \\DRUCKSERVER\C252 /persistent:yes
Der Befehl wurde erfolgreich ausgeführt.

--- ab hier gibt es Probleme auf dem Win2K-Rechner:


== Win2K ==
C:\>net view \\DRUCKSERVER
Systemfehler 64 aufgetreten.
Der angegebene Netzwerkname ist nicht mehr verfgbar.

== WinXP ==
Freigegebene Ressourcen auf \\DRUCKSERVER
Freigabename Typ Verwendet
C252 Drucker LPT3
Der Befehl wurde erfolgreich ausgeführt.


Tja und nun Würde mich über einen zielführenden Tipp sehr freuen!

Grüße,
Peter
Mitglied: Weasel1969
05.01.2008 um 21:19 Uhr
Hy,

hab mal "gegoogelt" und bekam das hier als Ergebnis.
Sofern bei dir Produkte der "gelben Gefahr" , sprich Symantec oder CA im Einsatz sind könnte dieser Artikel evtl. hilfreich sein...
M$-KB : KB923360

http://support.microsoft.com/kb/923360/de

Gruß,

Andy

p.s. : Vergiss, bzw. lach dich nicht über die deutsche Übersetzung schlapp... Die englische trifft es besser
Bitte warten ..
Mitglied: wannoy
06.01.2008 um 12:11 Uhr
Hallo Andy,

danke für deine Hilfe.

hab mal "gegoogelt" und bekam das
hier als Ergebnis.
Sofern bei dir Produkte der "gelben
Gefahr" , sprich Symantec oder CA im
Einsatz sind könnte dieser Artikel evtl.
hilfreich sein...

http://support.microsoft.com/kb/923360/de

Den Namen "S..." nehme ich nicht in den Mund, geschweige denn Software aus dieser Ecke auf den Rechner Aber wir hatten tatsächlich früher mal WinFax im Einsatz (auch so ein Produkt, dass "S..." kaputt gemacht hat), also habe ich den Rechner genauer unter die Lupe genommen. Aber weder die fraglichen Dateien von "S..." noch die von CA sind auf der Kiste drauf.

Habe mir inzwischen einen zweiten Win2K-Rechner vorgenommen und immerhin weiß ich jetzt, dass der net use lpt3 schon mal generell nicht richtig ausgeführt wird:

C:\>net use lpt3 \\KMBIZHUB\C252 /persistent:yes
Der Befehl wurde erfolgreich ausgeführt.
C:\>net use
Neue Verbindungen werden gespeichert.
Status Lokal Remote Netzwerk
OK M: \\Nbox\M Microsoft Windows-Netzwerk
OK X: \\Nbox\XFER Microsoft Windows-Netzwerk
OK LPT3 \\KMBIZHUB\C252 Microsoft Windows-Netzwerk
Der Befehl wurde erfolgreich ausgeführt.

jetzt ca. eine Minute warten und:

C:\>net use
Neue Verbindungen werden gespeichert.
Status Lokal Remote Netzwerk
OK M: \\Nbox\M Microsoft Windows-Netzwerk
OK X: \\Nbox\XFER Microsoft Windows-Netzwerk
Getrennt LPT3 \\KMBIZHUB\C252 Microsoft Windows-Netzwerk
Der Befehl wurde erfolgreich ausgeführt.

Also wird das LPT3-Mapping nach kurzer Zeit abgeworfen

Kann ich irgendwo das Logging soweit aufdrehen, dass ich mitbekomme, warum das Mapping getrennt wird?

p.s. : Vergiss, bzw. lach dich nicht über die deutsche Übersetzung schlapp... Die englische trifft es besser

Die maschinell germanisierten MS-Ergüsse tue ich mir schon lange nicht mehr an. Der Heiterkeitsfaktor ist inzwischen nicht mehr so groß

Peter
Bitte warten ..
Mitglied: Weasel1969
06.01.2008 um 13:12 Uhr
Hy,

unter 2000 gibt es das Problem, das Netzlaufwerke nach einer bestimmten Zeit als " disconnected" markiert werden. Nach doppelklick und kurzer Wartezeit sind diese aber wieder verfügbar.
Das wäre jetzt noch ein Denkansatz.
M$ hält auch hier eine Lösung parat, die auch funktioniert ( selbst getestet )

M$-KB: 138365
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q138365&ID= ...

Gruß,
Andy
Bitte warten ..
Mitglied: wannoy
06.01.2008 um 14:51 Uhr
unter 2000 gibt es das Problem, das
Netzlaufwerke nach einer bestimmten Zeit als
" disconnected" markiert werden.
Nach doppelklick und kurzer Wartezeit sind
diese aber wieder verfügbar.
Das wäre jetzt noch ein Denkansatz.

Jaaa, in diese Richtung könnte das gehen! Danke für den Schubser.

M$ hält auch hier eine Lösung
parat, die auch funktioniert ( selbst
getestet )

M$-KB: 138365
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q138365&ID= ...

Werde ich mir gleich mal ansehen.

Gruß,
Peter
Bitte warten ..
Mitglied: wannoy
16.01.2008 um 11:14 Uhr
unter 2000 gibt es das Problem, das
Netzlaufwerke nach einer bestimmten Zeit als
" disconnected" markiert werden.

Nicht nur unter W2K, wie ich feststellen musste; mit XP-Clients passiert das auch. Der MS-KB-Artikel bezieht sich auf den Server und das ist bei uns ein Samba auf Linux. bei Samba habe ich zwar auch eine entsprechende Konfig gefunden und die Disconnect-Zeit auf "unendlich" gesetzt, bringt dennoch nix, es erfolgt immer noch nach kurzer Zeit ein disconnect.

Was nun den LPT-disconnect betrifft, ist es nun bei uns so, dass ein "net use" den LPT3 nach kurzer Zeit (sowohl neim W2K- als auch XP-client) auf disconnected setzt, der Druck aber dennoch funktioniert - wenn auch manchmal erst nach einer Fehlermeldung und ca. 30 Sekunden Wartezeit. Aber immerhin, man kann drucken

Danke nochmal für die Hilfe,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows 7
Net use Befehl -Eingabe ungültig nach System-Neustart (8)

Frage von lderigo zum Thema Windows 7 ...

Batch & Shell
WinXP-PC mit einem Barcodescanner herunterfahren (6)

Frage von Sinzal zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...