Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

PHP Weiterleitung funktioniert nicht mehr

Frage Entwicklung PHP

Mitglied: pagemaker

pagemaker (Level 1) - Jetzt verbinden

02.04.2011 um 12:21 Uhr, 3500 Aufrufe, 3 Kommentare

Hallo, bastle mir gerade ein Kontaktforumlar für einen Kunden zusammen. Das funktioniert auch eigentlich, bis ich noch etwas dran rumgebaut habe.
Mein Problem ist jetzt das die PHP Weiterleitung die bei einem leerem Eingabefeld anspringt, nicht mehr anzieht. Es wird nur noch ein leerer Frame angezeigt.
Hier mal der Code in PHP (submit.php)
01.
  
02.
	 
03.
<?php 
04.
session_start(); 
05.
$_SESSION["kontrolle"] = 0; 
06.
$empfänger = "bla@web.de"
07.
$betreff = "Eintrag im Kontaktforumular"
08.
$absendername = "Kontaktformular"
09.
$absendermail = "bla@bla.de"
10.
 
11.
$name = $_POST["Name"]; 
12.
$strase = $_POST["Strase"]; 
13.
$plz = $_POST["PLZ"]; 
14.
$ort = $_POST["Ort"]; 
15.
$firma = $_POST["Firma"]; 
16.
$mail = $_POST["Mail"]; 
17.
$texted = $_POST["Text"]; 
18.
 
19.
$elofit = $_POST["elofit_inhalt"]; 
20.
$elopress = $_POST["elopress_inhalt"]; 
21.
$polietilenetubi = $_POST["polietilenetubi_inhalt"]; 
22.
$niron = $_POST["niron_inhalt"]; 
23.
$smartflex = $_POST["smartflex_inhalt"]; 
24.
$oiltech = $_POST["oiltech_inhalt"]; 
25.
$multinupi = $_POST["multinupi_inhalt"]; 
26.
$elotherm = $_POST["elotherm_inhalt"]; 
27.
$ecowave = $_POST["ecowave_inhalt"]; 
28.
$elosolar = $_POST["elosolar_inhalt"]; 
29.
 
30.
if ($name == ""
31.
32.
$_SESSION["kontrolle"] = 1; 
33.
Header("Location: kontaktmailer.php");  
34.
exit(); 
35.
36.
if ($strase == ""
37.
38.
$_SESSION["kontrolle"] = 1; 
39.
Header("Location: kontaktmailer.php");  
40.
exit(); 
41.
42.
if ($plz == ""
43.
44.
$_SESSION["kontrolle"] = 1; 
45.
Header("Location: kontaktmailer.php");  
46.
exit(); 
47.
48.
if ($ort == ""
49.
50.
$_SESSION["kontrolle"] = 1; 
51.
Header("Location: kontaktmailer.php");  
52.
exit(); 
53.
54.
if ($firma == ""
55.
56.
$_SESSION["kontrolle"] = 1; 
57.
Header("Location: kontaktmailer.php");  
58.
exit(); 
59.
60.
if ($mail == ""
61.
62.
$_SESSION["kontrolle"] = 1; 
63.
Header("Location: kontaktmailer.php");  
64.
exit(); 
65.
66.
 
67.
 
68.
 
69.
 
70.
 
71.
$text = "Hallo, es gab einen Eintrag im Kontaktformular: 
72.
 
73.
         Name: $name
74.
         Straße: $strase
75.
         Postleitzahl: $plz
76.
         Ort: $ort
77.
         Firma: $firma
78.
         Mailadresse: $mail
79.
 
80.
         Text: 
81.
         $texted 
82.
 
83.
         Der Kunde interessiert sich für folgende Produkte: 
84.
        Elofit: [$elofit
85.
        Elopress: [$elopress
86.
        Polietilenetubi: [$polietilenetubi
87.
        Niron: [$niron
88.
        Smartflex: [$smartflex
89.
        Oiltech: [$oiltech
90.
        Multinupi:  [$multinupi
91.
        Elotherm: [$elotherm
92.
        Ecowave: [$ecowave
93.
        Elosolar: [$elosolar
94.
 
95.
         _________________________________________________________________ 
96.
 
97.
         Diese eMail wurde automatisch verschickt, bitte nicht Antworten. 
98.
         _________________________________________________________________"; 
99.
 
100.
mail ($empfänger, $betreff, $text, "From: $absendername <$absendermail>"); 
101.
 
102.
echo "<font face=\"Arial\">Die Daten wurden erfolgreich gesendet!</font>"
103.
 
104.
 
105.
 
106.
 
107.
?>
Hoffe ich habe mich richtig ausgedrückt und ihr könnt mir helfen.
mfg pagemaker
Mitglied: Arano
02.04.2011 um 13:22 Uhr
Hallo Pagemaker,

die weiße Seite siehst du weil es einen PHP-Fehler gibt
Warning: Cannot add header information - headers already sent ...
Allerdings werden wohl die Fehlermeldungen unterdrückt was eine leere Seite zur Folge hat

Als erstes solltest du also einmal die beiden Leerzeilen am Anfang der Datei entfernen, dann sollte es wieder laufen.
Als zweites solltest du dann dafür sorgen das, solange du daran arbeitetest, die Fehlermeldungen Angezeigt werden.
Das kannst du entweder in der "php.ini", für globale Änderungen, machen oder mit den folgenden beiden Funktionsaufrufen:
01.
<?php 
02.
ini_set('error_reporting',E_ALL|E_STRICT); 
03.
ini_set('display_errors','On'); 
04.
 
05.
// folgend, dein php... 
06.
session_start(); 
07.
... 
08.
.. 
09.
10.
?>
Auf Umlaute in Variablen- und Funktionsnamen sollte man vielleicht besser verzichten ;)


~Arano
Bitte warten ..
Mitglied: pagemaker
02.04.2011 um 13:39 Uhr
vielen dank für die anwort ich weis gar nicht wie lange ich an diesem Fehler verzweifelt bin....
Bitte warten ..
Mitglied: Arano
02.04.2011 um 13:50 Uhr


Gerne doch, schönes Wochenende noch

~Arano
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst htaccess Weiterleitung (4)

Frage von schneerunzel zum Thema Apache Server ...

PHP
PHP 5.3 nach PHP 5.6 portieren (5)

Frage von nippon-tussi zum Thema PHP ...

Netzwerke
gelöst Weiterleitung nach Anmeldung im Captive Portal (1)

Frage von MLangHSE zum Thema Netzwerke ...

Exchange Server
Weiterleitung privater Termine über Exchange (3)

Frage von voelkeml zum Thema Exchange Server ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Microsoft Office
Office Druck fehler (14)

Frage von DaistwasimBusch zum Thema Microsoft Office ...

Festplatten, SSD, Raid
Uninitialisierte Festplatte - Daten retten (11)

Frage von peterla zum Thema Festplatten, SSD, Raid ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...