Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Postfix liefert teilweise keine Mails aus

Frage Internet E-Mail

Mitglied: GunterR

GunterR (Level 1) - Jetzt verbinden

20.06.2008, aktualisiert 24.06.2008, 5887 Aufrufe, 15 Kommentare

Hallo Zusammen,

ich habe ein Problem mit dem ausliefern von Mails über Postfix.
Folgende Meldung ist in der Log:
*
delays=0.19/0/4.8/0.06, dsn=4.0.0, status=deferred (host abc.def-xxxxx.de[217.6.xxx.xx] said: 421 SMTP service not available, closing transmission channel (in reply to MAIL FROM command))
*

Kann mir jemand was zu dieser Meldung sagen?
Die Mail an die Adresse abc.def-xxxxx.de (die Mail wird über unsere neue Firmenadresse verschickt) kommt also dort nicht an, schicke ich von einem GMX-Account eine Mail an die gleiche Adresse kommt diese an.

Help please
Gruß
Gunter
Mitglied: windlicht
20.06.2008 um 11:53 Uhr
Hi!

So wie es aussieht kannst Du zwar mit dem Ziel-Mailserver SMTP sprechen, allerdings ist der SMP-Dienst auf diesem Server nicht verfügbar.

421 SMTP service not available, closing transmission channel

Ggf. würde ich von Deiner Seite aus auf alle Fälle einmal auch die Firewallregeln prüfen, ob die entsprechenden Ports freigeschaltet sind, sicher ist sicher.

Sieht mir aber ganz so aus, als funktionert SMTP nicht auf dem externen Mailserver (des Providers?).

Gruß,

windlicht
Bitte warten ..
Mitglied: windlicht
20.06.2008 um 11:55 Uhr
...

was sagt denn ein telnet auf Port 25 (auf den externen Mailserver)?
Kommt da was zurück?

Gruß,

windlicht
Bitte warten ..
Mitglied: harald21
20.06.2008 um 11:56 Uhr
Hallo,

die Annahme deiner Mail wurde vom remote Host abgelehnt. evtl. haben die einen SPAM-Filter, der euren Mail-Server nicht mag

status=deferred
host abc.def-xxxxx.de[217.6.xxx.xx] said: 421 SMTP service not available

Sind die MX- und PTR-Records für euren Mailserver korrekt eingetragen?

mfg
Harald
Bitte warten ..
Mitglied: windlicht
20.06.2008 um 12:00 Uhr
... Stimmt. Sieht auch nach fehlerhaften MX/PTR-Einträgen aus.
Bitte warten ..
Mitglied: GunterR
20.06.2008 um 12:08 Uhr
Wow, das ging ja eben schnell.

Also sonst sind mir keine Fehler bekannt das Mails NICHT ausgeliefert werden.
Nur diese eine Adresse nimmt die Mails nicht an, ob dort ein Spamfilter ist weiß ich nicht.

Wenn ich ein telnet 217.6.xxx.xx 25 eingebe bekomme ich folgendes zurück:
Trying 217.6.xxx.xx...
Connected to 217.6.xxx.xx.
Escape character is '^]'.
220 SMTP service ready
helo
250 Requested mail action okay, completed
ehlo
250 Requested mail action okay, completed


Gruß
Gunter
Bitte warten ..
Mitglied: harald21
20.06.2008 um 12:14 Uhr
Hallo,

am SPAM-Filter des Remote-Mailservers kannst du nichts drehen, wohl aber an der Ursache, warum dieser keine Mails von euch annimmt.

Überprüfe dein DNS!

mfg
Harald
Bitte warten ..
Mitglied: GunterR
20.06.2008 um 12:16 Uhr
@harald

Das ich am Remote-Mailserver leider nichts drehen kann ist logisch, danke dir.

Was sollte ich im DNS ändern, damit das geht?

Gruß
Gunter
Bitte warten ..
Mitglied: dreadnik
20.06.2008 um 12:53 Uhr
Hallo,

in Klammern steht da ja: "in reply to MAIL FROM command".
Vielleicht ist bei dem User ne falsche Mailadresse eingetragen.
D.h.: nicht eure Domain als Absendeadresse.
Wenn der externe Server dann den Domainnamen auflöst und der nicht mit der IP des Absenders übereinstimmt.....

Gruß Klaus
Bitte warten ..
Mitglied: harald21
20.06.2008 um 12:54 Uhr
Hallo,

für eure Domäne gibt es eine Forward-DNS-Zone (entweder bei euch oder bei eurem ISP), dort muß der MX-Record auf den Mail-Server zeigen.
Dann gibt es für den IP-Bereich eures Mail-Servers eine Reverse-Lookup-Zone (wahrscheinlich bei eurem ISP). Dort sollte ein PTR-Record existieren, der die IP-Adresse eures Mailservers dem Hostnamen eures Mailservers zuordnet.

mfg
Harald
Bitte warten ..
Mitglied: GunterR
20.06.2008 um 13:11 Uhr
@harald21

Danke dir.
Das sollte eigentlich alles stimmen.
Bis jetzt hatten wir auch absolut keine Probleme mit verschicken oder empfangen von Mails nur dieser Empfänger macht Probleme.

@dreadnik
Mh...wie kann ich das überprüfen?


Gruß
Gunter
Bitte warten ..
Mitglied: dreadnik
24.06.2008 um 10:23 Uhr
Hallo,

bin erst jetzt wieder dazu gekommen hier vorbei zu schauen. Was ich meine, ist die Adresse, die im Mailclient eingetragen ist.
Bsp.: Outlook
Hier müsstest du das Mailkonto überprüfen.
D.h. Extras-> E-Mailkonten und dann im Reiter Allgemein die E-Mailadresse prüfen.
Die Fehlermeldung kommt ja auf die Antwort auf das MAIL FROM Kommando, was die eigene E-Mailadresse ist.
Wenn du jetzt von @microsoft.com schickst aber in deinem Mailclient @microschrott.com eingetragen hast (ausversehen) gibts Probleme.

Gruß Dreadnik
Bitte warten ..
Mitglied: GunterR
24.06.2008 um 10:45 Uhr
@dreadnik

Vielen Dank für deine Antwort.

Nein, die Adresse ist richtig eingetragen, leider.


Aber Frage:
Wie kann ich Reverseauflösung ausprobieren ob die stimmt?


Gruß
Gunter
Bitte warten ..
Mitglied: dreadnik
24.06.2008 um 11:29 Uhr
Den Mailvorgang kannst du über Telnet (vorausgesetzt keine SSL-Verschlüsselung) nachspielen.

Im Telnet:
open mail.beispiel.com 25

Dann kannst du wie folgt das SMTP Protokoll durchspielen.

(von www.rfc-editor.org kopiert):

S: MAIL FROM:<Smith@Alpha.ARPA>
R: 250 OK

S: RCPT TO:<Jones@Beta.ARPA>
R: 250 OK

S: RCPT TO:<Green@Beta.ARPA>
R: 550 No such user here

S: RCPT TO:<Brown@Beta.ARPA>
R: 250 OK

S: DATA
R: 354 Start mail input; end with <CRLF>.<CRLF>
S: Blah blah blah...
S: ...etc. etc. etc.
S: <CRLF>.<CRLF>
R: 250 OK

Deine Fehlermeldung kommt schon auf das MAIL FROM Kommando, darum meine Vermutung.

Deine eigenen Daten kannst du hier testen:

http://www.dnsstuff.ch/
oder hier
http://www.serversniff.de/

Hoffe hilft dir weiter

Gruß Dreadnik
Bitte warten ..
Mitglied: GunterR
24.06.2008 um 11:31 Uhr
Super das hilft bestimmt.

Gruß
Gunter
Bitte warten ..
Mitglied: GunterR
24.06.2008 um 16:33 Uhr
@All

Also, ich habe mal in den Queues geschaut und etwas geforscht.

Es liegt am Reverse DNS.
Einträge werden jetzt gemacht.

Gruß
gunter
Bitte warten ..
Ähnliche Inhalte
Ubuntu
gelöst Postfix Weiterleitung wenn Sender gleich .? (8)

Frage von SIPSIP zum Thema Ubuntu ...

E-Mail
Postfix + Dovecot mehrere Domains erhalten keine Mail

Frage von redShanks zum Thema E-Mail ...

Suse
Postfach aus Postfix exportieren (10)

Frage von tomi93 zum Thema Suse ...

DNS
Bind: Reverse DNS setzt teilweise aus

Frage von ketanest112 zum Thema DNS ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (59)

Frage von pjrtvly zum Thema Internet ...

DSL, VDSL
VDSL Signal via PowerLine an Fritzbox - Möglich? (19)

Frage von Seichobob zum Thema DSL, VDSL ...

Windows Server
Benutzer sperrt sich immer wieder im Active Directory Contoller (18)

Frage von Kirdy1301 zum Thema Windows Server ...