Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem bei DNS-Auflösung, obwohl nslookup korrekte IP liefert

Frage Microsoft Windows Netzwerk

Mitglied: crasherblue

crasherblue (Level 1) - Jetzt verbinden

10.08.2014, aktualisiert 11.08.2014, 3701 Aufrufe, 6 Kommentare

Hallo zusammen,

ich habe ein nerviges Problem, dessen Ursache ich einfach nicht auf die Schliche komme. Folgender Netz-Aufbau:

Im Standort X (Zentrale) steht ein Windows Server 2008R2 als DC namens DCFS (192.168.2.251) und ein 2008R2 als Terminalserver namens WTS2008R2 (192.168.2.250), Domäne lautet meganet.local, 192.168.2.0/24

Ich habe mehrere Filial-Standorte A-E, die per VPN über Lancom-Router angebunden sind (192.168.A-E.0/24). In A-E stehen keine Server, der jeweils vor Ort vorhandene Lancom-Router ist DHCP-Server. Die Client-PCs sind allesamt Win7 Professional, die gegen den DCFS authentifizieren und beziehen Ihre IPs eben vom Lancom; der erste DNS-Server in den DHCP-Optionen ist der DCFS, damit die Domänenanmeldung klappt.

Folgendes Phänomen, was nicht immer, aber immer öfter bei den Clients auftaucht nach einem Neustart: sie können den Namen wts2008r2 nicht auflösen.

ping wts2008r2 
Ping-Anforderung konnte Host "wts2008r2" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut. 
 
ping wts2008r2.meganet.local 
Ping-Anforderung konnte Host "wts2008r2.meganet.local" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut.
ABER:

ping dcfs 
 
Ping wird ausgeführt für DCFS.meganet.local [192.168.2.251] mit 32 Bytes Daten: 
Antwort von 192.168.2.251: Bytes=32 Zeit=74ms TTL=126 
...
ipconfig /all: (verkürzt)
Ethernet-Adapter LAN-Verbindung: 
 
   Verbindungsspezifisches DNS-Suffix: meganet.local 
   DHCP aktiviert. . . . . . . . . . : Ja 
   Autokonfiguration aktiviert . . . : Ja 
   IPv4-Adresse  . . . . . . . . . . : 192.168.10.147(Bevorzugt) 
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0 
   Lease erhalten. . . . . . . . . . : Sonntag, 10. August 2014 11:29:38 
   Lease läuft ab. . . . . . . . . . : Sonntag, 10. August 2014 19:49:35 
   Standardgateway . . . . . . . . . : 192.168.10.254 
   DHCP-Server . . . . . . . . . . . : 192.168.10.254 
   DNS-Server  . . . . . . . . . . . : 192.168.2.251 
                                       192.168.10.254 
   NetBIOS über TCP/IP . . . . . . . : Aktiviert
nslookup ist spannend:
nslookup wts2008r2 
Server:  dcfs.meganet.local 
Address:  192.168.2.251 
 
Name:    wts2008r2.meganet.local 
Address:  192.168.2.250
ping 192.168.2.250 
 
Ping wird ausgeführt für 192.168.2.250 mit 32 Bytes Daten: 
Antwort von 192.168.2.250: Bytes=32 Zeit=86ms TTL=126 
...
Das interessanteste ist, dass es funktioniert, sobald ich einen ipconfig /renew mache, was haargenau die gleichen ipconfig-Daten ergibt.

Die IP des wts2008r2 ist also pingbar, nslookup liefert die korrekte IP zum Namen, die Auflösung des direkt danebenstehenden dcfs klappt, nur die Auflösung des wts2008r2 nicht. Hat jemand eine Idee, was die Ursache sein könnte? Das ganze beschränkt sich auch nicht auf nur eine Filiale, sondern mittlerweile sporadisch alle.

Vielen Dank im Voraus für Eure Hilfe.
Mitglied: Pjordorf
LÖSUNG 10.08.2014, aktualisiert 11.08.2014
Hallo,

Zitat von crasherblue:
Folgendes Phänomen, was nicht immer, aber immer öfter bei den Clients auftaucht nach einem Neustart:
Neustart des DNS Servers oder der Clients?

Nimm mal dein Kabelhai (Wireshark) und schau was bei deinen DNS Anfragen TATSÄCHLICH passiert und schau Wer fragt, wer antwortet und vor allem WANN wird geantwortet.

Weiterhin solltest du dir deine lokalen Caches mal anschauen "Ipconfig /displaydns" und "arp -a" sowie auf deiner Serverseite.

WINS aktiviert?
Routing korrekt?

Gruß,
Peter
Bitte warten ..
Mitglied: gemini
LÖSUNG 10.08.2014, aktualisiert 11.08.2014
Hallo crasherblue,

du hast auf dem Client einen zweiten DNS 192.168.10.254 eingetragen, wahrscheinlich der Lancom Router.
Den würde ich zuallererst mal rausnehmen.

Gruß,
gemini
Bitte warten ..
Mitglied: crasherblue
10.08.2014 um 19:41 Uhr
Hallo Peter,

Neustart der Clients habe ich gemeint, quasi jeden Tag nach dem Hochfahren.

WINS ist deaktiviert, Routing ist korrekt.

Nach eben wieder neugestartetem Client funktioniert die Auflösung wieder nicht; arp -a listet keinen Eintrag, ipconfig /displaydns listet nach einem Ping auf den WTS

    wts2008r2 
    ---------------------------------------- 
    Der Name ist nicht vorhanden.
Wireshark habe ich eben laufen gelassen und damit erstmals einen Grund gesehen, danke für den Tipp: die DNS Anfrage geht an den Router, der dann eben auch korrekterweise keine Antwort hat. Der Router steht als zweiter DNS in den DHCP-Optionen drin, als erster jedoch der DCFS. Dieser taucht im Wireshark nicht auf, es wird also direkt der falsche DNS befragt. Nach dem ipconfig /renew scheint es dann zu klappen. Dann habe ich jetzt stark den DHCP-Server der Lancom-Router im Verdacht, werde ich erstmal genauer untersuchen und hier nochmal schreiben woran es lag.
Bitte warten ..
Mitglied: crasherblue
10.08.2014 um 19:42 Uhr
Hallo gemini,

werde ich versuchen, da meine eigenen Ergebnisse ja jetzt auch schon in diese Richtung weisen. Dankeschön.

Ronny
Bitte warten ..
Mitglied: crasherblue
11.08.2014 um 09:48 Uhr
Es liegt am Lancom als DNS (was er trotzdem ist). Sobald dieser per DHCP mit angegeben wird, wenn auch nur als zweiter DNS, dann werden seltsamerweise die DNS-Anfragen der Clients nicht mehr an den DCFS gesendet sondern an eben diesen. Nehme ich als zweiten DNS einen anderen (es gibt da in der Topologie noch weitere mögliche, die ich hier nicht genannt habe), dann funktioniert das wunderbar.

Also vielen Dank für die Hilfe.
Ronny
Bitte warten ..
Mitglied: Pjordorf
11.08.2014 um 10:41 Uhr
Hallo,

Zitat von crasherblue:
Es liegt am Lancom
Das glaube ich definitiv NICHT! Warum? Du hast einen Primary und einen Secondary DNS an deinen Clients eingetragen. Egal welchen Secondary DNS du eintragen lässt (DHCP), es wird immer NUR der Secondary befragt. Warum? So sieht es zumindest aus nach deinen Worten.

Trage mal an einen Client NUR den Primary ein (dein normaler DNS 2.251) WAS passiert dann? Können irgendwelche Namen aufgelöst werden (interne und / oder Externe)? Lass per Wireshark am Client ein Capturefilter auf Port 53 laufen und beobachte.

Trage einen Secondary DNS und teste noch einmal, auch per Wireshark. Was passiert dann?

Dir ist schon klar das der Secondary DNS erst genommen wird wenn der Primary NICHT ERREICHBAR sein sollte, oder? Nicht erreichbar kann alles mögliche sein. Selbst wenn der Primary DNS ein Antwort ala "Name nicht bekannt" liefert, wäre der DNS selbst aber erreichbar. Warum sollte dein Client also veranlasst werden sich in seiner Liste der DNS Server den nächsten zu nehmen? Es kommt da nur einen nicht Erreichbarkeit in frage oder einen Timeout, wobei der Timeout dir auffallen würde, da dies doch spürbar dauert.

Dein Client sollte nach 15 Minuten intern wieder auf seinen Primären DNS zurückgreifen und diesen befragen wollen.

http://technet.microsoft.com/en-us/library/bb457118.aspx
http://serverfault.com/questions/52923/when-does-a-windows-client-stop- ...

Gruß,
Peter
Bitte warten ..
Ähnliche Inhalte
DNS
Namensauflösung nslookup funktioniert nicht - W2k8R2 DNS
gelöst Frage von ConfettiDNS3 Kommentare

Hallo, ich habe folgendes Problem, ich habe Windows Server 2008 R2 unter VMware Workstation 11 mit der Netzwerkeinstellung „Bridged“ ...

Webbrowser
Chrome DNS-Auflösung funktioniert nicht
Frage von ChrFriedelWebbrowser17 Kommentare

Grüße zusammen, ich habe hier ein kleines Problem mit dem man Leben kann das mich jedoch ziemlich nervt. Kurz ...

DNS
DNS Auflösung aus Subnetz funktioniert nicht
Frage von SRandinDNS7 Kommentare

Hallo zusammen, wir haben einen Router (A) mit einem eigenen DHCP Server als Subnetz aufgebaut. An diesem Router A ...

DNS
Kein DNS auflösung über VPN RDP
Frage von DaHuberDNS6 Kommentare

Hallo, habe seit unser SystemPartner eine neue Firewall installiert hat , Probleme mit der DNS auflösung. Kann Server über ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 9 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 9 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 12 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 17 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...