Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei RPC-over-HTTP auf SBS2011 (Exchange2010)

Frage Microsoft Exchange Server

Mitglied: DerSchorsch

DerSchorsch (Level 2) - Jetzt verbinden

12.09.2011 um 12:20 Uhr, 7007 Aufrufe, 6 Kommentare

Bei Nutzung von RPC-over-http bei einem SBS2011 wird das OfflineAddressbuch nicht geladen.

Hallo,

wir haben bei uns von einem SBS2003 auf SBS2011 migriert (gemäß Anleitung von MS).
Das ganze hat auch soweit funktioniert.
Die Domänen-Rechner laufen sauber, der Zugriff auf den Exchange läuft problemlos.
Verwendet wird Outlook 2007 und 2010.

Nun haben wir aber auch 2 externe Rechner, die nicht Mitglied der Domäne sind (sprich: die stehen bei 2 Leuten zuhause).
Der Zugriff erfolgt über RPC-Over-https mit Outlook 2010.
Inhalte (also Mails, Kalender, etc..) gehen, jedoch wird das OfflineAddressBuch (OAB) nicht aktualisiert. Mit dem alten Server ging das noch. Auch Outlookprofil neu machen ändert nichts.

Bei Synchronisierungsprobleme findet sich folgender Eintrag.
"Fehler bei Synchronisierung des Ordners: [8004011D-526-80040115-0]
Microsoft Exchange ist nicht verfügbar. Es bestehen Netzwerkprobleme, oder der Servercomputer mit Exchange wurde für Wartungsarbeiten heruntergefahren."

Bisher habe ich nur Anleitungen gefunden, wenn RPC-over-https oder OAB gar nicht gehen.
Trifft aber beides so nicht zu:
Das OAB geht bei den Domänen-Clients, RPC-over-https synchronisiert Inhalte.

Hat irgendjemand eine Idee, was ich machen könnte?

Danke im vorraus
Schorsch
Mitglied: Patriot
12.09.2011 um 14:44 Uhr
Ausgeschlossen, das es andere Komponenten sein könnten (Firewall) die die Anfrage blocken?
Was sagt denn das Log vom Exchange, kommen Anfragen an? Blockiert die Windows Firewall vll externe Anfragen?
Bitte warten ..
Mitglied: DerSchorsch
12.09.2011 um 16:58 Uhr
Hallo,

ich denke, die Firewall kann ich ausschliessen. Sowohl die "richtige" als die die Windows-eigene.
Eingehend macht die nur ein Portforwarding tcp/443 auf den SBS. Ist kein ReverseProxy oder so.
Und eigentlich sollte bei dieser Art der Verbindung ja alles über https getunnelt werden. Ist übrigends das gleiche Setup wie beim alten SBS2003, da ging noch alles.

Der Witz ist ja auch, man bekommt Emails, der Kalender wird aktualisiert, etc.. Nur kommt leider auch ein Übermittlungsfehler, weil das OAB nicht geladen werden kann.
Die RPC-over-https-Verbindung geht also schon "irgendwie", nur geht halt nicht alles. (OWA geht übrigends auch.)

Man kann auch senden, aber wenn man die Adressliste aufmacht, sieht man halt auch alte Konten, die im Zuge der Migration gelöscht wurden, neuere hingegen nicht. Kennt man die Email, geht es trotzdem, ist aber halt unbequem.

Am Server sehe ich in der Ereignisanzeige nichts, was ich dem zuordnen könnte. Jedenfalls nicht während der Zeit einer Verbindung. Und lokal die bereits gepostete Meldung.

Gruß,
Schorsch
Bitte warten ..
Mitglied: xcabur
05.12.2011 um 16:31 Uhr
falls dein problem noch nicht gelöst ist, erstelle einmal auf dem externen Client im hostfile einen eintrag mit autodiscover.domain.tld mit der öffentlichen IP unter welcher auch dein OWA verfügbar ist, wenn es dann klaptt, dass ganze einfach in deine öffentliche DNS Zone übertragen, damit es auch für alle verfügbar ist.
Bitte warten ..
Mitglied: DerSchorsch
05.12.2011 um 22:29 Uhr
Hallo,

das geht soweit, allerdings gibts eine Fehlermeldung, weil der Name des Zertifikats falsch ist (es geht ja nicht auf autodiscover.unseredomain.de). Wenn man das bestätigt, macht er weiter. Und dann synct er tatsächlich auch das OAB.

Ich habe noch dies hier gefunden:
http://support.microsoft.com/kb/940881/de
Da wir gerade sowieso unseren Provider wechseln und beim neuen das Anlegen von SRV-Einträgen in den DNS möglich sein wird, wollte ich das dann testen.

Gruß,
Schorsch
Bitte warten ..
Mitglied: xcabur
06.12.2011 um 09:16 Uhr
ehm ja das sollte auch gehen, habe ich zwar noch nie ausprobiert (ein feedback würde mich interessieren). Der Grund wieso ich es noch nie so gemacht habe ist, weil mich folgender Punkte aus dem oben erwähnten Technet Artikel abgeschreckt hat:

5.Der Benutzer wird von Outlook aufgefordert zu bestätigen, dass Autodiscover weiterhin an "https://mail.contoso.com/autodiscover/autodiscover.xml" senden soll.

Hast du ein ofizielles Zertifikat oder hast du eines von deiner eigenen CA ausstellen lassen?
Falls du eines von deiner eigenen CA ausgestellt hast, kannst du einfach ein neues Zertifikat inkl. autodiscover.domain.tld ausstellen, und auf deinen "nicht Domänen Clients" das Stammstellenzertifikat deiner CA manuell installieren. Falls du eine offizielle CA verwendest, dann müsstest du notfalls nocheinmal eins kaufen. Natrülcih nur, wenn die Sache mit dem SRV-Record nicht funktioniert.
Bitte warten ..
Mitglied: DerSchorsch
06.12.2011 um 19:02 Uhr
Hallo,

wir haben das vom SBS selbst generierte. Allerdings auch nur 1 öffentliche IP. Ich bin mir nicht sicher ob so das mit 2 Zertifikaten korrekt funktioniert.
Ich muss meinen Kollegen fragen, wann er den Domainumzug fertig hat. Dann kann ich das mit dem SRV testen.

Wenn man die Abfrage nur einmal bestätigen muss, wäre das bequemer als im Moment. Man muss den Zertifikatsfehler bei jedem Aufruf erneut bestätigen.

Ich geb Bescheid, wie das mit dem SRV funktioniert.

Gruß,
Schorsch
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
gelöst SBS2011 Probleme mit Zertifikatsverlängerung (8)

Frage von Alchemy zum Thema Exchange Server ...

Microsoft Office
Office 2016 Probleme mit Outlook (5)

Frage von killtec zum Thema Microsoft Office ...

Exchange Server
gelöst SBS2011 Owa und Activesync funktionieren nach V2V Umzug nicht mehr (2)

Frage von Anulu1 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...