Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit XENSERVER Storage bzw. virtuellen Disks

Frage Virtualisierung Xenserver

Mitglied: hermes

hermes (Level 1) - Jetzt verbinden

01.10.2013 um 17:07 Uhr, 11214 Aufrufe, 16 Kommentare

Hallo liebe Fachleute, nach langer Suche im Netz und vielen Fehlschlägen frage ich jetzt hier mal.

Es geht um einen XENServer in der freien ( kostenlosen) Version. Aktuell ist die Version 6.2 installiert. Folgende zwei Fragen bekomme ich nicht gelöst :

Der Rechner hat insgesamt 4 TB Disk (genauer 3,7TB) von den laufenden VMs wird aber lt. XENCenter nur 2,2 TB verwendet, trotzdem stehen im SR nur noch knapp 200GB zur Verfügung. Ich hatte zwischenzeitlich mal ein paar Snapshots gemacht, diese sind aber längst gelöscht, also sollte doch der Plattenplatz wieder freigegeben sein.
Ich habe im Netz gesucht, wie man solchen Plattenplatz wieder freigibt, aber entweder habe ich über die falschen Suchbegriffe gesucht, oder es waren Lösungen für ältere XEN Systeme ( V5-V5.6) und da funktionierten die Vorschläge bei mir nicht.
Wenn also jemand weiss, wie ich in der V6.2 des Xenserver den belegten Plattenplatz feststellen kann, und vor allem wie ich überflüssige Dateien wieder loswerde, - ich bin ganz Ohr....

Das zweite Problem ist schwerwiegender. Auf dem Gerät läuft neben einem Win2008R2 auch noch ein alter Win2003R2. Letzterer hat eine 300GB Festplatte für die tägliche Arbeit, also System und Datenplatte. Daneben gibt es noch eine 500GB Datenplatte auf die jede Nacht eine interne Sicherung der Bewegungsdaten erfolgt. Diese werden dann normalerweise auf eine externe Festplatte tagsüber kopiert, und jeden Tag wird die ext. Platte getauscht.
Nun mussten wir heute morgen feststellen, dass der Win2003 nicht mehr erreichbar ist, das Gerät versuchte zwar neu zu starten aber noch bevor der Anmeldedialog da ist, bleibt er hängen und der Desktop ist schwarz. Man kann den Server zwar anpingen, aber das wars auch schon. Auffällig ist, das das Herunterfahren über XenCenter extrem lange dauert ( 7-8 Minuten, sonst etwa 1Minute).
Von diesem Fehler war ich erstmal nicht sonderlich beunruhigt, es gibt ja eine Sicherung, aber Pech gehabt, die externe Festplatte ist leider in der letzten Zeit stromlos geblieben ( bitte jetzt nicht fragen warum... )
Darauf dachte ich, dass ich ja evtl. die Sicherungsplatte beim Win2003 abmelden kann und dann beim Win2008 als weitere Platte anhänge, um so die tägliche Sicherung zu erreichen. Im vorigen Jahr hatte ich so was mal gemacht und es hat gut geklappt. aber nichts da, wenn ich die Platte am Win2008 anhänge, zeigt er das gleiche Startverhalten wie der 2003er, nur schwarzer Desktop, und Herunterfahren über XENCenter dauert jetzt auch etwa 10 Minuten. Sobald die 500GB Platte am Win2008 hängt, ist auch kein Export der Maschine möglich, entweder geht es gar nicht voran, oder aber der Export bricht mit Fehler ab.
Meine Frage daher : Kennt jemand ein Verfahren, wie unter der xenserver Konsole eine virtuelle Platte auf Schäden im Dateisystem untersuchen kann bzw. ob man solche defekten virteullen Platten mit irgendwelchen Tools wieder zum Laufen bringt.
Auch hier bin ich für jeden Hinweis dankbar !!

Mitglied: Der-Phil
01.10.2013 um 18:17 Uhr
Hallo!

Zum Speicherplatzproblem:
Beim Snapshot wird immer der doppelte Speicherplatz blockiert. Eigentlich wird ab Version 6.0.2 dieser wieder freigegeben - teilweise aber falsch angezeigt. Mache mal einen Rescan auf das Storage Repository und schau, was dann angezeigt wird.

Deine zweite Frage verstehe ich ehrlich gesagt nicht.
Was passiert, wenn Du die "Sicherungsplatte" abhängst und dann bootest und Sie anschließend an das Live-System anhängst?

Grüße
Phil
Bitte warten ..
Mitglied: hermes
01.10.2013 um 18:28 Uhr
Hallo,

Danke für das Interesse !

zu 1 : den rescan habe ich schon zigmal versucht, hat überhaupt nichts gebracht...

zu 2 : ich habe auch den Win2008 erst ohne die defekte Platte gestartet und diese dann eingehängt. Die Folge war, dass die Kiste noch einen Augenblick normal lief, ohne dass die Festplatte in der Datenträgerverwaltung auftauchte, dann stürzte die Datenträgerverwaltung ab, bzw. stellte komplett den Dienst ein.
Bei einem Win7prof Rechner, den ich auch auf der Maschine laufen lasse, konnteich über dieses Verfahren die Platte immerhin in der Datenträgerverwaltung sehen, aber dann ging die ganze Win7 Maschine in den Verweigerungsmodus, und konnte nur über ForceReboot aus dem XenCenter beendet werden. Anschliessend habe ich die def Platte wieder rausgenommen, und der Win7 startete als wäre nie was gewesen...

Viele Grüße !
Bitte warten ..
Mitglied: Der-Phil
02.10.2013 um 08:34 Uhr
Hallo!

Ich glaube, mit Deinem StorageRepository ist irgendetwas so gar nicht in Ordnung.

Eigentlich sollte das Freigeben des Speicherplatzes, wenn alle Snapshots gelöscht sind, automatisch laufen. Du könntest mal schauen, ob unter Xenserver 6.2 noch das manuelle "coalesce" funktioniert:

xe host-call-plugin host-uuid=<host-UUID> plugin=coalesce-leaf fn=leaf-coalesce args:vm_uuid=<VM-UUID>


Ich würde mal versuchen, die VHD zu exportieren und sie dann z.B. unter Windows zu mounten.

http://blogs.technet.com/b/danstolts/archive/2012/11/09/how_2d00_to_2d0 ...

http://social.technet.microsoft.com/Forums/windowsserver/en-US/4166ed08 ...

Phil
Bitte warten ..
Mitglied: hermes
02.10.2013 um 11:19 Uhr
Hallo,

der Verdacht liegt nahe, dass mit dem SR irgendwas nicht hinhaut, andererseits laufen der Win2008 und ein Win7prof Client völlig störungsfrei. Bei beiden habe ich auch mal die virtuellen Platten bis zu 95% vollgeschrieben, um zu sehen ob da auch Störungen auftreten, aber da sieht alles gut aus. Mittlerweile habe ich auch noch mal einen Win2003er in Minimalkonfiguration installiert, der seit einigen Stunden aus dem letzten funktionierenden Backup die Daten zieht.

Den coalesce Befehl hatte ich auch schon im Internet gefunden, aber dort eben nur für Xen 5x, und als ich es ausprobieren wollte, kam die Meldung, dass dieser Befehl nicht existiert. Allerdings hatte ich etwas andere Syntax bzw. Aufrufparameter gefudnen , also werde ich morgen nochmal versuchen mit der obigen Syntax zu starten.

Der Versuch die Festplatte selbst zu exportieren, gelingt mir nicht, ( ich weiss einfach nicht wo das gehen solle im xen center ), bisher habe ich immer die ganze Maschine inkl. eingebundener Festplatten exportiert. Doch wie schon oben beschrieben, export geht einfach nicht, wenn die defekte Platte eingebunden ist. Darum dachte ich ja an ein Tool zum reparieren, das auf der Konsole des Xen Servers gestartet wird ( ähnlich chkdsk ). Anschliessend wollte ich dann nochmal versuchen zu exportieren, in windows rechner einbinden und weitersehen.

Aber Danke für die Mühe !
Bitte warten ..
Mitglied: Der-Phil
02.10.2013 um 17:15 Uhr
Hallo!

Möglichkeit 1:
Erstelle doch eine "Dummy-VM", füge dort die VHD hinzu, die Du retten willst. Dann die VM exportieren. Das XVA dann umwandeln zu VHD über den Xenconverter.

Möglichkeit 2:
Du nimmst einen beliebigen NFS-Server und startes ein Cloning der VHD auf das NFS-Laufwerk. Dort liegt dann eine VHD, die Du auch unter Windows mounten kannst.

Phil
Bitte warten ..
Mitglied: hermes
02.10.2013 um 20:47 Uhr
Hallo,

Danke für die Antwort.

Punkt 1 habe ich schon versucht, wie oben beschrieben habe ich noch mal eine kleine Win2003 Maschine aufgesetzt, und bevor ich damit die Datensicherung aus den NT-Backup Dateien wiederhergestellt habe, habe ich versucht ide VHD dort einzubinden. Der Effekt war der gleiche, wie in den anderen Situationen, die Maschine friert ein, und kann nur über Force Shutdown beendet werden.

Punkt 2 hatte ich noch gar nicht in Betracht gezogen. Wenn ich das richtig verstehe, binde ich einen NFS - Server als Storage ein und kopiere dann die Datei dorthin.

Ich habe vor Ort ein Netgear NAS, ich glaube der bietet auch NFS an - werde ich Freitag mal ausprobieren

Vielen Dank für den Tip !!!
Bitte warten ..
Mitglied: Der-Phil
04.10.2013 um 08:00 Uhr
Hallo!

Zu 1.:
Ich würde die VM nie starten. Dann kann sie auch nicht abstürzen.

zu 2.:
Ja, genau so.

Phil
Bitte warten ..
Mitglied: hermes
04.10.2013 um 08:13 Uhr
Guten Morgen !

Punkt 1 betrachte ich mittlerweile auch so, immerhin hat der "kleine" Win2003er noch eine Datensicherung von vor 10 Tagen auspacken und wieder verfügbar machen können, damit sollen seine Aufgaben aber auch vorerst erledigt sein.

Punkt 2 konnte ich nicht abwarten und habe gestern per Fernwartung die Sache versucht. Sah alles ganz gut aus, wenn auch etwas langsam, aber das lag wohl nur daran, dass ich den NFS Server auf unserem Netgear NAS eingerichtet habe. Gestern abend nach etwa 300GB Kopiertätigkeit meldet xencenter dann einen End-of-File Error und bricht ab. Also auch kein Erfolg....

Ich bin zwar kein Linux Experte, meine mich aber zu erinnern, dass es einen fsck ( oder so ähnlich ) gibt, mit dem man das Filesystem einer Linux Maschine prüfen und ggf reparieren lassen kann. Wäre so etwas eine Möglichkeit unter Xenserver ?

Viele Grüße
Bitte warten ..
Mitglied: Der-Phil
04.10.2013 um 08:18 Uhr
Hallo!

Punkt 1 verstehe ich nicht so ganz. Ich würde nur eine Dummy-VM machen, die virtuelle Festplatte anhängen und dann die VM exportieren. Ohne Starts oder Sonstiges.

Punkt 2 klingt frustrierend
Das kann an so ziemlich allem liegen. Ehrlich gesagt geht mir hier das Latein aus. Ich würde noch den ersten Ansatz testen.

fsck oder ähnlich bringt Dir leider keinen Vorteil Du hast ja gar kein Filesystem, das Du reparieren könntest. Das ist nur LVM ohne Filesystem.

Phil
Bitte warten ..
Mitglied: hermes
05.10.2013 um 18:58 Uhr
Hallo,

zu 1 : habe jetzt nochmal die Sache mit einer Dummy VM ausprobiert, aber auch hier bricht der Export nach etwa 300GB ab.

Allerdings bin ich noch auf die Idee gekommen, die alte Systemplatte mal an der Dummy VM auszuprobieren. Die alte Konfiguration liess sich mit dieser Platte ja gar nicht starten, auch wenn die 500GB sicherungsdisk abgehängt war.

Also habe ich die 300GB Platte von dem alten Win2003 abgehängt, und wollte sie an meinen kleinen Dummy 2003 Server anhängen. Geht aber nicht, das System bietet mir diese Möglichkeit gar nicht an, andere Platte kann ich problemlos ranhängen , nur diese nicht. Dummerweise geht jetzt auch das Anbinden an den alten ( kaputten ) Win2003 Server nicht mehr. Jetzt habe ich also eine Platte und kann sie an kein System mehr ranhängen....

Was ich nicht ganz verstehe, ist dass diese Platte neben der Bezeichnung, die ich ihr mal gegeben habe, immer als "Control Domain on Host VSERVER1" bezeichnet wird.

Offenbar funktioniert dieses Teil ja noch einigermassen, denn sonst müsste doch eigentlich das ganze XEN System abschmieren, kennt jemand also eine Möglichkeit solch eine Platte evtl. auf einen NFS Share zu übertragen ?

Dann habe ich noch im Internet gefunden, dass man die XENServer Installationscd einlegen und die Maschine starten soll, kurz bevor die eigentliche Installation loslegt, kann man wohl mit ALT+F1/ALT+F2 auf eine Konsole umschalten und dann auf das Dateisystem zugreifen.

Was ich nämlich nicht verstanden habe, ist wieso im LVM kein Filesystem liegen soll, ich dachte immer, dass LVM eine Art Abstraktionsebene ist, die das Filesystem, das Linux sieht, vom eigentlichen, Hardware bzw. Festplattenbezogenen System, abkoppelt. Also müsste doch auch unter XEN so etwas wie ein Filesystem zu finden sein.

Wenn ich im Xencenter des Virtualisierungshosts die Konsole öffne, kann ich doch auch ein Filesystem erkenne. Ich hätte jetzt erwartet, dass die VHD-Dateien irgendwo (ich weiss leider nicht wo ) liegen würden.

Viele Grüße
Bitte warten ..
Mitglied: Der-Phil
07.10.2013 um 11:57 Uhr
Hallo!

Die VHDs liegen aber nicht im Filesystem.

LVM ist eine Abstraktionsebene - da hast Du Recht.
Im LVM sind eine Art von Partitionen. Diese Partitionen werden direkt der VM gegeben. Die VM legt dann ein Filesystem darauf ab (in Deinem Fall wohl NTFS).

Phil
Bitte warten ..
Mitglied: hermes
07.10.2013 um 18:29 Uhr
Hallo,

mittlerweile habe ich eine Lösung, zumindest für die Daten, gefunden.

Wie beschrieben, konnte ich die (Haupt-/System-)platte des 2003er Systems nicht mehr anbinden, insofern konnte ich die Kiste auch nicht mehr starten. Ich habe dann aber über die Konsole diese Platte auf ein NFS-System kopiert ( xe vdi-copy ) und siehe da von dort konnte ich dann die Platte wieder an den Server anbinden, danach 2003er Server gestartet und alle Daten schnell ( 12 Std ) auf eine externe Festplatte kopiert. Da der NFS Share auf einem Netgear NAS lag, war die Antwortzeit der Windows Maschine zwar grottenschlecht, aber es hat funktioniert. Aktuell bin ich dabei von dem NFS System die Datei wieder zurückzukopieren, und morgen früh sehe ich dann ob das System wieder hochfährt, dann habe ich ja vielleicht Glück, dass die Leute erstmal weiterarbeiten können, während ich parallel einen neuen 2008er Server vorbereite.

Auf jeden Fall vielen Dank für die Anregungen !!
Bitte warten ..
Mitglied: Der-Phil
08.10.2013 um 08:30 Uhr
Hallo!

Gern geschehen.

Ich würde mir nur wirklich Sorgen um das gesamte StorageRepository machen. Das klingt wirklich nicht gesund

Gruß
Phil
Bitte warten ..
Mitglied: hermes
08.10.2013 um 10:56 Uhr
Hallo !

Ja Sorgen mache ich mir schon, aber erstmal können die Leute wieder arbeiten, Sicherungen der Bewegungsdaten werden jetzt alle Stunde per robocopy auf zwei andere Systeme gemacht, DB System macht zweimal am Tag eine Sicherung und speichert diese dann auf andere Maschinen, insofern sehe ich dem nächsten Absturz gelassen entgegen.

Parallel werden wir jetzt aber das gesamte System etwas eher auf 2008er Server umstellen und dabei auch gleich kräftig entrümpeln. Eine zweite physikalische Maschine steht erstmal als provisorium daneben, und da wir als soziale Einrichtung günstig Win2008 Enterprise bekommen haben, läuft da jetzt ein Hyper-V und schon ein virtueller DC drauf. Jetzt werden wir also erstmal alles auf die neue Domäne umziehen, dann den alten Rechner deaktivieren und die Festplatten prüfen und ggf ersetzen, dann auch dort Hyper-V drauf, und den neuen virtuellen Win2008er dahin zurückschieben. Geplant war das Ganze für den Jahreswechsel, aber so müssen wir halt etwas eher ran.

Interessanterweise stimmt jetzt auf dem XEN auch wieder die Anzeige wieviel Speicher das SR noch frei hat. Ich habe gestern die defekte 500GB Platte gelöscht, und statt der erwarteten 500 GB hat er fast 800GB Plattenplatz im SR freigemacht, - ist schon seltsam, zeigt für mich aber auch wie wichtig es ist jetzt schnell umzuziehen und die Maschine aus der Produktion zu nehmen.

Viele Grüße
Bitte warten ..
Mitglied: PhillipKaPunkt
04.03.2014 um 10:09 Uhr
Hallo,

ich habe leider auch so ein Problem. Wir sind gerade dabei einen alten XenServer Pool abzulösen und wollten nun alle VMs von dem alten Pool exportieren und auf einen anderen importieren. Das Problem ist jetzt das wir beim export von 3 VMs auch die Fehlermeldung "end-of-File" bekommen. Das Problem scheint allerdings noch etwas hartnäckiger zu sein als es bei dir war, ein xe vdi-copy auf ein angehängtes NFS Storage funktioniert leider auch nicht und bricht auch mit der end-of-file Meldung ab. Das Eigenartige an der Sache ist allerdings das die VM auf dem alten XenServer Pool noch ohne Probleme läuft und funktioniert, ein export allerdings nicht funktioniert. Storage XenMotion auf einen anderen XenServer 6.2 Pool funktioniert auch nicht und bricht mit der end-of-file meldung ab. Wenn wir die VM mit einer Acronis live CD oder Clonezilla live CD booten und versuchen einen Abzug zu erstellen, bleibt die Software auch mit tausenden IOErrors hängen.

Irgendwelche Ideen?

Viele Grüße
Bitte warten ..
Mitglied: hermes
27.03.2014 um 21:23 Uhr
Hallo,

leider kenn ich mich in der Tiefe auch nicht mit Xen aus. Ich bin damals eigentlich nur auf Xen gekommen, weil das Teil kostenlos verfügbar war und sich einfach installieren liess. Insofern kann ich auf die obige Frage leider nichts sagen, - sorry.

Mein Problemserver von Anfang dieser Diskussion ist mittlerweile abgeschaltet. Der Transfer auf den 2008er in eine Hyper-V Umgebung klappte einwandfrei, insgesamt habe ich drei Tage gebraucht um alles auf die neue Maschine zu ziehen inklusive Neueinrichtung des Servers, Transfer der Benutzerdaten und etwa 20% der Clients. Die restlichen Clients konnte ich nach und nach in die neue Domäne überführen, weil die Leute im Urlaub oder Krank bzw. schichtfrei hatten.

Derzeit läuft also der 2008 auf dem provisorischen Blech, und demnächst fange ich an auf dem ehemaligen XEN Server auch 2008 zu installieren, und dann ist geplant die virtuelle Maschine dahin umzuziehen und den gesamten Vorgang abzuschliessen.

Interessant finde ich, dass auf dem Sevrer mit dem Festplattenproblem keine Schwierigkeiten mit den Platten feststellbar sind. Sowohl ein 2003 als auch ein 2008 liessen sich in verschiedenen Konfigurationen installieren. Festplattenchecker sagen mir dass alles ok ist, also bleibt der Fehler vom XEN eigentlich ungeklärt.

Trotzdem schliesse ich diesen Diskussionszweig jetzt !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Drucker und Scanner
USB-Drucker über virtuellen COM LPT- Port ansteuern (27)

Frage von magicman zum Thema Drucker und Scanner ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

SAN, NAS, DAS
Storage RAID LUN Konfiguration - Wie macht ihr es (4)

Frage von Marco-83 zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...