Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SDLT-Laufwerke streamt nicht - HP ML330 G1, Adaptec 39160, MSL5026

Frage Hardware Festplatten, SSD, Raid

Mitglied: Lousek

Lousek (Level 2) - Jetzt verbinden

23.09.2011, aktualisiert 12:17 Uhr, 3442 Aufrufe, 3 Kommentare

Hallo Forum

Ich habe hier ein kleines Problem mit meiner "Backup-Umgebung":
Backup-Server ist ein HP ML330 G1 (512MB RAM, 3GHz CPU) mit einem eingebautem Adaptec 39160 SCSI-Adapter, wo die HP MSL5026-Tape-Library angeschlossen ist.
Vom Adapter geht ein 4m SCSI-Kabel zum Drive-2 (SDLT160/320), von dort ein 15cm zum Drive-1 (SDLT160/320) und von dort wiederum ein 15cm zur Library Controller Card. Am zweiten Port der Library Controller Card hängt natürlich ein SCSI-Terminator.

Auf dem Backup-Server ist Ubuntu Server 10.10 installiert.
Library & Drives werden erkannt und können mittels mt und mtx gesteuert werden!

Mein Problem ist nun, dass das Drive (egal welches) nur in einem Stop-and-Go-Betrieb arbeitet.
Die Datentransfer-Rate zum Tape liegt bei mickrigen 6 - 7 MB/s.
Versucht habe ich dies mit dd und verschiedenen Inputs:
dd if=/dev/zero of=/dev/nst1
dd if=/dev/random of=/dev/nst1
dd if=/dev/random of=/tmp/test.img && dd if=/tmp/test.img of=/dev/nst1
dd if=/some/other/file.bck of=/dev/nst1

Auch probiert mit /dev/nst0, /dev/st0, /dev/st1 als Output ... die Performance bleibt leider bei diesem Wert ...

Edit: An der Disk oder der CPU kann es nicht liegen, die bringt (mit dd if=/dev/random of=/tmp/test.img und dd if=/tmp/test.img of=/dev/null) ca. 60MB/s, sowohl schreiben als auch lesen!

Heute Abend werde ich das ganze noch mit einem 29160LP als Controller probieren, anstatt dem älteren 39160 ...

Aber dennoch, hat jemand eine Idee, an was das dies liegen könnte?

Gruss
lousek
Mitglied: Ravers
23.09.2011 um 12:59 Uhr
Kenne jetzt nicht die Controller, habe aber auch einige Adaptec-Controller im Einsatz.
Wenn Sie laufen, laufen Sie super. Jedoch ist der beste Treiber nicht immer schnell zu finden. Der mitgelieferte ist idR. nicht wirklich gut, sondern wurde bei Markteinführung einfach X mal gepresst und mitgeliefert. Ich würde dort ansetzen. Wobei: in einer Windowsumgebung.

Greetz
ravers
Bitte warten ..
Mitglied: Lousek
23.09.2011 um 13:18 Uhr
Ja, bei Windows würde ich den Treiber der jeweiligen Backup-Software verwenden ... jedoch sollte beim Linux schon mehr oder weniger der richtige Treiber geladen worden sein - ich werde dies heute Abend ebenfalls mal überprüfen ...

Eine weitere Punkt ist mir eingefallen:
Was ist mit der Block-Size?
Wie gross ist der Unterschied, wenn ich zum schreiben 8KB, 16KB, 32KB, 64KB, 128KB oder 256KB Block-Size nehme?
Hat da jemand Erfahrungen damit? Sonst werde ich heute Abend mal die verschiedenen Block-Sizes testen ...
Bitte warten ..
Mitglied: Lousek
24.09.2011 um 15:32 Uhr
Ich habe es jetzt mal mit dem 29160LP versucht ... damit bekomme ich den gewünschten Durchsatz (13 - 15MB/s ohne Kompression)
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
HP Proliant ML30 + HPE H240 Probleme (7)

Frage von Sauropode zum Thema Server-Hardware ...

Drucker und Scanner
Sonderzeichen im Passwort HP-Printer (HP LaserJet CP1525N) (2)

Frage von malika zum Thema Drucker und Scanner ...

Festplatten, SSD, Raid
gelöst HP ProLiant DL360 G6 mit normalen HDD (7)

Frage von max.30Zeichen zum Thema Festplatten, SSD, Raid ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

KVM

How to: Libvirt Port forwarding

(2)

Anleitung von fundave3 zum Thema KVM ...

Heiß diskutierte Inhalte
Router & Routing
über Vmware auf eine FritzBox mit IPv6 per VPN (17)

Frage von Zockervogel zum Thema Router & Routing ...

Basic
Programmierung von Windows Programmen (8)

Frage von Ghost108 zum Thema Basic ...