Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Squid für vollen Internetzugriff konfigurieren

Frage Linux Linux Netzwerk

Mitglied: Willueueue

Willueueue (Level 1) - Jetzt verbinden

22.02.2006, aktualisiert 25.02.2006, 7650 Aufrufe, 23 Kommentare

Hallo,

ich habe hier einen Squid Server, dieser läuft auf einem Fedora Core 4 Linux. Ich habe das tar.gz Packet entpackt und installiert, dann habe ich die squid.conf bearbeitet und und bei http access von all deny auf allow all gesetzt. Dann habe ich einen Proxy bei Firefox auf diesem Server selbst eingetragen. Dann sagt mir Firefox die Verbindung wurde zurückgesetzt. Jemand eine Idee wie ich raus kommen kann ohne Authentifizierung auf diesem lokalen Host über den Proxy?

Danke.

/etc/init.d/squid start habe ich eingegeben um den Proxy Dämon zu starten. Danach mit Firefox das gleiche Problem.

Einstellungen aus der squid.conf, die ich verändert habe:

http_port 192.168.1.120:3128
http_access allow all
TAG: visible_hostname linsrv001.pykanet.de

Der Proxy hat die 192.168.1.120, Router zum WAN ist die 192.168.1.254, ohne Proxy Einstellung im Firefox komm ich auch ins WAN, liegts an iptables? Oder muss ich noch etwas im Script ändern?
Mitglied: heyko
22.02.2006 um 12:51 Uhr
Squid läuft und stürzt nicht beim starten ab (Config falsch)?

Kommt im Browser eine Squid Fehlermeldung (Squid läuft Config falsch)?

Kannst du vom Server aus Domains pingen (eventuell DNS Problem)?
Bitte warten ..
Mitglied: Willueueue
22.02.2006 um 14:09 Uhr
Wie stelle ich genau fest ob Squid läuft? Domains anpingen kann ich. Ebend nochmal überprüft. Wenn ich den Squid an anderen Clients eintrage passiert das gleiche wie am Squid selber.
Bitte warten ..
Mitglied: heyko
22.02.2006 um 14:13 Uhr
ps -aux |grep squid

poste mal die ausgabe ...

was sagen die clients wenn du eine seite aufrufen willst über squid
Bitte warten ..
Mitglied: Willueueue
22.02.2006 um 14:16 Uhr
[root@linsrv001 ~]# ps -aux|grep squid
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.5/FAQ
root 13906 0.0 8.8 38416 17612 ? S 12:45 0:03 kwrite [kdeinit] /usr/local/squid/etc/squid.conf
root 15169 1.0 0.2 3752 556 pts/2 D+ 14:19 0:00 grep squid
[root@linsrv001 ~]#

Bei den Clients kommt Netzwerk Zeitüberschreitung.

Hoffe du kannst mir helfen.

Edit: an iptables liegt es nicht, habe ich einfach mal deaktiviert.
Bitte warten ..
Mitglied: heyko
22.02.2006 um 15:11 Uhr
laut der ausgabe von ps -aux läuft squid überhaupt nicht ... wirf mal einen blick in den syslog ... /var/log/syslog

falls da etwas zum thema squid stehen sollte kopier das mal ...
du kannst dir den syslog mit cat /var/log/syslog ausgeben
Bitte warten ..
Mitglied: Willueueue
22.02.2006 um 16:32 Uhr
Kann ich morgen erst machen, aber dann werd ich es auch sofort posten. Hoffe wir kriegen Squid zum laufen. Danke.
Bitte warten ..
Mitglied: heyko
22.02.2006 um 17:01 Uhr
kein problem ich versuch ab und zu mal zu gucken ob du scho wieder geantwortet hast
Bitte warten ..
Mitglied: Willueueue
22.02.2006 um 17:10 Uhr
Super dank dir.
Bitte warten ..
Mitglied: Guenni
22.02.2006 um 17:21 Uhr
@Willüüü

Hi,

damit Squid startet, muß ein DNS-Server, z.B. Bind, laufen. (Bin mir aber nicht 100% sicher)

FC4 bietet doch bestimmt ein Paketmanagement. Warum entpackst und
installierst du Squid von Hand?

Die Paketmanager prüfen doch, ob Abhängigkeiten von anderen Paketen bestehen
ohne die das Programm nicht läuft, und installieren fehl. Pakete automatisch nach.

Zur Konfig.:

Den Eintrag, http_access deny all in http_access allow all
umzubenennen, ist normal nicht üblich.

Besser wäre, eine Zugriffsregel zu erstellen:

acl my_network src 192.168.1.120/24

Und vor dem Eintrag http_access deny all einfügen:

http_access allow my_network

Zu Squid findest du ein deutsches Handbuch unter http://www.squid-handbuch.de/

Gruß
Günni
Bitte warten ..
Mitglied: heyko
23.02.2006 um 09:46 Uhr
ein dns server ist nicht zwingend erforderlich solange in /etc/resolv.conf zwei funktionierende eingetragen sind ... d.h. wenn man vom server aus domains anpingen kann sollte auch squid keine probleme damit haben
Bitte warten ..
Mitglied: Willueueue
23.02.2006 um 10:35 Uhr
Mit dem Befehl cat /var/log/syslog erreiche ich nichts: Datei oder Verzeichnis nicht gefunden, wechsel ich in das Verzeichnis gibt es da auch kein syslog. Pingen kann ich wie gesagt.
Bitte warten ..
Mitglied: heyko
23.02.2006 um 10:45 Uhr
mmh eventuell heißt die datei bei dir dann /var/log/messages
Bitte warten ..
Mitglied: Willueueue
23.02.2006 um 10:53 Uhr
Feb 22 12:12:04 linsrv001 automount[2717]: failed to mount /misc/.directory
Feb 22 12:12:04 linsrv001 automount[2718]: >> /usr/sbin/showmount: can't get address for .directory
Feb 22 12:12:04 linsrv001 automount[2718]: lookup(program): lookup for .directory failed
Feb 22 12:12:04 linsrv001 automount[2718]: failed to mount /net/.directory
Feb 22 12:18:56 linsrv001 squid: parseConfigFile: line 2197 unrecognized: '/etc/rc.d/init.d/squid start'
Feb 22 12:18:56 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Feb 22 12:19:02 linsrv001 last message repeated 4 times
Feb 22 12:19:02 linsrv001 squid: parseConfigFile: line 2197 unrecognized: '/etc/rc.d/init.d/squid start'
Feb 22 12:19:02 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Feb 22 12:19:03 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Feb 22 12:19:06 linsrv001 squid: parseConfigFile: line 2197 unrecognized: '/etc/rc.d/init.d/squid start'
Feb 22 12:19:06 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Feb 22 12:19:07 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Feb 22 12:19:39 linsrv001 squid: parseConfigFile: line 2197 unrecognized: '/etc/rc.d/init.d/squid start'
Feb 22 12:19:39 linsrv001 squid: Could not determine fully qualified hostname. Please set 'visible_hostname'
Bitte warten ..
Mitglied: heyko
23.02.2006 um 10:58 Uhr
setz in der squid.conf erstmal die variable visible_hostname damit schonmal ein fehler weg ist

<font class="code">Beispiel:
visible_hostname 10.0.0.1
</font>
Bitte warten ..
Mitglied: Willueueue
23.02.2006 um 11:07 Uhr
Default:
  1. cache_effective_user nobody

  1. TAG: visible_hostname 192.168.1.120
#Default:
  1. none

So schauts in der squid.conf aus. Wenn ich jetzte "/etc/init.d/squid restart" oder auch start eintippe kommt:

#Stopping squid
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
CPU Usage: 0.016 seconds = 0.003 user + 0.013 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 6: 26411 Abgebrochen $squid -k shutdown
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
CPU Usage: 0.028 seconds = 0.002 user + 0.026 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 6: 26412 Abgebrochen $squid -k check
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
CPU Usage: 0.022 seconds = 0.001 user + 0.021 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 6: 26414 Abgebrochen $squid -k check
root 26355 1.4 11.0 38420 22056 ? S 11:10 0:02 kwrite [kdeinit] /usr/local/squid/etc/squid.conf
root 26409 0.0 0.5 4332 1032 pts/2 S+ 11:13 0:00 /bin/bash /etc/init.d/squid restart
root 26410 0.0 0.5 4464 1112 pts/2 S+ 11:13 0:00 /bin/bash /etc/init.d/squid stop
Starting squid
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
CPU Usage: 0.012 seconds = 0.002 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 6: 26419 Abgebrochen $squid -D -sYC
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
CPU Usage: 0.026 seconds = 0.001 user + 0.025 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
/etc/init.d/squid: line 6: 26422 Abgebrochen $squid -k check
root 26355 1.4 11.0 38420 22056 ? S 11:10 0:02 kwrite [kdeinit] /usr/local/squid/etc/squid.conf
root 26409 0.0 0.5 4332 1032 pts/2 S+ 11:13 0:00 /bin/bash /etc/init.d/squid restart
root 26418 0.5 0.5 4464 1116 pts/2 S+ 11:13 0:00 /bin/bash /etc/init.d/squid start
Bitte warten ..
Mitglied: Willueueue
23.02.2006 um 13:41 Uhr
Niemand einen Tipp für mich?
Bitte warten ..
Mitglied: heyko
23.02.2006 um 14:21 Uhr
hast du mal visible_hostname gesetzt?
Bitte warten ..
Mitglied: Guenni
23.02.2006 um 19:14 Uhr
@Willüüü

Hi,

>>FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Wie "heißt" dein Rechner?

fully qualified hostname oder auch vollständiger DNS-Name bedeutet:

rechnername.domain.tld

Wenn du an der Eingabe hostname -f eingibst, müßte etwas
rauskommen, was dem Muster entspricht. Falls nicht, konfiguriere erstmal
den Rechnernamen. Als tld aber bitte keine öffentliche wie .de, .com etc,
nimm statt dessen irgendwas wie z.B. loc.

In der Datei /etc/hosts kannst du dem Rechnernamen eine IP zuweisen.

Aufbau der Datei:
<font class="code">
<table border="0">
<tr>
<td>IP</td><td>Vollständiger DNS-Name</td><td>Rechnername</td>
</tr>
<tr>
<td>192.168.0.1</td><td>rechnername.domain.tld</td><td>rechnername</td>
</tr>
</table>
</font>

Versuche dann, Squid zu starten.

Gruß, viel Erfolg
Günni
Bitte warten ..
Mitglied: Willueueue
23.02.2006 um 20:11 Uhr
Wie ändere ich den Hostname?
Bitte warten ..
Mitglied: heyko
23.02.2006 um 21:49 Uhr
du kannst da auch einfach deine ip eintragen

halt eine adresse über die squid nachher von aussen erreichbar ist also nicht localhost/127.0.0.1
Bitte warten ..
Mitglied: Willueueue
24.02.2006 um 09:43 Uhr
So habe ich gemacht, jetzt startet auch Squid, noch kommt Firefox aber mit der Meldung: Verbindung wurde zurückgesetzt. Ich habe noch am Ende des PC Namen .de stehen, werde mal gegen .local tauschen. Bringt auch nichts:

Fehler: Proxy-Server nicht gefunden

Firefox wurde konfiguriert, einen Proxy-Server zu nutzen, der nicht gefunden werden kann.


          • Überprüfen Sie bitte, ob die Proxy-Einstellungen korrekt sind.

                  • Überprüfen Sie bitte, ob eine Netzwerk-/Internet-Verbindung besteht.

                          • Wenn Ihr Computer oder Netzwerk von einer Firewall oder einem Proxy geschützt wird, stellen Sie bitte sicher,
                          dass Firefox auf das Internet zugreifen darf.

                          [root@linsrv001 ~]# ps -aux|grep squid
                          Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.5/FAQ
                          root 2940 0.0 0.3 3780 772 pts/2 R+ 10:03 0:00 grep squid
Bitte warten ..
Mitglied: Willueueue
24.02.2006 um 10:09 Uhr
So der Fehler liegt wohl daran das wenn ich Eingebe:

/etc/init.d/squid status
squid: ERROR: No running copy
Bitte warten ..
Mitglied: heyko
25.02.2006 um 19:12 Uhr
kannst du squid vllt. über den befehl "squid -D10" (ich glaub das war der debug mode (detailiert)) starten? vllt. ist dein startscript auch einfach nur kaputt (was ich mir allerdings nicht vorstellen kann ...) was sagt denn /var/log/messages nachdem du visible_hostname gesetzt hast?
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Windows Server 2016 VPN richtig konfigurieren (1)

Frage von junior zum Thema Windows Server ...

Exchange Server
Abwesenheitsnotiz mit Powershell konfigurieren (2)

Frage von violak zum Thema Exchange Server ...

Windows 10
Win10 Enterprise - Standard Apps konfigurieren (2)

Frage von cuilster zum Thema Windows 10 ...

Windows Server
Weiterleitung im DNS konfigurieren??? (2)

Frage von alexdroid zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...