Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Strato - kein TLS?

Frage Internet E-Mail

Mitglied: grinser

grinser (Level 1) - Jetzt verbinden

09.08.2014 um 08:33 Uhr, 4510 Aufrufe, 8 Kommentare

Hi !

Ich versuche Outlook 2010 auf einen Strato Server zu konfigurieren für TLS. Lt. der Beschreibungen dort, sollte SSL/TLS Posteingang über den Port 993 und Ausgang über den Port 465 laufen. Mit SSL klappt das auch, aber nicht mit TLS. Doch angeblich soll auch TLS möglich sein. Leider gibt es keine gesonderte Beschreibung (FAQ) für TLS sondern zusammen mit SSL und alle Screenshots dort und Beschreibungen betreffen in erster Linie SSL.

TLS Postausgang klappt nur wenn ich den Port 587 einrichte.

?
Mitglied: DerSchorsch
09.08.2014 um 08:50 Uhr
Hallo,

SMTP mit SSL geht über den Port 465
SMTP mit TLS nutzt die Standard SMTP-Ports und startet über das StartTLS-Kommando die Verschlüsselung. Die sind entweder 25 oder 587 (Submission-Port nach RFC 2476

Die Beschreibung ist schlecht, das Verhalten richtig.
Also entweder SSL mit Port 465 oder TLS mit Port 587.

Gruß
Bitte warten ..
Mitglied: grinser
09.08.2014 um 09:03 Uhr
Acha! Das ist interessant zu wissen. Denn eigentlich ist TLS das SSL 3.1 und logisch gesehen wollte ich den Port 465 wählen. Was ist mit den Posteingangsserver ? Auch über 143 ?
Bitte warten ..
Mitglied: colinardo
09.08.2014, aktualisiert um 09:33 Uhr
Was ist mit den Posteingangsserver ? Auch über 143 ?
über Port 143 läuft normalerweise unverschlüsseltes IMAP. Für IMAP mit SSL ist Port 993 Standard.
https://www.fastmail.fm/help/technical/ssltlsstarttls.html

Grüße Uwe
Bitte warten ..
Mitglied: kingkong
09.08.2014 um 09:34 Uhr
Aber je nach Client (ich weiß nicht, wie Outlook das handhabt) kann StartTLS auch bedeuten, dass gar keine Verschlüsselung verwendet wird - nämlich dann, wenn die entsprechende StartTLS-Anfrage auf dem Weg zum Server modifiziert wird. Das ergibt einen Protokollfehler und wenn der Client das akzeptiert (laut Standard ist das meines Wissens nämlich zulässig), dann kommuniziert er anschließend weiterhin unverschlüsselt.

Eigentlich heißt SMTP mit SSL, dass halt ein eigener Port verwendet werden soll, auf dem von Anfang an und zwingend verschlüsselt werden soll.
TLS ist in diesem Kontext auch nur ein neues SSL (im Prinzipi SSL3.1, das heißt, aufbauend auf SSL3 gabs einige Änderungen - TLS kann aber anscheinend immer noch in einen Kompatibilitätsmodus wechseln, der auch SSL3 unterstützt).

Bei StartTLS hingegen findet die erste Kontaktaufnahme noch unverschlüsselt statt und erst nach erfolgreicher Übermittlung des StartTLS-Kommandos wird auch tatsächlich verschlüsselt.
Bitte warten ..
Mitglied: DerSchorsch
09.08.2014 um 09:42 Uhr
Hallo,

TLS ist zwar der Nachfolger von SSL, bei den Mailprotokollen hat man jedoch auch die Art des Verbindungsaufbaus auch geändert.
Sinn ist hier vor allem, dass bei SMTP zwischen Servern auch eine Verschlüsselung ausgehandelt werden kann. Will ein Server eine Mail an einen anderen weiterleiten, baut er zu diesem eine Verbindung zu Port 25 auf. Mit StartTLS kann der Empfangsserver anzeigen, dass er auch eine Verschlüsselung unterstützt. Der Sender kann dieses Angebot annehmen ohne eine neue Verbindung aufbauen zu müssen.
Das gleiche System kann auch ein Mailclient nutzen. Allerdings sollte man hier in den Kontoeinstellungen die Verwendung von StartTLS fest konfigurieren, nicht "automatisch" oder "wenn verfügbar". Theoretisch könnte sonst eine Behörde mit 3 Buchstaben (oder andere Bösewichte) und entsprechend Zugriff auf Netz die StartTLS-Kommandos manipulieren und zum scheitern bringen, wobei dann unverschlüsselt gesendet wird..

Ist auch für IMAP so spezifiziert. Auch hier den Standard-Port 143 nehmen und StartTLS einstellen. Allerdings weiß ich nicht, ob Strato dies für ihre IMAP-Server konfiguriert hat. Habe dort auch kein Konto zum testen.
Wäre aber nett, wenn du dies testen könntest und hier Rückmeldung gibst. Interessiert bestimmt noch andere.

Gruß
Bitte warten ..
Mitglied: kingkong
09.08.2014 um 09:59 Uhr
Genau um das "fest konfigurieren" geht es mir - und zwar genau aus dem Grund, den Du nochmal wiederholst (ich habe ja in meinem ersten Post auch schon von Manipulation geschrieben).
Im Thunderbird ist es beispielsweise (mittlerweile zumindest) so, dass bei aktivierter Option StartTLS auch tatsächlich eine verschlüsselte Verbindung via StartTLS zustande kommen muss und andernfalls die Verbindung abgebrochen wird.
Aber aus dem Wörtchen StartTLS geht das eben nicht hervor, hier könnte genau so gut auch eine Klartextverbindung akzeptiert werden. (Man merkt es bloß, wenn man die Beschreibungen der zwei Optionen "StartTLS" sowie "TLS, wenn möglich" vergleicht - wobei letztere Option im Programm gar nicht mehr verfügbar ist)

Erzwingt Outlook denn mittlerweile Transportverschlüsselung ebenfalls?
Bitte warten ..
Mitglied: 108012
09.08.2014 um 10:22 Uhr
Hallo zusammen,

TLS Postausgang klappt nur wenn ich den Port 587 einrichte.
Und wo bitte wenn man denn einmal fragen darf ist jetzt eigentlich
das Problem? Dann hast Du doch TLS, oder?

Das ist bei T-Online nicht anders

- SSL = Port 993
- SSL = Port 465
- TLS = Port 587

Einfach eingeben und dann fluppt das und gut ist!

Gruß
Dobby
Bitte warten ..
Mitglied: MS6800
09.08.2014, aktualisiert um 13:18 Uhr
@108012 Das ist korrekt, wie den auch Strato ist doch die Telekom Tochter.
Bitte warten ..
Ähnliche Inhalte
Netzwerke
OpenVPN TLS
Frage von 121851Netzwerke4 Kommentare

Hallo zusammen, habe mir mir einen OpenVPN Server aufgesetzt und der funktioniert. Habe jetzt mal in die Logdatei gesehen ...

Windows Server
Aktivierung TLS - GPO - Webseite greift nicht auf TLS zurück
Frage von Martin89Windows Server1 Kommentar

Hallo, ich bin etwas ratlos. Folgendes Problem: Unsere Finanzbuchhaltung greift per IE auf die Seite von ElsterOnline zu. Insofern ...

Internet
Strato Erfahrungswerte
Frage von thomasreischerInternet18 Kommentare

Hallo zusammen, Wir werden demnächst unseren hoster wechseln - auf der Suche nach alternativen ist mir strato aufgefallen, die ...

Firewall
PfSense: Freeradius, NUR EAP-TLS
Frage von mrserious73Firewall

Hallo zusammen, gibt's eine Möglichkeit, den Radiusserver in pfSense wirklich NUR EAP-TLS machen zu lassen? Man kann die restlichen ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 17 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 21 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...