Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN und Access Point TL-WA901N

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Pulle89

Pulle89 (Level 1) - Jetzt verbinden

30.12.2011, aktualisiert 18.10.2012, 8531 Aufrufe, 7 Kommentare

Hallo,

ich habe einen Access Point TP-Link TL-WA901N, dieser unterstütz Multi-SSIDs.
Ich möchte diesen nun an meinem Switch HP Procurve 5406zl anschließen und auf dem Access Point 2 VLANs zur Verfügung stellen,
eins für Intern und eins für Gäste. Ich habe bis jetzt die IDs von den bestehenden VLANs in der Konfig des AP eingegeben aber es fuktioniert leider nicht.
Der Procurve unterstütz meines Wissens IEEE802.1Q das dafür gebraucht wird, muss ich ggf. noch weitere Einstellungen am Procurve vornehmen.
Weiß leider nicht weiter un benötige eure Hilfe. Danke.

1ab75e759c2572eb6d0706fe937f7639 - Klicke auf das Bild, um es zu vergrößern

52f56ac98c4a8e2b541e1d47b373440c - Klicke auf das Bild, um es zu vergrößern

e13506e8cb77dcafa107872aec5e6850 - Klicke auf das Bild, um es zu vergrößern
Mitglied: d-g-l-80
30.12.2011 um 16:57 Uhr
Hallo,

hast Du denn am ProCurve ein VLAN definiert, ansonsten musst Du dies noch machen? Allerdings dürfte Dir ein VLAN ausreichen, da ja wahrscheinlich für "Verwaltung_intern" keine Beschränkung gelten soll.

Gruß
Daniel
Bitte warten ..
Mitglied: aqui
30.12.2011, aktualisiert 18.10.2012
Einfach mal die Suchfunktion benutzen...
Das folgende Tutorial beantwortet alle deine Fragen:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Im Rahmen des gesamten VLAN/WLAN Tutorials findest du auch eine fertige HP konfig zum Abtippen:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Am Procurve musst du natürlich logischerweise die VLANs 2 und 9 einrichten und die tagged auf dem Port des Switches anlegen ala
interface 10
name "VLAN Tagged Link zum WLAN AP"
exit
vlan 2
name "Privates LAN"
untagged 1-5
tagged 10
exit
vlan 9
name "Gäste WLAN"
untagged 6-7
tagged 10
exit

Das o.a. Tutorial hat diverse Beispiele dazu die das alles haarklein erklären.
Die Management IP des AP liegt bei solchen einfachen BilligA Ps oft fest im Default VLAN 1 das am Switch immer untagged anliegt. Achte also tunlichst darauf das das IP Netz in VLAN 1 dem Default VLAN auf dem Switch mit der AP Management IP korrespondiert !
Für die von dir eingestellten VLANs 2 und 9 arbeitet der AP als simple Bridge wie es alles APs machen.
Damit ist das Setup dann ein Kinderspiel.
Bitte warten ..
Mitglied: Pulle89
02.01.2012 um 10:39 Uhr
interface 10
name "VLAN Tagged Link zum WLAN AP"
exit

Dies ist ja nur die jeweilige Benneung des Ports, die habe ich bei mir weggelassen.

Die feste IP des AP befindet sich im meinem Default VLAN, die beiden VLANs 2 und 9 (ID identisch) haben den Port des AP (B11) als tagged,
desweiteren ist noch der Port mit LW-Verbindung zum anderen HP Procurve tagged.
Unten meine Konfiguration, es funktioniert aber nicht.


vlan 1
name "DEFAULT_VLAN"
untagged B1-B24,C2,C4-C12,C14,C16,C18,C20-C24
ip address 192.168.130.193 255.255.255.0
no untagged A1-A24,C1,C3,C13,C15,C17,C19
ip igmp
ip irdp
exit

vlan 2
name "Allgemein"
untagged A1-A24,C13,C15,C17,C19
ip helper-address 192.168.130.1
tagged B11,B20-B21
no ip address
ip igmp
ip irdp
exit

vlan 7
name "Drucker"
ip helper-address 192.168.130.1
tagged B20-B21
no ip address
exit

vlan 8
name "GL"
tagged B20-B21
no ip address
exit

vlan 9
name "Gaeste"
untagged C1,C3
tagged B11,B20-B21
no ip address
exit
Bitte warten ..
Mitglied: aqui
10.01.2012 um 12:07 Uhr
Ist dein Port wo der WLAN AP dran ist B-11 ?? Der Port zwischen den Switches ist das B20 und B21 ??
Wenn ja , dann ist die Switchkonfig soweit OK !

Du solltest dann strategisch vorgehen:
Wenn der AP alle 3 ESSIDs konfiguriert hat also:
ESSID1 = WLAN Name 1 = default VLAN 1
ESSID2 = WLAN Name 2 = VLAN 2
ESSID3 = WLAN Name 3 = VLAN 9
Dann solltest du nacheinander dich einmal mit einem WLAN Client (Laptop) mit ESSID 1 verbinden.
Der WLAN Traffic geht dann untagged ins default VLAN 1.
Hast du auf dem WLAN Client eine entsprechende IP Adresse bekommen (192.168.130.x /24, check mit ipconfig ) oder dir selbst statisch vergeben solltest du nun die Switch IP im Default VLAN 1 nämlich 192.168.130.193 problemlos anpingen können.
Diesen test wiederholst du nun für die VLANs 2 (ESSID 2) und VLAN 9 (ESSID 3)
Dabei solltest du dann testweise immer einem pingbaren PC mit entsprechender IP im Port A 1 (Bei Test mit VLAN 2 / ESSID 2) und/oder C1 (Bei Test mit VLAN 9 / ESSID 3) eingesteckt haben.
Alternativ kannst du auf dem Switch IP Adressen ala ip address 172.16.2.254 255.255.255.0 (für VLAN 2) und ip address 172.16.9.254 255.255.255.0 (für VLAN 9) eintragen und hier pingen.
ACHTUNG: Auch immer auf die dann entsprechend dazu korrespondierenden IPs des WLAN Clients in den ESSIDs achten !!!
Die VLAN IPs des Switches kannst du später mit no ip address wieder entfernen. Das erspart dann den Test PC in den Ports A1 und C1.

Wenn dieser Test sauber funktioniert, dann kannst du das auf die gesamte Infrastruktur ausweiten !
Bitte warten ..
Mitglied: codepoet
07.03.2012 um 13:34 Uhr
Hallo!

Ich denke der Vollständigkeit halber sollte dies hier noch erwähnt werden ...

Ich fahre einen ähnlichen Aufbau wie du, genauer nutze ich den benannten WLAN-AccessPoint (TL-WA901N), sowie diverse HP Switches. Der Access-Point ist hier an einem HP ProCurve 1810G-24 (WebSmart-Management) angeschlossen. Im Netz sind diverse VLANs konfiguriert, welche der Switch auch mit entsprechendem Tag an den AccessPoint weiter leitet. Entsprechende Konfiguration kann man bereits sehr gut den diversen Kommentaren entnehmen.

Nun hat dieser AccessPoint in der (derzeit noch aktuellen) Firmware jedoch einen Bug, welcher einem trotz korrekter Konfiguration einen Strich durch die Rechnung macht. Genauer ist es hier so, dass bei weniger als 4 verwendeten VLANs der AccessPoint die Konfiguration zwar akzeptiert (speichert), diese aber letztendlich nicht "greift". Erst wenn wirklich 4 VLANs konfiguriert werden, funktioniert das Ganze. Wie bei dir und mir werden nun aber eben keine 4 VLANs benötigt, was also tun?

Die Lösung ist einfach alle 4 VLAN-Einträge auszufüllen und zwar ggf. mit identischer Konfiguration!

Beispielsweise sieht das Ganze bei mir so aus:

SSID 1    Intern        VLAN (TAG) 10 
SSID 2    Gaeste        VLAN (TAG) 20 
SSID 3    Gaeste        VLAN (TAG) 20 
SSID 4    Gaeste        VLAN (TAG) 20
Es ist zu sehen, dass alle 4 SSID/VLAN-Einträge ausgefüllt sind, es sich jedoch um lediglich 2 unterschiedliche SSID/VLAN-Kombinationen handelt. ... Und es funktioniert!

Diese Information scheint auch direkt von technischen Support von TP-Link zu stammen, ein entsprechender Foren-Eintrag findet sich hier: http://whrl.pl/RcMfdo

Ich denke diese Information ist für die Besucher, welche diesen Thread lesen und noch immer keine korrekte Funktion erreichen durchaus hilfreich!


So long ...
Bitte warten ..
Mitglied: aqui
07.03.2012, aktualisiert 18.10.2012
Ist schon ziemlich krank wenn an ein ganz offensichtlich im Produkt enthaltenden SW Bug mit so einen üblen Quick and Dirty Konfiguration "verschlimmbessern" muss.
Die TP-Link Entwickler in China sollen sich dransetzen und den Bug fixen und nicht so einen Mist verzapfen !!
So löst man solche Probleme, aber vermutlich bezahlt das der gemeine "Sparwasdukannstkunde" im Blödmarkt wieder nicht...?!
Ein weiteres Indiz die Finger besser von TP-Link zu lassen und einen weiten Bogen um diese Produkte zu machen wenn deren Support so mies ist.
Wenn man schon jeden erdenklichen Cent sparen will und beim billigsten aller Billigheimer einkaufen muss können es andere Hersteller in diesem Bereich erheblich besser OHNE solchen (TP) Mist wie oben machen zu müssen ! Mal abgesehen von den Sicherheitsproblemen die man sich damit ggf. einfängt Siehe:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Bitte warten ..
Mitglied: codepoet
07.03.2012 um 14:04 Uhr
Jepp; Full ACK.

Auch aberwitzig in dieser Konfiguration ist, dass man den AP nicht direkt erreichen kann (ICMP Ping, HTTP, ...), sobald man selbst über diesen drahtlos verbunden ist. Es scheint fast so, als ob der AccessPoint die WLAN-Ethernet-Fragmente auch korrekt mit der entsprechenden VLAN-ID tagged, diese dann jedoch im Gerät selbst nicht korrekt zum Management-Device (also dem Netzwerk-Interface des AccessPoints selbst) weiter leitet. Kabelgebunden ist all dies kein Problem (Ethernet-Fragment mit entsprechendem Tag dringt auch bis zum AP durch) ...

So wie du schon sagst, alles sehr "kostenoptimiert" umgesetzt und so stellt es sich dann auch dar.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Access Point: Ubiquiti UAP AC PRO Einschätzung Reichweite (4)

Frage von TimMayer zum Thema LAN, WAN, Wireless ...

Router & Routing
Zyxel Support, Zyxel W-Lan Access Point NWA1100-NH (2)

Erfahrungsbericht von ThomasBIT zum Thema Router & Routing ...

LAN, WAN, Wireless
WLAN-Funkreichweite Access Point MikroTik (4)

Frage von teret4242 zum Thema LAN, WAN, Wireless ...

Router & Routing
Access Point konfigurieren (2)

Frage von accessp01nt zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...