Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLC UDP Streaming auf XP geht es und auf Win7 geht es nicht

Frage Multimedia

Mitglied: H41mSh1C0R

H41mSh1C0R (Level 2) - Jetzt verbinden

06.02.2013 um 14:58 Uhr, 5422 Aufrufe, 12 Kommentare

Hi@All,

wir stellen eine Umgebung von XP auf Win7 um. Jetzt sollen auch gleich sämtliche media player durch den VLC ersetzt werden, mit dabei auch eine Anbindung an einen Streamingserver.

Unter Windows XP findet der VLC den Streamingserver direkt alleine. Unter Windows 7 nada.

FWs sind aus. Wenn ich Wireshark nebenbei laufen lasse geht nichtmal eine Anfrage an den Streamingserver raus, so als ob da noch irgendwas blockt.

Hat einer eine Idee?

Gruß
Mitglied: Cometcola
06.02.2013 um 15:50 Uhr
Moin,

also wenn ich mit Windows 7 Netzwerkprobleme hatte, lag es zu 95% daran, dass ein/mehrere PCs nicht im "Heimnetzwerk" waren, sondern im Profil "Öffentlich". In den normalen Einstellungen blockt dann Windows 7 erstmal pauschal alles.
Bitte warten ..
Mitglied: H41mSh1C0R
06.02.2013 um 15:58 Uhr
=)

die Umgebung hier ist in einer Bank. Hier wird alles über policys geregelt.

Die Policy "Medienstreaming" haben wir nun auch ausprobiert, die war deaktiviert, daran liegt es aber nicht. =(

An welcher Stelle wird das geblock? Im Grunde tut dies doch die FW oder? Die ist deaktiviert.

Gruß
Bitte warten ..
Mitglied: Cometcola
06.02.2013 um 16:01 Uhr
ok das ist natürlich deutlich komplexer. Da kann ich dir dann leider nicht weiterhelfen, da die internen Strukturen deutlich über ein 0815 Netzwerk liegt.
Bitte warten ..
Mitglied: aqui
06.02.2013, aktualisiert um 16:25 Uhr
Er schreibt ja oben die Firewall ist deaktiviert !!
Folglich kann da dann ja auch nix mehr irgendwie blocken, logischerweise...
Es sei denn die FW ist doch nicht deaktiviert !!? Das sollte man natürlich verlässlich klären !
VLC auf der aktuellsten Version ??
Bitte warten ..
Mitglied: H41mSh1C0R
06.02.2013, aktualisiert um 16:23 Uhr
hi aqui,

VLC in der version 2.0.5 (die x86 und die x64 verhalten sich genauso)
FW deaktiviert

Gruß
Bitte warten ..
Mitglied: aqui
06.02.2013 um 16:27 Uhr
Wenn schon kein Connect Request auf den Stream aufs Netz geht (vermutlich machen die XP Maschinen das, richtig ?) dann ist das schon bedenklich ?!
Was für ein Protokoll nutzt dein Stream ? Multicasting, UDP ??
Bitte warten ..
Mitglied: H41mSh1C0R
06.02.2013, aktualisiert um 16:54 Uhr
Multicasting UDP ist korrekt.

Da ich auf der XP Maschine keine Admin Berechtigung habe um z.B. Wireshark mitlaufen zu lassen kann ich nicht sagen was genau auf der XP Maschine abläuft. Ich muss den VLC nur starten und kurz(30sec-1min) warten und die SAP Liste wurde abgeholt.

Ein weiterer Unterschied ist das die XP Kiste in der alten Domain hängt und die Win7 Kiste in der neuen.
Mir wurde von allen Seiten bestätigt das der Multicast überall verfügbar ist.

Die Streamingserver sind auch anpingbar.

Nichts destotrotz müsste ich ja beim anwerfen vom VLC auf der Win7 Kiste mit Wireshark wenigstens was sehen, dort ist aber Funkstille.



Zu ggf. Einstellungen bei dem VLC. Hier musste ich NICHTS einstellen, einfach nur plain Standardinstallation. Gegengetestet mit der Portable Version vom VLC auf beiden Clients. Verhalten identisch.
Bitte warten ..
Mitglied: aqui
06.02.2013 um 17:01 Uhr
Generiere dir am LAN Switch wo die XP Maschine angeschlossen ist einen Monitor Port. Dort kannst du deinen Wireshark dann anschliessen und unabhängig von der XP Maschine genau mitsniffern WAS von der XP Maschine kommt.

Machst du aktives Multicasting im Netzwerk ?? IGMP ?? oder hast du einen doofen Switch der nur dumm flutet ?
Hoffentlich ersteres. Wenn es aktiv ist, muss der Rechner eine IGMP Join Message absenden, die muss in jedem Falle kommen.
Multicast hat erstmal per se nix mit MS Domains zu tun.
Multicast IP Adressen 224.0.0.0 bis 239.255.255.255 oder alles mit FF00::/8 bei IPv6 werden von doofen, nicht managebaren Switchen geflutet wie Broadcasts, was sehr uneffizent im Netzwerk ist logischerweise, da es den Traffic erheblich belastet.
Bessere (managebare) Switches sprechen aktives Multicasting mit IGMP. Was man auch immer aktivieren sollte im Switch Setup !
Dort wird nur auf den Ports der Stream geforwardet wo auch ein Client ist der "joinen" will auf die entsprechende MC IP Adresse, was erheblich effizienter ist. Ports ohne Clients bleiben vom MC Traffic frei.

Winblows Domains spielen da keinerlei Rolle, es sei denn mit irgendwelchen Gruppenrichtlinen oder anderem Winblows Gedöns werden Rechte entzogen oder Filter gesetzt.
Deshalb macht es immer Sinn einen Domain unabhängigen Client zu haben um das zu wasserdicht testen.
Wenn du also IGMP fährst kann es durchaus sein das an dem Port wo der Win7 Rechner ist nichts zu sehen ist von MC. Wie gesagt ohne Join schickt der Switch dann nix.
Wenn der aber noch nichtmal kommst hast du ein generelles Win7 Problem erstmal.
Das zeigt ja auch die Tatsache das es vermutlich am selben Switchport mit XP wunderbar, klappt, oder ?
Bitte warten ..
Mitglied: H41mSh1C0R
06.02.2013, aktualisiert 07.02.2013
Hi Aqui,

schonmal danke für die ausführliche Antwort.

Ganz großes Problem:

- Ich habe NUR Zugriff auf die beiden Clients und eine Virtuelle Maschine die sich mit Ihrem Win7 genauso verhält wie der Laptop mit Win7.
- Nur auf dem Laptop und der VM habe ich Adminrechte und einen Testnutzer.
- Auf dem XP Client bin ich reiner Nutzer.

Umstecken von PCs an andere Ports ist nicht ohne weiteres möglich da die Ports abgezählt(Bodentanks) sind.

Ob IGMP genutzt wird kann ich in Erfahrung bringen.

Denke das das nicht zum Einsatz kommt da davon die Rede war das der Multicast überall verfügbar sein sollte. War auch schon mit dem Win7 Laptop in unterschiedlichen Subnetzen und überall ging es mit dem Win7 nicht.

Zum eventuellen generellen Win7 Problem hast du da eine Idee wie ich das erforschen könnte? ProgMon?

Gruß
Bitte warten ..
Mitglied: Nr60730
06.02.2013, aktualisiert um 21:14 Uhr
Zitat von aqui:
Er schreibt ja oben die Firewall ist deaktiviert !!
Folglich kann da dann ja auch nix mehr irgendwie blocken, logischerweise...

moin aqui,

"leider" muß ich dir berichtigen... (Fällt mir immer schwör)
[1/2OT]
  • Nimm mal ne 7er SpielKiste
  • stell die Firewall aus, starte die Karre neu
  • Versuche einen Drucker freizugeben
  • Du wirst solange scheitern, bis du:
  • Die Firewall wieder gestartet hast
  • Ne Ausnahme für File & Print eingestellt hast
(danach kannst die Fiewall wieder abklemmen)
[/1/2OT]

Von daher - never say never again wenns um Blows geht

Gruß
Tafkapmo
Bitte warten ..
Mitglied: aqui
07.02.2013 um 19:19 Uhr
Recht hast du ! Die Abgründe bei Blows sind grauselig....

@H41....
Du kannst auch testweise mal 2 Rechner mit Multicast Test Tools wie mcaster anschliessen oder auf zugänglichen Maschinen installieren und generell testen ob das Netzwerk auch Multicasts forwardet. Wovon aber vermutlich auszugehen ist wenn andere Maschinen es problemlos können.
Ist dann doch eher zu vermuten das es ein reines Blows 7 Problem ist ?!
Bitte warten ..
Mitglied: H41mSh1C0R
07.02.2013, aktualisiert um 19:27 Uhr
Hi Aqui,

auf den Rechnern bei denen das Streamen geht kann ich nichts selber installieren im Grunde darf ich die nur als Terminal benutzen von denen aus ich dann auf VMs connecte oder halt den Laptop.

Wir haben noch einen Verdacht, das das an den Streamingservern liegt.

Bekomme noch einen Streamingserver gestellt der explizit für die Win7 Domain ist, damit sollte es definitiv klappen wenn das Netzwerk forwarded.

Bin mal gespannt was sich in den nächsten Tagen tut. =)

Gruß
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...