Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMware Server und Broadcom VLAN

Frage Microsoft Windows Server

Mitglied: dog

dog (Level 4) - Jetzt verbinden

19.01.2009, aktualisiert 09:55 Uhr, 6858 Aufrufe, 6 Kommentare

Hallo,

ich habe ein Netzwerkproblem mit VMware Server 2.0 und einer Broadcom BCM5708C Netzwerkkarte.

Der Host hat mehrere virtuelle Netzwerkkarten für verschiedene VLANs.
Das "VMware Bridge Protocol" ist bei allen Karten außer der Physikalischen (die auch keine IP hat) aktiviert.

Ein Gast braucht nun Zugriff auf 2 der VLANs.
Dazu habe ich in der Konsole zwei virtuelle Netzwerkkarten (bridged) angelegt und im Gast beide mit einer statischen IP konfiguriert -> Kein Zugriff nach Außen.

Dann habe ich im Virtual Network Editor die Regeln etwas expliziter gesetzt und die betreffenden Adapter des Hosts an VMnet Adapter gebunden und ein Subnet für jeden Adapter konfiguriert -> auch keine Änderung.

Was mache ich falsch?

Grüße

Max
Mitglied: aqui
19.01.2009 um 10:29 Uhr
Hier steht was du dazu wissen musst:

http://www.vmware.com/pdf/esx3_vlan_wp.pdf
Bitte warten ..
Mitglied: dog
19.01.2009 um 11:02 Uhr
Hallo,

das bezieht sich soweit ich gesehen habe nur auf den ESX Server - Ich benutze aber den "normalen" Vmware Server, der selbst ja nicht "VLAN-aware" ist.

Grüße

Max
Bitte warten ..
Mitglied: RoterFruchtZwerg
19.01.2009 um 14:10 Uhr
Möglicherweise verwirft der VLAN Treiber des Hosts Pakete mit einer MAC Adresse die nicht von einem der VLAN Adapter stammt?
Wirf doch mal Wireshark an und schau ob du die Pakete der VMs überhaupt am VLAN Adapter des Hosts mitsniffen kannst. Wenn ja, überprüf mit einem weiteren PC, ob diese auch tatsächlich aufs Netz gegeben werden und ob sie dort mit dem VLAN Tag versehen sind.
Bitte warten ..
Mitglied: aqui
19.01.2009 um 16:42 Uhr
Das ist klar das das dann nicht geht !!!
VLAN getaggte Pakete nach 802.1q werden an normalen (untagged) Ports immer verworfen und umgedreht !!!
Die Frame Formate sind nicht kompatibel !!
Bitte warten ..
Mitglied: dog
19.01.2009 um 17:31 Uhr
Moment. So wie ich das verstehe sollte der Broadcom Treiber die VLAN-Tags aus der Gleichung rausziehen. Sprich einkommende getaggte Pakete werden zu normalen und auf eine der virtuellen Netzwerkkarten verteilt und ausgehende Pakete werden je nach virtueller Karte mit einem Tag versehen. Somit sollten die VLANs also für Windows und VMware eigentlich egal sein solange die richtige Netzwerkkarte für das richtige Subnet benutzt wird...

Allerdings habe ich mir grade mal mit Wireshark den Traffic des Hosts angeschaut und dort haben alle ausgehenden TCP/UDP Pakete eine fehlerhafte Checksum (was aber in der Praxis noch zu keinen Problemen geführt hat).

Ich glaube, ich sollte doch mal irgendwo die 70€ für eine Intel PRO Karte auftreiben.

Morgen werde ich aber erstmal versuchen Wireshark irgendwie in den Gast zu bekommen und schauen was dort so ankommt.

Grüße

Max
Bitte warten ..
Mitglied: RoterFruchtZwerg
19.01.2009 um 17:52 Uhr
Du siehst das schon richtig, die virtuellen Adapter sind ja dazu da die VLANs in (für das OS) virtuelle separate Netze aufzuteilen. Es sollten also keine VLAN Tags auf den virtuellen Adaptern zu sniffen sein. Die Frage ist aber, wo setzt der Treiber an und klebt das VLAN Tag davor... da kann es schon sein, dass es mit VMware Probleme gibt.

Aber du hast jetzt die virtuellen Adapter mit gesnifft, was kam dabei raus? Kommen Daten der VMs auf die virtuellen Adapter?

Und wegen der Checksumme, google mal nach "TCP/UDP Checksum offload", da gibt es oft eine Option in den Hardwareeigenschaften der Adaptern, wo man das umstellen kann.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Vmware
Storage für VMWare Server gesucht (10)

Frage von MichiBLNN zum Thema Vmware ...

Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...