Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vmware Workstation - 4 stk. rs232 mit bluescreen und automatischem Neustart

Frage Microsoft Windows Installation

Mitglied: devilshaver

devilshaver (Level 1) - Jetzt verbinden

28.03.2009, aktualisiert 17:11 Uhr, 7393 Aufrufe, 3 Kommentare

Event id (102) und 1003

Hallo an Euch alle !

Ich bin sicherlich nicht derjenige der sofort gleich seine Probleme in ein Forum tippt ohne vorher alles versucht zu haben selbst das Problem zu lösen ! Also bitte keine Antworten mit a la Suchfunktion benutzen usw. Danke.

Tja, wie sieht meine Umgebung aus:

AUFGABENSTELLUNG:
Der Computer ermöglicht es mit einer Software (OMRON) auf 2 SPS zuzugreifen und mit einer weiteren Software (Ge Fanuc) werden die Daten einer dritten SPS visualisiert.

Die Software Omron benötigt hierfür COM1 und COM2.
Die Software GE Fanuc benötigt hierfür COM3 und COM4

Ziel soll es sein, dass alle vier Schnittstellen zu gleichen Zeit Daten beziehen können.

PROGLEMSTELLUNG:

Der ursprünglich PC ist in die Jahre gekommen und musste ersetzt werden. Da das installieren der Software immer sehr zeitaufwendig ist - und um sich die Updates für spätere Betriebssystemanpassungen zu ersparen wurde die Variante VMware Workstation geboren.

Ich habe mir also vom alten PC ein Image gezogen und es in der VMware wiederhergestellt.

Nach fertigstellen aller Einstellungen funktioniert nun alles, aber nur solange eine Software läuft.
d.h. Wenn Omron alleine auf beide SPS zugreift funktioniert alles. Greift nur GE Fanuc auf die SPS zu dann funktioniert auch alles.

Nur wenn beide Programme laufen und mit den Schnittstellen verbunden werden, dann stürzt nicht die VMware sondern der ganze Computer !!
es kommt ganz kurz ein Bluescreen und das wars..... Danach startet der Computer ins Windows und tut so als ob nichts gewesen wäre...

SYSTEMUMGEBUNG:

Host:
- Windows XP mit SP3
- antivir
- openoffice
- VMware Workstation 6.5
- 2 PCI Steckkarten > VScom 200L UPCI wobei jede Karte zwei serielle Schnittstellen zur Verfügung stellt !! link: http://www.vscom.de/4462.htm
- tja und das wars eigentlich schon -- also eigentlich recht optimal da kein Schnick-Schack auf dem Host ist.

VM-WARE - virtualisiertes System
- Windows 2000 SP4
- Omron Software für die Ansteruerung von 2 SPS
- GE Fanuc Software für die Visualisierung

BISHERIGER LÖSUNGSWEG / VERSUCH :

(1) Fehler Lokalisierung

Als erstes habe ich mir die Fehlermeldung in der Ereignisanzeige angesehen:



Ereignistyp: Fehler
Ereignisquelle: System Error
Ereigniskategorie: (102)
Ereigniskennung: 1003
Datum: 27.03.2009
Zeit: 17:02:47
Benutzer: Nicht zutreffend
Computer: VISUALISIERUNG
Beschreibung:
Fehlercode 100000d1, 1. Parameter 00000000, 2. Parameter 0000001c, 3. Parameter 00000001, 4. Parameter 969201c2.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 53 79 73 74 65 6d 20 45 System E
0008: 72 72 6f 72 20 20 45 72 rror Er
0010: 72 6f 72 20 63 6f 64 65 ror code
0018: 20 31 30 30 30 30 30 64 100000d
0020: 31 20 20 50 61 72 61 6d 1 Param
0028: 65 74 65 72 73 20 30 30 eters 00
0030: 30 30 30 30 30 30 2c 20 000000,
0038: 30 30 30 30 30 30 31 63 0000001c
0040: 2c 20 30 30 30 30 30 30 , 000000
0048: 30 31 2c 20 39 36 39 32 01, 9692
0050: 30 31 63 32 01c2




Habe lange gegoogelt und mittels dem Minidump-file bin ich dann draufgekommen, dass die Datei Probably caused by : vss2k.sys ( vss2k+71c2 ) das Problem ist.
Und genau das ist die Treiberdatei von beiden Schnittstellen.

Hier noch die Details aus den Debuggintool von Microsoft:




Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Dokumente und Einstellungen\HAM\Desktop\Neuer Ordner\Mini032709-07.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: C:\WindowsSymbols
Executable search path is:
Unable to load image ntoskrnl.exe, Win32 error 0n2
WARNING: Unable to verify timestamp for ntoskrnl.exe
Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Machine Name:
Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
Debug session time: Fri Mar 27 17:01:39.390 2009 (GMT+1)
System Uptime: 0 days 0:08:06.060
Unable to load image ntoskrnl.exe, Win32 error 0n2
WARNING: Unable to verify timestamp for ntoskrnl.exe
Loading Kernel Symbols
...............................................................
................................................................
...............
Loading User Symbols
Loading unloaded module list
............
Unable to load image vss2k.sys, Win32 error 0n2
WARNING: Unable to verify timestamp for vss2k.sys
ERROR: Module load completed but symbols could not be loaded for vss2k.sys
ERROR: FindPlugIns 8007007b
*
  • *
  • Bugcheck Analysis *
  • *
*

Use !analyze -v to get detailed debugging information.

BugCheck 100000D1, {0, 1c, 1, 969201c2}

Unable to load image serenum.sys, Win32 error 0n2
WARNING: Unable to verify timestamp for serenum.sys
Probably caused by : vss2k.sys ( vss2k+71c2 )

Followup: MachineOwner
0: kd> !analyze -v
ERROR: FindPlugIns 8007007b
*
  • *
  • Bugcheck Analysis *
  • *
*

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 00000000, memory referenced
Arg2: 0000001c, IRQL
Arg3: 00000001, value 0 = read operation, 1 = write operation
Arg4: 969201c2, address which referenced memory

Debugging Details:

WRITE_ADDRESS: 00000000

CURRENT_IRQL: 1c

FAULTING_IP:
vss2k+71c2
969201c2 890a mov dword ptr [edx],ecx

CUSTOMER_CRASH_COUNT: 7

DEFAULT_BUCKET_ID: COMMON_SYSTEM_FAULT

BUGCHECK_STR: 0xD1

PROCESS_NAME: vmware-vmx.exe

LAST_CONTROL_TRANSFER: from 9691dfdc to 969201c2

STACK_TEXT:
WARNING: Stack unwind information not available. Following frames may be wrong.
ba237b58 9691dfdc 88724a28 00000000 00000001 vss2k+0x71c2
ba237bf8 804ef19f 88724970 8893b420 8893b420 vss2k+0x4fdc
ba237c1c b97f8a94 887247b8 0093b420 89100f20 nt!MiFlushSectionInternal+0x256
ba237c40 804ef19f 887247b8 00000000 806e7410 serenum!Serenum_IoCtl+0x76
ba237c64 805807f7 887247b8 8893b420 89100f20 nt!MiFlushSectionInternal+0x256
ba237d00 80579274 00000338 0000061c 00000000 nt!NtSetInformationThread+0x125
ba237d34 8054162c 00000338 0000061c 00000000 nt!SepOpenTokenOfThread+0x87
ba237d64 7c91e4f4 badb0d00 0d1bee90 94b7ed98 nt!RtlIpv4StringToAddressExW+0xad
ba237d78 00000000 00000000 00000000 00000000 0x7c91e4f4


STACK_COMMAND: kb

FOLLOWUP_IP:
vss2k+71c2
969201c2 890a mov dword ptr [edx],ecx

SYMBOL_STACK_INDEX: 0

SYMBOL_NAME: vss2k+71c2

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: vss2k

IMAGE_NAME: vss2k.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 467a5800

FAILURE_BUCKET_ID: 0xD1_vss2k+71c2

BUCKET_ID: 0xD1_vss2k+71c2

Followup: MachineOwner



(2) Lösungsversuche

- Ich habe dann versucht den neuesten Treiber mit Windowszertifikat runterzuladen und zu installieren. Leider hat dies auch keine Lösung des Problems gebracht.
- Beide Schnittstellen habe ich schon getauscht um eventuell die Hardware Seite auszuschließen.
- Memtest habe ich auch durchgeführt also der Computer ist Brandneu und alle Test waren OK
- Ich habe dann versucht die VMware - Windows 2000 Umgebung zu clonen und die Anwendungen in getrennten VMware Sitzungen zu starten. Das einzige was passierte, war dass die Zeit bis zum Absturz länger gedauert hat. Aber die Art und Weise inkl. der Fehlermeldung blieb gleich.

Ich hoffe jemand von euch hatte ein Problem dieser Art schon einmal und kann mir hier ein Stückweit weiterhelfen.

DANKE schon jetzt für die Antworten !!

Mit freundlichen Grüßen DS
Mitglied: StefanKittel
28.03.2009 um 22:18 Uhr
Hallo,

klingt nach einem Fehler im Treiber.
Den einzigen Tipp den ich hätte wären andere Karten oder LAN-COM-Ports. Da wüßte die andere Machiene gar nicht dass es diese gibt.

Stefan
Bitte warten ..
Mitglied: devilshaver
29.03.2009 um 15:14 Uhr
ja da hast du recht.

hab mir eh schon eine andere Karte bestellt und dazu noch die lancom Ports.

Melde mich dann, wenn ich mehr weiß !
Bitte warten ..
Mitglied: devilshaver
28.04.2009 um 08:26 Uhr
Juhu ! Problem gelöst !

Hier die Antwort nach meiner Supportanfrage beim Hersteller meiner 2 Port - PCI Schittstelle:

VMware greift mindestens teilweise am Treiber vorbei auf die Hardware zu. Wir erkennen das u.a. daran, daß die im System verfügbaren Schnittstellen mindestens I/O-Adresse und IRQ besitzen müssen.
Schnittstellen basierend auf USB werden von VMware nicht akzeptiert, und können in der virtuellen Maschine nicht genutzt werden. Bis vor wenigen Versionen war das sogar eingeschränkt auf Schnittstellen mittels MS-Treiber.
Im Gegensatz dazu die DOS-Box von Windows NT bis XP. Hier wird eine Schnittstelle namens Com3 komplett auf 3E8/IRQ4 emuliert. Hierbei ist es belanglos, ob eine "echte" Schnittstelle im Rechner vorliegt, oder ob diese per Netz oder USB zur Verfügung gestellt wird. Der "Treiber"
DOS-Box realisiert die notwendigen Ergebnisse ausschließlich durch Aufrufe des Treibers.

Wenn nun ein Treiber (VMware) dem zuständigen Treiber seine Hardware entzieht, ist es nicht überraschend, daß der eigentlich zuständige Treiber ein Problem bekommt.

Bei Ihnen tritt das Problem erst dann auf, wenn beide Karte gleichzeitig verwendet werden, und daher auch beide IRQs erzeugen. Die naheliegende Lösung ist, nur eine Karte mit 4 oder 8 Schnittstellen zu nutzen.
Dadurch wird das grundsätzliche Problem bereits im Ansatz vermieden.



Nach dem Tausch der beiden Karten auf eine mit 4 Ports waren die Probleme wie weggewischt !

lg. ds
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Vmware
W7 32 Host und VMWARE Workstation (4)

Frage von ganesh67 zum Thema Vmware ...

Virtualisierung
gelöst QEMU KVM - VMware Workstation - Oracle Virtual Box - Was denkt ihr? (17)

Frage von twoDarkMessiah zum Thema Virtualisierung ...

Vmware
gelöst VmWare Workstation Pro SQL Server Manager Zugriff Host - Guest (1)

Frage von Nintox zum Thema Vmware ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...