Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

W2k8 registry file is missing or corrupt, Bootprobleme

Frage Microsoft Windows Server

Mitglied: Eisern

Eisern (Level 1) - Jetzt verbinden

02.03.2012 um 10:46 Uhr, 4150 Aufrufe, 11 Kommentare

Hallo,

ich habe ein akutes Problem mit einem unserer Server (W2k8 Std inkl. Exchange 2010). Hier wurden gestern automatische Updates installiert, danach erfolgte in der Nacht der Neustart.

Nun startet der Server jedoch nicht mehr, es kommt die Fehlermeldung das Windows nicht gestartet werden kann und "windows failed to load because the registry file is missing, or corrupt"

Nun wollte ich von der CD booten und mit Hilfe der Systemreparatur den Fehler beheben, leider ohne Erfolg. Nach ein wenig Recherche im Netz habe ich noch den Tip mit sfc /scannow /offbootdir=c:\ /offwindir=c:\windows gefunden, leider erhalte ich bei sfc die Meldung das eine Systemreparatur aussteht und ich neu starten soll.

Hat hier jemand eine Idee der weiteren Vorgehensweise? Eine Neuinstallation würde ich gern umgehen! Wie komme ich noch in die Eingabeaufforderung ohne die Systemreparatur zu starten?

System:
Dell PE R510, 16GB RAM, RAID1
W2k8 SP2 + Exchange (kein AD, DNS...)

Vielen Dank für jegliche Hilfe!

Mit freundlichen Grüßen, Tom
Mitglied: broecker
02.03.2012 um 11:11 Uhr
Halbwegs aktuelle Backups der Registry gibt's nicht - da keine Domäne würde ich jetzt mal mutmaßen, daß man's nach einem Backup der jetzigen Situation durch zurückspielen nicht schlimmer für die anderen Server/Clients machen würde?
F8 beim Starten tut nix?
Bitte warten ..
Mitglied: Ravers
02.03.2012 um 11:20 Uhr
Hi,

ich würde ja mutmaßen, das eine AD inkl. Datensicherung vorliegt. Win2008 und Exchange2010 ist ja nunmal nicht der normale Homeuser
Aber die Registry einfach zurückspielen, ist auch gefährlich, da sich durch die Updates sich dort einiges getan hatt. Daher erstmal versuchen zu reparieren.
Wenn er beim aktualisieren der Reg-Keys ausgestiegen ist - dies hatte ich auch schon (beim DC), nach dem 5 oder 6 versuch hatte er sich dann berappelt. Vermute aber, das du das nicht weißt - war ja in der Nacht. Mehrmals versuchen - hast du wahrscheinlich auch schon gemacht.
Ein chkdsk könnte dir helfen, versuche dies mal! - und melde dich mit dem Ergebniss

greetz
ravers
Bitte warten ..
Mitglied: broecker
02.03.2012 um 11:54 Uhr
da fällt mir ja auch noch eine hübsche Lösung zur Reparatur ein:
mit Linux-Live-CD booten, NTFS mit ntfs-3g /dev/sda1 (z.B.) öffnen, Partition wird dann ggf. als defekt markiert,
dann Windows wieder booten und Windows versucht dann das Dateisystem zu reparieren.
Hat bei vielen XP-Clients aber auch bei Servern schon geholfen.
Bitte warten ..
Mitglied: Eisern
02.03.2012 um 12:55 Uhr
Hallo,

erst mal Danke für die Unterstützung.

Chkdsk bringt keine Fehler, sfc bringt ja immer die Meldung das ein Reparaturversuch läuft, irgendwie komme ich aber nicht in die Eingabeaufforderung. Per F8 komme ich zwar in die Auswahl Safe Mode etc, aber es erfolgt dann immer die Meldung mit der fehlenden oder zerstörten Registry.

Neustarts habe ich auch schon einige durch, ich denke über 10 waren es schon...

Bevor ich irgendwas als defekt markiere würde ich schon gern erst mal eine Reparatur des derzeitigen Standes versuchen.

Eine Datensicherung liegt schon vor, aber alles neu aufzusetzen und den Exchange wieder neu zu machen...wir sind schon sehr sehr knapp an Zeit.

Vielleicht noch Ideen welche ich übersehe?

Vielen Dank für die Hilfe!

Mit freundlichen Grüßen, Tom
Bitte warten ..
Mitglied: Eisern
02.03.2012 um 12:57 Uhr
Hallo nochmal, könnte ich auch einfach mal eine normale Installation starten, also wird dann auch wie bei W7 etc. nach bereits vorhandenen Installationen gesucht und diese dann mit neuen Systemdaten überschrieben?

Danke, Tom
Bitte warten ..
Mitglied: broecker
02.03.2012 um 13:20 Uhr
nicht mehr bei Windows 2008 (irre ich mich? das war doch nur bis XP so?)?
Das "Defekt markieren" soll nur auslösen, daß er erst sein Dateisystem anguckt & ggf. den nächtlichen Schaden repariert, da wird m.E. kein zusätzlicher Schaden ausgelöst.
Exchange neu wäre auch für mich nicht akzeptabel, aber aus dem Backup sollte sich der Bereich .../system32/... ja einzeln wiederherstellen lassen.
Kannst Du jetzt erstmal ein 1:1 Backup, z.B. auf eine USB-Platte (aus dem RAID raus) machen? dann fällt das "Basteln" schon leichter...
Mit SysrescCD oder (notfalls )Acronis o.ä.?

(Achtung bei Acronis: Üble Erfahrung bei LSI8204/LSI8208: RAID-Conf wurde beim Backup entfernt! - lies sich aber auch wieder herstellen...)
Bitte warten ..
Mitglied: broecker
02.03.2012 um 13:24 Uhr
es gibt doch getrennte Partitionen?
Bitte warten ..
Mitglied: Eisern
02.03.2012 um 13:49 Uhr
ich habe mal versucht zu installieren, es kommt dann die Info das die normale oder die Core Version installiert werden soll, ich denke also das es nicht geht mit der Drüberinstallationsreparatur.

was meinst Du mit getrennten Partitionen, also warum?

Der Server ist ja nicht das AD, DNS, hier ist nur der Exchange installiert...Ansonsten hat der Server ein RAID5.

ich würde ja gern sfc ausprobieren, bekomme aber immer die Fehlermeldung das eine Reparatur läuft und ein Neustart erforderlich ist, nur leider bringt ein solcher das gleiche Ergebnis...

Gruß, Tom
Bitte warten ..
Mitglied: broecker
02.03.2012 um 19:01 Uhr
Netzwerkkabel schon mal ziehen, daß der Exchange nichts mehr ändert, dann mit Rettungs-/Wiederherstellungs-CDs Teile der Registry verschieben und durch das Backup ersetzen, wieder booten und gucken...
Wenn keine Rettungssysteme vorhanden sind, die erst einmal bauen.
Wenn das Wissen fehlt, mich über PM fragen - WE ist durchaus Zeit dafür...
Bitte warten ..
Mitglied: Eisern
02.03.2012 um 21:15 Uhr
Nach Austausch der fehlerhaften Regdateien (SAM, Security, Software...) ist die erste Fehlermeldung weg.

Nun habe ich den Hinweis 0xc0000428, das es eine fehlerhafte Verifizierung der winload.exe vorliegt. Ein booten, Systemreparatur, abges. Modus etc. sind auch damit nicht möglich.

Ich gehe nach umfangreichen Lesearbeiten von einem fehlerhaften Treiber aus welcher irgendwie nach einem W-Update eingespielt wurde, weitere Veränderung, auch an der Hardware hat es definitiv nicht gegeben. Einzig wurde ein neuer Aten KVM per USB angeschlossen, dieser funktionierte aber schon ein paar Tage ohne Probleme.

Mit freundlichen Grüßen, Tom
Bitte warten ..
Mitglied: broecker
03.03.2012 um 16:55 Uhr
nanu, erledigt?__________________________________________________________
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
gelöst ( Batch ) Open File or Folder Dialog (5)

Frage von clragon zum Thema Batch & Shell ...

Windows Server
gelöst Active Directory File Extension - Associated Program (11)

Frage von adm2015 zum Thema Windows Server ...

CPU, RAM, Mainboards
PC Engines apu3a4 product file (7)

Link von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...