Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Webserver, Apache 2 auf Debian Lenny liefert extrem langsam Seiten aus

Frage Linux Apache Server

Mitglied: yogitee

yogitee (Level 1) - Jetzt verbinden

10.09.2009, aktualisiert 13:44 Uhr, 13068 Aufrufe, 5 Kommentare

Hallo zusammen, seit ein paar Tagen stelle ich fest, das der Seitenaufbau auf den Seiten von meinem Server extrem langsam ist. Ich kann in der Statusleiste von Firefox sehen das er sofort nach aufrufen eines Links die Hälfte fertig geladen hat, doch der Rest dauert manchmal bis zu 20 sec.

Als erstes habe ich geprüft ob ich Packetloss habe, meine Leitung und die Leitung zum Server hin, sowie das Rechenzentrum hat keine Probleme. Die Serverlast CPU liegt bei 5% wenn überhaupt mal so viel und Arbeitsspeicher habe ich noch 1 GB Frei. Anbindung ist 100MBit von denen nur ein KBit Bereich genutzt wird. Trotz allem ist der Seitenaufbau von Seiten mit fehlerlosem HTML/ CSS und maximaler Größe von 200-300 Kb katastrophal.

Nun würde es mich nicht wundern wenn ich etwas geupdatet hätte oder ähnliches, aber ich habe nichts geupdatet oder verändert, doch trotz dem liefert er auf einmal die Seiten so ewig lahm aus...was mich wundert und ein wenig fuchsig macht ist die Tatsache das vor knapp ner Woche noch alles Prima war...

Irgendwelche merkwürdigen Transaktionen fanden auch nicht statt, Spam oder DoS Attacken...

Läuft irgendwo ein Speicher voll beim Apache oder irgendwelche Temporären Dateien die ich löschen müsste?

Der SSH Zugang lahmt auch ein wenig rum der war auch mal schneller...

Kommt das alles jemand bekannt vor?

Hat jemand eine Idee wo ich mal nachsehen könnte?



Ich steh gerade ein wenig auf´m Schlauch.


Hier noch ein paar Daten:

Debian Lenny 5.0.1
Apache 2.2.9
Bind 9

Anbindung 100Mbit
Dualcore 3,6 GHz 64Bit
4GB RAM HT

* Update: Hab gerade mal nen Relaytest gemacht ob da irgendwas am Courier Mailserver fehlkonfiguriert ist und mein Server evtl. Spammt aber das tut er nicht. Dienst bzw. der ganze Server wurde auch neu gestartet...*

In den Logfiles habe ich außer dem üblichen Schmodder auch nichts auffälliges gesehen, nur eben Dateien die nicht vorhanden sind oder Seiten die es nicht gibt war da nichts besonderes.... Sehr mysteriös alles...Aber Danke für den Tipp
Mitglied: kaiand1
10.09.2009 um 13:10 Uhr
Dienste/Server mal neugetsratet?
Unstabiele Pakete eingespielt?
Konfigs geändert?
Logfiles ne abweichung drinne? Errorlogs?
Bitte warten ..
Mitglied: Driver401
10.09.2009 um 15:36 Uhr
Da läuft aber nicht zufällig Wordpress drauf? Oder ein anderes CMS, das vielleicht ähnliche Probleme hat?
http://wp-magazin.ch/2009/01/15/123-http-transport/
Bitte warten ..
Mitglied: yogitee
12.09.2009 um 17:55 Uhr
Danke für den Tipp mit dem CMS, tatsächlich habe ich einige laufen, Joomla und ein paar Wiki und Galerie Scripte, doch keines der von mir verwendeten Scripte benutzt diese PHP Klasse.

Ich habe auch noch einmal die Logs studiert und immer noch nichts ungewöhnliches sehen können.

Wie kann es denn sein das urplötzlich alles so lahmt?
Bitte warten ..
Mitglied: Driver401
14.09.2009 um 13:31 Uhr
Also Du schreibst,

nach aufrufen eines Links die Hälfte fertig geladen hat,
doch der Rest dauert manchmal bis zu 20 sec

was auch darauf hindeuten kann, dass Du in Deinen Seiten Abrufe von anderen Seiten drin hast - soll heißen, er lädt Deine Seite bis zu einem bestimmten Code, wo er auf fremde Server zugreifen muss, dann macht er weiter (z.B. als einfachstes Beispiel ein Wetterwidget o.ä.).
Falls diese andere Adresse nicht erreichbar ist.....

Nur 'ne Idee.
Bitte warten ..
Mitglied: yogitee
14.09.2009 um 16:34 Uhr
Wir haben den Wurm gefunden, den Fehler hat ein nicht korrekt funktionierender DNS Server verursacht.

Nach dem wir diesen Second Server in der, resolv.conf auskommentiert hatten, war alles wieder paletti.

Danke auch noch mal an Driver401 für den Tipp Hätte es bestimmt auch sein können
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Windows Update
gelöst WSUS-Downloads im LAN extrem langsam seit Win-10-Anniversary-Update 1607 (1)

Frage von departure69 zum Thema Windows Update ...

Hyper-V
gelöst Win Server 2012 und Hyper V gleich Netzwerk extrem langsam (20)

Frage von Edaseins zum Thema Hyper-V ...

Windows 10
FTP ist extrem langsam (3)

Frage von grka zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...