Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Website funktioniert nur mit firefox, mit IE und chrome nicht

Frage Internet Webbrowser

Mitglied: alienmaster

alienmaster (Level 1) - Jetzt verbinden

26.02.2010 um 21:12 Uhr, 6115 Aufrufe, 7 Kommentare

ich mache gerade ne website für meinen chef


www.alienmaster.at/service/index.htm

mit dreaweaver CS4 gemacht
fürs menü hab ich Sothink DHTML Menu 9 verwendet


lokal wie auf dem webserver lässt sich die site nur mit firefox anzeigen

internet explorerund chrome zeigen die site nicht an, nur dunkles bild

auf 2 pc`s getestet
browser gewechselt
code nochmal geprüft

aber ich find den fehler nicht

beim googlen hab ich auch nicht wirklich was gefunden.

gibt es hier ein genie das weiss warum und mir helfen kann?

greets and merci
alienmaster

(günther)
Mitglied: mrtux
26.02.2010 um 22:06 Uhr
Hi !

Was passiert, wenn Du das Javascript-Menü auskommentierst bzw. durch normale und einfache Links ersetzt, wird die Seite dann komplett angezeigt?
Browser ist nicht gleich Browser, die Verhalten sich eigentlich immer unterschiedlich, darum baue ich mit Dreamweaver nur das grobe Gerüst und "code" den Rest von "Hand" mit einem Editor (z.B. Homesite).

mrtux
Bitte warten ..
Mitglied: alienmaster
26.02.2010 um 22:46 Uhr
also wenn ich den code

<style type="text/css">
<!--
body {
font: 100% Verdana, Arial, Helvetica, sans-serif;
background: #666666;
margin: 0;
text-align: center;
color: #000000;
}
.twoColLiqLtHdr #container {
width: 90%;
background: #FFFFFF;
border: 1px solid #000000;
text-align: left;
margin-top: 0;
margin-right: auto;
margin-bottom: 0;
margin-left: auto;
}
.twoColLiqLtHdr #header {
background: #DDDDDD;
padding: 0 10px;
}
.twoColLiqLtHdr #header h1 {
margin: 0;
padding: 10px 0; */
font-size: 12px;
}
.twoColLiqLtHdr #sidebar1 {
float: left;
width: 24%;
background: #EBEBEB;
padding: 15px 0;
}
.twoColLiqLtHdr #sidebar1 h3, .twoColLiqLtHdr #sidebar1 p {
margin-left: 10px;
margin-right: 10px;
font-size: 18px;
}

.twoColLiqLtHdr #mainContent {
margin: 0 20px 0 26%;
text-align: center;
font-weight: bold;
font-size: 18px;
}
.twoColLiqLtHdr #footer {
padding: 0 10px;
background:#DDDDDD;
}
.twoColLiqLtHdr #footer p {
margin: 0;
padding: 10px 0;
text-align: center;
font-size: 36px;
font-weight: bold;
}
.fltrt {
margin-left: 8px;
}
.fltlft {
float: left;
margin-right: 8px;
}
.clearfloat {
clear:both;
height:0;
font-size: 1px;
line-height: 0px;
}
.twoColLiqLtHdr #container #mainContent p {
font-size: 18px;
}
.twoColLiqLtHdr #container #mainContent h1 {
font-size: 50px;
}
.a {
font-size: 36px;
}
b {
font-size: 18px;
}
.a1 { font-size: xx-large;
color: #F00;
}
.a1 { color: #FFF;
}
.a1 {
font-size: 24px;
}
.twoColLiqLtHdr #container #mainContent p .a1 strong {
color: #000;
}
.twoColLiqLtHdr #container #sidebar1 p breit {
font-weight: bold;
}
.twoColLiqLtHdr #container #footer p18 {
font-size: 18px;
}

.a11 {font-size: xx-large;
color: #F00;
}
.a11 {color: #FFF;
}
.a11 { font-size: 24px;
color: #000;
}
</style>


rausnehme geht die site.

weiss aber nicht wo der fehler liegt!!!!!

ich bräuchte den style code nähmlich

merci
Bitte warten ..
Mitglied: mrtux
26.02.2010 um 23:00 Uhr
Hi !

Zitat von alienmaster:
ich bräuchte den style code nähmlich

Also auf ein CSS-Problem hätte ich jetzt als nächstes getippt. Die Unterschiede zwischen den Browsern sind auch, und gerade bei CSS heimtückisch, daher wirst Du wohl eine Browserweiche bauen müssen. Diese Site hilft dir evt. weiter, die Unterschiede der Browser beim Thema CSS einschätzen zu können.

mrtux
Bitte warten ..
Mitglied: alienmaster
26.02.2010 um 23:08 Uhr
hab den fehler gefunden

<style type="text/css">

<!-- <das gehörte gelöscht

body {
font: 100% Verdana, Arial, Helvetica, sans-serif;
background: #666666;
margin: 0;
text-align: center;
color: #000000;

komisch ist nur das FF es auslesen kann
aber IE und chrome nicht.

aber merci für die hilfe
Bitte warten ..
Mitglied: Arano
27.02.2010 um 00:38 Uhr
<!-- <das gehörte gelöscht
Öhm... mehr oder weniger....

"Das" leitet ja eigentlich einen Kommentar ein der vom Browser komplett ignoriert wird:
01.
<!-- 
02.
 Ich bin ein Kommentar und werde vom Browser ignoriert 
03.
-->
Dir hat scheinbar das Ende des Kommentars gefehlt: "-->" wodurch alles folgende als Kommentar angesehen und somit ignoriert wurde.
Das CSS innerhalb des <style>-Tags als Kommentar auszuzeichnen macht man für ältere Browser die kein CSS kennen und dieses somit (sowieso) ignorieren würden.
01.
<style type="text/css"> 
02.
  <!-- 
03.
    /* hier das CSS */ 
04.
  --> 
05.
</style>
Nun weist auch du Bescheid

komisch ist nur das FF es auslesen kann aber IE und chrome nicht.
Ja ja, das sind die kleinen aber feinen Unterschiede aller Browser... der eine übersieht es, der andere korrigiert es und andere verhalten sich wieder anders.


~Arano
Bitte warten ..
Mitglied: mrtux
27.02.2010 um 19:13 Uhr
Hi !

Zitat von alienmaster:
<!-- <das gehörte gelöscht

Ups, den Comment-Tag habe ich wohl überlesen aber grundsätzlich ist es für die Übersichtlichkeit eh besser die CSS in eine extra Datei auszulagern.

mrtux
Bitte warten ..
Mitglied: alienmaster
28.02.2010 um 03:11 Uhr
@Arano merci dir deine inputs, waren sehr hilfreich

@mrtux danke master
dein durch deinen eintrag zwecks css hab ichs gefunden

jscript weg
uploaden, testen
site funkt nicht
css weg
uploaden
site funkt
logischerweise css fehler im QT
die drei zeichen die im QT gelöscht, das war das problem.

is gelöst
eure mitarbeit war da hammer.
merci masters!

und die beste site by probs is http://administrator.de


DANKE!!!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst Zentrale Verwaltung der Proxysettings für Firefox und Chrome (7)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Windows Update
Microsoft Update Catalog mag jetzt auch Firefox und Chrome (6)

Link von tomolpi zum Thema Windows Update ...

LAN, WAN, Wireless
Internetverbindung funktioniert erst nach ipconfig renew (6)

Frage von Joshh1 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...