Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wget über Proxy Syntax

Frage Microsoft Windows Tools

Mitglied: Ruffy1984

Ruffy1984 (Level 1) - Jetzt verbinden

06.07.2010, aktualisiert 17:23 Uhr, 19821 Aufrufe, 16 Kommentare

Hallo Community,

habe mich soeben bei Administrator.de registriert, das ist also mein erster Beitrag bzw Frage.

Ich hoffe einer kann mir weiter helfen.

Ich möchte ein Script ausführen der Daten von einem FTP Server holt, leider muss ich über einen Proxy.
Ich benutze das kleine Programm wget. Habe eine .bat gebaut die folgendermaßen aussieht:
01.
cd\ 
02.
cd Programme\gnuwin32\bin 
03.
 
04.
wget -nH -P -Proxy=on "c:/Zielordner" -r ftp://Test_User:Passwort@TESTPAGE.de:/Testordner
Vorher habe ich folgende Befehle ausgeführt:
01.
set http_proxy = http://192.168.1.10: 8080 
02.
 
03.
set ftp_proxy = http://192.168.1.10: 8080
Irgendwie will er sich trozdem nicht mit meinem Server verbinden.

Wenn ich das Script auf einem PC ohne Proxy teste, funktioniert es ohne probleme.

Hat jemand eine Idee ?

Danke im Vorraus
Mitglied: 45877
06.07.2010 um 17:00 Uhr
Hallo,

.wgetrc ist was du brauchst.

http://www.home.umk.pl/~mgw/wget/wget_6.html
Bitte warten ..
Mitglied: masterofdisaster09
06.07.2010 um 17:39 Uhr
Müsste unter Win auch mit wget.rc gehen. AFAIR.
Bitte warten ..
Mitglied: paulepank
06.07.2010 um 19:41 Uhr
Hallo Ruffy1984,
Willkommen im Forum.
Falls du mit der wgetrc nichts am Hut hast, kannst du die Übergabe des Proxy mit dem -e-Kommando lösen.
Falls die Proxy auch User und PW verlangen gibt es hierzu auch die entsprechen Optionen. Siehe auch wget -h.
Es heisst auch nicht -Proxy=on sondern --proxy=on.
01.
wget -nH -P --proxy=on  -e ftp_proxy=http://192.168.1.10:8080/ -e http_proxy=http://192.168.1.10:8080/  "c:/Zielordner" -r ftp://Test_User:Passwort@TESTPAGE.de:/Testordner
Danke im Vorraus
Das wird hier nicht so gern gesehen. Feedback ist uns lieber. Na gut, manche trinken auch Becks. brhh

cu paulepank
Bitte warten ..
Mitglied: Biber
06.07.2010 um 19:46 Uhr
[OT]
Zitat von paulepank:

> Danke im Vorraus
Das wird hier nicht so gern gesehen. Feedback ist uns lieber. Na gut manche trinken auch Becks. brhh

cu paulepank

i cu, too....
Biber
[/OT]
Bitte warten ..
Mitglied: paulepank
06.07.2010 um 19:48 Uhr
[OT]
i cu, too....
ich hoffe doch bei einem Guinness
[/OT]
Bitte warten ..
Mitglied: Biber
06.07.2010 um 19:57 Uhr
[OT]
Zitat von paulepank:
> i cu, too....
ich hoffe doch bei einem Guinness
Das wäre ein äußerst akzeptabler Kompromiss.
[/OT]
Bitte warten ..
Mitglied: Ruffy1984
06.07.2010 um 22:01 Uhr
Hallo Paulepank,

danke für deine ausführliche Antwort.

Wie würde das aussehen wenn man sich am Proxy mit benutzername und Kennwort authentifizieren müsste ?

Danke im Vorraus..
Bitte warten ..
Mitglied: paulepank
06.07.2010 um 22:32 Uhr
was nutzt meine ausführliche Antwort, wenn sie nicht verstanden wird ?

letztmalig: wget -h
letztmalig: kein Danke im Voraus

Frisch angemeldet und schon so viele Fettnäpfchen

cu paulepank
Bitte warten ..
Mitglied: Ruffy1984
06.07.2010 um 23:01 Uhr
hehe, sorry..

das kann doch passieren, man lernt aus fehlern

könnte das dann so aussehen ?

wget -nH -P --proxy=on -h --proxy-user=benutzer --proxy-passwd=passwort -e ftp_proxy=http://192.168.1.10:8080/ -e http_proxy=http://192.168.1.10:8080/ "c:/Zielordner" -r ftp://Test_User:Passwort@TESTPAGE.de:/Testordner

cu ruffy
Bitte warten ..
Mitglied: paulepank
06.07.2010 um 23:10 Uhr
...könnte
wer hindert dich das auszutesten ?

cu paulepank
Bitte warten ..
Mitglied: Ruffy1984
06.07.2010 um 23:17 Uhr
ich werde es erst morgen auf der arbeit testen können,

geb dir aufjedenfall nochmal feedback!

cu Ruffy
Bitte warten ..
Mitglied: Ruffy1984
07.07.2010 um 09:42 Uhr
Hallo Paulepank,


wenn ich das erste probier also ohne -h dann kommt folgende fehlermeldung:

verbindungsaufbau zu proxy:8080 verbunden
Proxy anforderung gesendet , warte auf Antwort---502 Proxy erros ( Isa Server hat die URL verweigert).

ftp://..............
Verbindungsaufbau zu Proxy:8080....verbunden
Proxy anforderung gesendet , warte auf Antwort...403 Forbidden
Fehler 403: Forbidden


Ich habe aber die Seite auf dem proxy freigeschaltet.

Wenn ich das ganze mit " -h " teste, dann sagt er mir Sysntax error, und listet mir die ganzen Befehle,

wenn ich dann -E nehme, dann kommt die selbe Fehlermeldung wie oben.
Bitte warten ..
Mitglied: paulepank
07.07.2010 um 14:55 Uhr
Hallo,

Wenn ich das ganze mit " -h " teste, dann sagt er mir Sysntax error, und listet mir die ganzen Befehle,
Die Option -h fordert lediglich die Hilfe an und steht immer allein. Also so
01.
wget -h
Mein Beispiel mit
01.
wget -e <Kommando1> -e <Kommando2> ...weitere Optionen URL...
ist nur eine Alternative für die Übergabe mehrerer Kommandos, die sonst in der wgetrc stehen.
In deinem Fall sollte ein
01.
wget -nH -P "c:\Zielordner" --proxy=on --proxy-user=benutzer --proxy-passwd=passwort -e ftp_proxy=http://192.168.1.10:8080/  -r  ftp://Test_User:Passwort@TESTPAGE.de:/Te ...
genügen,da ja nur eine Verbindung (FTP oder HTTP) je Codezeile gemacht wird .
Beachte auch hier die Zusammengehörigkeit von -P und Zielordner. Auch wird die Übergabe von ftp-user und ftp-passwd eigentlich anders gemacht.
Siehe hierzu wieder die Hilfe. Da du jedoch schreibst, das dein Code ohne Proxy geht, wird die Angabe von ftp://Test_User:Passwort@TESTPAGE.de:/Te ...
auch richtig sein.
wenn ich dann -E nehme, dann kommt die selbe Fehlermeldung wie oben.
-e und -E sind ein Unterschied. Sorgfalt ist hier angebracht.

Ich kann dir zur Unterstützung auch gern die deutsche Hilfedatei wget.mo der Version 1.11.4 von wget zukommen lassen.

cu paulepank

Edit: wobei sich der ftp-proxy mit http und port 8080 mir nicht erschließt. Aber vielleicht ist das ja so konfiguriert.
Bitte warten ..
Mitglied: jhinrichs
07.07.2010 um 16:28 Uhr
Zitat von paulepank:
> Danke im Vorraus
Das wird hier nicht so gern gesehen. Feedback ist uns lieber. Na gut, manche trinken auch Becks. brhh


<OT><Korinthenmodus>
@paulepank: Der Dank im Voraus stört mich nicht so sehr , aber.....
@Ruffy1984: Aber immer diese Doppel-"rr"s in "Voraus", "Voraussetzung", "herunter", die sehe ich überhaupt nicht gern. Ist aber ein echter Don-Quichote- Feldzug dagegen....
</Korinthenmodus></OT>

Grüße und Prost
Bitte warten ..
Mitglied: Ruffy1984
18.07.2010 um 14:06 Uhr
Hallo Paulepank und co,

es hat nun funktioniert, ich habe einen lokalen benutzer angelegt. Am anfang hatte ich noch Probleme mit unserem integrierten WebFilter, aber in den zeiten wo der WebFilter nicht greift funktioniert es jetzt einwandfrei. Am anfang kam dort dann immer Robots.txt oder sowas.

Ich hoffe das ich mich jetzt mal bedanken darf

Vielen Dank für dein/euer Support..
Bitte warten ..
Mitglied: Ruffy1984
01.02.2011 um 08:53 Uhr
Hallo Community,


muss diesen Thread nochmal wiederbeleben

das Script funktioniert immer noch wunderbar, nur die ZUgangsdaten haben sich geändert und im Benutzernamen ist ein "@" Zeichen vorhanden.

Das Mag wget nicht wirklich ?

Wie kann ich wget sagen dass das "@" zum Benutzernamen gehört ?

Grüße
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Sicherheits-Tools
Tor hinter (eigenem) Proxy (12)

Frage von mrserious73 zum Thema Sicherheits-Tools ...

Windows Netzwerk
gelöst Proxy Settings sperren (2)

Frage von joehuaba zum Thema Windows Netzwerk ...

Microsoft Office
Proxy-Firewall Einstellungen in Excel? (4)

Frage von BlueShadow9 zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...