Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 Professional als Server XP als Client, verbindung funktioniert nur ein mal.

Frage Microsoft Windows Netzwerk

Mitglied: s0m3ting

s0m3ting (Level 1) - Jetzt verbinden

01.06.2011 um 13:19 Uhr, 8973 Aufrufe, 10 Kommentare

In einer Arztpraxis läuft ein Win 7 Prof. 64 bit Rechner mit einem Programm + Datenbank (TurboMed).
Der Ordner des Programms ist freigegeben (über "Erweiterte Freigabe") Berechtigungen für "Jeden" auf Vollzugriff.
Im Netzwerk und Freigabecenter wurden unter "Erweiterte Freigabeeinstellung ändern...", habe ich kennwortgeschütztes Freigeben aktiviert und verwendung von Heimnetzgruppe deaktiviert.

In einer Arztpraxis läuft ein Win 7 Prof. 64 bit Rechner mit einem Programm + Datenbank (TurboMed).
Der Ordner des Programms ist freigegeben (über "Erweiterte Freigabe") Berechtigungen für "Jeden" auf Vollzugriff.
Im Netzwerk und Freigabecenter wurden unter "Erweiterte Freigabeeinstellung ändern...", habe ich kennwortgeschütztes Freigeben aktiviert
und Verwendung der Heimnetzgruppe deaktiviert.

Der Client-Rechner ist der einzige im Netzwerk mit Win XP Prof. (die 7 anderen laufen mit Win 7 Prof 32 bit)

Der XP Rechner hat eine .bat Datei die über net use Netzlaufwerke wiederherstellt (Autostart)


PROBLEM: Der Client verbindet sich nur EIN mal mit dem Server, bis man den Server wieder neustartet.

Was kann ich dagegen tun?

Vielen Dank
Mathias
Mitglied: kopie0123
01.06.2011 um 13:25 Uhr
Hey,

wie sieht die bat aus?

Gruß
Bitte warten ..
Mitglied: cardisch
01.06.2011 um 13:27 Uhr
Hallo Mathias,

poste mal die Batch-Datei...

Gruß

Carsten
Bitte warten ..
Mitglied: s0m3ting
01.06.2011 um 14:23 Uhr
@ECHO OFF
set versuche=
set maxversuche=5

ipconfig /renew

:verbinden
net use t: /delete
net use n: /delete
net use t: \\server\turbomed /user:Server\Benutzer passwort /persistent:no
net use n: \\server\ifap /persistent:no
if %ERRORLEVEL%==0 goto fertig

set versuche=%versuche%x
if "%versuche%"=="%maxversuche%" goto fehler

ECHO Fehler. Neuer Versuch in 03 Sekunden. (Max. 5 Versuche)
ECHO.
ping 127.0.0.1 -n 4 > nul
goto verbinden

:fehler
ECHO Keine Verbindung zum Server.
ECHO.

PAUSE
goto fertig

:fertig

cd C:\TurboMed\Programm\

TurboMed.exe

exit
Bitte warten ..
Mitglied: vossi31
01.06.2011 um 14:37 Uhr
Hallo,

ich hatte auch bei einem Kunden immer wieder Verbindungsprobleme zwischen XP und Win7.
Löschen und Wiederaufbau der gesamten Netzwerkschnittstelle hat dann geholfen, so etwa:

netsh interface set interface LAN-1 disabled
netsh interface set interface LAN-1 enabled
if exist E: net use E: /delete
net use E: \\192.168.2.11\c


Henning
Bitte warten ..
Mitglied: jenni
01.06.2011 um 14:41 Uhr
Moin,

Du hast 7 Rechner mit win 7 32bit und einen mit Win XP, kann es vielleicht sein das du die maximale Anzahl an Verbindungen überschreitest und es deswegen nur einmal funktioniert?
Der Server, auf dem win 7 installiert ist, löscht nicht sofort die Verbindungen zu den Clients. das kann unter Umständen dauern...

Ich meine auch das der Befehl für Net Use falsch ist:
NET USE
[Gerätename | *] [\\Computername\Freigabename[\Volume] [Kennwort | *]]
[/USER:[Domänenname\]Benutzername]
[/USER:[Domänenname im Punktformat\]Benutzername]
[/USER:[Benutzername@Domänenname im Punktformat]
[/SMARTCARD]
[/SAVECRED]
[[/DELETE] | [/PERSISTENT:{YES | NO}]]

gruß
jenni
Bitte warten ..
Mitglied: s0m3ting
01.06.2011 um 14:59 Uhr
Nein, das denke ich nicht... Windows 7 Prof hat meines Wissens nach 10 User Cal's
die anderen Befehle teste ich gleich, werde dann Berichten.

Danke erstmal für alle Antworten
Bitte warten ..
Mitglied: s0m3ting
01.06.2011 um 15:10 Uhr
Die batch für net use läuft hier eig. ohne einwände. Ich denke das es ein Freigabeproblem bei Win 7 ist.... Hab schon ein Win7-Netzwerk-Topologie-Erkennungs-Hotfix von MS runtergeladen, ist aber für SP2, ich hab hier SP3....

Alle anderen Rechner haben gar keine Probleme, nur bei XP kann der keine Netz-LWs wiederherstellen.
Ich kann auch nicht mehr in die Arbeitsgruppe schauen und über die IP komm ich auch nicht dran.
Pingen kann ich alles und jeden

Bin weiter gespannt auf Hilfestellungen.
Bitte warten ..
Mitglied: Pjordorf
01.06.2011 um 15:32 Uhr
Hallo,

Zitat von s0m3ting:
Nein, das denke ich nicht... Windows 7 Prof hat meines Wissens nach 10 User Cal's
Nein, falsch. Windows 7 (auch nicht XP oder Vista) haben und kennen weder User noch Device CAL's.
Start - Eingabe von WinVer im Suchfenster - WinVer.exe starten
Im Fenster Info unten auf Microsoft-Softwarelizenzbedingungen klicken. Im EULA Fenster runterscrollen nach 3.f Geräteverbindungen. Dort kannst du nachlesen wie viele gleichzeitige Verbindungen (Fileserver etc) dein OS unterstützt. W7 Prof / Ultimate / Enterprise = 20.

Gruß,
Peter
Bitte warten ..
Mitglied: s0m3ting
01.06.2011 um 18:25 Uhr
Da hab ich mit 8 verbindungen ja nochmal glück gehabt peter ;)
ich wähl jetzt den leichten weg und setz n Win 7 auf...
dann verkauf ich noch nen Langzeit-EKG.. ;)
die dinger sind eh ein alptraum gewesen von der config ;)

zwar nicht gelöst und immernoch mysteriös aber ich danke euch allen für die hilfe. werd hier im forum aktiv bleiben!
Bitte warten ..
Mitglied: Pjordorf
01.06.2011 um 18:28 Uhr
Hallo,

Zitat von s0m3ting:
ich wähl jetzt den leichten weg und setz n Win 7 auf...
Dann doch noch bitte ein http://www.administrator.de/index.php?faq=32

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
gelöst Windows Server 2012 - VPN Verbindung nach Update nicht mehr möglich (1)

Frage von ruNN0r zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 R2 Ordnerfreigabe funktioniert plötzlich nicht mehr (7)

Frage von it2016 zum Thema Windows Server ...

Windows Server
gelöst GPOs für Windows 10 in Server 2008 R2: Erfahrungsberichte (8)

Frage von honeybee zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...