Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 schickt alle Pakete durchs Gateway

Frage Microsoft Windows Netzwerk

Mitglied: LordGurke

LordGurke (Level 2) - Jetzt verbinden

10.05.2010 um 22:32 Uhr, 7152 Aufrufe, 5 Kommentare

Ein Client mit Windows 7 x64 schickt seit neuestem *alle* Pakete durch das eingestellte Standardgateway, auch zu solchen Adressen, die im gleichen Subnet liegen.

Hallo zusammen,

wie oben angedeutet schickt der Win7-Client alle Pakete - auch zu Adressen, die im gleichen Subnet liegen - durch das Standardgateway.
Warum er das tut, habe ich bisher leider nicht herausgefunden, die Routingtabelle sieht für mich eigentlich so aus, wie sie aussehen sollte - zumindest sind da keine Abweichungen zu einem anderen Client, der dieses Verhalten nicht zeigt:

01.
=========================================================================== 
02.
Schnittstellenliste 
03.
 15...00 ff e8 0c 40 1f ......TAP-Win32 Adapter V9 
04.
 11...00 22 15 6c af c1 ......Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller 
05.
 20...08 00 27 00 fc f8 ......VirtualBox Host-Only Ethernet Adapter 
06.
  1...........................Software Loopback Interface 1 
07.
 13...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter 
08.
 14...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface 
09.
 16...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #2 
10.
 21...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #3 
11.
=========================================================================== 
12.
 
13.
IPv4-Routentabelle 
14.
=========================================================================== 
15.
Aktive Routen: 
16.
     Netzwerkziel    Netzwerkmaske          Gateway    Schnittstelle Metrik 
17.
          0.0.0.0          0.0.0.0      192.168.0.3     192.168.0.10    276 
18.
        127.0.0.0        255.0.0.0   Auf Verbindung         127.0.0.1    306 
19.
        127.0.0.1  255.255.255.255   Auf Verbindung         127.0.0.1    306 
20.
  127.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    306 
21.
      169.254.0.0      255.255.0.0   Auf Verbindung    169.254.11.241    276 
22.
   169.254.11.241  255.255.255.255   Auf Verbindung    169.254.11.241    276 
23.
  169.254.255.255  255.255.255.255   Auf Verbindung    169.254.11.241    276 
24.
      192.168.0.0    255.255.255.0   Auf Verbindung      192.168.0.10    276 
25.
     192.168.0.10  255.255.255.255   Auf Verbindung      192.168.0.10    276 
26.
    192.168.0.255  255.255.255.255   Auf Verbindung      192.168.0.10    276 
27.
        224.0.0.0        240.0.0.0   Auf Verbindung         127.0.0.1    306 
28.
        224.0.0.0        240.0.0.0   Auf Verbindung    169.254.11.241    276 
29.
        224.0.0.0        240.0.0.0   Auf Verbindung      192.168.0.10    276 
30.
  255.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    306 
31.
  255.255.255.255  255.255.255.255   Auf Verbindung    169.254.11.241    276 
32.
  255.255.255.255  255.255.255.255   Auf Verbindung      192.168.0.10    276 
33.
=========================================================================== 
34.
Ständige Routen: 
35.
  Netzwerkadresse          Netzmaske  Gatewayadresse  Metrik 
36.
          0.0.0.0          0.0.0.0      192.168.0.3  Standard 
37.
=========================================================================== 
38.
 
39.
IPv6-Routentabelle 
40.
=========================================================================== 
41.
Aktive Routen: 
42.
 If Metrik Netzwerkziel             Gateway 
43.
 11    276 ::/0                     2a02:a00:e000:b:8000::2 
44.
 11    276 ::/0                     fe80::222:2dff:fe27:76d5 
45.
  1    306 ::1/128                  Auf Verbindung 
46.
 11     28 2a02:a00:e000:b:8000::/65 
47.
                                    Auf Verbindung 
48.
 11    276 2a02:a00:e000:b:8000::d00f/128 
49.
                                    Auf Verbindung 
50.
 20    276 fe80::/64                Auf Verbindung 
51.
 11    276 fe80::/64                Auf Verbindung 
52.
 20    276 fe80::6c14:2125:bc61:bf1/128 
53.
                                    Auf Verbindung 
54.
 11    276 fe80::6c67:80b2:a5f1:bbfc/128 
55.
                                    Auf Verbindung 
56.
  1    306 ff00::/8                 Auf Verbindung 
57.
 20    276 ff00::/8                 Auf Verbindung 
58.
 11    276 ff00::/8                 Auf Verbindung 
59.
=========================================================================== 
60.
Ständige Routen: 
61.
 If Metrik Netzwerkziel             Gateway 
62.
  0 4294967295 ::/0                     2a02:a00:e000:b:8000::2 
63.
===========================================================================

Etwas zur Konfiguration:

Der Client hat eine reale Netzwerkkarte mit der statisch zugewiesenen IP 192.168.0.10/24, Standardgateway ist 192.168.0.3.
Wenn ich nun auf einen Rechner mit der IP 192.168.0.7 zugreife, werden alle Pakete durch das Gateway geschickt, was erstens das Gateway unnötig belastet und zweitens natürlich auf die Geschwindigkeit drückt.

Die IP-Konfiguration sieht so aus - für mich eigentlich auch alles im Grünen Bereich:

01.
Windows-IP-Konfiguration 
02.
 
03.
   Hostname  . . . . . . . . . . . . : Max 
04.
   Primäres DNS-Suffix . . . . . . . : 
05.
   Knotentyp . . . . . . . . . . . . : Hybrid 
06.
   IP-Routing aktiviert  . . . . . . : Nein 
07.
   WINS-Proxy aktiviert  . . . . . . : Nein 
08.
 
09.
Ethernet-Adapter LAN-Verbindung 2: 
10.
 
11.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
12.
   Verbindungsspezifisches DNS-Suffix: 
13.
   Beschreibung. . . . . . . . . . . : TAP-Win32 Adapter V9 
14.
   Physikalische Adresse . . . . . . : 00-FF-E8-0C-40-1F 
15.
   DHCP aktiviert. . . . . . . . . . : Ja 
16.
   Autokonfiguration aktiviert . . . : Ja 
17.
 
18.
Ethernet-Adapter LAN-Verbindung: 
19.
 
20.
   Verbindungsspezifisches DNS-Suffix: 
21.
   Beschreibung. . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller 
22.
   Physikalische Adresse . . . . . . : 00-22-15-6C-AF-C1 
23.
   DHCP aktiviert. . . . . . . . . . : Nein 
24.
   Autokonfiguration aktiviert . . . : Ja 
25.
   IPv6-Adresse. . . . . . . . . . . : 2a02:a00:e000:b:8000::d00f(Bevorzugt) 
26.
   Verbindungslokale IPv6-Adresse  . : fe80::6c67:80b2:a5f1:bbfc%11(Bevorzugt) 
27.
   IPv4-Adresse  . . . . . . . . . . : 192.168.0.10(Bevorzugt) 
28.
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0 
29.
   Standardgateway . . . . . . . . . : 2a02:a00:e000:b:8000::2 
30.
                                       fe80::222:2dff:fe27:76d5%11 
31.
                                       192.168.0.3 
32.
   DNS-Server  . . . . . . . . . . . : 192.168.0.3 
33.
   NetBIOS über TCP/IP . . . . . . . : Aktiviert 
34.
 
35.
Ethernet-Adapter VirtualBox Host-Only Network: 
36.
 
37.
   Verbindungsspezifisches DNS-Suffix: 
38.
   Beschreibung. . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter 
39.
   Physikalische Adresse . . . . . . : 08-00-27-00-FC-F8 
40.
   DHCP aktiviert. . . . . . . . . . : Ja 
41.
   Autokonfiguration aktiviert . . . : Ja 
42.
   Verbindungslokale IPv6-Adresse  . : fe80::6c14:2125:bc61:bf1%20(Bevorzugt) 
43.
   IPv4-Adresse (Auto. Konfiguration): 169.254.11.241(Bevorzugt) 
44.
   Subnetzmaske  . . . . . . . . . . : 255.255.0.0 
45.
   Standardgateway . . . . . . . . . : 
46.
   DHCPv6-IAID . . . . . . . . . . . : 319291431 
47.
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-11-6A-53-A6-00-22-15-6C-AF-C1 
48.
   DNS-Server  . . . . . . . . . . . : fec0:0:0:ffff::1%1 
49.
                                       fec0:0:0:ffff::2%1 
50.
                                       fec0:0:0:ffff::3%1 
51.
   NetBIOS über TCP/IP . . . . . . . : Aktiviert 
52.
 
53.
Tunneladapter isatap.{E80C401F-07A4-45F0-B609-4424DBE86937}: 
54.
 
55.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
56.
   Verbindungsspezifisches DNS-Suffix: 
57.
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter 
58.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
59.
   DHCP aktiviert. . . . . . . . . . : Nein 
60.
   Autokonfiguration aktiviert . . . : Ja 
61.
 
62.
Tunneladapter Teredo Tunneling Pseudo-Interface: 
63.
 
64.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
65.
   Verbindungsspezifisches DNS-Suffix: 
66.
   Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface 
67.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
68.
   DHCP aktiviert. . . . . . . . . . : Nein 
69.
   Autokonfiguration aktiviert . . . : Ja 
70.
 
71.
Tunneladapter isatap.{70E35D64-F2C1-4282-9F34-CB774D7F6511}: 
72.
 
73.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
74.
   Verbindungsspezifisches DNS-Suffix: 
75.
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #2 
76.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
77.
   DHCP aktiviert. . . . . . . . . . : Nein 
78.
   Autokonfiguration aktiviert . . . : Ja 
79.
 
80.
Tunneladapter isatap.{7E67FA66-990E-403F-B875-92E7EF0CFA00}: 
81.
 
82.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
83.
   Verbindungsspezifisches DNS-Suffix: 
84.
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #3 
85.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
86.
   DHCP aktiviert. . . . . . . . . . : Nein 
87.
   Autokonfiguration aktiviert . . . : Ja

Hier mal ein Traceroute:

01.
Routenverfolgung zu 192.168.0.7 über maximal 30 Abschnitte 
02.
 
03.
  1    <1 ms    <1 ms    <1 ms  192.168.0.3 
04.
  2    <1 ms    <1 ms    <1 ms  192.168.0.7 
05.
 
06.
Ablaufverfolgung beendet.

Die Schnittstelle habe ich testweise einfach mal neu konfiguriert und neu installiert, in der Hoffnung irgendwelche falschen Einträge zu löschen, geholfen hat es bisher aber nicht.


Hat jemand einen heißen Tipp für mich?

DANKE!!!
Mitglied: kingkong
11.05.2010 um 08:47 Uhr
Hat es einen bestimmten Grund, warum Du eine ständige Route eingetragen hast, die den selben Inhalt hat wie die erste dynamische? Ich habe solch eine Route nämlich nicht und mir fällt gerade auch nicht ein, wozu die gut sein könnte - aber wie gesagt hast Du ja vielleicht eine Erklärung?!
Was mir außerdem noch auffällt ist, dass die Metrik der dynamischen Gateway-Route bei mir deutlich kleiner ist. Hängst Du hinter vielen Switches? (Gut, eigentlich spricht die hohe Metrik ja gerade nicht dafür, dass die Pakete standardmäßig durchs GW sollen...)

Gruß, kingkong
Bitte warten ..
Mitglied: aqui
11.05.2010 um 10:06 Uhr
Woher weisst du denn das der Rechner alle Pakete an lokale Hostadressen immer an das Gateway schickt ???
Hast du das mit einem Wireshark Sniffer auch wirklich mitgesniffert ??? Wenn nicht, ist das ja nur wilde Spekulation, denn das würde der korrekten Funktion eines TCP/IP Stacks vollkommen widersprechen.
Normalerweise sendet der Client 192.168.0.10 zuallererst einen ARP Request an die 192.168.0.7, was du im Sniffer auch sehen solltest. Damit bekommt der die Layer 2 Adresse (Mac) die für die Ethernet Kommunikation mit der Hostadresse 192.168.0.7 ja relevant ist von diesem Client. Danach initiiert er dann über die MAC Adressen eine TCP oder UDP Session je nach Dienst.
Auch wenn er das Paket an das Gateway 192.168.0.3 schickt (er ARPt dann dieses) schickt das Gateway ihm sofort ein ICMP Redirect Paket (Typ 5) zurück und spätestens dann ist die Kommunikation immer lokal.
Würde deine Behauptung von oben also stimmen, dann wäre der gesamte Stack in der grundlegenden Kommunikation vermurkst.
Poste also mal den Verbindungsaufbau von 192.168.0.10 und 192.168.0.7 als Wireshark PCAP Output hier und dann sehen wir mal ob du wirklich recht hast !!!
Das kannst du z.B. mal schnell machen wenn du auf dem 192.168.0.7 Client einen kleinen Webserver_wie_HFS einfach als Datei startest und von 192.168.0.10 eine Browsersession auf ihn öffnest.
ARP Request, Reply und TCP SYN (4 Pakete Trace) die kannst du dann mal posten hier... !
Bitte warten ..
Mitglied: LordGurke
11.05.2010 um 18:50 Uhr
@kingkong:
Also ich habe nichts eingetragen, werde aber mal versuchen, die Route zu löschen.
Leider habe ich den Rechner gerade nicht vor mir und per Fernwartung komme ich auch im Moment nicht drauf.

@aqui:
Ich weiß es daher, weil das Gateway mir mit iptraf mitteilt, dass es Daten von 192.168.0.10 nach 192.168.0.7 schaufelt
Es gab ja keine wirklichen Probleme, denn der Rechner konnte ja wunderbar mit anderen kommunizieren, nur haben wir uns gewundert, warum das Gateway manchmal so 80-90 MBit/s durch die Gegend gepöngelt hat und die Latenzzeiten ins Internet so plötzlich hochgingen

Aber danke für die Tipps, ich werde mich mal mit Wireshark dranhängen und den gesamten Verkehr mitlesen.
Bitte warten ..
Mitglied: aqui
12.05.2010 um 12:08 Uhr
Es ist möglich das du am Gateway oder an den beteiligten Engeräten ICMP Redirect (Typ 5)
http://de.wikipedia.org/wiki/Internet_Control_Message_Protocol
deaktiviert hast.
(Bei Winblows heisst das in den ICMP Eigenschaften der Firewall "Umleitungen zulassen") Bei Winblows ist das in der Regel immer unsinnigerweise deaktiviert.
Dann kann es natürlich solche lokalen Umwege geben wenn es mehrere lokale Router geben sollte... Das solltest du also auch nochmal kontrollieren ob dem so ist !!
Bitte warten ..
Mitglied: LordGurke
12.05.2010 um 20:39 Uhr
Exakt das scheint es gewesen zu sein - jedenfalls gehen die Pakete nun direkt durch... Zumindest taucht das Gateway nirgendwo mehr über Wireshark auf.

Die Firewall hatte ich überhaupt nicht im Verdacht, da diese normalerweise deaktiviert ist und überhaupt nicht zur Windows-Firewall gepasst hätte, dass sie etwas zuverlässig blockt.
Irgendein obskures Update scheint die Firewall wohl wieder aktiviert zu haben.
Ich habe jetzt sämtliche Protokolle freigegeben, die Firewall erneut ausgeschaltet und hoffe mal, dass das so bleibt.

Danke!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
gelöst OpenSense schickt alles ans Gateway (15)

Frage von FA-jka zum Thema Router & Routing ...

Windows 7
Windows 7 Client zieht sich keine MSI Pakete (6)

Frage von Ghost108 zum Thema Windows 7 ...

Router & Routing
ICMP reply Pakete werden nicht an das Standard Gateway geschickt (4)

Frage von tvprog1 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...