Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

wmic percentprocessortime liefert immer 100 Prozent

Frage Microsoft Windows Server

Mitglied: AlbertMinrich

AlbertMinrich (Level 2) - Jetzt verbinden

09.09.2009, aktualisiert 16:25 Uhr, 4089 Aufrufe, 1 Kommentar, 1 Danke

Hallo,

dieser Befehl
"wmic /node:"SERVERNAME" path win32_perfformatteddata_perfos_processor get percentprocessortime"
liefert mir die Prozessorauslastung der Prozessoren von SERVERNAME und zwar die Auslastung der einzelnen Prozessoren und die Gesamtprozessorauslastung.
Also z.B. bei einem Server mit 4 Prozessoren
40
15
32
21
27
Die ersten vier sind die einzelnen CPU´s, der letzte Wert is der Durchschnitt.

Das funktioniert auch gut, nur bei einem Server bekomme ich immer
100
100
100
100
100
obwohl der natürlich nicht zu 100% ausgelastet ist.

Woran kann das liegen?

Danke
Martin
Mitglied: TuXHunt3R
09.09.2009 um 23:04 Uhr
Hallo Martin

Habs gerade mal mit der PowerShell getestet. Folgender Befehl:
01.
get-wmiobject win32_perfformatteddata_perfos_Processor | select-object percentprocessortime
Bei mir habe ich die jeweils richtigen Werte bekommen.
Ist bei diesem Server etwas speziell? Anderes OS? Von Hand etwas am WMI rumgeschraubt?

Sieh auf dem entsprechenden Server die Klasse win32_perfformatteddata mal mit dem Wbemtester an. Pfad: C:\Windows\system32\wbem\wbemtester.exe
Ist dort die Childclass win32_perfformatteddata_perfos_processor sichtbar?

Mit Gruss
TuXHunT3R

Edit:
Ist eventuell die Windows Firewall an diesem Server eingeschaltet?
Vielleicht hilft das noch weiter:
http://windowsxp.mvps.org/repairwmi.htm
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Windows 2012 R2 Server CPU 100 Prozent Auslastung (4)

Frage von Sindax zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 Std - Windows Update Dienst - 100 Prozent CPU Auslastung (8)

Frage von harald.schmidt zum Thema Windows Server ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (38)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...

Netzwerke
VPN-Server einrichten PPTPD-Einrichtung gescheitert (15)

Frage von MIlexx zum Thema Netzwerke ...