Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

xcopy und vista

Frage Entwicklung Batch & Shell

Mitglied: wulfhelm

wulfhelm (Level 1) - Jetzt verbinden

21.09.2009 um 09:10 Uhr, 4020 Aufrufe, 4 Kommentare

Ich versuche eine Datensicherung mit Windows Vista und xcopy zu machen.
Robocopy möchte ich nicht verwenden.

Also habe folgende batch Dateien geschrieben:
Sicherung
01.
@echo off 
02.
set fail=0 
03.
set suc=1 
04.
echo ******************************* 
05.
echo Datensicherung Fabian-PC 
06.
echo ******************************* 
07.
echo Start:%date% %time% 
08.
 
09.
xcopy e:\*.* x:\ /E /F /Y /M 
10.
echo errorlevel:[%errorlevel%] 
11.
if not %errorlevel% EQU 0 goto fehler 
12.
 
13.
xcopy d:\Steam\*.* x:\Steam /E /F /Y /M 
14.
echo errorlevel:[%errorlevel%] 
15.
if not %errorlevel% EQU 0 goto fehler 
16.
 
17.
echo Ende:%date% %time% 
18.
echo %suc% > status.stat 
19.
goto :eof 
20.
 
21.
:fehler 
22.
echo Fehler am:%date% um:%time% 
23.
echo %fail% > status.stat
Startskript
01.
@echo off 
02.
set eMail=xxx 
03.
set subj=-s "Status der Datensicherung vom %date%" 
04.
set at=-attach log.zip 
05.
set debug=-debug -log blat.log -timestamp 
06.
set messageF="Die Datensicherung ist mit Fehlern abgebrochen." 
07.
set messageS="Die Datensicherung war erfolgreich." 
08.
color 1F 
09.
echo ******************************** 
10.
echo Datensicherung Fabian-PC 
11.
echo ******************************** 
12.
echo Datensicherung laeuft das Fenster nicht schliessen!! 
13.
 
14.
call Sicherung.bat 1>>Datensicherung.log 2>&1 
15.
 
16.
7za.exe a -tzip -y log Datensicherung.log 
17.
 
18.
set /p "status="<"status.stat" 
19.
 
20.
if %status% == 0 blat -p - -body %messageF% -to %eMail% %subj% %debug% %at% 
21.
 
22.
if %status% == 1 blat -p - -body %messageS% -to %eMail% %subj% %debug% %at% 
23.
 
24.
echo.>Datensicherung.log 
25.
 
26.
wait 60 KEY
Jetzt habe ich das Problem das beim kopieren des Ordners d:\Eigene Dateien (wurde dorthin verschoben) imer der Fehler kommt z.B. Ordner Bilder kann nicht erstellt werden.
Schreibrechte auf das Ziellaufwerk habe ich aber. Manuelles kopieren im Explorer funktioniert.

Gruß
wulfhelm
Mitglied: Iwan
21.09.2009 um 09:25 Uhr
guten morgen,

funktionert der XCOPY-Befehl auch, wenn du es im CMD-Prompt so eingibst?
Bitte warten ..
Mitglied: wulfhelm
21.09.2009 um 09:41 Uhr
Ja also es werden ja bevor das Skript zu dem Ordner Eigene Dateien kommt schon Ordner bzw. Dateien kopiert.
Scheint an diesem Ordner zu liegen. Und ein Berechtigungsproblem liegt denke ich nicht vor.

Gruß
Bitte warten ..
Mitglied: Snowman25
21.09.2009 um 10:26 Uhr
Möglicherweise geöffnete Dateien?
Oder ist der Bilderordner vllt. ein Share im Netzwerk, auf welches nicht zugegriffen werden kann?
Du kannst auch mal versuchen, zeitweilig die Benutzerkontensteuerung zu deaktivieren.
Bitte warten ..
Mitglied: wulfhelm
21.09.2009 um 11:31 Uhr
Sie sind weder geöffnet noch freigegeben. Kann es was damit zu tun haben, dass Eigene Dateien verschoben wurden. Sie sind ja auch noch als Link vorhanden unter Eigene Dateien auf dem Desktop liegen aber auf d:
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Xcopy leeren Folder1 nach Folder2 geht nicht (9)

Frage von Yauhun zum Thema Batch & Shell ...

Windows Vista
gelöst Vista Home Premium nur Basic Key (8)

Frage von Chonta zum Thema Windows Vista ...

Windows Server
gelöst WSUS auf Server 2008 R2: Windows 10 wird als Vista angezeigt (2)

Frage von honeybee zum Thema Windows Server ...

Windows Update
gelöst WSUS Windows 10 wird als Vista angezeigt (3)

Frage von Dkuehlborn zum Thema Windows Update ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...