Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XP DHCP problem

Frage Netzwerke

Mitglied: kaimibeh

kaimibeh (Level 1) - Jetzt verbinden

01.02.2006, aktualisiert 03.02.2006, 9487 Aufrufe, 6 Kommentare

XP und SUSE auf einem Rechner mit WLAN Karte an Telekom Router (W500) SUSE geht XP zickt

Hallo,

ich habe ein Problem das mich zur Verzweiflung treibt!!
Ich betreibe unter anderem einen Rechner der sowohl unter SUSE10 als auch unter XP SP2 läuft. User brauchen angeblich beides????!!!
Der WLAN Router fungiert für diesen und zwei andere Rechner als DHCP Server (nur diese werden unter WLAN betrieben)

Unter SUSE betreibe ich die Karte mit ndiswrapper, XP-Treiber und kernelmodul da von SUSE nicht direckt unterstützt
DHCP funktioniert, d.h. der Rechner bekommt eine private Adresse vom Router. Alles wunnebar

Unter XP kann der client ich mit dem Router verbinden (d.h. Karte geht, SSID ok) bekommt aber keine IP Adresse vom DHCP des Routers.
Fehlermeldung im eventlog: Adresse nicht kompatibel mit dem Protokoll ??!! Was soll mir das sagen?

Meine Idee war zunächst , dass der Router dem xp CLient keine Adresse zuweisen kann, da die mac adresse bereits unter anderem hostnamen für die linux konfiguration vergabenist.
Also habe ich testweise die lease auf 30 min runtergesetzt, gewartet, gewartet und gewartet und es dann noch einaml verucht lease hätte abgelaufen sein müssen.
FEHLSCHLAG identishe Fehlermeldung.

Leider gibt das dchp log des router nicht viel her da steht immer nur die zuletzt vergeben ip mit mac und host aber keine uhrzeit oer fehlgeschlagene requests. toilles log!!

hat jemand eine idee??
Mitglied: IceBeer
01.02.2006 um 12:34 Uhr
Hallo,

ist zwar eher unwahrscheinlich, aber überprüf mal, ob für die WLAN Karte das TCP/IP Protokoll installiert und aktiviert ist.

MfG IceBeer
Bitte warten ..
Mitglied: Schlachter
01.02.2006 um 14:08 Uhr
Hast du am Router WEP eingestellt? das wär ungut. Ich hab auch das Problem, dass XP mit SP2 da so Probleme hat. Soweit ich weiß unterstützt XP SP2 nur WPA aus Sicherheitsgründen. Aber wenn man die zur Karte mitgeliefert Software nutzt, dann sollte es gehen. Probier das soch mal aus. Oder gib den Clients manuelle IPs und probier mal nen Ping, dann weißt du, ob es am DHCP liegt oder nicht. Denn ich glaube nicht, dass es am DHCP liegt.
Bitte warten ..
Mitglied: IceBeer
01.02.2006 um 14:23 Uhr
Hallo,

@Schlachter, dass wäre mir neu dass Win XP SP2 nur WPA unterstützt... Ich betreibe unter selbigem System nur WEP, da mein AP noch kein WPA kann...

MfG IceBeer
Bitte warten ..
Mitglied: kaimibeh
01.02.2006 um 15:36 Uhr
vielen Dank nochmals für die Antwort,

ich bin momentan völlig ideenlos was das dhcp anbelangt.
Wie gesagt im Router ist dhcp eingeshaltet. range 192.168.2.32 - 192.168.2.64
Alle anderen Optionen wie dyndns, verschlüsselung etc. sind deaktiviert.
Die SSID wird übertragen und ist auf der Karte und dem Router identisch.
Die Karte kann sich ja auch mit dem Router verbinden, sprich in das WLAN einkinken, erhält allerings keine ip Adresse
stattdessen wird eine von Windows vergeben, das passiert automaisch wenn sonst keine Adresse eingetragen oder von dhcp vergeben wird,

Auch die Neuinstallation habe ich jetzt schon versucht, auch ohne Änderung!

Was mich stutzig macht, ist die Tatsache, dass bei manueller Vergabe einer IP adresse, zwar der Router einwandfrei erreichbr ist (ping, tracert) allerdings unter windows kein Verbindungsaufbau zum internet möglich ist. Ansonsten könnte ich ja auch mit einre festen IP leben.
Bitte warten ..
Mitglied: kaimibeh
01.02.2006 um 15:37 Uhr
WEB etc. sind deaktiviert, danke für dieAntwort!
Bitte warten ..
Mitglied: kaimibeh
03.02.2006 um 12:21 Uhr
allo,

vielen Dank für di e Antworten. Um auf die letzte Frage zu antworten: ja der Dienst konfigurationsfreie WLN VErbdg. ist gestartet.

Ich habe mittlerweile herausgefunden, dass das Problem definitiv nichts mit dem WLAN zu tun hat.
Ich habe eine ethernet Karte eingebaut und zusätzlich eine Netzwerkverbindung per Kabel eingerichtet.
Diese funktioniert unter Linux ebenfalls einwandfrei auch mit dhcp. w00t.gif

Unter XP funktioniert auch hier kein dhcp. Fehlermeldung: Netzwerkadresse nicht kompatibel mit Protokoll.
Habe den Router auf Lieferzustand zurückgesetzt und völllig neu eingerichtet.
Keine Änderung!
Es sind definitiv keine Filterregeln, keine Firewall, keine Verschlüsselung oder ähnliches am laufen.

Mittlreile will ich wissen was mit dem Client los ist. Da ist was mit XP nicht in Ordnung.
Ich habe wiederholt TCP/IP neu indstalliert und SP2 neu aufgespielt.. Die KArte neu installiert. Praktisch alle sneu eingerichtet ausser einer Neuinstallation von XP.
Die TCP/IP dienste laufen , dhcp läuft. Alle lassen sich problemlos stoppen und neu starten. Ausser der Meldung oben sind im Eventlog keine weiteren Einträge vorhanden.


In der Knowledge base gibt es einen Hinweis auf einen Eintrag in der Registrie:HKLM, current control set, services, dhcp, depend on service: SMTLK. Wenn diser Eintrag besteht kann es zu problemen mit dhcp kommen.
w00t.gif

Dieser Eintrag ist aber definitiv nicht vorhanden.
Das ganze erinnert ja schon fast an uralte Zeiten. Ich weigere mich wegen so einem Schrott den Recvhner neu aufzusetzen.
(Na ja den Usern hab ich schon vor Tagen einen ersatzcliient hingestellt)
Aber ich will wissen was da los ist.
HAt jemand eine Idee. 20.gif 20.gif nixweiss.gif nixweiss.gif
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
gelöst DHCP Problem mit Lancomrouter und neues HP-Notebook (WLan) (7)

Frage von Wern2000 zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...

Windows Netzwerk
gelöst Einrichtung DHCP (6)

Frage von halington zum Thema Windows Netzwerk ...

Windows Server
gelöst Verständnisprobleme DHCP (22)

Frage von nofear87 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (19)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...

Voice over IP
Über Fritzfax over IP gehen nur einige Faxe (12)

Frage von shearer9 zum Thema Voice over IP ...