Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zugriff von aussen auf Webserver

Frage Internet Hosting & Housing

Mitglied: ran

ran (Level 1) - Jetzt verbinden

01.10.2007, aktualisiert 04.10.2007, 6108 Aufrufe, 14 Kommentare

Hallo zusammen

Nach einigen ringereien läuft jetzt mein Apache 2.2 auf dem Windows Server 2003. Die vHosts gehen jetzt auch. Nun habe ich aber das Problem, dass ich nicht mehr weiter weis. Ich möchte das ganze jetzt noch so einrichten, dass ich von aussen auf die Webseiten zugreiffen kann. Also ganz normal mit z.B. www.irgendeinedomain.ch. Ich wollte bei Switch mal die fixe externe IP-Adresse eintragen. Die hats mir aber nicht angenommen. Ich bin am verzweifeln. Wenn dies nicht läuft kann ich ja auch nicht das Routing auf der Firewall testen.

Wie sollte ich am besten vorgehen? Habe ich was vergessen?

Grüsse
Mitglied: aqui
01.10.2007 um 09:29 Uhr
Wie soll man dir denn einen qualifizierten Rat geben wenn du uns nicht einmal das kleinste bischen über dein Netzwerk mitteilst ????

  • Wo steht dieser Server ?
  • Zuhause hinter dem eigenen DSL Router ?
  • bei einem Hoster im Rechenzentrum ?
  • Hast du eine eigene öffentliche IP Adresse ? DMZ etc. ?
usw. usw.
Wenn wir uns das hier alles zusammenraten müssen und dir alle Wenns und Abers der unterschiedlichen möglichen Designs beschreiben müssten, würden das 10 Seiten ergeben. Dazu hat sicher keiner Lust hier !!!
Fazit: Etwas detailierter musst du schon werden mit deiner Netzwerktopologie, denn wir besitzen hier alle keinen Merlinhut und eine Kristallkugel.... !!!
Bitte warten ..
Mitglied: ran
01.10.2007 um 09:38 Uhr
Ok, sorry tut mir leid.

Ich habe hier (zuhause) eine ZyWall und eine öffentliche fixe IP. Der Server befindet sich hier in der DMZ.
Die vHosts auf dem Apache sind eingerichtet und funktionieren.

Die öffentliche IP hab ich bei der Domain beim DNS versucht zu hinterlegen. Sie wurde aber leider nicht angenommen.

Auf eine Antwort würde ich mich freuen. Danke schonmal!
Bitte warten ..
Mitglied: aqui
01.10.2007 um 09:51 Uhr
Du musst im DNS Server des Domain Providers dann diese (deine) feste öffentliche IP zu deiner Domain hinterlegen. Das macht normalerweise dein Provider wo deine Domain gehostet wird. Selber kann man das normalerweise nicht, es sei denn du betreibst einen eigenen DNS Server.

Deine öffentliche IP ist mit Sicherheit die IP Adresse des externen(DSL) Interfaces an der Zywall und dahinter liegt dein lokales Netz mit sehr wahrscheinlich privaten IPs in der auch dein Webserver liegt.. ???
Du musst dann natürlich zwingend in der Zywall eine Port Forwarding Liste einrichten die dir eingehenden HTTP Connections auf diese öffentliche IP auf Port TCP 80 und TCP 443 auf deine interne Web Server IP Adresse forwardet, sonst geht es natürlich nicht !!
Das sollte es dann gewesen sein...
Bitte warten ..
Mitglied: ran
01.10.2007 um 10:18 Uhr
Das Problem ist ja, dass ich beim Domain-DNS die öffentliche IP nicht eintragen kann. Bei uns in der Schweiz ist das Switch. Ich glaub bei .com-Domains ist es nic.

Es sagt mir, dass es diesen DNS nicht kennt. Hab ich da etwas falsch begriffen? Müsste ich auf dem Webserver noch einen DNS-Server installieren?
Bitte warten ..
Mitglied: aqui
01.10.2007 um 10:23 Uhr
Nein, normalerweise hats du auf DNS Konfigs des Domain Hosters deiner Domain überhaupt keinen Zugriff. Vermutlich kannst du es deshalb nicht ändern... Das kann nur dein Provider selber machen, der dir deine öffentliche IP auf deine DNS Domain www.irgendeinedomain.ch dort einträgt !!! Dort musst du also dessen Hotline kontaktieren !

Du kannst das ja auch ganz einfach mal testen indem du einfach mal in der Eingabeaufforderung nslookup eingibst und dort dann deine Domain www.irgendeinedomain.ch. Der DNS Server müsste dir daraufhin deine eigene feste öffentliche IP ausgeben ! ...oder eben die IP die dein Domain Provider derzeit daraufgelegt hat !!!
Was gibt dir nslookup denn für eine IP aus auf deine Domain ??
Bitte warten ..
Mitglied: ran
01.10.2007 um 10:33 Uhr
Nicht autorisierte Antwort:
Name:
Address:
Aliases:

Ich kann mich bei nic schon einloggen und die zwei DNS verändern. Nur nimmt er sie nicht. Oder meinst Du etwas anderes?
Bitte warten ..
Mitglied: aqui
01.10.2007 um 10:38 Uhr
In der Antwort siehst du schon das Elend:

1) hosting for this domain is not configured
or
2) there's no such domain registered in Plesk.

Also entweder ist das ein freier Webserver auf den das zeigt oder vermutlich ist die Domain zur IP Zuordnung nicht eingetragen !
Wie gesagt das muss dein Domain Provider machen...selber darf man das normalerweise nicht, sonst könntest du ja schnell mal www.google.de mirnichtsdirnichts auf deine IP Adresse umbiegen und das wäre ja fatal.
Also: ruf deinen Provider an und bitte ihn die IP umzustellen !
Bitte warten ..
Mitglied: ran
01.10.2007 um 10:47 Uhr
Also im Moment ist die Seite noch extern gehostet. Dort ist PLESK im Einsatz...
Ich komm irgendwie grad nicht mehr ganz mit mit der ganzen DNS-Geschichte ;).

Ich weis nicht ob wir vom selben sprechen ;). Ich habe bei Switch ein login, wo ich dann die Daten zu den Domains verwalten kann. Ich kann pro Domain zwei DNS-Einträge machen.
Bitte warten ..
Mitglied: ran
03.10.2007 um 13:43 Uhr
So, ich bin jetzt schon ein Stück weiter gekommen.

Nun komme ich von aussen mit http://IP-Adresse drauf. So weit so gut alles ok .

Bei Switch konnte ich die öffentliche fixe IP als DNS registrieren und bei der Domain (.ch) eintragen. Wenn ich jetzt von aussen im Browser die Domain eingebe geht es nicht. Mit der IP schon. An was kann das jetzt liegen?

Im Moment sieht es so aus:
Modem > ZyWall (mit NAT- und Firewall-Regeln) > Alles von Port 80 auf den Webserver in der DMZ.

Bei Apache sind die vHosts erstellt und laufen so weit auch. Die hosts-Datei in Windows Server 03 ist auch angepasst.

Freundliche Grüsse
Raphael
Bitte warten ..
Mitglied: aqui
03.10.2007 um 16:01 Uhr
Dann liegt der Fehler ganz klar in der DNS Aufloesung !!!
Was ergibt den nslookup auf die Domain. Wird dort deine private IP zurueckgegeben ???

Wenn es mit der nackten IP klappt mit dem Domainnamen aber nicht, kann es nur daran liegen. Du musst dem DNS Server auch etwas Zeitgeben den Eintrag zu syncen. 5 Min solltest du immer warten. Wenn nslookup dir die richtige Adresse zurueckgibt dann klappts auch mit dem Domainnamen !!!
Bitte warten ..
Mitglied: ran
04.10.2007 um 07:58 Uhr
Ich hab mal ein nslookup durchgeführt:
* Der Servername für die Adresse 192.168.1.1 konnte nicht gefunden werden.
Non-existent domain
* Die Standardserver sind nicht verfügbar.
Server: UnKnown
Address: 192.168.1.1

DNS request timed out.
timeout was 2 seconds.
*** Zeitüberschreitung bei Anforderung an UnKnown

Ist etwas mit dem DNS-Dienst auf dem Windows-Server, auf dem Apache ist, nicht in ordnung?

//edit:
Noch ein paar Infos... Bei der Firewall > NAT > Port Forwarding habe ich den Port 53 weitergeleitet zum Apache. Ich bin mir gerade nicht sicher, ob ich sonst noch eine Einstellung vornehmen muss.
Bitte warten ..
Mitglied: aqui
04.10.2007 um 12:03 Uhr
Das ist Unsinn, denn dein Webserver ist ja kein DNS Server ! Ausserdem steht der DNS Server der Cients die IP zum Namen zurückgibt beim Domain Provider und ist mitnichten dein eigener Webserver. Das Port 53 Forwarding musst du also wieder entfernen !!!

Wenn ich in meinen Browser www.irgendeinedomain.ch eingebe, dann fragt der DNS Server meines Providers den der die Top Level Domain .ch bedient und der fragt dann den deines Doamin Providers. Von diesem bekomme ich dann z.B. die 87.1.10.50 als IP Adresse zurück. Hast du das richtig eingetragen, dann muss dies die IP des DSL Ports deines Routers sein !!!
Daraufhin versucht mein Firefox Browser dann eine TCP Port 80 Verbindung auf diese IP Adresse, die dann an deinem Router ankommt.
Der sieht in seine PFW Liste und sieht: Aha, eingehende TCP Port 80 Session, die soll ich lokal auf 192.168.1.x (dein lokaler Server) forwarden !!! Was er dann auch macht. Und....
voila ich sehe die Indexseite deines lokalen Apache bei mir im Browser !
Irgendwelche DNS Dienste bei dir sind da gar nicht involviert und gehören auch deaktiviert !!!

Wenn dein nslookup dir nicht die richtige IP ausgibt hast du de facto ein DNS Problem.
Gib die Domain sonst hier mal auf einem externen nslookup Client an, da sollte in jedem Falle die richtige IP zu deiner Domain rauskommen:

http://www.kloth.net/services/nslookup.php
Bitte warten ..
Mitglied: ran
04.10.2007 um 13:38 Uhr
Ich hab bei meinem Provider extra 2x nachgefragt wie das ist mit dem DNS. Die sagten mir ich müsse einen einrichten. Ich hab jetzt den Standard-Dienst wom Windows eingerichtet und konfiguriert. Jetzt gehts. Ich komme drauf.

Den Name-Server musste ich bei Switch übrigens auch selber regisrieren.

Ich bin aber froh dass es jetzt geht und bedanke mich wirklich ganz herzlich für den Support! Es hat mich immer wieder ein Stück weiter gebracht ;)! Jeden Tag etwas bis ich heute beim Ziel angelangt bin :D. Vielen Dank!

Grüsse
Bitte warten ..
Mitglied: aqui
04.10.2007 um 14:07 Uhr
OK, dann bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !!!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Video & Streaming
gelöst Plex TV von aussen kein Zugriff (4)

Frage von xpxy15 zum Thema Video & Streaming ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (6)

Frage von Kroeger02 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...