Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zugriff auf ext3-Partition

Frage Linux

Mitglied: northern

northern (Level 1) - Jetzt verbinden

22.07.2013, aktualisiert 17:47 Uhr, 2883 Aufrufe, 14 Kommentare, 3 Danke

Hallo,
ich habe hier zwei Platten aus einem NAS (Buffalo, ls-wvl). Die Platten liefen in dem NAS als RAID1.
Jetzt ist eine Platte abgeraucht. Da alles schnell schnell gehen musste habe ich die Platten gegen
zwei langsam drehende WD-Platten ausgetauscht und die sofort benötigten Daten wieder zurückgespielt.
Jetzt habe ich die alte Platte an meinen Win7-Rechner angeschlossen und versuche bislang erfolglos auf
die restlichen Daten (380GB) zuzugreifen. Ich habe es mit diskinternals versucht und auch mit dem TotalCommander-Plugin
ex2fs. Damit werden mir die einzelnen Partitionen zwar angezeigt, ich kann aber nicht auf die Dateien
zugreifen.
Ich habe die Platte auch via USB an meine Synology_DS213+ geklemmt. In der Filestation wird mir nur der Lost&Found-Ordner angezeigt,
von den anderen Daten sehe ich nichts.

a555f31c0b5d9cc798ec13efb7eb3429 - Klicke auf das Bild, um es zu vergrößern

Hat das Problem etwas mit den Berechtigungen auf dem NAS zu tun?
Wie komme ich an die Daten `?

northern
Mitglied: Lochkartenstanzer
22.07.2013 um 17:54 Uhr
Moin,

Hast Du das System mal unter linux gestartet? Das kommt besser mit ext3 zurecht als Windows.

lks
Bitte warten ..
Mitglied: aqui
22.07.2013 um 17:55 Uhr
Eigentlich ganz einfach:
Wo ist dein Problem genau ?
Bitte warten ..
Mitglied: northern
22.07.2013, aktualisiert um 18:15 Uhr
Moin,
danke für die schnellen Reaktionen.
Den Universaladapter habe ich, der steckt jetzt gerade via USB an meinem Laptop, den ich mit einem UltimateBoot-Image (http://www.ultimatebootcd.com) gestartet habe. Hier habe ich den DiskExplorer 'SpaceFM' gestartet. Dort werden mir die Partitionen gelistet, wenn ich dann auf sdd6 (wo die Daten liegen) zugreifen will kommt:
udevil:/dev/sdd6 is known to mount - runnig mount as current user
udevil:warning 45:options ignored for device in fstab (or specify mount point)
mount:unknown filesystem type 'linux_raid_member'
Bitte warten ..
Mitglied: catachan
22.07.2013 um 18:53 Uhr
Hi

die Platte war wohl in einem LVM Verbund. Probier das mal: http://www.tuxradar.com/answers/296

LG
Bitte warten ..
Mitglied: Lochkartenstanzer
23.07.2013, aktualisiert um 08:39 Uhr
Zitat von northern:
mount:unknown filesystem type 'linux_raid_member'

Dann nimm eine live-CD, die md/mdadm mit an Bord hat (knoppix, ubuntu, etc.).

Dann startest Du die md-devices und schon kansst Du drauf zugreifen.

lks
Bitte warten ..
Mitglied: northern
23.07.2013 um 07:57 Uhr
Moin,
ich werde die Vorschläge heute abend umsetzen und gebe dann Rückmeldung.
Bis später
northern
Bitte warten ..
Mitglied: Lochkartenstanzer
23.07.2013 um 08:41 Uhr
Moin,

Du könntest natürlich testweise den Partitionstyp auch auf "linux" setzen (0x83).

lks
Bitte warten ..
Mitglied: northern
23.07.2013 um 22:16 Uhr
iich habe Bammel das ich mir das Dateisystem zerschiesse.
Bin heute zu nichts gekommen, morgen gehts weiter.
Bitte warten ..
Mitglied: Lochkartenstanzer
23.07.2013 um 22:53 Uhr
Zitat von northern:
iich habe Bammel das ich mir das Dateisystem zerschiesse.

Dann mach vorher ein Image der Platte. oder hol jemanden, der sich damit auskennt.

lks
Bitte warten ..
Mitglied: 16568
24.07.2013 um 08:15 Uhr
Zitat von catachan:
Hi

die Platte war wohl in einem LVM Verbund. Probier das mal: http://www.tuxradar.com/answers/296

RAID -> LVM???
Wie meinen?


Lonesome Walker
Bitte warten ..
Mitglied: Lochkartenstanzer
24.07.2013 um 08:24 Uhr
Zitat von Lochkartenstanzer:
> Zitat von northern:
> ----
> iich habe Bammel das ich mir das Dateisystem zerschiesse.

Dann mach vorher ein Image der Platte. oder hol jemanden, der sich damit auskennt.


nachtrag: Wie man sowas macht, wurde z.B. in diesem Thread (und vielen anderen) schon durchgespielt.

lks
Bitte warten ..
Mitglied: northern
24.07.2013, aktualisiert um 16:41 Uhr
Hallo,

wie ich ein Image erstelle weiß ich. Trotzdem Danke.
Ich komme jetzt übrigens klar. Habe Zugriff auf die Datein mit PartedMagic, welches sich mit der UniversalBootCD starten lässt. Keine Ahnung warum es vorher nicht geklappt hat.

viele Grüße
nortern
Bitte warten ..
Mitglied: aqui
24.07.2013 um 18:19 Uhr
Bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: northern
24.07.2013 um 23:10 Uhr
nee nee, das vergesse ich nicht.
das hat eben doch nicht so geklappt wie ich dachte. Das Dateisystem der Platte aus dem Buffalo-NAS ist XFS. Beim mounten jedoch habe ich ext3 angegeben, weil der Filemanager unter partedmagic mir das so angezeigt hat. Mit dem Befehl mount -t xfs /dev/<partition_name> /<einhängepunkt> konnte ich die entsprechende Partition mounten und mit einem Dateimanager die Dateien sichern.
Danke für eure Unterstützung !!
Bitte warten ..
Ähnliche Inhalte
Windows Installation
Partition Bootfähig machen
Frage von M.MarzWindows Installation6 Kommentare

Hallo zusammen, ich habe eine 1 TB HDD Platte mit mehreren Partitionen drauf und 2 OS. 1x Windows 10 ...

Hyper-V
Verkleinerung von Partition
gelöst Frage von KnorkatorHyper-V11 Kommentare

Hallo zusammen, ich habe hier einen virtuellen Server2008 (mit Exchange 2010) mit 2 virtuellen Festplatten (beide Fixed vhdx). Laufwerk ...

Windows 10
Partition vergrößern aber wie?
gelöst Frage von M.MarzWindows 108 Kommentare

Hallo zusammen, wie kann ich im Windows 10 meine Partition P vergrößern? Es wird mir nur das verkleinern angeboten. ...

Batch & Shell
Partitionen auslesen
gelöst Frage von TlBERlUSBatch & Shell2 Kommentare

Hi Zusammen, ich probiere mich momentan an der Powershell, stoße momentan leider auf das Problem, dass sich mein Skript ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 8 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 10 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement15 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...