Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst MSI über Gruppenrichtlinien fehlgeschlagen da Netzlaufwerk noch nicht verbunden.

Mitglied: Machete

Machete (Level 1) - Jetzt verbinden

18.07.2011 um 01:08 Uhr, 5461 Aufrufe, 8 Kommentare

Hallo Zusammen,

Bin im Thema Server noch recht neu und hätte da mal eine Frage zur Verteilung von Software über die Gruppenrichtlinien.

Es geht um eine Software, welche ein zentrales Verzeichnis auf dem Server nutzt.
Server: Win 2003 als auch Win 2008.
Clients: XP, Vista und Win 7.

Die Rechner auf welche die Software verteil werden, sind entsprechend die Clients.
Das Zentrale Verzeichnis wird über ein Laufwerks mapping verbunden.

Wenn nun das Setup/MSI verteilt wird, bricht die Installation ab, da vor der Win Useranmeldung das Laufwerk noch nicht verbunden ist.

Die Software hat eine Abfrage drin, ob das gemappte Laufwerk vorhanden ist.

Hat jemand eine Idee wie ich das Ganze hinbekommen könnte?

Vielen Dank schon mal im voraus.

Gruß Machete
Mitglied: breppe
18.07.2011 um 07:08 Uhr
Hallo,

schau dir mal folgende GPO an:
Computerconfg -> Richtlinien -> Admin. Vorlagen -> System -> anmelden -> Bei neustart immer auf Netzwerk warten (so, oder so ähnlich)

Gruß
Bitte warten ..
Mitglied: Xboxer
18.07.2011 um 07:12 Uhr
Hi,

das mit der Abfrage wird immer fehlschlagen, da das Loginscript erst mit der Benutzeranmeldung ausgeführt wird.

Warum nutzt du keine UNC Pfade?

Gruß
Christoph
Bitte warten ..
Mitglied: Machete
18.07.2011 um 07:35 Uhr
Hallo Christoph,

es wird nur ein Verzeichnis gepflegt und dann auf die anderen Server geklont.
In manchen Dateien ist der Pfad hinterlegt, d.h. wenn nun die Clients auf einen anderen Server zugreifen würden
Sie die richtigen Dateien nicht mehr finden da es sich um einen anderen UNC Pfad handelt.

Es kann schon mal vorkommen das bis zu 30 Server im Einsatz sind, diese alle einzeln zu Pflegen wäre zu zeitaufwendig.

@breppe: Werde ich mal nach schauen.

Gruß
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 07:42 Uhr
Moin,

welchen Sinn hat das denn, dass die Software über mehrere Server verteilt werden?

Eigentlich braucht man nur einen und da liegt die Software.

Bei der GPO wird dann die Software aus dem Ordner :

\\Servername\Install

eingetragen und gut ist.
Da braucht man keine Laufwerkmappings - eh sinnlos, weil warum sollen die User auf dieses Verzeichnis direkten Zugriff haben?
Überflüssig und lästig und verwirrend.

VG
Bitte warten ..
Mitglied: tikayevent
18.07.2011 um 09:01 Uhr
Ich lege saemtliche msi-Pakete die per GPO verteilt werden sollen in den SYSVOL-Ordner. Dadrauf haben normale Benuter nur Leserechte, aber die Computer koennen auch vor der Anmeldung darauf zugreifen. Ebenfalls wird das Verzeichnis zwischen allen Domaenencontrollern repliziert. In die GPO haenge ich das msi-Paket dann mit dem DFS-Pfad ein, also \\domaene.local\sysvol\scripts\...
Bitte warten ..
Mitglied: 101238
18.07.2011 um 19:27 Uhr
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000 war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige Ansatz.

Viel Glück
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 19:30 Uhr
Zitat von 101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück

Diese Richtlinie ist nicht relevant, wenn man die Software per UNC Pfad angibt wie ich es oben schrieb.

VG
Bitte warten ..
Mitglied: Machete
18.07.2011 um 22:30 Uhr
Zitat von 101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück



So etwas habe ich bei Herrn Google auch gefunden und es geht nun endlich.

Es werden mehrere Server benötigt, da diese in unterschiedlichen Filialen zum Einsatz kommen.
Die eigentliche Pflege soll aber nur aus einer Filiale heraus stattfinden.

Deshalb keine Installation über UNC Pfad möglich.

Vielen Dank,
Gruß Machete
Bitte warten ..
Ähnliche Inhalte
Windows Server

Netzlaufwerk mit net use verbunden, aber doch nicht?!

Frage von jlrantWindows Server3 Kommentare

Hallo zusammen, und zunächst mal vielen Dank für Euer hilfreiches Forum. Ich habe bisher ausschließlich Linux-Server administriert, muss mich ...

Windows Server

Passwort von verbundenem Netzlaufwerk löschen

Frage von mastap2002Windows Server3 Kommentare

Hallo zusammen , ich hab da eine etwas seltsame Anfrage eines Kunden ;-). Also Wenn ich über Ausführen \\192.168 ...

Windows 7

Netzlaufwerk nach Neustart nicht mehr verbunden

Frage von ahstaxWindows 76 Kommentare

Hallo, auf einem Win7-PC sind einige Netzlaufwerke unter Verwendung der Checkbox "Verbindung bei Anmeldung wiederherstellen" eingebunden. Bei einem Netzlaufwerk ...

Windows Server

Einmal verbundenes Netzlaufwerk löschen

gelöst Frage von killtecWindows Server10 Kommentare

Hallo, ich möchte gern an allen Clients / Benutzern ein Bestimmtes Netzlaufwerk löschen. Es soll nur bei den angegebenen ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 1 TagHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement13 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android12 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...