Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache mit Php3 und phpmyadmin

Frage Linux Apache Server

Mitglied: SunziX

SunziX (Level 1) - Jetzt verbinden

16.09.2011, aktualisiert 24.09.2011, 4602 Aufrufe, 4 Kommentare

Hallo liebe Community,
ich habe ein Problem mit PhpMyAdmin, aber vielleicht erst mal von Anfang an. Ich habe einen Ubuntu Linux 10.04 Server aufgesetzt mit MySQL 5.x Apache2 und PhpMyAdmin, das läuft auch alles.
Jetzt sollte ich einen weiteren Server in PhpMyAdmin einbinden (unser phpmyadmin verwaltet einige andere DBs auf anderen Serevern problemlos), das klappt nicht und phpmyadmin spuckt mir eine Fehlermeldung aus:

Fehler
SQL-Befehl:
01.
SET CHARACTER SET 'utf8'; 
MySQL meldet:
01.
#1115 - Unknown character set: 'utf8'
Im Netz habe ich herausgefunden das alte MySQL Version <5.x mit den aktuellen phpmyadmin Versionen genauso einen Fehler verursachen.
Ich habe mir eine geeignete phpmyadmin version gezogen und als viruellen Host hinzugefügt.
Wenn ich das Web über den Browser ansteuere dann wird mir aber nur der Inhalt des Ordners Browser angezeigt, ich denke das das PHP noch net läuft (obwohl das aktuelle phpmyadmin geht).
Mein Frage ist, wie sage ich Apache das PHP bzw. PHP3 dafür zu nutzen oder habe ich was übersehen?

Über Tipp und Anregung würde ich mich freuen.

Mit freundlichem Gruß,
SunziX
Mitglied: Phalanx82
16.09.2011 um 21:55 Uhr
Zitat von SunziX:
Hallo liebe Community,
ich habe ein Problem mit PhpMyAdmin, aber vielleicht erst mal von Anfang an. Ich habe einen Ubuntu Linux 10.04 Server aufgesetzt

Ja du hast ein Problem, welches verrat ich Dir auch gleich...

Mein Frage ist, wie sage ich Apache das PHP bzw. PHP3 dafür zu nutzen oder habe ich was übersehen?

wtf?! PHP3?? Bist du Irre? Das Ding ist vom Juni 1998!

Wir sind gerade bei php Version 5.3.8 vom August!

Über Tipp und Anregung würde ich mich freuen.

Hoffe mein Wink mit dem Zaunpfahl war ausreichend? Oder muss ich dir jetzt beschreiben,
warum man keine aktuelle linux Distri mit über 12 Jahre alter Software betreiben sollte...?


Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: Dirmhirn
16.09.2011 um 22:27 Uhr
Hi!

Im Netz habe ich herausgefunden das alte MySQL Version <5.x mit den aktuellen phpmyadmin Versionen genauso einen Fehler verursachen.
du schreibst ja nix von MySQL < 5.x kann auch ned dein problem sein.

ist das:
Ubuntu Linux 10.04 Server aufgesetzt mit MySQL 5.x Apache2 und PhpMyAdmin
gleich das:
unser phpmyadmin verwaltet einige andere DBs auf anderen Serevern problemlos
?

MySQL 4 unterstützzt kein UTF8 phpmyadmin dürfte es aktuell aber vorraussetzen - kannst nur schauen ob man für jede datenbank einen eigenen charset angeben kann...

Dirm
Bitte warten ..
Mitglied: dog
17.09.2011 um 00:08 Uhr
MySQL 4 unterstützzt kein UTF8

Wie kommst du denn auf die lustige Idee?

> mysql --version 
mysql  Ver 14.7 Distrib 4.1.10a, for suse-linux (i686) 
> mysql 
 
mysql> SHOW CHARACTER SET; 
+----------+-----------------------------+---------------------+--------+ 
| Charset  | Description                 | Default collation   | Maxlen | 
+----------+-----------------------------+---------------------+--------+ 
... 
| utf8     | UTF-8 Unicode               | utf8_general_ci     |      3 | 
... 
+----------+-----------------------------+---------------------+--------+ 
34 rows in set (0,00 sec) 
 
mysql> SET NAMES 'utf8'; 
Query OK, 0 rows affected (0,00 sec)
UTF-8 gibt es ab 4.1 (die kam im Oktober 2004 auf den Markt!)
Wer eine noch ältere Version als die einsetzt ist wahnsinnig
Bitte warten ..
Mitglied: mrtux
17.09.2011 um 11:24 Uhr
Hi !

hab lang mit mir gehadert, ob man zu dem Thread überhaupt was schreiben kann oder darf....

Zitat von Phalanx82:
warum man keine aktuelle linux Distri mit über 12 Jahre alter Software betreiben sollte...?

Naja Du kennst aber doch seine Intention gar nicht...Es könnte sich ja auch um eine, mit Forschungsgeldern finanzierte, Diplom oder Projektarbeit handeln, Titel: "How to setup a high frequently used social community for black-hat members"

mrtux
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Apache Server
Alias bzw. Weiterleitung unter Apache 2.4 einrichten (2)

Frage von m.reeger zum Thema Apache Server ...

CMS
PHP - WordPress auf Apache schneller als auf IIS? (13)

Frage von Rene1976 zum Thema CMS ...

Apache Server
gelöst Apache Webserver HTTP 500 Error (7)

Frage von ClepToManix zum Thema Apache Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...