Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum bremst Windows XP VDSL 25 aus?

Frage Netzwerke DSL, VDSL

Mitglied: akelus

akelus (Level 1) - Jetzt verbinden

03.08.2009, aktualisiert 13:25 Uhr, 15026 Aufrufe, 16 Kommentare

Hallo,
ich benötige Hilfe von einem Experten, der sich in VDSL und XP gut auskennt!

1. bla-bla

Seit vergangenem Freitag habe ich pünktlich und vertragsgenau VDSL 25 geschaltet bekommen. Hat sofort ohne Probleme funktioniert und die Geschwindigkeiten (mit meinem LG Notebook) können sich auch sehen lassen: downstream 23 500 kbit/sec, upstream 4 700 kbit/sec ohne Virenscanner, über speed.io und wieistmeineip.de gemessen. Der webguard von Avira „klaut“ etwa 15 000 bis 20 000 kbit/sec beim downstream, der upstream ist davon nicht betroffen.

2. Mein Problem

Wenn ich die Speedtests mit meinem PC - also nicht mit meinem Notebook - mache, fehlen ca. 10 000 bis 15 000 kbit/sec beim download.! Ohne Antivir / webguard. Es werden immer nur "schlappe" 11 000 bis 15 000 kbit/sec angezeigt. Der upload liegt immer bei 4 500 bis 4 800 kbit/sec.

Folgendes habe ich ausprobiert:
Alle Programme / Anwendungen beendet
über autoruns alle Dienste und Anwendungen aus dem Startmenü entfernt
über msconfig / Start auch alles abgeschaltet
Ergebins: Keine Verbesserung der Downloadzeiten.

Ubuntu 9.04 live verwendet: download liegt bei 23 567 kbit/sec, also sehr gut!!

Alle Versuche über LAN, nicht über WLAN!

3. Meine Frage

Wer oder was von Windows XP bremst den download so beträchtlich? An der Hardware kann es nach dem Test mit Ubuntu also nicht liegen. Wie kann ich noch systematisch vorgehen, um den Flaschenhals zu finden? Der Process Monitor hat mir auch nicht weitergeholfen (weil zu doof?)

4. Meine Hardware und Software

Notebook
LG LW25 Pro, 1,83 GHz, 1 GB RAM, Windows XP SP3
PC
Dell Dimension 4550, 2,46 GHz, 1024 MB RAM, Windows XP SP3, Intel Pro 100 VE Netzwerkkarte mit neuestem Treiber.
Modem / Router:
Speedport 300HS und W701V

Vielen Dank für eure Hilfe(n)
akelus

Hinweis für den Admin: Falls ich hier nicht richtig bin, bitte den Beitrag verschieben
Mitglied: Raider88
03.08.2009 um 13:36 Uhr
Hallo, habe auch VDSL ,

das mir 10.000Kbit bei der Leitung fehlen, bemerke ich nur, wenn ich TV schaue.

Mein XP sowie Vista Rechner erbringt im Einzelnen volle Bandbreite.

Ist es vieleicht möglich das du zufälligerweise den Reciever am Netzwerk hattest wärend du mit dem XP Rechner ein Speedtest Probiert hast ;)

was ich ganz vergessen habe, du solltest aufjeden fall vor einem Test Irgendwelche Firewall und sonstige Programme deaktivieren, da diese gerne Werte manipulieren

Gruß, Raider
Bitte warten ..
Mitglied: harald21
03.08.2009 um 13:57 Uhr
Hallo,

die von dir angegebenen Geschwindigkeiten wurden ja über eine Down-/Upload des Browsers gemessen.

Vergleiche doch mal die Browsereinstellungen der beiden XP-Systeme (IE6, IE7, IE8, Cache-Größe, etc.)
Ubuntu wird ja vermutlich einen anderen Browser verwenden (Firefox). Bitte überprüfe auch hier die Einstellungen zum Vergleich. Welche Geschwindigkeit hast du, wenn du auf WinXP mit dem Firefox arbeitest?

Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: akelus
03.08.2009 um 15:06 Uhr
@ Raider: Ich habe das VDSL ohne das Entertainpaket bekommen. Also keinen Receiver dran! Und ich hatte ja geschrieben, dass ich alles ausgeschaltet hatte - es sei denn, ich habe etwas übersehen - aber was????

@ Harald: Vielen Dank für Deinen Kommentar und Deine Hilfen. Sorry, war meine Nachlässigkeit, dass ich nicht erwähnt hatte, dass ich die Versuche sowohl mit dem IE 8 als auch mit dem Firefox 3. 0.11 gemacht habe. Bei Ubuntu kommt ja der Firefox automatisch mit. Ich werde aber trotzdem mal die Eistellungen auf dem Notebook mit denen vom PC vergleichen. Auf beiden habe ich den IE und den Firefox und mit beiden Browsern waren die Werte auf dem Notebook "glänzend" und auf dem PC lahm! Über "speed.io" jeweils etwas besser als über "wie ist meine ip adresse".
Ich suche weiter....

Wie "unbedarft" kann ich eigentlich über den Task Manager einzelne Prozesse "abschießen"? Die CPU-Auslastung liegt bei wirklich 0%!! Und beim Speedtest ist nur der iexplore.exe aktiv. Mit 8% aber auch bis zu 70% beim Download.
Und: Nach ad-ware und Spyware habe ich auch schon alles durchsucht und gereinigt. Hatte auch nichts gebracht.
Gruß
akelus
Bitte warten ..
Mitglied: Cometcola
03.08.2009 um 15:15 Uhr
hallo,

also wenn ich es richtig verstanden habe, hast du einen Internetspeedtest gemacht. Das ist mitunter sehr ungenau. siehe -->

http://www.heise.de/netze/Online-Speedtests-im-Test--/artikel/139815

Eine Möglichkeit wäre, wenn du auf mehreren Linux-Distributionsseiten z.B. auf opensuse.org dir ein Image herunterlädts und paralell noch zwei Downloads startest...dann sollte sich deine Geschwindigkeit einpendeln und du bekommst einen ungefähren Eindruck deiner Geschwindigkeit.

Serverseitig kann es auch Beschränkungen geben.
Bitte warten ..
Mitglied: aqui
03.08.2009 um 15:46 Uhr
Hast du deinen XP TCP Stack angepasst ?? Speziell was die Windowsize anbetrifft ??

http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619

http://www.psc.edu/networking/projects/tcptune/

Dann verschwindet auch dieser Effekt im Handumdrehen !
Bitte warten ..
Mitglied: akelus
03.08.2009 um 16:37 Uhr
Dank an aqui.
Alle möglichen Test gemacht und bestanden - und immer noch so langsam. Ping liegt bei 22 bzw. 25 ms, Windowsize (MTU) mit 1464 optimal, ab 1465 wird fragmentiert. (Test über ping -f -l 1464 bzw. 1465 <Provider> ).
Was nun??? Es kann ja nur am XP liegen, da mit Linux die Werte gut sind und zwischen IE 8 und Firefox quasi keine Unterschiede sind. Die CPU-Auslastung geht beim download schon mal an 100% ran. Aber nur kurzzeitig. Normal liegt sie zwischen Null und 4%.

akelus
Bitte warten ..
Mitglied: Noiseless
03.08.2009 um 19:03 Uhr
Hast du schonmal was von nem FTP Sever gezogen? Damit könntest du ausschließen, dass dein Browser die Leitung ausbremst.
Bitte warten ..
Mitglied: akelus
04.08.2009 um 22:02 Uhr
So, hier nun einige Zahlen:

FTP-Server: Mit beiden Rechnern identische 300 kBytes. Mehr gab der Server wohl nicht her.

Download über HTTP (Ubuntu download von unterschiedlichen Servern):
PC mit IE8 und Firefox: 736 kByte
Notebook mit IE 8 und Firefox: 1.4 bis 1.6 MByte!!

Lokale LAN-Verbindung über den Router (Speedport W701V): ca. 10 0000 kBytes in beiden Richtungen.

Wo steckt nun der Falschenhals?? Und wie finde ich ihn?

Die im ersten Beitrag genannten unterschiedlichen Werte wurden auch heute wieder erreicht und bestätigt.

Hat jemand eine Idee oder die Lösung??
akelus
Bitte warten ..
Mitglied: nEmEsIs
09.08.2009 um 13:50 Uhr
Hi

Hast du mal das QoS Paketplaner aus deiner Lan bzw W-Lan verbindung herrausgenommen vll. geht es dann schneller.

Mit freundlichen Grüßen Nemesis
Bitte warten ..
Mitglied: akelus
09.08.2009 um 16:01 Uhr
Hi Nemesis,

vielen Dank für den Tipp mit dem QoS Paketplaner. Nur, er ist auf dem PC überhaupt nicht aktiviert - kann also wohl auch keine Auswirkungen haben - oder?

Hier noch ein "Testergebnis": Mit dem Speedmesser von www.numion.com erreicht der PC mit beiden Browser über 23 MB!! Da der Test voll auf Java aufbaut, scheint er die Microsoftbremsen zu umgehen.

Ansonsten habe ich die Einstellungen vom Notebook mit denen des PC verglichen: Keine erkennbaren Unterschiede!! Und trotzdem immer noch die Unterschiede zum Notebook.

Mit freundlichen Grüßen
akelus
Bitte warten ..
Mitglied: DanielH
10.08.2009 um 09:32 Uhr
- Deleted -

Sorry, hatte deinen letzten Eintrag nicht gelesen...
Bitte warten ..
Mitglied: Wildboy
10.08.2009 um 16:17 Uhr
Xp ist eh total veraltet und ist normalerweise grademal für isdn ausgelegt,ohne das du die registry und die systemsettings bearbeitest haste nie volle bandbreite,natürlich kommst auch drauf an welchen provider du nutzt,wie gut dem sein routing und anbindung ist,und vor allem mit einem laptop der nur 1.8ghz und nur 1 gb ram hat kannste solche geschwindigkeiten wie Vdsl bietet eigendlich eh vergessen.
als kleines beispiel zwischen laptop und meinem momentanen pc:
mein laptop hat 4gb ddr2 ram,nen intel 6300 dualcore cpu und schafft wenns mal gut geht auch nur maximal 2.7mb/sek.(xp sp3 ohne das was an der registry oder sonstwo was verstellt wurde),wenn ich die kabel an meinem pc steck hab ich locker 3.76-3.86mb/sek. an downloadspeed und auch der upload ändert sich extrem von laptop auf pc.
Merk das auch beim usb2,laptop schafft lächerliche 12-13mb/sek.,pc locker 39-42mb/sek. an durchsatz,da sieht man sofort was sache is.
Pc hat vista ulti x64 drauf und das doppelte an cpu und ram was der laptop hat.
anbindung:32mbit(Down)/2mbit(up) statik digital kabel

Tipp: teste auch mal nen andern router & netzwerkkarte,und schließ wenn du die möglichkeit hast auch mal nen Pc an das Vdsl an ob sich da was ändert.z.b. nen pc von nem freund.

das mit dem QoS ist zwar schon ne gute idee aber der macht im windows normal betrieb wenn überhaupt nur ein paar kb aus.

Zum speedtesten hab ich ne gute site gefunden die immer sehr gute leistung bietet:

ftp://ftp.free.fr/mirrors/AmericasArmy/

such dir dort ne grosse datei aus und saug sie,z.b. die:

ftp://ftp.free.fr/mirrors/AmericasArmy/Windows_v2.8.5/aa2.285.server.w ...

Zum einstellen deines Windows kann dir 2 sehr gute Tools empfehlen:

1. http://www.dslreports.com/drtcp (Dr.TCP heist es,aber da muss man eben schon wissen was man wo und wie einstellen muss,also eher was für fortgeschrittene Leute gedacht)

&

2. http://www.speedguide.net/files/TCPOptimizer.exe (Das Tool finde ich ist für den grossteil der Users die leichtere und schnellere lösung,und vor allem ist es nett übersichtlich gemacht.)

Website: http://www.speedguide.net/downloads.php

Start das Tool,stell deine Bandbreite ein und übernehm die einstellungen,dann ein reboot und das wars.

Hoffe ein wenig geholfen zu haben ;)
-
http://www.kabeldeutschland.de/info-service/speedtest.html

Dieser Speedtest ist einer der genaueren,dort wird dein Ping,Download und Upload gemessen und am ende des test´s ausgegeben und anschließend noch angezeigt wie lange ein upload,bzw. download eines bestimmten volumes dauert.

teste z.b. 3x am tag an unterschiedlichen zeiten.

tschÜss
Bitte warten ..
Mitglied: akelus
10.08.2009 um 16:36 Uhr
@Wiildboy

Danke für die sehr gute und ausführliche Antwort. Werde mich da mal dranmachen.
Hier die neuesten Testergebinisse:

1. über www.speedtest.netcologne.de mit der 30 GB Datei als Download

PC: IE 8: 706 KB/sec, Firefox: 716 KB/sec
Notebook: IE 8: 1,26 KB/sec, Firefox: 1,3 KB/sec

Das Notebook ist also fast doppelt so schnell!!
Zur Erinnerung: Mit der Ubuntu live CD ist der PC genau so schnell wie das Notebook. Es muß also im PC liegen.

Hier noch Werte von: www.speedguide.net/analyzer.php

PC:
« SpeedGuide.net TCP Analyzer Results »
Tested on: 08.10.2009 10:09
IP address: 87.157.xxx.xx
Client OS: Windows XP

TCP options string: 020405ac01010402
MSS: 1452
MTU: 1492
TCP Window: 32767 (NOT multiple of MSS)
RWIN Scaling: 0 bits
Unscaled RWIN : 32767
Recommended RWINs: 63888, 127776, 255552, 511104, 1022208
BDP limit (200ms): 1311kbps (164KBytes/s)
BDP limit (500ms): 524kbps (66KBytes/s)
MTU Discovery: ON
TTL: 45
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)

Notebook:
« SpeedGuide.net TCP Analyzer Results »
Tested on: 08.10.2009 10:06
IP address: 87.157.xxx.xx
Client OS: Windows XP

TCP options string: 020405ac01010402
MSS: 1452
MTU: 1492
TCP Window: 65535 (NOT multiple of MSS)
RWIN Scaling: 0 bits
Unscaled RWIN : 65535
Recommended RWINs: 63888, 127776, 255552, 511104, 1022208
BDP limit (200ms): 2621kbps (328KBytes/s)
BDP limit (500ms): 1049kbps (131KBytes/s)
MTU Discovery: ON
TTL: 109
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)

Ist daraus etwas Entscheidendes zu erkennen, bevor ich mit dem Optimizer-Tool so einige Werte "verbiege"?

akelus
Bitte warten ..
Mitglied: Wildboy
10.08.2009 um 20:33 Uhr
(Dr.TCP Werte)

TCP recive windows hab ich 2055680
window scaling yes
time stamps nein
selective acks nein
Ras MTU 1492
MTU Discovery yes
Black hole detections nein
max dupclicate acks 0 (2 geht auch)
TTL 128 (zum online spielen sollte man unbedingt 128 nutzen da dadruch der ping "weicher" rennt,wer aber nur an Websites,Saugen und uploads interessiert ist kann das locker auch 64 setzten)
MTU 1500 (Onlinespiele 1500,,,saugen,websites,grosse datenmengen,ect.. kann man auch 3000 nutzen)

Das sind meine werte die für meine leitung,pc konfig. & Hardware gelten.

Du kannst beim TcpOptimizer im grunde nichts falsch machen da alles sehr gut beschrieben ist,und nicht zu vergessen das Tool legt dort wo es sich befindet ein Backup an,also falls doch mal was schief gelaufen ist kannst du das vorherige ganz easy wieder herstellen :D

Stell beim Tool deine Connection Speed ein (geht sogar genau bis auf deine 20000^^) und klick unten auf Optimal settings,danach auf Apply klicken.
Das vorhandene überschreiben lassen aber noch NICHT Rebooten.
Bei Advanced Settings auch auf Optimal Settings gehn und übernehmen,so wie oben.

Jetzt solltest du ein Reboot machen damit die sachen übernommen und somit Aktiv werden können.
Nach dem Reboot sollte man immer nochmal den TcpOptimizer starten und schaun ob die sachen übernommen wurden was man unten bei Current Settings ersehn kann.

Einen sehr guten trick um das laden von websites noch weiter zu verbessern/beschleunigen ist wenn man in die Advanced Settings geht,dort bei den Optionen:

MaxConnectionsPerServer
&
MaxConnectionsPer1_0Server

von den vorgegeben 10 auf 50 oder wenn man viel surft,viele websites gleichzeitig auf hat,auch auf 100 stellen kann.

Das bewirkt im grunde das mehr als nur 10 treats zu einer website aufgebaut werden können und somit bilder,flash,videos,text,..ect..also alles was sich auf ner website befindet DEUTLICH schneller zugegriffen werden kann,also somit schneller auf deinem Pc/Laptop sich befinden können.

Auch hat das den grossen vorteil das man downloads (!per browser!) von websites die sonst schon bei den Windows default´s 2,du schon auf 10 hattest,aber dann auf stolze 100 setzten kannst,wenn die gegenseite es zulässt kannst du dann bis zu 100 downloads von ner website starten anstatt den nur 2 oder eben den 10.

Ich habe immer nen ping von 8-10 bei meiner leitung,auch weil ich keinen Router habe der mir die leitung verlangsamen kann was offt der fall ist,ich bin leidenschaftlicher onlinespieler und wie jeder weis ist es nötig einen möglichst kleinen ping zu haben :P

Largest MTU geht bei mir leider nicht so richtig,evtl. liegts am tool oder bei meinem provider ka.
Den rest vom tool kann man in ruh lassen.
PC: IE 8: 706 KB/sec, Firefox: 716 KB/sec <- =?
Notebook: IE 8: 1,26 KB/sec, Firefox: 1,3 KB/sec <- =? kb/sec.?

Mit ner 20mbit leitung solltest du doch sowas um ~2mb/sek. haben...

Geh mal in den Geräte Manager und klick auf deine netzwerk-karte,schau das auch dort alles auf maximal (in & out puffer z.b.) gestellt ist und die karte auch wirklich 100mbit hat und auch nutzt,kannst du in den netzwerk verbingungen nachschaun.und wenns sogar ne gigabit ist geht auch das.

Sonst fällt mir im moment nichts weiter ein um das max aus deiner fetten leitung rauszuholen.

Vdsl von telekom?
Vdsl25? also echte 25mbit´s down,also was kommt bei dir auch wirklich davon an ist die frage denn Dsl hat halt den grossen nachteil das schon nach 5Kilometern du von den 25mbits nur noch ca. 20mbits ankommen,naja oder so ähnlich. Beim Adsl1 und 2 ist das sogar noch viel extremer.
wieviel up hast du denn da?

1Gb normaler ram im laptop,wovon schon ~300-600Mb allein nur fürs Xp draufgehn,und wenn du dann noch sachen laufen hast wie irgendwelche sicherheitsprogramme,zusatztreiber,programme,tools,autostartssachen ect. ist der ram in 0kommaNix eh weggelutscht :P

maChS GuT
sry is wieder so viel text geworden,hoffe du blickts da noch durch *g*
Bitte warten ..
Mitglied: akelus
10.08.2009 um 21:10 Uhr
Großer Dank an alle, die mir hier geholfen haben!

Das "Problem" ist gelöst, dank TCP optimizer. Jetzt habe ich auch auf dem PC satte 23.5 Mbit/sec download und sogar 4.9 Mbit/sec upload. Mehr dürfte da wirklich nicht drin sein - und meckern gilt schon garnicht. Hat aber eine ganze Weile gebraucht, bis ich über speedguide.net auf diesen Optimizer gestoßen bin - und von Wildboy noch etwas ermutigt wurde, dieses Tool tatsächlich einzusetzen. Die Liste der vorgeschlagenen Änderungen war schon zum Fürchten lang.
Vielleicht liegt es ja auch bei anderen usern, die sich über eine zu langsame DSL-Leitung beschwerden, nur an den Einstellungen und nicht am Provider. Ich - oder die T-Com - hatte das Glück, dass das Notebook mit der gleichen Leitung sofort die volle Geschwindigkeit brachte und der Fehler also bei mir liegen mußte.

Bis zum nächsten Problemchen
akelus
Bitte warten ..
Mitglied: Wildboy
12.08.2009 um 12:01 Uhr
na super wenns geklappt hat.


dann kann man dir nur noch viel spass im web wünschen,und nat. auch bei deinen down & uploads :D

cU
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Windows XP
gelöst Windows XP SP 3 System Clonen (19)

Frage von zeroblue2005 zum Thema Windows XP ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...