Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CMD startet auf Netzlaufwerk

Frage Microsoft

Mitglied: jimmyone

jimmyone (Level 1) - Jetzt verbinden

08.07.2008, aktualisiert 10.07.2008, 6161 Aufrufe, 10 Kommentare

Hallo zusammen,

ich habe ein Problem mit meiner CMD.
Und zwar wenn ich diese starte, wird diese automatisch mit dem Netzlaufwerk H verbunden.

Ich habe auch keine Möglichkeit auf C:\ zu wechseln.
Das kann ich erst dann bzw. die CMD startet auf C:\ wenn ich das Netzlaufwerk trenne.

Was ist das? Was kann ich dagegen tun?

Ich verbinde mir die Laufwerke mit einem Script, welches beim Logon läuft.
Also ein ganz normales Batchscript.

Danke im Voraus für eine Rückmeldung.

Viele Grüße
Jimmyone
Mitglied: ForgottenRealm
09.07.2008 um 00:29 Uhr
Hi


Wie genau schaut denn deine Batchdatei aus ? Magst die mal posten ? Passwort/Benutzername bitte vorher x´n
Bitte warten ..
Mitglied: jimmyone
09.07.2008 um 01:09 Uhr
Hi,

ich hab sie auf diesem Rechner hier nicht verfügbar.
Ich poste die gerne Morgen früh mal.

Das ist aber nichts weiter, als eine ganz normale Batch Datei welche den net user Befehl für die Laufwerke und eine Einbindung eines Registry Files enthält, welches für Einstellungen im IE verantwortlich ist.

Aber ich poste es Morgen mal...
Bitte warten ..
Mitglied: Iwan
09.07.2008 um 09:06 Uhr
guten morgen,

wenn ich das richtig verstehe, startest du lokal eine Batchdatei, die ein Netzlaufwerk verbindet und dann ein Regfile importiert, richtig?
wenn ja: wie rufst du die Batchdatei auf: per Verknüpfung, in einem CMD oder direkt per Doppelklick?
Bitte warten ..
Mitglied: jimmyone
09.07.2008 um 10:15 Uhr
Soo...
Das ist die Batchdatei.

@echo off

net use * /DELETE /YES

net use /persistent:no H: \\192.168.1.1\%USERNAME% /YES
net use /persistent:no I: \\192.168.1.1\Ablage /YES
net use /persistent:no P: \\192.168.1.1\Projekte /YES
net use /persistent:no S: \\192.168.1.1\Install /YES

net time \\192.168.1.1/set /yes

Regedit /s \\192.168.1.1\SYSVOL\test.testdomäne.de\scripts\ProxySet.reg

Dieses Script wird vom ADS Server bei Anmeldung ausgeführt.
Auf jedem anderen Rechner klappt das einwandfrei. Auf meinem Rechner läuft das auch ohne Probleme. Nur, bei mir wird beim Start von CMD automatisch auf H:\ verwiesen.

Wenn ich H aber trenne, dann läufts auf C:\ wie es sein soll.
Ich finde das komisch... Überall sonst läuft das Script auch genau so.
Und da gibts keine Probleme.
Bitte warten ..
Mitglied: 60730
09.07.2008 um 10:59 Uhr
Moin,

kann es sein, das dein "Homedir" im AD das Laufwerk H ist?
Schau mal nach - das ist der Grund, warum h:\ dein "root" ist und nicht c:\

mit einer vorgestellten Zeile
01.
c:\
kannst du auf c:\ wechseln.

Ps:
net time \\192.168.1.1/set /yes
läuft besser wenn vor /set ein Leerzeichen ist

Ps²:
01.
@echo off 
02.
if not exist h:\%username% net use /persistent:no H: \\192.168.1.1\%USERNAME% 
03.
if not exist i:\Ablage net use /persistent:no I: \\192.168.1.1\Ablage 
04.
if not exist p:\Projekte net use /persistent:no P: \\192.168.1.1\Projekte 
05.
if not exist s:\Install net use /persistent:no S: \\192.168.1.1\Install 
06.
 
07.
net time \\192.168.1.1 /set /yes 
08.
 
09.
Regedit /s %logonserver%\NETLOGON\ProxySet.reg
/persistent:no xyz /YES - ist flüssiger als flüssig - überflüssig

\\192.168.1.1\SYSVOL\test.testdomäne.de\scripts\
ist auch eine sehr gewagte Kombination - %logonserver%\NETLOGON\ bewirkt das gleiche - bzw. wenn das Script (batch) eh darin liegt - brauchst du den Pfad überhaupt nicht

Try it
Gruß
Bitte warten ..
Mitglied: Iwan
09.07.2008 um 11:11 Uhr
bezügl. dem CMD starten auf H:
schau mal in die registry unter
HKEY_CLASSES_ROOT\Drive\shell\CMD-Prompt\command
was dort eingestellt ist
Bitte warten ..
Mitglied: 60730
09.07.2008 um 11:13 Uhr
Servus iwan,

schau dir doch den Code mal genauer an

H: \\192.168.1.1\%USERNAME%
SYSVOL\test.testdomäne.de


Fällt der Groschen / Eurocent ?????

wie war das mit dem Trapper, der vorher abdrückt, bevor Ihm jemand in (nicht auf) die Flinte pinkelt

Ps³:
Echo off
Ist nicht für "Testscripte"
Bitte warten ..
Mitglied: Iwan
09.07.2008 um 12:13 Uhr
ich kann mir mein Homedir auch vom Server her mappen und habe trotzdem CMD immer mit C:\
mein Profil ist serverbasiert und trotzdem startet CMD auf C:\
welche Groschen/Cent soll denn nun fallen?
Bitte warten ..
Mitglied: 51705
09.07.2008 um 21:58 Uhr
Hi,

eine cmd startet ohne weitere Angabe im %HOMEPATH%. Was du dir 'mappst' ist egal, die Variable gibt den Ausschlag.

Grüße, Steffen
Bitte warten ..
Mitglied: jimmyone
10.07.2008 um 09:28 Uhr
Morjen,

das hätte ich dazu schreiben sollen...
Wenn ich %HOMEPATH% öffne, dann wird im Explorer C:\ geöffnet.

Das hatte ich nämlich schon probiert.
Lediglich die CMD startet auf H. Und das verstehe ich halt nicht.

@Iwan

HKEY_CLASSES_ROOT\Drive\shell\CMD-Prompt\command

Unter dem Ordner shell existiert bei mir kein CMD-Prompt...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
CMD cURL Access Token parsen (2)

Frage von maddig zum Thema Batch & Shell ...

Ubuntu
Kerio Mailserver Startet nicht (5)

Frage von Patrick2017 zum Thema Ubuntu ...

Windows 10
Surface 4 Pro Netzlaufwerk verbinden (4)

Frage von Yannosch zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (27)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (20)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...