Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS-Problem nach Virtualisierung

Frage Microsoft Windows Server

Mitglied: wet-beirat

wet-beirat (Level 1) - Jetzt verbinden

15.02.2010 um 11:14 Uhr, 8541 Aufrufe, 13 Kommentare

Ein W2K-Server, der auch als DC für eine Windows-Domain fungiert, muss aus bestimmten organisatorischen Gründen bestehen bleiben. Im letzten Jahr wurde dieser Server - gegen meinen Rat - mit VMware auf einem Mac-Xserver virtualisiert.

Seit diesem Zeitpunkt erscheint im Log des Dateireplikationsdienstes die untenstehende Fehlermeldung. Und eine bestimmte netzwerkfähige Applikation (RADAR), mit der bis dahin problemlos auf mehreren Clients gleichzeitig gearbeitet werden konnte, lässt sich nur mehr auf 1 Client betreiben - sobald sie auf einer weiteren WS geöffnet wird, funktioniert die Applikation auf beiden WS nur mehr extrem langsam (Startdauer > 15 Minuten).
Die anderen Applikationen laufen ohne Probleme mit guter Performance.

Seit der Virtualisierung wird im Server-Systemprotokoll der NETLOGON-Fehler 5774 protokolliert.
<...
27.01.2010 09:24:19 NETLOGON Fehler Keine 5774 Nicht zutreffend SERVER "Die Registrierung für den DNS-Eintrag ""_kerberos._tcp.domaene.local. 600 IN SRV 0 100 88 server.domaene.local."" ist fehlgeschlagen. Fehler: Der DNS-Name ist nicht vorhanden. ...>

Und im Protokoll des Dateireplikationsdienstes steht:
< ...
06.12.2009 09:06:25 NtFrs Informationen Keine 13501 Nicht zutreffend SERVER Der Dateireplikationsdienst wird gestartet.
06.12.2009 08:56:59 NtFrs Fehler Keine 13559 Nicht zutreffend SERVER "Der Dateireplikationsdienst hat ermittelt, dass ein Replikatstammpfad von ""c:\winnt\sysvol\domain"" in ""c:\winnt\sysvol\domain"" geändert wurde. Falls diese Änderungen absichtlich vorgenommen wurde, muss die Datei NTFRS_CMD_FILE_MOVE_ROOT im neuen Stammpfad neu erstellt werden. Folgendes wurde für diesen Replikatssatz ermittelt: ""DOMAIN SYSTEM VOLUME (SYSVOL SHARE)""

Die Replikatstammpfadänderung erfolgt in zwei Schritten, die durch das Erstellen der Datei NTFRS_CMD_FILE_MOVE_ROOT ausgelöst wird ...>

Auf Event-ID.net fand ich Meldungen, wonach eventuell der DNS-Server des Mac-Hosts mit jenem des W2K-Gastes in Konflikt kommen könnte.

Was bedeutet, der Replikationsstammpfad wurde von ""c:\winnt\sysvol\domain"" auf ""c:\winnt\sysvol\domain"" geändert?

Hat jemand eine Idee, welches Problem hier vorliegt und wie man es lösen kann?

Danke!
Alois
Mitglied: Gilneas
15.02.2010 um 11:46 Uhr
Mir graut da dunkel was. Ich bilde mir ein, dass wir beim virtualisieren unseres PDCs damals ein paar Dinge in Sachen Services und manchen Strukturen vorbereitet haben, um solche Probleme zu vermeiden.
Evtl. finde ich meine Notizen dazu noch...

Beim Virtualisieren ändert sich die MAC-Adresse deines Servers.
Hast du eine Reservierung im DHCP für diese alte MAC Adresse angelegt?

Hast du schon überprüft, ob im DNS tatsächlich kein Eintrag für deinen Server existiert?
Bitte warten ..
Mitglied: datasearch
15.02.2010 um 11:52 Uhr
Zuerst versuche mal die DNS-Probleme zu beheben. Führe bitte "netdiag" und "dcdiag" aus. Hier sollten genauere Informationen zum DNS-Problem stehen. Ich vermute die Anwendung ist langsam, weil das System auf Broadcast-Namensauflösung zurückfällt weil wiederum irgend etwas mit dem DNS nicht stimmt. Dazu passen auch das Verhalten und die Eventlog-Einträge.


Nochwas, Domänencontroller sollte man nicht einfach Clonen. Das gilt auch für P2V Importer diverser Virtualisierungsumgebungen. Dein Rat war goldrichtig. Wenn man so etwas virtualisiert, dann bitte über eine saubere Installation.
Bitte warten ..
Mitglied: wet-beirat
15.02.2010 um 11:55 Uhr
Die Virtualisierung auf dem Xserver hat ein Mac-Anbieter gemacht, der meinem Kunden ziemlich viel Blaues vom Himmel versprach. An meiner Frage kannst du erkennen, dass mein Kunde mich nun gebeten hat, die von diesem Anbieter hinterlassenen Probleme zu lösen

Aber deine Anmerkungen finde ich sehr interessant und werde ich heute Nachmittag gleich mal überprüfen!
Herzlichen Dank!
Bitte warten ..
Mitglied: dog
15.02.2010 um 20:34 Uhr
Vmware Fusion für OS X ist eine Client-Software (Irgendwo zwischen VMware Player und VMware Workstation).
Beim Thema Server-Virtualisierung hat die nichts verloren.
Dafür gibt es Parallels Server und das ist schon eine ganz andere Preisklasse.

Und jetzt die Grundfrage: Läuft die Netzwerkkarte im Bridge-Modus?
Bitte warten ..
Mitglied: Gilneas
15.02.2010 um 21:43 Uhr
Weder VMware Server noch der ESXi und ich vermute der ESX auch nicht bieten die Möglichkeit des Bridge-Modus.
Was hätte das auch für einen Sinn?
Bitte warten ..
Mitglied: dog
15.02.2010 um 21:48 Uhr
Er hat das ganze auf einem Xserve virtualisiert.
Auf dem laufen weder der ESXi, noch der ESX, noch Vmware Server (der übrigens den Bridge,NAT und Host-Only-Modus) kann.

Auf dem Xserve läuft nur VMWare Fusion unter OS X...
Bitte warten ..
Mitglied: Gilneas
15.02.2010 um 22:05 Uhr
Sorry, ich steh scheinbar grade voll am Schlauch. Wo schalte ich am ESXi eine Netzwerkkarte einer VM in den Bridge Modus?
Bitte warten ..
Mitglied: dog
15.02.2010 um 22:11 Uhr
Lies dir doch bitte nochmal meinen Kommentar genau durch

Beim ESXi laufen Karten ausschließlich im Bridge-Modus.
Beim Vmware Server/Vmware Player/Vmware Fusion kannst du Bridge/NAT/Host-Only einstellen.
Bitte warten ..
Mitglied: Gilneas
15.02.2010 um 22:19 Uhr
Okay, danke für die Nachhilfe... jetzt weiß ich was du meinst... das läuft bei mir unter Virtual Network.
Bitte warten ..
Mitglied: datasearch
16.02.2010 um 00:46 Uhr
Die IT ist ein permanenter Lernprozess auf einem riesigen Spielplatz voller bunter Dinge. Kaum entdeckt man etwas neues, lernt man wieder dazu und möchte immer mehr. Weiter so.


@wet-beirat

Hast du schon Ergebnisse von dcdiag?
Bitte warten ..
Mitglied: wet-beirat
09.03.2010 um 18:21 Uhr
Guten Tag,
vorerst nochmals danke für eure Rückmeldungen: Leider bin ich aus gesundheitlichen Gründen außer Gefecht gesetzt, ein Kollege hat mir nachgeschaut und mir die folgenden Ergebnisse mitgenommen:

Offensichtlich ist es ein DNS-Problem: Warum fragt der DC den externen DNS-Server des österr. Gesundheitsnetzes (10.205...) - siehe netdiag?

Danke!

DCDIAG
Doing initial required tests
Testing server: Standardname-des-ersten-Standorts\SERVER
Starting test: Connectivity
SERVER's server GUID DNS name could not be resolved to an
IP address. Check the DNS server, DHCP, server name, etc
Although the Guid DNS name
(524af6f3-fba3-4f23-9635-9958cde0e478._msdcs.domaene.local) couldn't
be resolved, the server name (server.domaene.local) resolved to the IP
address (192.168.0.100) and was pingable. Check that the IP address
is registered correctly with the DNS server.
......................... SERVER failed test Connectivity
Doing primary tests
Testing server: Standardname-des-ersten-Standorts\SERVER
Skipping all tests, because server SERVER is
not responding to directory service requests
Running enterprise tests on : domaene.local
Starting test: Intersite
......................... domaene.local passed test Intersite
Starting test: FsmoCheck
Warning: DcGetDcName(TIME_SERVER) call failed, error 1355
A Time Server could not be located.
The server holding the PDC role is down.
Warning: DcGetDcName(GOOD_TIME_SERVER_PREFERRED) call failed, error 1355
A Good Time Server could not be located.
......................... domaene.local failed test FsmoCheck


NETDIAG
Global results:
Domain membership test . . . . . . : Passed
NetBT transports test. . . . . . . : Passed
List of NetBt transports currently configured:
NetBT_Tcpip_{635E26D3-1BAF-4698-9056-355445917B14}
1 NetBt transport currently configured.

DNS test . . . . . . . . . . . . . : Failed
[WARNING] Cannot find a primary authoritative DNS server for the name
'server.domaene.local.'. [RCODE_NAME_ERROR]
The name 'server.domaene.local.' may not be registered in DNS.
[WARNING] The DNS entries for this DC are not registered correctly on DNS se
rver '10.205.36.194'. Please wait for 30 minutes for DNS server replication.
[WARNING] The DNS entries for this DC are not registered correctly on DNS se
rver '195.3.96.67'. Please wait for 30 minutes for DNS server replication.
[FATAL] No DNS servers have the DNS records for this DC registered.
The command completed successfully


DNS Servers
gina-933443-98-1.ginalan.at IP: 10.205.36.194
IP: 172.17.0.100
server.domaene.local IP: 192.168.0.100
WS01IS01.highway.telekom.at IP: 195.3.96.67
Bitte warten ..
Mitglied: Edi.Pfisterer
10.03.2010 um 20:45 Uhr
Aloha!
obwohl ich in diesem Beitrag nicht angesprochen wurde, meld ich mich jetzt trotzdem zu Wort

gina-933443-98-1.ginalan.at IP: 10.205.36.194
IP: 172.17.0.100
server.domaene.local IP: 192.168.0.100
WS01IS01.highway.telekom.at IP: 195.3.96.67

da ist etwas schwer verkehrt...
ist ja direkt ein Wunder, dass da überhaupt noch was geht

Dein DC muss Deinen internen DNS eingetragen haben.
Wenn dieser 2000er DC selbst der DNS ist (was ich mal vermute), dann muss er sich selbst an der Netzwerkkarte als DNS eingetragen haben.

In der DNS-Konfiguration leitest du dann unbekannte Anfragen an den DNS der telekom weiter

Gib mal bekannt, was Du so in der NIC eingetragen hast, ob meine Vermutung mit dem DNS richtig ist, usw. bzw. wie die gesamte Infrastruktur ausschaut, dann können wir das Problem detaillierter in Angriff nehmen...

lg
Edi
Bitte warten ..
Mitglied: wet-beirat
12.03.2010 um 08:48 Uhr
Danke für deine Antwort; ich hoffe, dass ich heute noch Rückmeldung über die *aktuellen* Einträge bekomme.

Etwas weiß ich allerdings bereits: Der DC (server.domaene.loca) hat der korrekten lokalen DNS eingetragen: 192.168.0.100.

lg, Alois
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Webbrowser
DNS Problem in Browsern - Suche in Adresszeile (5)

Frage von tobivan zum Thema Webbrowser ...

DNS
gelöst Homeserver (Zentyal) und Fritzbox DNS Problem (6)

Frage von CharlyXL zum Thema DNS ...

DNS
gelöst Server 2012 R2 DNs Problem (9)

Frage von dan0ne zum Thema DNS ...

DNS
DNS Problem im VLAN (7)

Frage von momai zum Thema DNS ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...