Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

EXCEL-Formel mit Problem

Frage Microsoft Microsoft Office

Mitglied: MiSt

MiSt (Level 2) - Jetzt verbinden

14.06.2012, aktualisiert 25.06.2012, 3406 Aufrufe, 9 Kommentare

Hallo,
ich habe für eine Zeitermittlung (3 Schichten) folgende Formel verwendet.

=((STUNDE(L2-K2)*60+MINUTE(L2-K2))/60)-D2

L2 = Endzeit
K2 = Startzeit
D2 = Pause (0,5 == eine halbe std.)


Ergebnis: 14:00 bis 22:00 = 8std.
Jetzt zum Problem: 22:00 bis 06:00 = #ZAHL

Wie kann ich das kl. Problem beheben?

Gruß
Michael
Mitglied: LianenSchwinger
14.06.2012, aktualisiert um 08:03 Uhr
Hallo Michael,

die Anzahl der Stunden kannst Du so ermitteln

01.
=STUNDE(WENN(L2<K2;24-ABS(L2-K2);L2-K2))
und mit

01.
=WENN(L2<K2;24-ABS(L2-K2);L2-K2)-D2
bekommst Du die genaue Arbeitszeit abzüglich der Pause im HH.MM-Format.

Gruß Jörg
Bitte warten ..
Mitglied: Nebellicht
14.06.2012 um 11:47 Uhr
... oder und die Zellen als Datum/Zeit formatieren: TT.MM.JJJJ hh:mm
Bitte warten ..
Mitglied: MiSt
14.06.2012 um 13:27 Uhr
Vielen Dank. Funktioniert...

Gruß
Michael
Bitte warten ..
Mitglied: MiSt
25.06.2012 um 15:40 Uhr
es schon doch noch nicht zu funktionieren
wenn ich von 22:10 bis 6:00 arbeite, kommt als ergebniss 7,00std. raus. oder habe ich da was übersehen?
Bitte warten ..
Mitglied: LianenSchwinger
25.06.2012 um 17:24 Uhr
Hallo Michael,

wie sieht denn Deine Formel jetzt genau aus?

Wenn die Zellen D2, K2 und L2 im hh:mm:ss formatiert sind, dann gibt die untere Formel die genau Zeit aus.

01.
=WENN(L2<K2;24-ABS(L2-K2);L2-K2)-D2
Willst Du nur die Stunden oder Minuten dann einfach =Stunde(...) bzw. =Minuten(...)

Gruß Jörg
Bitte warten ..
Mitglied: MiSt
02.07.2012 um 15:36 Uhr
Hallo,
ermal danke für deine Geduld & Zeit.

Irgendwie blicke ich da nicht durch.

Ich habe mal eine neue Datei aufgemacht.
A1: 22:15:00
B1: 06:00:00
beide als hh:mm:ss formartiert.

C1 bringt das Ergebniss: 23,333
mit dieser Formel: =WENN(B1<A1;24-ABS(B1-A1);B1-A1)
Wie muss ich C1 formatieren. Ich habe div. probiert. Es sollte aber 7,45 raus kommen.
Bei =stunde() kommt 8 und bei =minute() kommt 45 raus.

Was mache ich falsch?
Bitte warten ..
Mitglied: 76109
02.07.2012 um 16:48 Uhr
Hallo MiSt!

So, sollte es gehen:
=WENN(B1<A1;B1-(A1-24);B1-A1)

Gruß Dieter
Bitte warten ..
Mitglied: MiSt
02.07.2012 um 17:02 Uhr
Hallo Dieter,
ja, das funktioniert. Danke...
Kann ich das Ergeniss Dezimal ausgeben lassen? --> so, das nicht 7:45 rauskommt, sondern 7,75. Mit der Zellenformatierung geht es nicht.
Bitte warten ..
Mitglied: 76109
02.07.2012, aktualisiert um 18:35 Uhr
Hallo MiSt!

Wenn Du's in Dezimal haben willst, dann wird es etwas komplizierter, weil in dem Fall nicht einfach 24 subtrahiert oder addiert werden darf. Der Grund dafür ist, dass das Datum und die Uhrzeit in einer Kommazahl ausgedrückt wird (Datum links vom Komma und Zeit rechts vom Komma. D.h. damit der Zeitwert zum umrechnen in eine Dezimalzahl geeignet ist, muss das Datum zur Berechnung mit einbezogen werden, also kleine Zahl in Spalte B dann mit Datum 'Heute() + 1 Tag...

Mit dieser Formel wird die Differenz im Zeitformat angegeben:
=WENN(B1<A1;(HEUTE()+1+B1)-(HEUTE()+A1);B1-A1)
und mit dieser Formel im Dezimalformat:
=WENN(B1<A1;(HEUTE()+1+B1)-(HEUTE()+A1);B1-A1)*24

Gruß Dieter
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Microsoft Office
gelöst Excel-Formel oder VBA (7)

Frage von nicki01 zum Thema Microsoft Office ...

Microsoft Office
gelöst In Excel das Datum aus einer Registerlasche in einer Formel verwenden (7)

Frage von michael1306 zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel: Matirx mit Formel automatisch befüllen (5)

Frage von sims zum Thema Microsoft Office ...

Microsoft Office
Excel verliert die Formel, behält aber den Wert (10)

Frage von derausgroenloh zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (17)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...