Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

EXCEL-Formel mit Problem

Frage Microsoft Microsoft Office

Mitglied: MiSt

MiSt (Level 2) - Jetzt verbinden

14.06.2012, aktualisiert 25.06.2012, 3461 Aufrufe, 9 Kommentare

Hallo,
ich habe für eine Zeitermittlung (3 Schichten) folgende Formel verwendet.

=((STUNDE(L2-K2)*60+MINUTE(L2-K2))/60)-D2

L2 = Endzeit
K2 = Startzeit
D2 = Pause (0,5 == eine halbe std.)


Ergebnis: 14:00 bis 22:00 = 8std.
Jetzt zum Problem: 22:00 bis 06:00 = #ZAHL

Wie kann ich das kl. Problem beheben?

Gruß
Michael
Mitglied: LianenSchwinger
14.06.2012, aktualisiert um 08:03 Uhr
Hallo Michael,

die Anzahl der Stunden kannst Du so ermitteln

01.
=STUNDE(WENN(L2<K2;24-ABS(L2-K2);L2-K2))
und mit

01.
=WENN(L2<K2;24-ABS(L2-K2);L2-K2)-D2
bekommst Du die genaue Arbeitszeit abzüglich der Pause im HH.MM-Format.

Gruß Jörg
Bitte warten ..
Mitglied: Nebellicht
14.06.2012 um 11:47 Uhr
... oder und die Zellen als Datum/Zeit formatieren: TT.MM.JJJJ hh:mm
Bitte warten ..
Mitglied: MiSt
14.06.2012 um 13:27 Uhr
Vielen Dank. Funktioniert...

Gruß
Michael
Bitte warten ..
Mitglied: MiSt
25.06.2012 um 15:40 Uhr
es schon doch noch nicht zu funktionieren
wenn ich von 22:10 bis 6:00 arbeite, kommt als ergebniss 7,00std. raus. oder habe ich da was übersehen?
Bitte warten ..
Mitglied: LianenSchwinger
25.06.2012 um 17:24 Uhr
Hallo Michael,

wie sieht denn Deine Formel jetzt genau aus?

Wenn die Zellen D2, K2 und L2 im hh:mm:ss formatiert sind, dann gibt die untere Formel die genau Zeit aus.

01.
=WENN(L2<K2;24-ABS(L2-K2);L2-K2)-D2
Willst Du nur die Stunden oder Minuten dann einfach =Stunde(...) bzw. =Minuten(...)

Gruß Jörg
Bitte warten ..
Mitglied: MiSt
02.07.2012 um 15:36 Uhr
Hallo,
ermal danke für deine Geduld & Zeit.

Irgendwie blicke ich da nicht durch.

Ich habe mal eine neue Datei aufgemacht.
A1: 22:15:00
B1: 06:00:00
beide als hh:mm:ss formartiert.

C1 bringt das Ergebniss: 23,333
mit dieser Formel: =WENN(B1<A1;24-ABS(B1-A1);B1-A1)
Wie muss ich C1 formatieren. Ich habe div. probiert. Es sollte aber 7,45 raus kommen.
Bei =stunde() kommt 8 und bei =minute() kommt 45 raus.

Was mache ich falsch?
Bitte warten ..
Mitglied: 76109
02.07.2012 um 16:48 Uhr
Hallo MiSt!

So, sollte es gehen:
=WENN(B1<A1;B1-(A1-24);B1-A1)

Gruß Dieter
Bitte warten ..
Mitglied: MiSt
02.07.2012 um 17:02 Uhr
Hallo Dieter,
ja, das funktioniert. Danke...
Kann ich das Ergeniss Dezimal ausgeben lassen? --> so, das nicht 7:45 rauskommt, sondern 7,75. Mit der Zellenformatierung geht es nicht.
Bitte warten ..
Mitglied: 76109
02.07.2012, aktualisiert um 18:35 Uhr
Hallo MiSt!

Wenn Du's in Dezimal haben willst, dann wird es etwas komplizierter, weil in dem Fall nicht einfach 24 subtrahiert oder addiert werden darf. Der Grund dafür ist, dass das Datum und die Uhrzeit in einer Kommazahl ausgedrückt wird (Datum links vom Komma und Zeit rechts vom Komma. D.h. damit der Zeitwert zum umrechnen in eine Dezimalzahl geeignet ist, muss das Datum zur Berechnung mit einbezogen werden, also kleine Zahl in Spalte B dann mit Datum 'Heute() + 1 Tag...

Mit dieser Formel wird die Differenz im Zeitformat angegeben:
=WENN(B1<A1;(HEUTE()+1+B1)-(HEUTE()+A1);B1-A1)
und mit dieser Formel im Dezimalformat:
=WENN(B1<A1;(HEUTE()+1+B1)-(HEUTE()+A1);B1-A1)*24

Gruß Dieter
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel-Formel-Problem
gelöst Frage von MiStMicrosoft Office2 Kommentare

Guten Morgen Excel-Interessierte, ich sitzte gerade vor einem kleinem Excel-Problem. Ich hoffe mir kann jemand helfen. Hier mein Problem: ...

Microsoft Office
Excel Formel mit Raute
gelöst Frage von Florian86Microsoft Office2 Kommentare

Hallo, ich habe folgende Formel im Netz gefunden =HYPERLINK("#A"&VERGLEICH(B1;A:A;);"Gehe zu: "&B1) Die Formel an sich ist mir Klar aber ...

VB for Applications
Excel VBA Formel "WENN" einfügen
gelöst Frage von chef1568VB for Applications2 Kommentare

Hallo zusammen, ich möchte per Excel-Makro folgende Formel eintragen: EXCEL: VBA: Leider bekomme ich hier immer einen anwendungsrelevanten Fehler ...

Microsoft Office
Excel formel vereinfachen Mittelwert wenn
Frage von neueradmuserMicrosoft Office1 Kommentar

hi, ich habe aktuell diese formel: =MITTELWERT(WENN((A2:A10)=HEUTE();(B2:B10));(WENN((A2:A10)=HEUTE()-1;B2:B10));(WENN((A2:A10)=HEUTE()-2;B2:B10));(WENN((A2:A10)=HEUTE()-3;B2:B10));(WENN((A2:A10)=HEUTE()-4;B2:B10));(WENN((A2:A10)=HEUTE()-5;B2:B10));(WENN((A2:A10)=HEUTE()-6;B2:B10));(WENN((A2:A10)=HEUTE()-7;B2:B10))) zerlegt also: =MITTELWERT (WENN((A2:A10)=HEUTE();(B2:B10)); (WENN((A2:A10)=HEUTE()-1;B2:B10)); (WENN((A2:A10)=HEUTE()-2;B2:B10)); (WENN((A2:A10)=HEUTE()-3;B2:B10)); (WENN((A2:A10)=HEUTE()-4;B2:B10)); (WENN((A2:A10)=HEUTE()-5;B2:B10)); (WENN((A2:A10)=HEUTE()-6;B2:B10)); (WENN((A2:A10)=HEUTE()-7;B2:B10)) ) ...

Neue Wissensbeiträge
Microsoft

Update für AMD CPU (Spectre und Meltdown Lücke)

Information von sabines vor 56 SekundenMicrosoft

Wegen Problemen (BOSD, nicht startende PCs) wurde das Update KB4056897 und KB4056894 für AMD CPUs zurückgezogen. Dieses Update scheint ...

Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 12 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 19 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 21 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...