Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Klasse A Netz mit DSL Router verbinden

Frage Netzwerke Router & Routing

Mitglied: renald

renald (Level 1) - Jetzt verbinden

13.05.2006, aktualisiert 16.05.2006, 6826 Aufrufe, 10 Kommentare

Hallo,

folgende Sachlage:

Ein vorhandenes Netz mit Server, Switch und 11 Clients soll mit einem DSL Router ins Internet
gebarcht werden.

Die ipconfig auf einem Client sagt folgendes:

DHCP aktiviert ja
Autokonfiguration aktiviert ja
IP-Adresse 10.4.2.110
Subnetzmaske 255.255.255.0
Standardgateway 10.4.2.1
DHCP-Server 10.4.2.201
DNS-Server 10.4.2.201
Primary WINS-Server 10.4.2.201


in dieses Netz soll nun ein DSL Router integriert werden damit alle Clients auf das Internet
zugreifen können.
Wie muss ich den DSL Router oder den Server konfigurieren damit das funktiontiert ohne das das bestehende Netz beeinträchtig wird.

Für eine rege Anteilnahme bin ich sehr dankbar, muss es schnell gebacken kriegen

Danke im vorraus...

Gruss Renald
Mitglied: superboh
14.05.2006 um 00:31 Uhr
Hi,

wenn Du die Subnetmaske 255.255.255.0 hast, ist es ein CLASS C Netz. Ein Class A Netz hat 255.0.0.0

Gib dem Router eine noch freie Adresse die nicht im DHCP-Range des DHCP-Servers liegt.
Diese IP-Adresse trägtst Du dann am Server als Gateway ein und auch in den DHCP-Einstellungen. Die Clients bekommen diese dann automatisch.
Der DNS-Server auf der Server muss so konfiguriert werden, dass er Anfragen die er nicht selber auflösen kann, an den Router weiterleitet (auf die IP des Routers), siehe Register Weiterleitungen wenn es ein Win-DNS-Server ist.

Was ist denn die IP 10.4.2.1 (das bisherige Standard-Gateway) für ein Gerät?

Gruß,
Thomas
Bitte warten ..
Mitglied: elCativo
14.05.2006 um 08:48 Uhr
Dein Problem dürfte werden das dein Netz kein reinrassiges A Netz ist sondern ein Subnet wg der Subnetmaske.Da dürfte es schon problematisch werden einen Hardwarerouter zu finden der so was unterstützt und sich auf eine solche Lanadresse einstellen lässt.Die preiswerten Geräte können das in der Regel nicht sondern lassen sich nur auf Standartnetzadressen einstellen.
Ansonsten kann ich mich nur superboh anschliessen was die Konfiguration angeht.
Bitte warten ..
Mitglied: Rafiki
14.05.2006 um 10:22 Uhr
Hey Renald,

bist du dir sicher dass du das darfst?
Das Netzwerk ist anscheinend bereits eingerichtet mit Server und DNS. Versuchst du gerade eine Hintertür in das Netzwerk einzubauen? Frag doch mal euren Administrator!

Wen der DSL Router dann die Internetverbindung aufbaut, wie sollen die Clients dann in das Internet? Soll auf dem Server ein Proxy (mit Virusfilter) laufen oder gehen die Clients direkt raus? Für eine direkte Verbindung musst du den DNS Dienst auf dem Server noch anpassen. Auch dafür gilt: "Frag doch mal euren Administrator!"

Gruß Rafiki
Bitte warten ..
Mitglied: MagicM
14.05.2006 um 11:25 Uhr
Nö nö, kein Problem. Hab auch ein A-Netz mit C-Netz Subnet; das geht mit jedem Marken-Netzwerkdevice.
Bitte warten ..
Mitglied: renald
14.05.2006 um 13:39 Uhr
Vielen Dank erstmal für euer Interesse an meinem Fall.

Nun eine Erklärung zu diesem Netzwerk.
Es handelt sich ein Produktiv Netzwerk welches nicht von uns eingerichtet wurde und
um welches wir uns nun kümmern sollen, weil der Betreiber des Netzes nicht zufrieden war
mit Service des Errichters.
Der neue Admin sind also wir.
Ich habe schon alle vorhandenen Unterlagen über das Netzwerk angefordert.

Nun zu euren Antworten:

Nein, ich möchte keine Hintertür einbauen, die Rechner sollen schlicht und einfach (und Sicher) ins Internet gebracht werden.

Der Betrieb des vorhanden Netzes soll auf keinen Fall gestört werden.

Welches Gerät sich hinter der IP 10.4.2.1 (Gateway) verbirgt werde ich morgen herausfinden.
Das hat mich ja auch verwirrt. ein Netz ohne Internet aber mit Gateway ?

Auch welcher Server dort läuft, kann ich auch erst am Montag sagen.

Danke für den Hinweis mit dem Klasse C Netz. War wohl etwas fertig und hab das glatt übersehen mit der Subnetzmaske.

Alle Clients werden dann direkt über den DSL Router aufs Internet zugreifen. Auf dem Router ist die Firewall aktiviert und alle Clients werden durch Gdata Antivir-Server mit einem Virenscanner versorgt.

So soll es in der Realität aussehen. Und ich sitz nun hier mit einem 35.- ? Netgear Router und frag mich, ob das mit der Kiste überhaupt geht.

P.S. Werde den sowieso ersetzen weil ich einen Router mit DSL-Modem brauche.

Gruß Renald
Bitte warten ..
Mitglied: Rafiki
14.05.2006 um 22:02 Uhr
Hallo Renald,

hier die mutmaßliche Konfiguration für Montag.
Der Server hat DNS und DHCP dienst laufen. Server IP 10.4.2.110
Gateway IP ist 10.4.2.1

Der neue DSL Router von Netgear wird das Gateway ersetzen. Ping test auf das Gateway, dann das Kabel von dem Gateway abziehen und mit ping bestätigen dass man das richtige Kabel abgezogen hat.

Der Netgear Router bekommt intern die IP 10.4.2.1 und wird mit dem Netzwerk verbunden. Dank Auto Uplink geht das mit jedem Kabel, auch ohne CrossOver. (Netgear DG632 und alle neuen Modele.)

Der DNS Dienst auf dem Server ist primär für seine Zone (Domain) zuständig. Alle DNS Anfragen von den Client PCs werden an den Server geschickt. Der DNS von dem ISP ist für den Rest der Welt zuständig und wird unter Forwarders eingetragen. Aber nur der DNS Server fragt den ISP. Der Netgear Router wird am besten übergangen. Dafür im DHCP Dienst auf dem Server unter den Optionen als DNS Server nur der Server eingetragen, nicht der Netgear Router.

Beachte bitte auch die ganz ähnliche Konfiguration von Hermann, dort habe ich auch eine erste Diagnose mit nslookup beschrieben.
DNS-Probleme unter Windows

Wenn das bisherige Gateway auch eine Einwahlmöglichkeit anbietet, z.B. Router mit ISDN Anschluss, dann muss das Gateway hinterher umkonfiguriert werden. Ihr solltet prüfen, und mit dem Auftraggeber abstimmen, ob der ehemalige Administrator sich über dieses Gerät immer noch einwählen kann. Je nach Gerät macht es Sinn die gesamte Konfiguration zu löschen und neue Passworte für alle Mitarbeiter zu vergeben. Das hängt natürlich davon ab was der Auftraggeber so erzählt und wünscht.

Gruß Rafiki
Bitte warten ..
Mitglied: renald
14.05.2006 um 22:34 Uhr
Vielen Dank für die sachkundige Hilfestellung.
Werde am Montag weiter posten was mit "meinem" Netz los ist. Aber so wie ihr das erklärt ist es schon richtig und so sollte es auch funzen.
Also noch einen frohen Abend und Grüße von
Renald
Bitte warten ..
Mitglied: aqui
15.05.2006 um 10:37 Uhr
Mmmmhh, das ist aber etwas gefährlich gleich die Gateway Adresse zu ersetzen. Es kann hier ja immer nur gemutmasst werden wenn die Topologie des Netzes nicht bekannt ist aber gesetzt den Fall du befolgst die Anweisung von oben aber hinter der 10.4.2.1 befindet sich ein Router der Aussenstellen oder was auch immer an das Netzwerk anbindet, oder DMZ, oder der Internetzugang ist in einem anderen Segment des 10er Subnetzes und und und..... Damit würdest du gandenlos so etwas killen und solche Links zum Stillstand bringen.
Einfach eine IP Adresse zu ersetzen ist immer gefährlich wenn man die Netzwerk Topologie nicht kennt.
Gut, erster Schritt wäre ein Ping um überhaupt erstmal rauszubekommen ob hinter dieser Adresse noch etwas "lebt". Ist das nicht der Fall wird der o.a. Tip wohl funktionieren und du kannst den Internet Zugang so recht einfach realisieren indem du den neuen Router mit entspr. Konfig ins Netz hängst und ggf. den DHCP Server anpasst (DNS).
Lebt nochwas hinter der Adresse musst du rausfinden was das ist (Layer 3 Switch, Router, FW oder was auch immer). Lässt die Adresse sich pingen, kannst du über die MAC Adresse (arp -a) herausbekommen wer der Hersteller des Gerätes ist falls du es nicht weisst
http://coffer.com/mac_find/
um überhaupt erstmal grob einzuschätzen was das ist. Ist dies ein Router oder Layer-3 Switch muss du erstmal sehen wo IPseitig was hingeht also dir einen Layer-3 Überblick über das Netz verschaffen. Wenn jemand 10er RFC 1918 Adressen subnettet denkt er sich meist etwas dabei....
Wenn wirklich kein anderer Internet Zugang besteht, diese Gateway IP Adresse aber existiert, kannst du den Router trotzdem ins Netz hängen mit einer FREIEN Adresse ausserhalb der DHCP Range und kannst dann auf diesem ursprünglichen Router eine default Route auf die Adresse des neuen Routers eintragen. Den DNS Server Eintrag im DHCP Server solltest du dann ebenfalls auf die Adresse des Routers ändern (Der hat meist einen DNS Proxy Cache an Bord !)

Bei fast allen Consumer Routern kannst du aber die LAN Adresse auf Subnetze einstellen. D.h. die haben so gut wie alle eine variable Maskeneinstellung sonst wären sie in solchen Netzwerken nicht zu gebrauchen ! Den DHCP Server musst du hier aber vorher abschalten, damit es nicht zu Konflikten mit dem bestehenden DHCP Server im Netzwerk kommt !
Bitte warten ..
Mitglied: renald
15.05.2006 um 23:44 Uhr
Ja Hallo erstmal,

Vielen Dank für eure interessanten Vorschläge und Meinungen.

Also heute ist ja Montag und ich habe natürlich sofort die 10.4.2.1 angepingt und musste feststellen das keine Antwort kommt. Auch war der Abteilungsleiterin kein Zugang über ISDN oder Analog bekannt.
Also den Router auf die 10.4.2.1 eingestellt und DHCP aus.
Mit dem Laptop geprüft ob er auf die IP hört, alles klar.
Router und Laptop an den Switch gesteckt und mit ipconfig -renew die IP Einstellungen
angepasst. Dann ein Versuch auf mein neues Gateway zuzugreifen, das Webinterface des
Routers startet wie gewohnt.

Vorher hatte ich mir natürlich auch das gesamte Netz untersucht und hatte dabei festgestellt das die IPCONFIG auf dem Server schon das Gateway mit der 10.4.2.1 und auch als 2. DNS eingetragen hatte und so DNS Anfragen die der Server nicht auflösen kann automatisch zum Router weitergeleitet werden und dort beantwortet werden.

In den DHCP und DNS Einstellungen habe ich vorerst nichts geändert.
Und die Firewall des Routers blockt auch sauber alle Ports (http://scan.sygatetech.com)

Bis jetzt will nur das Startcenter von T-online auf einem Rechner keine richtige Verbindung
aufbauen und es startet immer einen DFÜ-Einwahl Dialog obwohl die Kiste ja schon längst online ist und auch der IE online ist und auch der T-online Browser erfolgreich eine Webseite laden kann.
Die Änderung der Einstellungen auf LAN brachte auch nichts.
Wenn ich auf Verbinden klicke, bin ich dann verbunden, aber ohne IP !!
Probleme mit der T-online Software kenne ich schon seit T-online 3.X , alles ist online, nur die Software von T-O merkts nicht so richtig...HHMMM
Manche Dinge ändern sich wohl nie...
Auch der Assistent half nicht richtig weiter. Er analysierte mir, das alles im grünen Bereich ist und ich online bin, er übernimmt aber keine Einstellungen so das alles geht.
Also muss irgendwo noch was falsch eingestellt sein.

Nun muss der Virenscanner auf alle Clients rauf und ein neuer Netzdrucker ran und weiter gehts. Werde mein neues Gateway und den Rest des Netzes im Auge behalten und auch
den Server beobachten.
Es ist übrigens ein IBM E-Server mit Windows 2003 Server Standard Edition drauf.

Also ich dachte mir schon bei der Fragestellung das es so schwer nicht sein kann, aber ich wollte alles absichern und dabei habt ihr mir alle sehr sehr geholfen.
Eigentlich sollte ich es aus dem Hemdärmel schütteln als LPIC 2 Anwärter. Für die die es nicht kennen: Das Linux Professional Institute zertifiziert Linux Admins

So, genug gelabert, muss früh raus,
Gute Nacht und einen Supertag wünscht

Renald
Bitte warten ..
Mitglied: aqui
16.05.2006 um 20:54 Uhr
Als Firefox (www.mozilla.com) Benutzer bin ich nicht ganz so sattelfest mit dem IE, meine aber das in der Systemsteuerung -> Internetoptionen -> Verbindungen du ihm das abgewöhnen kannst das er immer automatisch eine DFÜ Verbindung aktiviert.
Die T-Online SW kannst du ja nun auch beruhigt über die Systemsteuerung entfernen....
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Linux Netzwerk
OpenVPN, zwei OpenWRT Router verbinden und VLAN durchs VPN leiten (6)

Frage von sharbich zum Thema Linux Netzwerk ...

Router & Routing
gelöst Proxmox Netzwerk: LAN Netz ohne Router (2)

Frage von sebastian2608 zum Thema Router & Routing ...

DSL, VDSL
DSL-Störung im Telekom-Netz (6)

Link von sabines zum Thema DSL, VDSL ...

Netzwerkmanagement
gelöst Gäste WLAN vom eigenen Netz trennen mit einem eigenen Port am Router? (9)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...