Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Microsoft Virtual PC mit Linux - Floppy kann nicht eingebunden werden

Frage Linux

Mitglied: Erix83

Erix83 (Level 1) - Jetzt verbinden

08.01.2010, aktualisiert 11.01.2010, 7624 Aufrufe, 7 Kommentare

Hallo zusammen,

ich habe da folgendes Problem. Auf meinem MS Virtual PC habe ich eine vhd-Datei mit Linux drauf geladen. Es funktioniert auch alles wunderbar, bis auf das Floppy.

Wenn ich das einbinden möchte erscheint immer folgende Fehlermeldung (siehe auch Bild): Laufwerk konnte nicht eingebunden werden. Die Fehlermeldung war: mount: /dev/fd0 ist kein gültiges blockorientiertes Gerät.

Da ich auf das FDD angewiesen bin, wäre ich für Ideen oder Lösungen sehr dankbar.

Viele Grüße
Erix

PS: falls jemand einen Vorschlag hat oder weiß, wie man diesen Fehler beheben kann, bitte die Lösungsschritte lieber etwas ausführlicher. Ich hatte noch nicht viel mit Linux zu tun.
Mitglied: TheDarkLord
08.01.2010 um 19:38 Uhr
Hallo

ähm, welches Bild genau meinst Du? Hier ist keins zu sehen... vergessen anzuhängen?

Linuxtechnisch kann es sein, dass das Diskettenlaufwerk nicht unter /dev/fd0 liegt, das müsste man mal recherchieren...
Ich kenne mich aber mit MS Virtual PC nicht so aus, weiss also nicht genau, wie das FDD virtualisiert wird.
Probier doch analog mal VirtualBox aus und schau, ob da das FDD richtig erkannt und eingebunden wird.
Ach ja und bitte nochmal das Bild anhängen

Gruß Dark
Bitte warten ..
Mitglied: Erix83
11.01.2010 um 09:31 Uhr
Hi,

so, jetzt nochmal mit Bild (hoffe es klappt).
b438caa12bd0f1ee2aadef5bcb65a259 - Klicke auf das Bild, um es zu vergrößern

VirtualBox werde ich gleich mal ausprobieren...soll ja auch vhd-Dateien mounten können

Übrigens, wenn ich mit Virtual PC eine WinXP lade, dann klappt das mit der Integration aller Laufwerke.

Ich hoffe, es weiß noch jemand rat.

Vielen Dank
Erix
Bitte warten ..
Mitglied: TheDarkLord
11.01.2010 um 09:53 Uhr
Hm ja dann wirds nicht an Virtual PC liegen, sondern wohl eher am Linux direkt.
Wenn ich "vhd-Datei" richtig verstehe, ist das ein fertiges Image für Virtual PC richtig? Da kann es natürlich gut sein, dass der ersteller das Floppy an anderer Stelle "sitzen" hatte als es bei Dir der Fall ist. Per Ferndiagnose ist es aber natürlich ziemlich kompliziert, da jetzt genaueres herauszufinden. Du kommst nicht zufällig aus FFM oder? xD

Hast Du Unterstützung für das Diskettenlaufwerk direkt in den Kernel gelinkt? Falls nicht mußt Du das Modul laden (d.h. floppy.ko). Passiert z.B. wenn der Ersteller des Images gar kein FDD hatte, dann ist beim Kernel kompilieren natürlich auch kein FDD-Modul geladen
"lsmod |grep floppy" zeigt Dir, ob das Kernelmodul geladen ist. Wenn nicht, als Root "modprobe -v floppy" eingeben, um es zu laden.
Dann am besten noch mit root-Rechten die /etc/modules editieren und da das Modul eintragen (ein Modul pro Zeile!), um es beim Systemstart nächstes mal automatisch laden zu lassen.

Wenn das alles schon der Fall ist, mal ne ganz doofe Frage: Du hattest aber schon eine funktionstüchtige Diskette eingelegt vor dem mounten oder?
Boote auch mal Linux und gib in der Konsole mal "cat /var/log/messages | grep Floppy " ein.
Da müsste dann das gültige /dev stehen und wir können sicher sein, dass es auch /dev/fd0 ist.

Gruß Dark
Bitte warten ..
Mitglied: Erix83
11.01.2010 um 10:18 Uhr
ja, hatte es mit diskette und ohne probiert...dürfte zwar ne windowsformatierung drauf sein, aber sowas wie ein formatieren befehl kann er mir ja immer noch anzeigen oder nicht?

Per Virtual Box funktioniert die Floppyeinbindung...allerdings startet nachdem das System hochgefahren ist keine grafische Oberfläche, alles was kommt ist die Konsole...

Gibts da bei Linux noch einen extra Befehl dafür, dass er das lädt, oder muss man in den Einstellungen nur einen Haken irgendwo setzen? Mit Virtual PC klappts ohne Probleme. Nachdem der Rechner fertig gestartet hat kommt eine grafische Benutzeroberfläche, wo man anch der Anmeldung (für WinUser gewohnten) zur Arbeitsplatzansicht kommt.

VG
Erix
Bitte warten ..
Mitglied: TheDarkLord
11.01.2010 um 10:33 Uhr
Ja das müsste bei VirtualBox auch klappen. Es könnte sein, dass die Grafikeinstellungen des Images für VirtualBox irgendwie quer sind. Wenn die Desktop-Umgebung nicht geladen wird, ist das bei Linux ein typisches Zeichen für eine verstellte X-Einstellung.
Welches Linux ist denn das?

Vielleicht muss der X-Server auch mal neu konfiguriert werden, weil bei VirtualBox u.U. eine "andere Grafikkarte" emuliert wird.

Je nach Linux als root mal folgendes eingaben:
"XF86config" oder
"dpkg-reconfigure xserver-xorg"

Ich hatte das auf jeden Fall mal bei Kubuntu, dass ich an der xorg.conf rumgespielt hatte, um was zu testen und nach nem Neustart wurde KDE nicht mehr geladen und er blieb in der Konsole. Ich hab dann "sudo dpkg-reconfigure xserver-xorg" eingegeben und danach gings wieder, weil die xorg.conf mit Einstellungen neu geschrieben wurde, welche auch funktionieren

Zitat von Erix83:
Gibts da bei Linux noch einen extra Befehl dafür, dass er das lädt, oder muss man in den Einstellungen nur einen Haken
irgendwo setzen?

Wenn Du z.B. Kubuntu hast, kannst Du in der Konsole mit "/etc/init.d/kdm stop" den Displaymanager anhalten und genauso auch mit "/etc/init.d/kdm start" wieder hochfahren, um wieder nen "Desktop" zu haben. Aber wenn er beim starten nicht von alleine den Displamanager hochfährt, ist irgendwas falsch konfiguriert!
Schau Dir vielleicht mal die Ausgabe von "dmesg" an, evtl. steht da was, warum der Displaymanager nicht geladen wurde...

Gruß Dark
Bitte warten ..
Mitglied: Erix83
11.01.2010 um 11:45 Uhr
so....ich habe das mal alles ausprobiert (natürlich ohne Erfolg)...habe auch ein paar Screenies gemacht:

Systemstart:
198bf43afb051260e592354c1ddee123 - Klicke auf das Bild, um es zu vergrößern

Auswahl:
f22ff472dc73cfc5290aa7bac2f63e80 - Klicke auf das Bild, um es zu vergrößern

Befehlseingabe:
4956644a2ff8edf6c561f95f4c47a3e7 - Klicke auf das Bild, um es zu vergrößern

ich hoffe, dass hilft dir weiter. Ich kann dir nicht einmal genau sagen, was das jetzt für eine Linuxversion ist, aber aufgrund der Grafik der Oberfläche (aus Virtual PC) würde ich sagen, eine "etwas" ältere...

So sieht es eigentlich aus...
526037fd7ef41d43cd3d66a77410785f - Klicke auf das Bild, um es zu vergrößern

6ac159fbc950e7d2edd8ad10f117edbd - Klicke auf das Bild, um es zu vergrößern

Bilder sagen ja bekanntlich mehr als 1000 Worte...hoffe daher, dass ich dir zumindest eine Kleine Vorstellung von dem hier geben konnte^^
Bitte warten ..
Mitglied: TheDarkLord
11.01.2010 um 12:03 Uhr
Wenn die Konsole da ist, logg dich mal als "root" ein und gib dann "dmesg > logdatei" ein.
Wahrscheinlich hast Du keinen Zugriff vom Host-PC auf die VM, also dann vielleicht die logdatei seitenweise mit Screenshots hier posten. Ich weiss nicht, welcher Editor bei Suse standardmäßig installiert ist, "vi" müsste es aber geben - ich hoffe, Du kennst Dich mit der Bedienung von "vi" aus, ich komme mit dem nicht zurecht xD

Ausserdem würd mich der Displaymanager interessieren, also mal (als root eingeloggt) folgendes eingeben: /etc/init.d/TABTAB (natürlich nicht ausschreiben sondern nach dem / zweimal auf tab klicken, dann wird alles angezeigt, was in init.d/ liegt - diese Ausgabe auch mal "fotografieren", könnte auch mehrere Seiten lang werden.

Dann wieder hier posten ;)

Ach ja, falls Du aus FFM kommst, kann ich Dir vielleicht persönlich helfen...

Gruß Dark


Edit: Hab Dir ne PM geschrieben
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...