Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Remote Installation Service - Untersch. Hardware

Frage Sonstige Systeme

Mitglied: GaDgeT

GaDgeT (Level 1) - Jetzt verbinden

09.01.2008, aktualisiert 15.01.2008, 4115 Aufrufe, 9 Kommentare

Hallo!

Ich habe auf einem Windows 2003 Server den RIS Dienst installiert. Nun kann ich per PXE booten und ein Betriebssystem auswählen und installieren.

Bisher habe ich das für einen PC-Typ eingerichtet.

Neben dem I386 Verzeichnis habe ich noch ein $oem$ Verzeichnis, in welchem ich die Treiber und zusätzlichen Programme reingeschoben habe.

Die Treiberordner habe ich außerdem in der sif Datei unter "OEMPnPDrivers" angegeben.
Den Treiber für die Netzwerkkarte habe ich zusätzlich ins I386 Verzeichnis geschoben.

Nun meine Frage:
Wie kann ich das ganze nun für einen weiteren Rechnertyp einrichten?

Ich will damit sagen, das die Treiber, die ich in dem OEM Ordner gepackt habe, für einen weiteren Rechner nicht zutreffen, sondern andere Treiber eingefügt werden müssen.

Muss ich nun für jeden Rechnertyp ein eigenes Flat Image anlegen? Oder kann ich irgendwie den Inhalt des OEM Ordners (und damit der Treiber) anderweitig ändern?

Muss ich dann im Bootmenü neben dem System auch immer angeben, für welchen Rechnertyp es gedacht ist?

Wie löst ihr das Problem mit den unterschiedlichen Treibern?


Danke und Gruß
Mitglied: Dani
09.01.2008 um 19:09 Uhr
Abend,
das kommt drauf an, wie viele unterschiedliche Rechnertypen du hast. Je nachdem, würde ich extra Images anlegen bzw. alle Treiber in eines packen. Grenzwert ist 3-5 unterschiedliche Typen.


Grüße
Dani
Bitte warten ..
Mitglied: GaDgeT
10.01.2008 um 10:16 Uhr
du meinst das ich gleich alle Treiber in den einen OEM Ordner packe?

Gruß
Bitte warten ..
Mitglied: Dani
11.01.2008 um 15:19 Uhr
Nene, da habe ich mich falsch ausgedrückt!

Beispiel:
01.
+$OEM$ 
02.
++$1 
03.
+++Drivers 
04.
++++rechnertyp1 
05.
+++++lan-intel 
06.
+++++gk-ati 
07.
++++rechnertyp2 
08.
+++++lan-intel 
09.
+++++gk-ati 
10.
....
Diese Pfadstruktur musst du natürlich in die .sif-Datei noch aufnehmen, Stichwort: Batch.


Grüße
Dani
Bitte warten ..
Mitglied: GaDgeT
12.01.2008 um 12:20 Uhr
Hallo!

Tut mir leid, aber noch kann ich dir nicht folgen.

Also die Ordnerstruktur ist mir klar, aber wie du angesprochen hast, muss ich ja noch den Pfad unter OEMPnPDriversPath angeben (abhängig davon, welcher Rechnertyp gerade den RIS benutzt)

Wie soll das mit einer Batch Datei funktionieren?
Und wo muss die liegen, damit sich ausgeführt wird?
Woher erkennt die Batch, welcher Rechnertyp gerade gefragt ist?

Das verstehe ich noch nicht!

Danke und Gruß
Bitte warten ..
Mitglied: Dani
12.01.2008 um 13:31 Uhr
Hi Gaget,
ich habe eben festgestellt, dass das so nicht gehen wird. Am Besten du legst doch für jede Maschine ein extra Abbild an und integrierst dann die Treiber. Denn im Endeffekt ist so der Traffic kleiner. Das Abbild kannst du ja immer schön 1:1 kopieren, jedoch bitte in der SIF-Datei den Abbildnamen ändern, weil sonst hast du 10x das gleiche Abbild drin stehen und blickst selber nicht mehr durch.
Zum Schluss in der jeweiligen SIF-Datei noch die Treiberverzeichnisse anlegen und gut ist.


Grüße
Dani
Bitte warten ..
Mitglied: GaDgeT
13.01.2008 um 11:38 Uhr
Hallo!

Ja, mit mehreren Abbildern würde es wohl gehen, aber das ist ja nicht sehr schön.

Gibt es denn die Möglichkeit mit einer Batch Datei die ausgeführt wird?

Wie löst man dieses Problem denn?
Auf dieses Problem werden doch sicher schon mehrere gestoßen sein, oder?


Danke und Gruß
Bitte warten ..
Mitglied: Dani
13.01.2008 um 11:58 Uhr
Moin,
Auf dieses Problem werden doch sicher schon mehrere gestoßen sein, oder?
Richtig...wir gehörten auch dazu! Wir haben nicht den RIS im Einsatz sondern Empirum von Matrix42. Kostet zwar einige Euros (je nach Version und Clients) aber du kannst halt alles mit machen (Os Installer, Softwareverteilung, Patchmanagement, Richtlinien, Einstellungen, etc....)


Grüße
Dani
Bitte warten ..
Mitglied: Rafiki
13.01.2008 um 21:08 Uhr
In der Regel ist es kein Problem mehrere Treiber in ein Image einzubinden. Diese werden zwar mit kopiert aber eben nicht geladen. Wenn eine Datei doppelt vorkommt z.B. die txtsetup.oem von SATA oder RAID treibern mußt du mehrere Verzechnisse anlegen und in der .sif Datei aufführen.

Gruß Rafiki
Bitte warten ..
Mitglied: GaDgeT
15.01.2008 um 09:55 Uhr
Hallo
also bei den normalen Treibern kann man das ja machen. Alle in einen Ordner schmeißen und nur diesen in der "sif" Datei angeben, oder eben jeden in nen einzelnen Ordner, und dann eben alle Ordner in der "sif" Datei angeben.

Aber zusätzliche Treiber für SATA müssen ja in den Pfad:
...\RemoteInstall\Setup\<Sprache>\Images\<Ordnername des Abbilds>\$oem$\textmode

hier wird es ja zwangsläufig Probleme geben, weil darin ja immer eine txtsetup.oem liegen muss.

Oder meinst du das man unter "textmode" noch Unterordner angelegt? Geht das?

Ist hier dann nicht ein weiteres "Image" nötig?

Danke und Gruß
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Terminal Service Remote Desktop service (8)

Frage von winlin zum Thema Windows Server ...

Firewall
gelöst SOPHOS UTM - Installation auf Hardware - install.tar nicht gefunden?! (2)

Frage von 129511 zum Thema Firewall ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...