Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung per GPO funktioniert nur teilweise

Frage Microsoft Windows Server

Mitglied: Joh2308

Joh2308 (Level 1) - Jetzt verbinden

23.02.2012 um 01:01 Uhr, 4621 Aufrufe, 6 Kommentare

Software die per Gruppenrichtlinie verteilt wird kommt auf manchen Rechnern nicht an

Hallo zusammen,

Ich versuche seit ein paar Tagen neue Software per Gruppenrichtline an meine PCs zu verteilen. Bei der Verteilung von Software per Gruppenrichtline wird die Software aber nur auf einem Teil der Rechner installiert. Zur Verteilung habe ich ursprünglich einer bestehenden Gruppenrichtlinie ein paar neue Pakete hinzugefügt (einige neue Versionen für Flash etc. und einige neue Programme wie Paint.net). Die Programme werden auf etwa 80% der Rechner auch artig installiert - nur die restlichen 20% weigern sich standhaft.

Was mich daran langsam verzweifeln lässt:
Meine Umgebung ist recht homogen, alle Rechner laufen mit Windows 7 deutsch 32Bit und alle Domaincontroller sind Windows Server 2008 R2, sogar die Hardware ist nahezu identisch.


Bisher habe ich probiert/überprüft
  • Ereignisanzeige nach Fehlern durchsucht ==> nichts gefunden
  • Die Spracheinstellungen der Pakete dürften kaum Probleme bereiten, einige davon haben als Sprache neutral eingetragen, zur Sicherheit habe ich aber mal die „Sprache ignorieren“ Option gewählt ==> keine Veränderung
  • Die manuelle Installation der Programme getestet ==> klappt auch an den PCs die die Pakte nicht per Gruppenrichtlinie gezogen haben
  • Irgendwelche Gemeinsamkeiten der "Problem-PCs" im AD gesucht ==>Alle PCs sind Mitglied in den selben Gruppen und in jeder meiner OUs gibt es PCs die die Pakete ziehen und welche die sie nicht ziehen
  • GPRESULT an einem PC der die Software nicht zieht ==> Im Bericht sind die Pakte die ich vermisse nicht aufgeführt - kein Wunder also, dass sie nicht installiert werden
  • GPRESULT an einem DC für einen PC der die Software nicht zieht ==> hier stehen die Pakete drin
  • Um zu prüfen ob die Richtlinie überhaupt übertragen wird habe ich:
    • Einen anderen Wert in der Richtlinie geändert ==> kommt anstandslos am PC an
    • Eine neue Richtline erstellt die ein Softwarepaket und einen Eintrag in der Computerkonfiguration enthält ==> Das Paket kommt nicht an, der andere Wert schon

Habt ihr eine Idee wie ich meine restlichen PCs zum Installieren der neuen Pakete per Gruppenrichtlinie bewegen kann?

Vielen Dank und viele Grüße

Joh
Mitglied: jsysde
23.02.2012 um 07:21 Uhr
Moin,

* GPRESULT an einem PC der die Software nicht zieht ==> Im Bericht sind die Pakte die ich vermisse nicht aufgeführt -
kein Wunder also, dass sie nicht installiert werden
Korrekte, logische Schlussfolgerung.
Damit hast du den Fehler auch schon gefunden, oder besser gesagt, die Fehlerursache.

Hast du mehrere Standorte, mehrere DCs?
Klingt spontan nach einem Replikationsproblem, schau mal ins sysvol, ob dort nicht irgendwelche *_NTFRS-Ordner existieren.

Cheers,
jsysde
Bitte warten ..
Mitglied: DanielLeib
23.02.2012 um 07:58 Uhr
..................
Bitte warten ..
Mitglied: 60730
23.02.2012 um 08:32 Uhr
Moin,

Ich lese da was ganz anderes raus....

Die kisten, die das urspruengliche paket aus der gp gezogen haben, sind diejenigen, die es jetzt nicht mehr ziehen.

Baue einfach eine neue saubere gpo fuer den kram.

@ daniel:
Threadhijacking ist garnicht gern gesehen.
Vor allem, weil dein problem und das des to nur eine schnittmenge von 230 volt und 50 hz haben.
Bitte warten ..
Mitglied: Joh2308
23.02.2012 um 09:21 Uhr
Vielen Dank für die schnellen Antworten dazu

Zitat von jsysde
Hast du mehrere Standorte, mehrere DCs?
Ja, ich hab' mehrere Standorte und an jedem Standort einen eigenen DC - hab ich an jedem Standort PCs die alle Pakete ziehen und welche die das nicht tun - immer etwa 20% verweigern sich.

Zitat von jsysde
Klingt spontan nach einem Replikationsproblem, schau mal ins sysvol, ob dort nicht irgendwelche *_NTFRS-Ordner existieren.
Ja, da sind _NTFRS Ordner, allerdings sind die schon erheblich älter und enthalten weder meine GPO zur Softwareverteilung noch meine Test-GPO. Ich gehe mal davon aus, dass die von einem älteren Replikationsproblem kommen, das inzwischen behoben ist. Kann ich die eigentlich irgendwie löschen?

Zitat vonTimoBeil
Die kisten, die das urspruengliche paket aus der gp gezogen haben, sind diejenigen, die es jetzt nicht mehr ziehen.
Baue einfach eine neue saubere gpo fuer den kram.
Das hab ich mir auch gedacht - nur meine neue GPO wird eben auch nur zum Teil gezogen. Der Richtlinien-Teil der keine Software enthält wird gezogen, die Software fehlt.

Konkret habe ich das in der Testrichtlinie (also einer komplett Neuen) mit einem Update auf Java 6.30 probiert (6.26 war drauf) - auch hier: etwa 80% kriegen das, 20% nicht - und auch hier taucht das vermisste Paket nicht im GPRESULT an meinen Problem-PCs auf, die restlichen Einstellungen aber schon. Kann ein PC eine Gruppenrichtlinie nur teilweise übetragen?


Viele Grüße

Joh
Bitte warten ..
Mitglied: jsysde
23.02.2012 um 10:29 Uhr
Moin,

Ja, da sind _NTFRS Ordner

Womit klar ist, dass du ein Replikationsproblem hast. Für eine voll funktionsfähig Infrastruktur musst du zuerst dieses Problem beheben.

Cheers,
jsysde
Bitte warten ..
Mitglied: DerWoWusste
23.02.2012 um 19:45 Uhr
Hi.

Stell erstmal sicher, dass die Richtlinie gezogen wird, das macht gpresult - richtig. Dann schau am Client mittels rsop.msc nach, ob bei deren Verarbeitung etwas schiefgelaufen ist.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Wake on LAN funktioniert teilweise nicht (11)

Frage von DarkScabs zum Thema LAN, WAN, Wireless ...

Windows 10
Microsoft-Konten blockieren via GPO funktioniert in der Domäne nicht (7)

Frage von DieReiseZumMittelpunktDerErde zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...